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Software License Agreement

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS
BEFORE USING THIS PRODUCT. BY INSTALLING THE
PRODUCT YOU THEREBY INDICATE YOUR ACCEPTANCE OF
THESE TERMS AND CONDITIONS. SHOULD YOU DISAGREE
WITH ANY OF THE TERMS OR CONDITIONS LISTED BELOW,
PROMPTLY REMOVE ALL FILES RELATED TO THIS PRODUCT
FROM YOUR HOST PLATFORM AND RETURN THE PRODUCT
TO SATO CORPORATION.

1. You explicitly agree to accept a non-exclusive license to use
the Software identified on the distribution media solely for your
own customary business or personal purposes. Your local
and national laws govern this Agreement.

2. Henceforth, “Software” shall refer to the digitally encoded,
machine-readable data and program. The term “Software
Product” includes the Software identified on the distribution
media, including any accompanying documentation. The
term
“Distribution Media” refers to any method by which the
Software Product is delivered to the end user, including but not
limited to Floppy Disks, CD-ROM, Magnetic Tape and On-Line
distribution via the Internet. The Software Product is licensed
(not sold) to you, and SATO® either owns or licenses from
other vendors who own all copyright, trade secret, patent and
other proprietary rights in the Software Product.

3. To protect the proprietary rights of SATO Corporation, you
agree to maintain the Software Product and other proprietary
information conceming the Software Product in strict
confidence and to establish reasonable procedures regulating
access to and use of the software.

4. You agree not to duplicate or copy the Software except that you
may make one backup copy. You agree that any such copy
shall contain the same proprietary notices as those appearing
on the original.

5. You shall not sub-license, sell, lease, or otherwise transfer all
or any portion of the Software Product separate from the
printer(s), without the prior written consent of SATO, Inc.

6. You may not modify or prepare derivative works of the
Software Product. You may not transmit the Software
Product over a network, by telephone, or electronically
using any means; or reverse engineer, decompile or
disassemble the Software.

7. You may transfer the Software Product with the printer(s), but
only if the recipient agrees to accept the terms and conditions
of this Agreement. Your license is automatically terminated if
you transfer the Software Product and printer(s).

8. This License remains in force until terminated, and may be
terminated by agreement between you and SATO Corporation,
or by SATO Corporation, if you fail to comply with the terms of
this License if such failure is not corrected within thirty (30)
days after notice. When this License is terminated, you shall
either return to the place you obtained them from, or destroy,
the printer and all copies of the Software and documentation.

9. SATO warrants that for ninety (90) days after delivery, the
Software will perform in accordance with specifications
published by SATO, and that the distribution media will be free
from defects in material and workmanship. SATO does not
warrant that the Software is free from all bugs, errors and
omissions.

10. Your exclusive remedy and the sole liability of SATO in
connection with the Software is replacement of defective
distribution media upon their return to SATO. SATO will not be
liable for any loss or damage caused by delays in furnishing a
Software Product or any other performance under this
Agreement.

SATO does not warrant that the functions contained in the Software
will meet your requirements or that the operation of the Software will
be uninterrupted or error free.

11.  Use, duplication or disclosure by the Government is subject to
restrictions as set forth in the relevant guidelines of your country,
such as the Rights in Technical Data and Computer Software
clause at FAR 242.227- 7013, subdivision (b) (3) (i) or
subparagraph (c) (1) (i), as appropriate. Further use,
duplication or disclosure is subject to restrictions applicable to
restricted rights software as set forth in FAR 52.227-19 (c) (2)
or equivalent rules.

THE PARTIES AGREE THAT ALL OTHER WARRANTIES, EXPRESS
OR IMPLIED, INCLUDING WARRANTIES OF FITNESS FOR A
PARTICULAR PURPOSE AND MERCHANTABILITY ARE
EXCLUDED.

SATO reserves the right to make changes and/or improvements
in the Software without notice at any time. IN NO EVENT WILL
SATO BE LIABLE FOR LOST PROFITS, LOST DATA,
BUSINESS INTERRUPTIONS OR ANY OTHER DIRECT,
INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES
ARISING OUT OF THE USE OF OR INABILITY TO USE THIS
PRODUCT, EVEN IF SATO HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES, OR ANY DAMAGES
CAUSED BY ABUSE OR MANIPULATION OF THE
SOFTWARE. SOME STATES DO NOT ALLOW THE
EXCLUSION OR LIMITATION OF LIABILITY FOR
CONSEQUENTIAL OR INCIDENTAL DAMAGES, SO THE
ABOVE LIMITATION MAY NOT APPLY TO YOU.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT,
UNDERSTAND IT, AND AGREE TO BE BOUND BY ITS TERMS
AND CONDITIONS. NEITHER PARTY SHALL BE BOUND BY ANY
STATEMENT OR REPRESENTATION NOT CONTAINED IN THIS
AGREEMENT. NO CHANGE IN THIS AGREEMENT IS EFFECTIVE
UNLESS WRITTEN AND SIGNED BY PROPERLY AUTHORIZED
REPRESENTATIVES OF EACH PARTY. BY INSTALLING THIS
SOFTWARE PRODUCT, YOU AGREE TO ACCEPT THE TERMS
AND-CONDITIONS OF THIS AGREEMENT.
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Copyrights

The contents of this document are proprietary information protected by copyright. No part
of this document may be reproduced, copied, translated or incorporated in any other
material in any form or by any means, whether manual, graphic, electronic, mechanical or
otherwise, without the prior written consent of SATO Corporation.

SATO Corporation and all its companies worldwide make no representations or
warranties of any kind regarding this material, including, but not limited to, implied
warranties of merchantability and fitness for a particular purpose. SATO Corporation shall
not be held responsible for errors contained herein or any omissions from this material or
for any damages, whether direct, indirect, incidental or consequential, in connection with
the furnishing, distribution, performance or use of this material. The information in this
manual is subject to change without notice.

Trademarks

SATO is a registered trademark of SATO Corporation and/or its subsidiaries in Japan, the U.S
and other countries.

AlX is a registered trademark of International Business Machines Corporation.

Cisco is a registered trademark of Cisco Systems, Inc.

EPSON is a registered trademark of Seiko Epson Corporation. J2SE, Java, and Solaris are
trademarks of Sys Microsystems, Inc.

Linux is a registered trademark of Linus Torvalds.

Microsoft and Windows are registered trademarks of Microsoft Corporation.

Pentium is a registered trademark of Intel Corporation.

Unix is a registered trademark of UNIX System Laboratories, Inc.

Software updating disclaimer

While all efforts have been taken to ensure accuracy and currency of the information
contained herein, there are instances where the contents of this document may be
outdated. In that case, proceed to SATO worldwide websites (www.satoworldwide.com)
to check whether an updated document has been made available for your reference.

Alternatively, you can consult your nearest authorized SATO technical representative, as
listed on the back cover, to obtain the relevant information about SATO All-In-One
Software.

Version 1.0.75.0
© 2012 SATO Corporation. All rights reserved.
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Overview

The SATO All-In-One application for printer remote control was developed to achieve the
following goals:

- To simplify the SATO printer configuration and operation processes for end-users

- To allow remote configuration and control of SATO printers that are compatible with this
application

- To consolidate as many of the separate software printer utilities as possible into a
integrated application

1.1. Supported Models of SATO Printers

Currently only the following models of SATO printers are supported by the current version of
the SATO All-In-One application:

- CL4e/CL6e Series
- CG2/CG4 Series

- GT4e Series

- GlL4e Series

- M-10e

- MB2i/ MBA4i

- MB84SE Series

- M84 Pro Series

- CT4i Series

- LM Series (step 2)
- S84 Series

- DR308e

- LM4 Series

- LT408

- Db5xx Series

- GY4 Series

- TG3 Series

- TH2 Series

- GZ4 Series

The SATO All-In-One application will be undergoing continual refinement, and it is expected
that other SATO printer models will be supported in future, in line with customer demand.

SATO All-In-One Application 6-60
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System
Requirements

The minimum system requirements for the SATO All-In-One Application are

¢ A computer with at least a 450MHz Pentium® CPU with 128 MB of RAM, running
Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Windows Server
2008 or Windows 7 platforms.

¢ Installed .NET Framework 2.0 (or higher version)

¢ Atleast one supported model of SATO printer that can connect to the computer
running this application

Standard SBPL commands are sent to SATO printers to update configuration settings or to
retrieve data. The data will then be presented in a meaningful and graphical interface for the

software user.

All-In-One
Application

User

Communicate with
printers using
TCP/IP, USB, LPT
or RS232 with SBPL

Handle all different
commands and
operational
parameters among
the various printer
models

Present control
information in a
friendly graphical
user interface

- The complexities
of configuration
and SBPL
commands are
hidden from users

- User will see a
unified approach
to configure and
administrate
various models of
SATO printers.

Figure 1 System Overview

Currently, SATO All-In-One Application does not require a database system. The only
scenario where persistent data is needed is during the exporting of application profile into

XML files.

Please Note that Windows Vista and above OS user must be administrator in order All-In-
One tool to perform well. Things like saving Preference Settings, Firmware download etc
might not function well if user does not have admin rights.

SATO All-In-One Application
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Setup

After obtaining the installation software, double click on the setup file to install the application.

i SATO All-In-One Application |Z||§|[g|
= -||||“

Welcome to the SATO All-In-One Application : Il

Setup Wizard '

The ingtaller will quide vau thrauagh the steps required to install the SATO All-ln-One Application an
Yaur cormputer.

WARMIMG: Thiz computer program iz protected by copyright law and international treaties.
Ilnauthorized duplication or distibution of thiz program, or any paortion of it may rezult in severe civil
ar criminal penalties, and will be prozecuted to the magimum extent pozsible under the law.

Cancel

Figure 2 Setup screen

SATO All-In-One Application
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— 3
i SATO All-In-One Application |Z|| - |[z|

License Agreement

Please take a mamett ta read the licenze agreement now. If vou accept the terms belaw, click "
Agree", then "Mext”. Otherwize click "Cancel”,

[

AGREEMENT

Please read this Agreement carefully before indicating acceptance at the end
af the text of this Agreerment, This Agreement states the terrs and
conditions upon which SATO International Pte Ltd and its representative
(collectively, "SATO"Y offers wou a right to use this software together with all
related explanatory written materials and accompanying items including, but
not limited to, the executable programs, drivers, and data files associated
with such programs {collectively, "Software™), If vou agree to the Terms and
Conditions (*Terms™) of this Agreement, click on the &CCEPT button below,

If yvou do not agree with the Terms, click on the DECLINE button, If you do ™
(O Do Mot Agres @i Agres
[ Cancel ] [ < Back ] [ MHewt » J

Figure 3 License Agreement

In order to have access to the “Next” button to proceed with the installation, the user must
agree with the License Agreement by clicking on the “| Agree” radio button.

SATO All-In-One Application 9-60
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i SATO All-In-One Application |Z||E|E |
: lII||“I|

Select Installation Folder

The ingtaller will inztall SATO All-ln-0ne Application ta e following falder.

Toinztall in thiz folder, click "Mest”. Ta nstall ko a different falder, enter it below ar click "Browse"',

Fnolder:
C:AProgram FileshSATOMVSATO All-ln-One Application®, [ Browse... ]

| DiskCost. |

[nztall SATO All-ln-One Application for pourzelf, or for anyone who uses tis compuker;

) Eveone
) Just me

Cancel ] [ < Back ] | Mext >

Figure 4 Installation folder

i SATO All-In-One Application

Confirm Installation
The inztaller iz ready to install SATO All-ln-One Application on your computer.
Click "Me=t" to start the installation.
Cancel ] | < Back ] | Hest >
Figure 5 Confirmation
Click the “Next” button to start the installation.
SATO All-In-One Application 10-60

User Manual



WATW

DCS & Labeling Worldwide

¥ SATO All-In-One Application EEE

z -Il”ll
Installing SATO All-In-0One Application I

SATO All-ln-One Application iz being installed.

Pleaze wait...

Cancel

Figure 6 Installation in progress

i@ SATO All-In-One Application

Installation Complete

SATO All-ln-One Application has been successfully installed.

Click "Cloze" to exit,

Pleaze uze Windows Update to check for any critical updates to the MET Framewark.

Figure 7 Installation Complete

The program can then be launched from the Start Button->All Programs->SATO->SATO All-
In-One Application program group.

SATO All-In-One Application 11-60
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Using the All-In-
One Application

4.1. Overview

The SATO All-In-One Application works on the following paradigm:

IEEE1284/ - AE
RS232C |
/ ;‘:  Infomation
W % 1
LAN/ WLAN
usB =
CONNECT ORGANIZE CONTROL
Link to supported Use the graphical treeview Configure/control
printer(s) via Auto- structure to organize connected any SATO printer
Discovery or via printers into groups using regardless of its
manual entry custom folders & display names. location in the world.
SATO All-In-One Application 12-60
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4.2. Summarized Features List

Feature ol ol ol o wl o N w
8151552/ 8/2135 8 5 8528335
;JEBGE%%BS?)%QEBI—I—GOO

1 | Auto-Discovery ojojojojo|x|jolojo|jo|jlojojojojo|jo|joO]|O

2 | Saving and loading Printer 60|0|0jO0jO0|O0|O0O|O0O|O|O|O 0O|X|O0j]O0|0O|O
Configuration

3 | Displaying and setting of 6jjojo|jojojojojo|ojo|o0jo0|xj0|0|0|O0
Printer Configuration

4 | Firmware Download ojojojo|jojo|jo|lO|jO|lO|lO|J]O|J]O|O|O|O|O]|O

5 | Concurrent download 6/ojojo0o|jo|xXx|ofojojo|jojofjojojo0jo|o|o
firmware to multiple printers

6 | Sendand query SBPL o/lojojojojojojojojojojojo|x|ojoj|jo|o
command

7 | True Type Font Download O X|OJO|X|X|X|X|OX|X|X|X|X]|OlO|X]|X

(Expanded

Memory/Cartridge)

8 | Graphics Download ojojojojo|xXx|ojo|jo|jo|jo|jOo|jO0o|JO|jO|O|O]|O

Supported Interface

9 | LAN o[o[oJ]oJo[o]J]o]o[oJ]o|o]Oo]OoJ]O[O[O[O]O
10 | RS232¢ olo[o[o|o|o|o|o[o|o|o|Oo|]O[O[O|O|O]O
11 | IEEE1284 Parallel Port 6j6jojojo|xXx|j0ojo0ojo0jo0|0|0|0|O0|0|0|0]|O0O
12 | USB olo[o[o|o|o|o|o[o|o|o|Oo|]O[O[O|O|O]O
13 | Test Print olo[o[o]jo|o|o|]o[o|o|o|]Oo]O|[X]O|O|O]O
14 | LAN Interface Card o|lolo]o|o|[x]|]o|lo|]o|o]o|ofo|[x|[Xx[]o]oOo]O

Configuration

15 | Format Download to Keypad | X | X | X | X | X | X | X | X | X XX X[ X|X]|X]|X
16 | Bitmap Font Download 60j0j0}|X|0|O0]O0O|O0O|O0O|O0O|O0O|O|O|X|O|O|0O]|X

(Internal Memory)

17 | TH2 Package Download XPX XXX XX XX XXX PX]O XX | X|X
Note: For troubleshooting purposes, SATO All-In-One Application generates a log file to

capture important debugging information such as error codes. By default, the log file is

created at c:\ directory and the file name is SATO_All-in-one.log.

The default directory can be changed from the dialog box in Option->Preferences. Refer

to Section 4.24 Application Configuration for details.

When reporting bugs or problems, copy the log file to the systems support team.

The default directory can be changed from the dialog box in Option->Preferences. Refer

to Section 4.24 Application Configuration for details.

SATO All-In-One Application 13-60
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4.3. Multi-Lingual Support

SATO All-In-One Printer Utilities
i JTEMNL ME TE O EE ®Bh
ERC e TS O e S I P s =
= @ Main
? 7 S MB200i) mb
M S MBueSe Series] rfdd
&) (DR3058) DRI0GE

i@ (2 (CiE2 Series) CGI0G
B2y (6T Series) PRIBODIZ (Online state Wait to raceive - Mo errar)

Viza

CGZEf

FTERETE & 05208

BE - DG Seies
— USH Port Gormemunicati
[] BT Splash RETHZEH USE Port : 0091 #dmhot
L AT BT IRTE Treviow (55 SRR A0
4 st BRRGIRTFEY Treeview (S8,
=H TREE
—HFEITEMLEAEE: 25
L) &KE|ica
RIS RIENEIFREE (500 - 50000 ZE3: | 2000
C] 1TEMES
EREAER [cWIATO Allinonelog [ =A@ |
(FERGEE T 4 FERE
STES | bt ) v 4 BOES
L T8
EH RN 3
M RIEYHNTIE

] fisep s
el PEETE
el IR

Figure 8 Multi-Lingua Support

This version of All-In-One tool supports English and Traditional/Simplified Chinese.
User can change the language setting at the Options->Preferences.

4.4. Adding a Printer

Only SATO printers, specifically those supported by this All-In-One application, can be
detected and added. Currently, the following interfaces are supported:

LAN (Wired and Wireless, TCP/IP)
Serial Communication (RS232c)
Parallel Port (IEEE 1284)

USB (Plug & Play)

* & & o

For printers using SILEX Network Interface card (such as GT and CL), it is
necessary to use the SILEX firmware which supports bi-directional communications
on port 9100, i.e., version A1.2.3 and above.

* For SAI-SILEX firmware, it is necessary to add the printer with Port no.: 1024.

The All-In-One Application provides three methods for detecting and/or adding
compatible printers to the system:

1. Using the Auto-Discovery mode
2. Manually entering an IP Address, or Parallel Port/Serial Comm settings
3. Specifying a range of IP Addresses

SATO All-In-One Application 14-60
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In any of the above modes, the system will attempt to handshake with the target
printer(s) and issue an appropriate command to retrieve the printer firmware
information. If the handshake is successful, the detected printer(s) will be presented in
the main panel’s treeview as an icon.

Note: When All-In-One Application tries to connect to the printer, it is important to
ensure that there is no other application (such as printer driver) using the printer at the
same time.

For example, a printer driver which is actively connecting to the CT412i via the USB port
with printer driver will cause connection problems to All-In-One Application with this
printer.

& SATO CT412i Properties

Stocks Language Barcode Fonts Command Fonts About
General Sharing | Portz | Advanced Secunty || Printer Settings
‘:”9 SATOCTA12
Print to the following port[z]. Documents will print to the first free
checked port.
Port Dezchption Printer e
L comMi: Serial Port
O coMz: Serial Port
L] COM3Z: Serial Port E
[ COM4: Serial Port
|_| U Flatink b ]| CA Tl Ann [V e T i 1
T LI LS I | L= PELro S LS | S LW LN |y [ SRLE ) L% I R o
[ SB... “irtual printer port fo...  SATOCT412 ]
L1 ush  iguatprnterpetfo— SATO-GEA09e{Capys 2} —
[ Add Port... ] [ Delete Port ] [ Configure Paort. .. ]
Enable bidirectional zupport
[_TEnable printer pocling
[ (] 4 ] [ Cancel ] [ Apply

Figure 9 Active connection from printer driver

4.41. Adding a Printer via Auto-Discovery

The All-In-One Application can automatically detect SATO printers connected via USB
interface, the SILEX network interface card (CL and GT series), or the standard built-in
LAN interface (new CT4xxi series, CG Series), or the GL Series Network Interface card.

Upon installation, the software automatically registers itself into the Windows Firewall
Exception list. Thus, the firewall can continue to protect the computer without
compromising the functionality of the Auto-Discovery feature.

SATO All-In-One Application 15-60
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™= Windows Firewall

General | Exceptions I.-'l'-.dvanc:edg

windows Firewall iz blocking incoming network. connections, except far the
programs and zervices selected below. Adding exceptions allows some programs
to work. better but might increase your security risk.

Brograms and Services:

Mame Group Policy ~
tMeszzenger Mo
Microsoft Management Console Mo
S RfidProviderCertificationT ool exe Mo
Remate Assiztance Mo
Femote Dezkiop Mo
RAdServices. exne Mo
SAP Logon for Windows Mo
Mo i,
MNa
MNa
Wl zilew merk bl Y__!
| addProgram... | [ AddPert. ||  Edit. | [ Delete |

Dizplay a notification when wWindows Firewall blocks a program

What are the rizks of allowing exceptions?

[ Ok ] [ Cancel ]

Figure 10 Exception entry in FireWall

4.4.2. Adding a Printer via LAN, Parallel Port or Serial Comm settings

You can add a new printer to the system by specifying its IP Address, USB port, Parallel
Port or Serial Comm settings such as network port, communication port and baud rate.
User with USB to Serial can easily notify with USB2Serial text beside com port. USB to
Parallel port is now supported and will listed under USB Port.

Add New Printer

Mesws Printer Information ' Serial Comm. I j E
Printer Name |GLADS | € UsE Por WA
f ™ Parallel Part IEDM4[USB2SEHE||] .
Model | GL Series v

Interface

@ LaNAwireless 1P| 192.168.0.1] |[3] & 1JSE Part

) Serial Comm, ra

O USB Part A

() Parallel Port
[ Ok ] [ Cancel ]

Figure 11 Add New Printer

Note: GL printer with Standard Protocol is able to be added with this method. However,
it might take a little longer.
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4.4.3. Add a Printer by specifying an IP Range

SATO printers such as MB200i/400i which do not use the SILEX Network Interface card
can be auto-detected if you use the “Add Printer — By IP Range” feature.

&% Search SATO Printer by IP Range

IF Range
From:[ 108 5@ ©&[ 15388
o B Z| [ E]] 5@ [ 158
Frovide a closer range for faster returrn
[ Search ] [ Cancel J
Type IP Address FMac Address

Add

Figure 12 Add Printer - By IP Range

It takes the application approximately one second to probe each IP address in the IP
range to determine whether it is a SATO printer (by checking the vendor code in the MAC
address). Thus, if you specify a wide IP range, the application may take an unacceptably
long time to complete the task. Therefore, a “Cancel” button is provided to allow you to
cancel the operation.

4.5. Navigating the Treeview

After all target SATO printers have been successfully detected or registered into the
application, they will appear in a Tree view as icons (See Figure 12 below) representing a
Node. You can manage the nodes in this view (hereafter called the treeview) in various
ways, as follows.

5 SATO All-In-One Printer Utilities

File  Printer View Tools Options Help
AE e M E RS N e N e W = R
= @ Main

/[E}] (CG4 Series - Std) CG4 Series (Online State : Wait to receive : Mo Error)

[E}] (CL Series - 5td) PR3AAGBT (Online State : Ready)

f'ﬁ@ new folder1

Nodes S (GY412 - 5td) GY (Not Connected)
o [Eh {CLEFIus Series - Std) CLEFIus (Mot Connected)
[Eh (TG3 Series - Std) TG3 (Mot Connected)
A (TH? Seres - StAl TH?
Figure 13 Treeview
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4.5.1. Creating folders

By default, detected printers will populate the treeview as nodes at the root. However,
just as with any standard treeview in Windows Explorer, you can also create your own
folders in the root, and then drag-and-drop any registered printer to and from any folder
or root area.

By creating folders, you can organize connected printers into groups meeting particular
criteria such as “all GL printers on the Production Floor” or “All compact printers in the
Packaging Dept” . You can then control printers in that group more conveniently rather
than individually select different printers when needed.

The only limitation is that your custom folders must contain a non-blank name, and the
folder name cannot be “root” or “main”. Also, within the same level, the same folder
name cannot be repeated.

4.5.2. Renaming folders

The folder name and the “display” of the printer can be renamed on the treeview. Click
on the folder name and wait for the text editing cursor to appear, then type the new
name.

4.5.3. Relocating printers via Drag-and-Drop

A node icon can be moved in and out of the root area or folders easily. Just make sure
the source and target locations are visible, then drag the icon and drop it in the target
location.

4.6. Displaying Printer Firmware Information

When a printer node on the treeview is clicked, you will see basic information about the
printer, as depicted below.

£ SATO All-In-One Printer Utilities

File ~ Printer Wiew  Tools  Options  Help
A EE R R ARl A R P W=
= @ Main

-4 D) (DR3062) DR30GE 1 Information a
e @ a

=l new foldert -
7 24 (MB200) s Q J"..-Ilr :)
| MB4ueSe Series) rfdd -

5 (062 Seras) CE208

Printer Name | PRIG0033

Mode! - GT Seres

IP Address 10256412

Mac Address  00-80-92-35-00-32
Firrrware Version : 13000007

Figure 14 Printer Information
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4.7. Editing Printer Information

You are allowed to change the printer’s Display Name and the Model, which are
displayed next to the node icon.

@ SATO All-In-One Printer Utilities =&
File  Printer View Tools Options Help

S 512 01|03 8 e o i

= g Main

LE] (TG4 Series - Std) CG4 Series (Online State . Wait to receive | Mo Error)
} LQJ (CL Series - 5td) PR3IAAGET (Online State : Ready)

-EJ Information

-l new folde=g -
£y (Gv{ % Edit Printer Information r‘ r il
[EJ ;CL! el ‘!IJ "=
[EJ tTG Prirter Infarmation
@ (THZ Display Name : |CG4 Series
G4
[EJ ' Model Mame :

IP Address : |10.25.5.21 5100

MAC Address ©  p9-19-98-00-62-D1

Firmmware Version ©  39.00.03.01 IE|

= configuration A/

0K ]l Cancel ]

(9 Edit Information |
Figure 15 Edit Printer Information

Changing the Display Name/Model does not affect the printer. No command will actually be
sent to the printer. The changes apply only to the treeview of the SATO All-In-One
application, and are stored in memory or exported to XML files when you export profiles
(See Section 4.11 Export/Import Profile).

4.8. Enquiring Printer Status

For printers connected by LAN, the SATO All-In-One application periodically sends a
status-probing command and display the printer status for monitoring purposes.

This feature is not available to printers connected via Parallel Port and RS-232. This is
based on the assumption that local printers (non LAN) can be monitored locally rather
than via remote.

&% SATO All-In-One Printer Utilities

File  Printer Miew  Tools  Options  Help

P o 15 D) B X |G e ) (5] s
aﬂP
[E,‘J (GT Series) PRIGO0O3Z (Error: Head opem

L new foldert

Figure 16 Status Monitoring
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4.9. Interface Configuration

Interface Configuration feature is available for CT, MB, CG printers and e-series models

that connected with LAN interface.

‘-.'n"._S_.lTﬂ All-In-One Printer Utilities

File  Prinker  Wiew Tools  Options  Help
IR FART X P Te
= ﬁMain

J,J Information

(rd 3

-@ (5T Series) PR360O033 (Errar . Head apen)
-5 new folder]

5% Network Interface Setting

Model - GT Series

IP &ddress

Subnet Mask 255,265.0.0
Default Gatewzy |10.25.1.238

= Configuration

Prnter Narme : PRIGONIS

- [B]x]

s 1P Address - 10 25 6112
Mac Address - 00-80-92-36-00-33
] Use DHCP [ USE R&RP Firrrware Version - 13.00.00.07

(3

Edit Information

Mo wireless Lan

[ j Printer Configuration

[ |

(]

’ a Label Configuration

a
)
J
)

( ﬂ Interface Configuration )

Figure 17 Interface Configuration

Note: When the “Interface Configuration” window is open, the ENQ Status monitoring
function of the printer will be stopped.

The following picture shows the Interface Configuration for MB printer:

v
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MB Interface Configuration

[Rsz3z | DA |[ Bluetooth WwLAN Security Setting |

Wireless LAN Interface Settings
e funcfion & o waia far A8 pninfar el WA profocol)

MAB e -
IP iddess [192.168.0.1 | Set
Subnet Mask |2552552860 | Socket Port | 1024
D efault Gateway |000.000.000.000 | Socket Timeout 000

IP &ddress Setting (%) Manual setting 2 DHCP

(Aead axciuda Socket Port & Timeout) Set
[ Ensble Muliple Selection The printer goes into Sleep Mode after completing the settings.
Con e e Restart the printer after it goss into Sleep Mode
*Mote: The displayed walues are are the default setting, not the walues from printer

Figure 18 MB-series Interface Configuration

This function supports concurrent setting to multiple MB printers. The following interface
settings can be configured on this functionality:

- RS232 settings

- IrDA settings

- Bluetooth settings

- Wireless LAN settings

4.10. Displaying Configuration Information

The displaying and updating of printer configuration information is split into 2 parts:
Printer information and Label information. These can be viewed and updated by clicking
the “Printer Configuration” and the “Label Configuration” button respectively.
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4.10.1. Printer Configuration

SBPL commands will be sent to the printer to retrieve the printer configuration
information. The screen will only display the system configuration Information such as
print speed and darkness level.

5% Configuration Information

Printer Configuration

. Mame Yalue Remark [
Print M;aiho-u_;l - R [hermal Transker . Fired :
Pririt Hésolution e et | Fixed

. Printer Speed | ‘Ill[rnrn.-":z: b

| Print Mation . Tear off - | Fined

[ Eutter Mode_Setting. . Head Positic Fixed B
Dispenze Mode Setting || Cutter Position Fied

: Sensar Type Setting | Fixed
Print D arkness |,-'l'-, w |
Drarkness Range | Lewvel 4 w | .
Zem Slagh '|.E nabled v |
KaniCode [415 code ~||
Initial Feed | Disabled 2 | ’ J

i Proporticnal F'itc:l;u | Proportional pitch b |I
Linerless Media Ti itter Poziion ] Fixed )
Media Type Il : Mot Applicable
Buzzer Setting | On b | |

. Auto Power Off | | Mot .fb.nppliu-:aiéuie
Serial Interface Priarity . Mat Applicable

Subrmit ] I Feset ]

Figure 19 Printer System Configuration Information

Use the drop-down lists to make any necessary changes to the configuration. When the
“Submit” button is pressed, the system captures your inputs and issues SBPL commands to
change the settings in the printer.
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User Manual



WATW

DCS & Labeling Worldwide

4.10.2. Label Configuration

The remaining configuration data contains label configuration information. The unit of
measurement will be changed from “dot” to “mm”.

*! Label Configuration Information

Label Canfiguration

| Name | Value l | Remark ]

| Vertical Label Size I [E| 07356 mm

| Horizontal Label Size I 104 07152mm

|“'V'erti|:a|foset_“\-’;ll._m-___-“ 0126 0793mm 1733 mm

| HoenialDisatvae: _|| 0126/ 0783mm 1783 mm

| Label Pitch Dffsst 1 = B

Tewof I | Fred |

| Cutter Dfset [ | Fied |

| Dispenser Dffset E || 0| Fired T __i
Label: Gap Size .| .|i Fived

[ Subrmit J[ Reset J

Figure 20 Label Configuration

Use the drop-down lists to make any necessary changes to the configuration. When the
“Submit” button is pressed, the system captures your inputs and issues SBPL commands
to change the settings in the printer.

4.10.3. Print Head Information Display

Some supported model can click on ‘Print Head Information’ button under Configuration to
view the detail information for print head counters and statuses.

7] o - -
S Print Head Information E
Printer Head Status
Name Value Remark
Head Status Print Head OK
Printer Courtter Status
—
MName Value Remark ey Configuration A
Life Counter 10235057375 {mm) —
[ 9 Edit Information ]
Head Counterl 9522512125 {mm)
Head Courter2 316124.25 fmm) [ 39 Printer Configuration l
i Head Counter3 0 {mm) [ d Label Configuration l
d Cutter Counter 18 [ i Interface Configuration l
g Dispenser Counter 0 fmm} 'y Print Head Information
- ) | ) —
Please referto the courter values in Factory Test Prirt 5 Recently Used Tools a

Figure 21 Print Head Information Display -
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4.11. Export/import Profile

The effort and time required to populate the application’s treeview with the correct
printers and folders, need not be repeated every time you start the All-In-One
application. By saving the “profile” of already detected printers into a file (in XML format),
the application will not normally need to auto-detect printers on the network again, unless
you force the software to do so.

The profile can also be exported to other computers connected to the same printers, so
that the same treeview information can be restored without delay.

The following information is captured in the XML profile file:

- Folder Information
- Name
- Tree Level
- Printer type
- Name
- Model
- DisplayName
- Firmware Version
- Folder Name
- Interface Type
- I[P Address
- Mac Address
- Port
- Baud rate
- Parity
- DataBits
- StopBit
- HandShake
- PortName

Click File->Export Profile or File->Import Profile to download or upload the printer
configuration profiles.

4.11.1. Using External Profile

£ SATO All-In-One Printer Utilities

File | Printer Miew  Tools  Option

i |4 Export Profile E
i j'ﬁ Impark Profile

| Open External Profile |

Exit

Figure 22 Open External Profile
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By default, All-In-One loads printer profile information stored in the application directory during
start-up. However, user can choose to load the printer profile information stored in other
directory.

User chooses an external printer profile by File->Open External Profile. The application title
shows the name of the external profile, to indicate that the current printer profile used by the
application.

&9 SATO All-In-One Printer Ltilities [C:ADocuments and Settingsikonghing\DesktopMest. xml|

File  Printer  Miew  Tools  Opktions  Help
A0 N NN NS R | N N N BN =N N =
=@

(= (CG4 Series) CG408

[E}J (CL Series) PR3AMEBT (Mot Connected)
[Eb [GL Series] gll

(= [GL Serie) P_300008

Figure 23 Using External Profile

File | Printer Migw  Tools O

44 Export Profile

IE:

[an]

=
m

| Close External Profile |

=

Switch to Local Praofile

Exit

Figure 24 Closing and Switching Profile

Close External Profile: This is to close the external profile and loads again the internal
application profile. The internal profile will be loaded during the next application start-up.

Switch to Local Profile: This is to switch to the local application profile but the external profile is
still open. The external profile will be loaded during the next application start-up.
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4.12. Graphics Conversion

This utility provides conversion functions from raster graphics files
(*.BMP;*.GIF;*.JPG;*.PNG) into SBPL commands. Click Tools->Graphic Conversion.

&3 Graphics Conversion [Z||E| |

Select Picture File

C:Documents and Settingshkonghing\DesktophUntited-1 copy. gif | [ Open ]

Ficture

&3 SATO All-In-One Printer Utilities

File  Printer  View  Tools  Cphions  Help

Pl o3 ) B X

2 Hm
= (Online state :Wait to receive - Mo error) MB200i

Marmal ][ Stretch ]’ Center

SBPL Command

=H DA FOT IFE DAt i o i i o o o oty g g g o i i g gt g g o o gt o o o i i g
BT L ] B R R
Ty Ty T TO0FFBEEF7YEEBEBEEEEEEEBEBEEEBEBEEEEEEEBEBEEBEERE
EEEEEBEEEEEEEEEEREEEEEBEREREEEBEREREREBERERERASIDAFFERDDDDODODDDDODODDDDOD
oooooboooboooDDDODODDDDODODDDDDDODDDDDDDDDDDDDDDDDDDDDDDDDDDDDDFS
1 N L L L L T L
f7Frheib457EFODDDOODODDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDODDDDDDDDDD
DOODDDDDDDDDDDDDDDDDDDDDDDDDDFOOFAMAE BT PR TR 77 P TR 7 FF P TR 7 fF T TR TR T TR 77T
FR R TR TR T TR R T P F R T 7 TR 7 7 P TR 7 7 7R F 7 TA0ERARBEEEEEFEBFERFEBFEBFEBFEEFERBFERFE

Save ] [ Close

Figure 25 Graphics Conversion

Click the Open button to browse for the desired graphics file. A preview of the file will be

displayed. You can also edit the graphic by using the Stretch or Center button, or reset the
changes using the Normal button.

The appropriate SBPL commands for printing the file will be displayed in the bottom-most
window. Click Save to save the commands into a file, or click Close to end the conversion.

4.13. Loading Graphics

Click Tools->Graphics Download. This function allows you to upload and store the
graphics into the memory of a printer. It supports the following graphics formats:

- BMP

- JPG

- GIF

- PNG

The function supports the following types of uploading formats:
1) SATO Graphics (ESC+GR/GI command)

2) Bitmap Images (ESC+GT/GC command)

3) PCXImages (ESC+PI/PY command)

4) Logo in Internal Flash (FD command)

SATO All-In-One Application 26-60
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GraphicsDownload

Select Printer and Slot
Registered Printer |DR3DSE Printer [ DR30Ge - Port: LPT1) v

hemary Shat | Irternal Flash W | Information

Select Picture File

Graphics Operstions
Registor ID [1-399] Dither Made: | Disatiled
Graphic Type |SATOGraphic [GIGR Command] v'| File Size Max 1 04x400@8dotinm, 156600 2datimm
‘ Open ‘ ‘ Downiload ‘ Dielete Delete ALL ‘ ‘ Dizplay ‘ ‘ Test Print ‘
Image D Image File Graphics Type Dither Mode File Size(Byte)

phic [G e EBOOOS

[ Load List ][ Save List J

Picture

>

4| il . | @

Close

Figure 26 Graphics loading
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4.13.1. Dithering Effect

For Bitmap and PCX files, the Dithering effect feature is available to allow downloading
of graphics with color fading effects.

S GraphicsDownload

Select Printer and Slot
Rediztered Printer | DR308e Printer ( DR305e - Port: LPT1) W

hdemary Slhot Irternal Flash | |nfaorrmation

Select Picture File

Graphics Operstions —
Fegistor 10 [1-999] |52 = Dither MoRle: | [§

Graphic Type | BMP [GTIGC Comimand] * | File Size Max [99993 Bytes]
‘ Cipen ‘ ‘ Diowvnload ‘ Delete ‘ Delete ALL ‘ ‘ Display ‘ ‘ Test Print ‘
Image D Image File Graphics Type Dither Mode File Size(Byte)
a0 CDocuments and Settingz\al User...  SATOGraphic [GUGR C.. Goo0g
51 ChDocuments and Settingz\ll User...  BMP [GTAGC Command] Mode3 51988
Load List I [ Save List
Picture

Close

Figure 27 Dithering Effect
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4.14. Font Downloading

Click Tools->Font Download.

& Font Download

Direct

Printers

Regiztered |Esfd [ GT Series - Port: LPT1) -

femary Card |Cartridge Memary b

Fort =) to downlosd
Dovenloaded Fonits

‘ Add ‘ Dovvnload ‘ Remove ‘ Clear H Dizplay H Test Print ‘

Fort el Fort Mame Forit File File Size(Byte)  Characters  Style Code
atial ftf 367112 bytes All Detault

t Bell T BELL.TTF 4540 bytes All Extended

[ Load List ][ Sawe List l

Cloze

Figure 28 Font Download

Full set of True Type Font (TTF) can be downloaded to the extended memory or cartridge.
Whereas only selected size font (bitmap font) can be downloaded to internal flash. The
following shows the steps of downloading full set of TTF into extended memory or

cartridge.

The Font information can be reused and applied onto another printer by using the “Load
List” and the “Save List” functions.
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4.14.1. Font Selection

£ Font Selection

True Twpe Font List

Select the Font pou wish bo dowvemload and click the "Select” buttan.

i e F v -~
=] 3 GEMCYE.TTF |
HiE

E.
4 0 GEMCYH.

MAAMD O SAFontstahronbd.
Algerian C:wwINDOW S Fonts AL GER. TTF
Andalus CowWIMH D OW S SFontshandlso. b
Angsana Mew C:wwW IR D OWS W Fonts WA HNGSAS. TTE
=] Angzana New Bold CwWIND DWW S Fonts AN GSAE. TTF
(F 3] Angsana Mew Italic Crow TN D O S Fonts WM GSAL. TTE
AngsanalPC CowWINDOWS S Fonts W aMGSAU TTF
AngsanalPC Bold C: WM D OWSWFontsh aHGSAUB. TTF >
Frewview
Agency FB

This is a test string. ABC abc 123
Estimated file size : 38320 bytes

Style Code

Recall Parameter Setting
& wwithout specifying international character set The Font will be recalled by ESC+R D <x> command.
Flease define the <= wvalue here.
. . ) = I ol
€3 Ewmtension international character et 220 Walue: | ~ | Cartridae Font values

< Standard international character set i

2 Double-byte character set

¢

[ selest ][ Cancel |

Figure 29 Font Selection

When the “Add Font” option is selected from the popup-menu (5), the above dialog box will be
displayed to let you select the font to load.

- Without specifying international character set
This option is for User TrueType Font load. The command will have a prefix
ESC+RD<x>00, where x ranges from ‘U’ to ‘Z’, to be specified by user.

- Standard international character set
This option is for Code Page 850 character set. The command will have a prefix of
ESC+RD<x>10, where x is specified by user according to the font style:

F FuturallBook

G CG Triumvirate Condensed
P CG Palacio

S CG Century Schoolbook

\Y Univers Medium

u,v,w,x,y,z User True Type Font

- Extension international character set
This option is for a font that contains an extension international character set such as
Arabic and Thai. The command will have a prefix of ESC+RD<x>20, where x is
specified by user according to the font style:

V Univers Medium
t CG Times
T Angsana UPC

u,v,w,x,y,z User True Type Font
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- Extension international character set
This option is for double-byte character sets such as Chinese, Korean and Japanese.
The command will prefix with ESC+RD<x>00, where x is specified by user according to

the font style:
C Simplified Chinese (GB2312)
C Traditional Chinese (Big5)
K Korean (HYGungSo-Bold)

u,v,w,x,y,z User True Type Font

4.15. Bitmap Font (fixed size) Download

Bitmap font with specific size can be downloaded into the Internal Flash of the printer using FD
command. The font downloaded with this method can be recalled using the ESC+RF command.
Refer to the command specifications of each model for details.

&5 Font Download

Drirect |
Prirters
Fegistered Printer | td-10e [ M-10e - Port: LFT2) s
fdernory Card Slot | Internal Flazh b | AvailabledT otal Size: @
Font(z] to download
Diownloaded Fonts
Add D ovenload Remowve l Clear l l Dizplay l Test Print
Fontld = Font Mame Font File File Size(B pte] Characters Style Code

Figure 30 Selecting Internal Flash for Bitmap Font Download
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The Refresh button is to get updated storage information of the Internal Flash. Note that the
storage space is used for both Bitmap Font and Graphics downloaded using ESC+FD
command.

Font Storage Information

Crwerall Selection List

Fort I 5-01 e Font Mame: |_ | *Max 32 Characters sal .
| _ elections
Selected Font |Ar|a| [ Regular, Size 10] | [ Change Fart ] | iBasicilatain
n | * 30 [0025-0042]
.! # .$.% &. (;' [ [y s ..’r 0.1 2.3 31 [00SF-007D]
EEORECR RS ONES C (D [ E |F |G
HilTJJ[KILIM NIOIPIQIRIS T UV W A Y[Z|] Ztalharoniere
NI A R R T A R N T P A AN e | Unicoe 007D 5
o e N e ) R R S N - |

Hehrew ~
Arabic i
Latin Extended Additional
General Punctuation
Superscripts and Subscripts
Currency Symbols

Letterlike Symbols

Murmber Forms

Arrows

Mathematical Operators
Mizcellaneous Technical

B Drawving

Block Elements

Geometric Shapes

Miscellaneous Symbols

Pre=s and hold the Control Key for multiple ranges of characters selection Private Use Area

Alphabetic Presentation Forms

CurrentSelection Arabic Presertstion Forms-4
From [00sF | To [oo7D | Total chars|x | oK Cancel Arabic Presertation Forms-B
: - Specialz b

Figure 31 Download Fixed Size Bitmap font

Multiple range of character set is possible by selecting the character while holding down the
[Ctrl] key. It is able to span across different Character Set.

4.16. Firmware Download

4.16.1.MB200i and MB400i

Select any MB200i and MB400i printer from the treeview, right click on it and choose
Firmware Download from the popup menu. The firmware must be loaded using RS232c
interface.
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&% MB Firmware Download

Printer Infarmation

Printer Hame: mb400i
Interface: Serial Paort; CORM1

|ntructions

1. Switch the ME printer to Download Mode. Then connect it from Host with R5232 cable.
DEw-0ff, DSWE-O, DSW3-0n, DSW-OF [Screen)

2. Select the firrware directany
3. Turn an the prinker
4. Press the [Start Download)] button,

Post-Installation procedure
5. Turn aff the printer after completion of download
B. With the same DSW zetting, perform a Factory Default Clear
Cover Open, prezs and hold the Print and the Feed buttons, then power on
7. Cloze the cover and press the Feed button to do a Factory Default Test Print,

Firrvware Directon

Browze ]

Filez | 0M00_KMJ.EBIN MB dxxi_ 270100071 _10.bin

It
MEB deC2i_27010001_1.bin @

MB 4w 27010007 _2.bin
MB 4w 27010001 _3.bin
MB 4w 27010007 _4.bin

MB 4270100071 _5.bin
ME 4ui_27010001_E.bin

MB 4w 27010007 _3.bin Total File Size

2502 KBytes

[ Start Download ] [ E xit

Figure 32 MB Firmware download

4.16.2.CL, CG, CT, LM, S84 and GT

select Download Mode 3]

Flash Download Mode Boot Download Mode

‘For Advanced User only

Figure 33 Boot or Flash Download

User is to select the download mode: Boot or Flash Download.
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4.16.2.1. Boot Download mode

£ Boot Firmware Download for printer S84 ( Port: LPT1 )

Domwrload Instruction

1. Set the printer to be in Boot Download Mode now.
i] Restart the printer with [ Function + ENTER + DownArmrow + POWER ON |.
i) Use ENTER key to select the correct INTERFACE slot (check behind printer for slot name)
and printer will show PROGRAM DOWWNLOAD READY"
- Use "+ " button and add firrmware files into the list. (NOTE: Do NOT add START WOT file)
. Make sure the file list is correct order for download. {filename with 'boot’ follow by 1" 2" etc ) =¥
. I you are certain and ready click Download’ Button.
. Upon completion of Entire pracess, restart the Printer with Default Setting. [ CANCEL + POWER ON ]

584 Senies

[ N L

[Iriport Matice: Failure in Boot Firrmware Download may cause damage to printer. In some models replacing PCB
board might be anly repair option. Download process might fail if the target interface connection is being used in
Windows Print Spooler (Printer Driver). It is recormmended to stop the Print Spooler Service for the duration of
firrmware download. ]

Firmnware File to Download

Selected Fimware Files Tatal File Size :
File: Marne File Size:
bt
Dowrload Progress
Mame Progress iz Statuz
< >

Figure 34 Boot Download mode

User is advised to take extra precautions when using this function. Instruction on the dialog
must be strictly followed. This process is carried out with a mixture of human interventions of the
printer and the application.

When the first firmware file is completed, user is to set the printer (by pressing button on the
printer) to ensure it is on “Program Download” mode before the next file is sent from the
application. Failure in doing so might cause unexpected exceptions and damages to the printer.
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&% Boot Firmware Download for printer S84 ( Port: LPT1 )

Diawwnload Instruction

1. Set the printer to be in Boot Download Mode now.

i} Restart the printer with [ Function + ENTER + DownArrow + POWER ON |.

i) Use EMTER key to select the correct INTERFACE slot (check behind printer far slot name)
and printer will show 'PROGRAM DOWRNLOAD READY

Use "+ "hutton and add firrmware files into the list. (MOTE: Do NOT add START.MOT file]

. Make sure the file list is correct order for download. (filenarme with ‘boot' follow by 1" 2" ete )

. If wou are certain and ready click ‘Download’ Buttan.

. Upon completion of Entire process, restant the Printer with Default Setting. [ CANCEL + POWER ON ]

584 Series

[y

[Irrport Matice: Failure in Boot Firrmweare Download may cause damage to printer. In some models replacing PCB
board might be only repair option. Download process might fail if the target interface connection is being used in
Wyindows Print Spooler (Frinter Driver). It is recommended ta stop the Print Spoaler Senice for the duration of
firmwvare download. |

Manually set the printer to Boot Download Mode

EZ?:C?;ZI; P Make sure th_e printer islin Boot Download Mode and ready ko accept the File.
- Current File to send ; S84_17000003_3.RPU
File Mar [Use EMTER ke to select the correct INTERFACE slok and printer will show 'PROGRAM DOWNLOAD READY']
s Click OK when Ready,
L:¥Firm ‘
L:#Firm :
L:¥Firm ok ] [ Cancel v
| 1%
Dawnload Progress
Mame Progrezs % Statuz
S84 17000003_1.RPU [SEESEEREs R EE s Rl 100%  File sent, Received ALK
584_17000003_2 RPU |WEEeE s e EE s 100%  File sent, Received ACK
S84_17000003_3. RPU I
&) )
l Ahbort ] [ E «it ]
Figure 35 Executing next firmware file
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& Boot Firmware Download for printer S84 ( Port: LPT1 §

Download [nstruction

1. Set the printer to be in Boot Download Mode now.

i1 Restart the printer with [ Function + ENTER + DownArmow + POWER ON ].

i) Use ENTER key to select the correct INTERFACE slot {check behind printer far slot name)
and printer will show 'PROGRAM DOWNLOAD READY"

Ize "+ " hutton and add firmware files into the list. (MOTE: Do NOT add START.MOT file)

. Make sure the file list is correct order for download. (filename with 'boot follow by 1" 2" etc )

. If you are certain and ready click ‘Download’ Button.

. Upon completion of Entire process, restan the Printer with Default Setting. [ CANCEL + POWER ON ]

[

[Irmport Motice: Failure in Boot Firmware Download may cause damage to printer. In some models replacing PCEB
board might be only repair option. Download process might fail if the target interface connection is being used in
Windows Print Spooler (Printer Driver). It 1s recommended to stop the Print Spocler Service for the duration of
firrmweare download. ]

Firrmware File to Download
Selected Fimware Files i Firmware Book Download Process Completed Successfully, o0k -
File M arne \‘\I) Restart the printer with Default Setting, [ CANCEL + POWER, QN ] File Size
L ¥ Firrmwware 5 84:2-% Standarn 5153 KB ‘
L ¥ Firrmwwareé 5 84:7-% Standarn ok 2014 KB :
L ¥ Firmwwareié 5 84:7-% Standarn - 1953 KB ‘f‘
ot
Download Progress
MHame Progress % Statuz
584_17000003_1.RPU [WeeE R s s s s s el 100%  File sent, Becerved ACK
SE84_17000003_2.RPU |[Wummmsmmmsmnsl 100%  File zent, Beceived ACK
S84_17000003_3.RPU (WM e e e Me ey 100%  File zent, Received ACK
3 2

Cam | [ |

Figure 36 Download Complete

When the downloading processing is complete, user is to perform a default setting on the
printer, manually.

Please note that the downloading process must be complete without interruptions of the
connectivity to the printer.

* Important: for downloading of emulation firmware, it is important to refer to the respective
firmware download manual for the correct procedure. Certain types of firmware require
downloading of font file in order to get the firmware upgrade process working. The sequence of
files to download also has to be strictly followed.
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4.16.2.2. Flash Download Mode

This function supports firmware loading of GT/CG/CL/CT/LM/S84 with the following
limitation:
- Older CL firmware that does not provide the Auto Download and the Restart
command will not be supported

The download process is automatic, where the All-In-One tool automatically sends the next
firmware file and restarts the printer to perform factory clear + default setting after download
completes.

It supports concurrent firmware loading to multiple printers (of the same model).

&% Firmware Download (CL)

Instructions
MNofe- Thiz funclfion iz only pozzibfe for GT/CL prinfoar (with
LAN inferface} thaf supporfs ) command
1. Set the printer(z]) to OMLIME mode.
2. After firmware files are completely zent to printer,
) a factary clear and default zetting will be performed.
Select Printer 3. The printer will be back to OMLIME maode automatically
INTE o after the whalz process.
4. The whole operation for each printer takes about 3-5 minutes.

CL Series

* Boot firrmware download iz NOT supported in thiz function.
Firrare File to Download
Select Fil=
E:\firmware\CLA05.00.08.00(2120) Latest | Browse
JADROCRRL L . Tatal File Size :
05000800_2 RPU :
- 5111 KBuptes
Download Frogress
Chick and hoid the mayse for maltioie [ Start Download J [ E it J
selection =
Ready
Figure 37 Firmware Download for CL and GT
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4.16.3.GL

This function currently supports firmware loading via a LAN interface. The FTP protocol is
used to transfer the firmware file from host to printer.

The printer will automatically restart after the firmware loading is complete.

& Firmware Download

Instructions

GL Series f 1. Switch OFF the printer. Switch OM the printer while press and hold down the
“"Enter” and “Cancel” K.eys on the printer control panel. Releaze the keys
when “Firrmware Download Mode” status meszage appear an the LCD.

download.

Fleaze make sure that network, connection between the printer and firmsare
downloader FC iz ztable. [t iz important not ba interupt the downloading process
once it iz ztarted.

Firrmweare File to Download

[Screen)
. 2. Select the firware file and prezs [Start Download] button belaw,
Select Prinker
[P 380159 IP- 10.25.5 201 Mate: It is recommended ta print the current caonfiguration of the Printer settings
[P 300008k [ IF: 10,251,123 before proceed with firmware download and restors it back after firmware

Select File

E:MirmwarehGL Printershhirmwaret 0524 PRG

File Size: 5404 Kb

Download Progress

Mame i Frogrezs

Click and hold the monse for multioe [ Start Dawrlaad J [ Euit J
selection —

Ready

Figure 38 GL Firmware loading

4.16.4. TH2 Downloader

User can use TH Downloader Feature to File Printer Wiew | Tools | Options  Help
download package (.pkg) file to multiple TH2 g 28 |3 D) £ | A Auto-Discover
printers concurrently. Select Tools->TH _
= @ Main 3 Firmware Download
Downloader menu to open TH2 Downloader & (CL Serie e d
dialog. Select .pkg file to download, select the ) (GL Serie| 4 Fork Donload
printers to download and proceed with “Start % (=) (LG4 Serief =) Format Download
Download” button. - % [(CCLLS;”E,S I;g Graphics Download
[=141=1 .

] [EJ (TG3 Serl s+ Mass Apply Configuration

L/ (=h [MB4Pro 54 (25]  Send SBRL Commands

: 'E] (CG4 Ser vé Skakus flerts

L (= [GZ Series
b% % TH Downloader )

=l TP fezianenent Tanl
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- SATO All-In-One Printer Utilities

Printer  View Tools  Options  Help

BoRax Bgd@EsEmAN e s
M ain
(B; (L Series - Btd) PR3IAAERT {Online State | Ready)

File

L Information e

(B; (GL Series - Sted) P_300009 (Mot Connected) .
(= [CE4 Series - 5td) CG 408 LY N oy
(b ICL Series - Std) CL .l" -‘.J 2 &
(= (CL Series - Sty PRIGDE2E (Mot Connected) - .-,ﬁ:u,’

@ (T3 Series - StdY PRA1 CA9C (Mot Connected)
ﬁ@ [MB4Pro Series - 5td) MB34Pro Series

Q; (34 Series - 5td) CG4 Series (Mot Connected)
“Q; [GZ Series - Std] TEST
b Q; [TH2 Serigs - 5td) TH2

FPrinter Name ; THZ

Model : TH2 Seres

1P Address - 10.25.7.88

Mac Address - 00:00:00:00:00:00

&5 TH2 Downloader

Package File To Download

Model
o -~ ..

T
e '-‘;‘ |E:\nai‘\M_l,l DocumentzyMy Sato work spaces\MeDonaldzhinstall pkg |
o pasy 27 Kb

Select Printer Download Progress

Mame Progress s Rems

Chck and hold the manse for mistinle "
selection l Start D ownload J [ Exit J

o
Figure 39 TH2 Downloader

4.17. Test Print feature

= @ Main - :
B IREY (5T Series) o ‘L Information
I ) [DRa0ae] DR| 2 Delete

: & (MB400) My Test Print 3 | User Test Prnt(Small) M) .

@ (G2 Senadg Send SBPL Commands User Test Print{Large) r-:d
Save Printer Configuration | Factory Test Prink(Srnall) |
Apply Printer Configuration Factory Test PrintiLarge) ey Name Q_'t
Bl AT A Ije;f .gi—ﬂsggifmumcaﬂon
Skatus Protocal 3 LET Port - LETI

I Frrrmware Verston : 130000 07

Figure 40 Test Print

This feature allows user to send built-in Test Print commands to any registered printer.
The user can invoke the standard test print functions such as User Test Print or Factory
Test Print, in either small or large label sizes.
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4.18. Switching Interface Selection for CG Printer

After the CG printer is added to the application, the interface selection can be switched by

right-click the printer to bring up the Context Menu, and choose the “Interface Mode”.

&% SATO All-In-One Printer Utilities

File  Printer  Wiew

BRI REGEESEE

Tools

Cptions — Help

= b ain

5 (MB200i) MBM

(= (TG4 Series) CG408_1
.5 (GL Series) P_ BDDDDE (Mot connected)

"l

[CGZ Senes

E: % [CL Series]
=
=

WS (CT Series)
4 ) (D5 Series)

55 {GL Series) GL403e
(GT Series) GT412e

Delete

Test Prink

Send SBPL Comrmands
Save Printer Configuration
Apply Printer Configuration

Firmware Download

Interface Mode

2.en _E‘éﬁ.ﬁfﬁ:ﬁ*‘uﬂ@?{

Restark Prinker

RFID Mode Setup

5B Wireless LAMN
R3-232C/LAMN

Kevpad

Figure 41 Switching Interface Selection for CG Printer

Note: User is required to manually restart the printer after switching the printer

interface mode.

SATO All-In-One Application
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4.19. Restart Printer

Currently, this function is only available on CG and GT models.
€3 SATO All-In-One Printer Utilities

File  Printer  Miew  Tools  Opbions  Help
@B RX |5 NS E S EE

= ﬂ M ain
=5 (MB200i] MEM
%Q} (GL Series) GL408%e

(= (GT Series) GT41 2e
() (CG4 Series) CGA08_1

(=h (GL Series) P_300008 (Nat connected)
|: N 1

™,

N

CL Series) CL4 Helete

|
[
[CT Sernies] ct
D5 Seriez] d5

t,: Test Print »

=
s
- &

Send SEPL Commands

Apply Printer Configuration

Firmware Download

Interface Mode 3

Restart Prinker 13 | Restart Prinker

x
(=
£
-Q Save Printer Configuration
g
5%
Ha
=
o
s

| RFID Mode Setup | Restart Prinker with Factory Default

Figure 42 Restart Printer
For CG printer, if the printer is on LAN interface, it will be switched to USB mode after
restarting the printer with Factory Default.

Note: Do not use this function if the printer has just changed the interface mode.

Question r}_(|

Please make sure the printer is on OMLINE mode,
' Are you sure you want ko restart the printer now?
*
Printer with LAM interface takes longer time {~30 second) to restart,

Mote; This funckion will nok work if the Interface Mode of printer has just been swtiched,

| ok |[ Zancel ]

Figure 43 Restart Printer Function will not work if the Interface Mode has changed

SATO All-In-One Application 41-60
User Manual



WATW

DCS & Labeling Worldwide

4.20. RFID Mode Setup (for CG2 and CT4i)

Currently, this function is only available on CG2 and CT4i printer.

&% SATO All-In-One Printer Utilities

File  Printer Wiew  Tools  Options  Help
NN E R e R N NS =

= ﬁ h_*!aln
_'3‘ EEJ (B 2001 MEBEM

(GL Series) GL403e
(=h (GT Series) GT412e
g

(=} (CG4 Series) CG408_1
[EJ (GL Senes} F' BDDDDE (Mot connected)

g
g
Ll

Delete
[CT Senes] o

Tesk Prink 3
D5 Series) d S

@@@@

Send SEPL Commands
Save Printer Configurakian
Apply Printer Configuration

Firmware Download

Inkerface Maode 3

Restart Prinker ]

7 € M E::E;;ﬁilﬁu@x

RFID Mode Setup

Figure 44 RFID Mode Setup

This function allows user to switch between normal mode, RFID mode and enhanced RFID
mode. It is only applicable to printer with the optional RFID kit installed.

&% RFID Mode Setup

RFID Mode
Set to AFID Mode: | LRI Set |
Data Type: |‘I:;’-'-.SEII Vl
Retry Times: |3 Vl
Frint Perrniszion: |St|:||:| Frirting Vl
Rebooting: |Stn:||:| to rebont ?l

Figure 45 RFID Mode Setup Dialog

SATO All-In-One Application 42-60
User Manual



WATW

DCS & Labeling Worldwide

4.21. Sending Printer Command Strings

Right-click a printer icon from the treeview and choose Send SBPL Command from the
popup menu. This function allows the user to send SBPL commands in both text format and
file format. The user can also use it to retrieve printer response from the command.

The response of the printer is displayed in both ASCIl and HEX formats.

&% Send RAW S5BPL Commands to Printer [ GL : LPT1 ]

Send
Send Command File [3 byte] Q
D-#¥doc¥CL 408 commands¥firmwareyersionS B bt | [ Browse ][ Send _”_ Cluerny ]
Command Text ]
Click to enter special character: [ 5Tx | [ E™¢ | [ Esc ][ soH J [ EoT ][ ENG ][ NUL |
rSB Send
[(Clear ]

00 01 02 03 04 05 05 07 02 03| 0A OB OC OD OE OF Data
safaz| [ [ | [ [ | |/ [ [ | |=e

Feceive
Hex Data )
|00 01 02 03 0405 05 07 08 03 04 OB OC 0D CE | OF Tatalbyte
> WM 31 |33 (2E 30 |30 |2E |30 |30 |2E |30 (33 |41 |20 |20 |20
20 |30 |34 |2E |30 |30 |20 |20 |20 |20 |20 |20 (20 |20 |20 |20 -
20 |20 |20 |20 20 |20 |20 |20 |20 |20 |20 (20 20 |20 |20 |20
20 |20 |20 o3 [ 1 [ | [ 1
ASCII Text )
112.00.00.034  04.00 L
Clear
ALL
Ready

Figure 46 The Send Printer command

4.22. Saving and Applying Printer Profiles

g
= { =) (DR303e) D ¥ | Delete
o ) (MB400) &4 Test Print b

----- &y (C2 Ser

"] Send SBPL Commands

|Q Save Printer Configuration |I
g Apply Printer Configuration

LM% Firmware Download

Skakus Protocol »

Figure 47 Saving and Applying a Printer Configuration
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This feature is necessary for users
who need to apply a set of tested

settings to many printers at once.

For Saving Printer Configuration, an
SBPL command will be executed to
retrieve the Printer Configuration of
the selected printer. The information is
then saved into an XML file specified

by the user.

For Applying Printer Configuration, the
command will be executed after
reading the XML file which is specified

by the user.

An example of the XML file is shown
here (Figure 30).

23 C:\mb4.xml - Microsoft Internet Explorer ' J

File Edit Wiew Favorites Toals Help ","
& bod
o ] ﬁl B ¥ B ;
@ Back = x | h P Search \:-;--é/ Favarites
Address | C:imbe.xml v e
~

=7uml version="1.0" encoding="utf-8" 7=

- <Model value="MB400i"=
=<PrintkMethod value="" /=
=<PrintResolution value="8 dot /mm" /=
<PrintSpeed value="753{(mm/fsec)" />
=PrintMode value="Continuous" /=
=< CuttertMode wvalue="Label" /=
<DispenseMode walue="" />
=<LinerlessMode value="" /=
=PrintDarkness wvalue="A" /=
=DarknessLevel value="Level 4" /=
<SensorType value="Gap sensor" />
=ZeroSlash value="Enabled" /=
=kKanjiCode value="§hift JI§ code" /=
<MediaType value="" /=
=<InitialFeed value="Disahled" /=
<ProportionPitch value="Proportional pitch" /=
<LabelHeight value="300" /=
<lLabelwidth value="104" /=
<vVerticalStart value="0" /=
=HorizontalStart value="0" /=
=lLabelPitchoffset value="0" /=
=TearOffset value="0" />
<Cutteroffeet value="" /=
=Dispenseroffset value="0" /=
<CompatiblePrint value="3" /=
<LabelGap value="3" />
<BuzzerSound value="0n" /=

=/Model=

|£

'-E] Done *j My Computer

Figure 48 XML File
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4.23. Mass Update of Printer Configuration

This feature is to apply a printer configuration to more than one printer (within the same
model) concurrently. Click Tools->Mass Apply Configuration.

&) Applying Printer Configuration
Select Model

Frinter tModel | CL Series

Select Configuration File to apply

Configuration File i[ Browse ]

Select Printers
Prinker List

Select by
) Al Printers Printers Status
cllpt [ Part: LPT1]

Oy Current Folder cl [P 10.25.1.221]

Current Folder + Subfolders

Select All
Select Mone

[
|

Figure 49 Mass Update of Printer Configuration

After selecting the printer model, the user can choose the printer configuration file (that
was previously saved as explained in section 4.22). A list of printers of the selected
models will be displayed. User can hold the Control Key to perform the multiple
selections of the printer to apply the configuration.
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4.24. Application Configuration

Some aspects of the application can be configured at Options->Preferences

=

% Preferences

General

Show splash screen on startup

Save Treeview information when exit application
Load last saved Tree\iew information when startup
[ ] Enable Debug Logging of &pplication

[] Discover unknown printers

[ ] Auto resolve Model for unknown printers

Application
Maximum number of printers for concument download:

ra
in

Status Monitor refresh interval [ 300 - 50000 msec | 2000

Log file directory |e\SATO_AllHn-one log [

iz wil fake effect on Bhe next sopfcation &3t o)

Default Language | English R i

Save Cancel

Figure 50 Preferences Dialog

This should be the only proper way to change the application configuration information.
Configuration files should not be modified without advice from SATO technical staff.
In case of application problem user should check “Enable Debug Logging of Application” feature

and run the application to recreate issue and provide SATO_All-in-One.log file to customer
support for help.

4.25. AutoDiscovery Setup

To refine the AutoDiscovery feature use the setup dialog available from Options->Auto-Discover
Setup menu. This is option is meant for advance user who has good knowledge with networking
on PC. This dialog allows changing the default interface to send discovery packages. Multiple
broadcast address could be added to suite the various customer needs.
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o5 AutoDiscovery Setup u@
Local Interface Selection

Local Network Interface
| Intel(R) 82566MM Gigabit Network Connection - VirtualBox Bridged Networt|» |

MName : | Local Area Connection |

MAC Address :  |D0:1A6B:3679:13 |

P Address . |10.257.77 |

Broadcast Address Setup

Broadcast IF Add | |0.0.0.255 |

255 255 255 285 Samples:

Remove | |ncal Network Broadcast IP
255 265 255 255 (Default)
Directed Broadcast IP
10255255 1025255256
(Mote: Router must be configured
accordingly for Directed Broadcast to
work)

Aoy | [ cancel |

Figure 51 AutoDiscovery Setup Dialog

4.26. Configuration of Network Interface Card

For SATO Printers equipped with Network Interface Card, the network properties (such as IP
address and Wireless settings) can be configured by choosing the “Interface Configuration”
function.

Edﬂ)' gt (Online state  Wait to receive : Mo errar)

A g, CLaos
W M0 £ Wireless LAN Setting
| 32 Chars[mas.]
£ Network Interface Setting Ehariel 1 o
Appl Cl
Authentication: Open System v R oo
MacAddess  |00-803201-0C42 WEP Config | wEP 802.1% Config || 'WPA Config|
lUse DHCP [] USE R&RP
IP Address 1025159 ® Disable Key Size:
0| |
Deteul Gateway O key2 | |
) Kepa | |
0o )
Hint an character counts:
10 Hex Chars [ 0-9, AF )
Figure 52 Configuration of Network Interface Card
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4.27. Check for Newer Version of Application

The application offers a feature to help user to check if a newer version of the application is
available on the website.

File  Printer  Miews  Tools  Options | Help |

o 2R (5] 2 B K |23 [ 45 | @) FeQ !
= @ Main 39 Technical Support
| [GT Sefiez] gt
E [EJ (DF30%2] DR 308s | Check for Update |
[EJ (B0 MB T O About SATO

L (CE2 Series) CGL

ﬁ about This Application

Figure 53 Check for Update

If there is a newer version, the following dialog will be displayed.

Mew Yersion Available X]

P There is a newer version available For this application,
\':) Current Yersion @ 1.0.73.0

Latest Yersion :1.0.74.0

Lo wou want to download latest software now?

Figure 54 Found newer version

If the user clicks the “Yes” button, an Internet Browser will be opened to download the latest the
application package.
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4.28. Changing Communication Protocol of GL4

The communication protocol of GL4 printer can be configured by right-clicking on the GL printer
node, and then choose “Communication Protocol”.

5% SATO All-In-One Printer Utilities

File  Printer  Wiew  Tools  Options  Help

)50 0 £ |3 i 4l ] o i )

= @ Main
u [Eg (GL Series) td (Online | Ethermet'Sholi
¥ Delete
= Test Print b
#|| Send SBPL Commands
,_H Save Printer Configuration
Q Apply Printer Configuration
% Firmware Download
‘ﬁ' Communication Protocol 3 || Status 5
Status 4
Status 3
Status 2
Standard

Figure 55 Changing Communication Protocol of GL4

The printer is not required to be restarted after this operation.
This function is only applicable for GL4 printer with LAN/WLAN interface mode.

4.29. Send SBPL Print File to Printer Driver

This function allows sending of SBPL print file to SATO printer driver. The print
file will be sent to the print through the interface defined in the driver properties-
>Port Setting.

Note that the driver settings such as Print Speed or Print Darkness will not be
applicable to the print file.

Click Tools->Send SBPL to Printer Driver
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& Send SBPL To Printer Driver

File | [ Browse |

Frinter Driver | SATO Mi-10e [SATO M-10e) v|
[Printer Spooler must be running)

[] Interval |:| (mili-zecond)

[ Pririt ] [ Cloze ]

Infarmnatian

Thiz function allows sending SEPL command print file to SATO printer driver. The priat file
will be zent ta the printer through the interface defined in the part zetting of the driver

Mate: The properties zetting in the printer driver will not be applicable in the printing

Figure 56 Send SBPL to Printer Driver

Only SATO printer drivers installed in the PC will be displayed.

If the print file is to be printed more than once, and delay is needed in between
the print files, then check the Interval checkbox and input the time delay value
(in millisecond, 1 second = 1000 millisecond).
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4.30. IP Assignment

This function allows user to perform quick search of all Sato printers connected to

network. Some network configurations such IP and SubnetMask settings are possible.

Click file menu->Tools->IP Assignment Tool

& Printer Network Setup

Refresh ] ’ J— ] ’ Rehoot LAN ] ’ Restart ] ’ il ] [ Setup ]

Printer ...  IP Addresz | Mac Addressz Infa Status

PR3IGFDAD 10251226 00:80:9236:F0AD SATO PRIMTER Online state | Ready
PR3GF09B 10251228 00:80:9236:F0:98 SATO PRIMTER Online state | Ready
PR3I&AEE0 10251220 00:80:92:34: A6:50 SATOPRINTER'WL  Offline state
PR3I&2CC2 10251227 005092 342C.C2 SATOPRIMTER online state | Ready
PR3IGFO1A 10251224 00:80:92:36:F014  SATOPRIMTER Online state : Ready
PR3GFO1A 10251224 00:80:92368:F014  SATO PRIMTER Online state : Ready
SCCIEE4D 10251 222 08:00:1F:C1:EE4D  AR-C2ZEZM Online state : Ready
PRIAAESD 10251220 00:80:92:34: 86880 SATOPRIMTERWL  Offline state
PR3IAZCCZ 10251227 008092 3A2C.C2 SATO PRIMTER Online state | Ready
PR3GF09B 10251228 00:80:9236:F0:98 SATO PRIMTER Online state | Ready
PRIGFDAD 10251226 00:80:9236:F0AD SATO PRIMTER Online state | Ready
SCCIEE4D 10251222 0S:001F.C1.66:40 AR-C2E2M online state | Ready

Ready

Figure 57 IP Assignment Tool

&3 Network Interface Setting

MAC Address | 00-80-92-3A-2C-C:
[] DHCP RARP

IP Address | |
SubnetMask | R |

Default Gateway |10.25.1.235 |

Mo YWireless Lan

‘ Ay | ‘ Cloze

]

Figure 58 Network Setting
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4.31. Unit Convertor

This function allows user to perform unit conversion among dots, mm,
cm, inch and hex, in the corresponding resolution.

Click file menu->Tools->Unit Conversion

= UnitConvertor

Canyersion

Prirter Rezolution: |203dpi 3 dotzinim v |

Conwerting From: ) dots O omm Oem Oinch O hex

Converting To: O dotze @ mm O oem O inch (O hex

Converting %alue: |2IZIS |

I Convert H Clear ]

Fezult

Converted Value: (254 |

Figure 59 Unit Convertor
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4.32. Status Alert via Email

This function sends alert emails to the specified users if an error occurs on the
monitored LAN/WLAN printers. Click file menu->Tools->Status Alert

By default Popup is enabled to disabled check the Disable Popup top right
corner of Alert Configuration dialog box. Alert popup will appear top right corner
of Display Screen.

&3 Email Alert Notification |;E]EJ
Alerts Delivery Setup [Global Setting)

. —
CG2 Series % Email | Log Filei Enable Email Alet [] Enable Log File [ Dizable Popup
s SMTP Mail Server Email Fecipients
S elect Printer Server Addresslyour_EmaiI_Server_addre3s| ’_ .-’-‘tid ][ Edit J[ Remave J
CG2 Senes - 1 [ [P 10256 36] Port Mumber [] UsessL Ezz:aggzmﬁzzi:zgm
LGZ Series [ 1P 10.25.5.101) Mail Server Authentication
GH412TT [IP: 10.25.5.137)
PRIGDAZE [ IP: 10.25.6.207 User Name |usemane |

GLL [IF: 10.25.5.118)

PaSSWD[d |.......... |

Sender Email |.t’-'«||—|n-Dne@c:0mpany.c:0m |

Subject |Email Alert |

Alerts Matifications [tems Setting For Selected Printer

DOifline Cawver Open PrintHead Open
Paper End Ribbon End Battery Low
Ribban Law Buffer Low Rewind Ful
B uffer Overflaws Errar Battery Ermrar Senszor Enor
PrintHead Errar Media Eror Cartridge Errar
Card Error RFID Tag Error RFID Protect Errar
Cutter Errar [] Connection Ermar Other Errors
g;:zﬁ;;:f hald the monse for maltiple [ — l [ Earcal ]

Figure 60 Email Alert Notification

Note : User is to specify the address of out-going email server (SMTP Server).
Depending on the email configuration, user might need to provide information of
an authenticated email account under the “Mail Server Authentication” in order
to make use of the server to send emails.

SATO Printer Status Alert

Figure 61 Alert Popup Dialog
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£ Email Alert Motification

CG2 Series

Select Printer

ez -1 [P 1 |
CG2 Series [1P: 10.25.5101)
GHAT2TT [IF: 10.25.5.137]
FRIEDEZE [ IP: 10256207

Click and bold the mouse for muitipie
selection

Alerts Delivery Setup [Global Setting)

Emau"-LC'Q File | Enable Email Alet ([Z] Enable Log File ) [] Disable Popup

ﬁ_ng File |E:'\Dcu:uments and Settingshuserdh D ezktophlog, tat i [:] J

Alertz Mohifications [tems Setting For Selected Prinker

Offline Caover Open
Faper End Ribban End
Ribbon Low Buffer Low

B uffer Owerflaw Errar B attery Erar

FrintHead Ernrar Media Eror
Card Error RFID Tag Error
Cutter Errar [] Connection Enror

PrintHead Open
Battery Law
Rewind Ful
Senzar Eror
Cartridge Error
RFID Protect Ermor
Other Errars

| spol | [ cancel |

Figure 62 Log File

Detected errors can be logged in a log file by enabling the Log File option and

provide a log filename.
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4.33. Real Time Clock (RTC) Setting

This function is to send the RTC configuration command to the printer. It is only applicable on
those printers with RTC module installed.

File  Printer  Wiew  Tools  Opkions  Help
A0 N NI E R e N i N NN =

= ﬂ h:'!ain
_'3‘ @ [MB 2001 kB b

(=4 (GL Series) GL4D8e
(=4 (GT Series) GT412e
g

(=) (054 Series) CGA0E_1
(=4 [GL Series) P_300008

-

[CGZS erles] ChG2

=
5 RE
=3
=3

‘|

Delete

IL [CT Senes]

W & (D5 Series) Test Print "

Send SEPL Commands

Save Printer Configuration

&1%@&

Apply Printer Configuration

"% Firmware Download

Al

RTC Configuration

Figure 63 RTC Configuration

By default, the current date/time from the host system is displayed as the setting. Upon
changing the value of the drop-down list, the value of the date/time is changed accordingly.

&% RTC Configuration

Set RTC Configuration
Y'ear kdanth Dran Haour kdinLite

Ml (3 v |23 v |17 ¥ [0 v

Date: 2000/73/29
Time: 1730

Refrezh ] [ Submit

*Thiz funchion will only work when BTC module 1z installed
in the printer.

Figure 64 RTC Date/Time Setting

Click the “Refresh” button to get the updated date/time information from the host PC.
Click the “Submit” button to send the RTC Setting command to the printer.
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4.34. Format Download to Keypad

This function is to send the Format files to the keypad via the printer. It is only applicable to
those printer models which support Keypad and download can be done only when keypad is
attached to printer. Format Files are created with SATO Keypad Tool software. In Format
Download Dialog click Open button and select SD Card folder \Data\FMT\FMT_xx\*.dat file to
download to printer.

&% Format Download

Format Deszign

Dezigner Application Installed  [SATO Kevpad Tool vH Start Application ]

1. Pleaze zave the label farmat bo a destination lacation uzing 50 Card Oukput,
2. Open the zaved label format and download it wia printer.

Format Infarmation

Format File: | FMT_0001.DAT |

File Destination: | CATemphSDADATANFMTYFMT _OO0NFRT_0007 .D.-'l‘-.'| Open

FormatNo. | 00m| | Ed
Faormat M ame: | Layout] | Edit

Farmat Size: | 264 |

File Size: 273 |

Crawrload Farmnat

Drownload Mow [] Clear &)l Farmats Before Download

Status: Mone

Figure 65 Format Download to Keypad

4.35. Status Bar Icon, System Tray

All-In-One tool provide Status Bar icon so that if needed user could run All-In-One tool in
background and minimize to System Tray. If Close to Tray setting is selected, Application will
minimize to System Tray when user try to Close the windows without using File->Exit menu.
Exit menu will actually exit the application from System Tray as well.

3 Fimware Download
Close to Tray
[Z] Format Download
Restore
Hide ko Tray
Exit

&S0 TERES , 15w

Figure 66 Status Bar Icon and menu
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4.36. Shortcut Menu to SATO External Tools

All-In-One tool provided shortcut menu for all tool installed under “SATO” Start Menu Program
folder. This provides quick and easy access to other SATO software user might need directly
from All-In-One tool.

& 5ATO All-In-One Application
Stardock » AEPWOrks y
Startup ’ PSim b
Strokelt » TH2 Utility b
Symantec Endpoint Prokection ¥ [} === Keypad Tool
TeraZopy * Eﬁ Kevpad Tool Operation manual

File  Printer  Yiew T{u:upl_sa Cptions  Help

g 70 | 3 &) 1 dl Auto-Discover E P M =
= “ _I| Firrmware Download

: % Egt gg::g q} Font Download &)

e EEJ [CG4 Sened F2J|  Format Download

g [EJ (CL Series 1 [ 2 izraphics Download
B S (CL Serie| 1 o
B [Eb (T332 Seri a3 Mass Apply Configuration
- h[‘é‘; (MB4Pro 54 #7]|  Send SBPL Commands
] % Eg; g SEN | Status Alerts
. | eries |
: B[Eb [THZ Serie 3, TH Downloader
lteal TP Assignment Taool
_.',,'ﬂ iGraphics Corversion
|

Send SEPLTa Prinkter Driver

nit Converkor

| AlIUSERSATO r : keypad Tool Operatior
AEP\Woarks Kevpad Tool
PSirm L4 .
THZ Ukility 3

Figure 68 Shortcut Menu to SATO External Tool via All In one
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4.37. Non-Standard Protocol

All-In-One use Standard Protocol for sending or querying data to printer. In Standard Protocol
mode, commands are started with ESC (Hex 0x1B). SATO printer can be operated in Non-
Standard mode where escape character where printable characters (eg. * character is used
instead of ESC for command).

User can identify the current protocol by looking at the main treeview, before the printer name.
By default printer were added as Standard protocol and user has to manually change to correct
protocol mode by using context menu of printer in treeview.

User can change the Non-Standard code while switching to Non-Standard protocol.

‘ b ain
L Series - Mon-Stdy PR2ZAAGRT Onlme State | Readyge
% EGL Series - Std) ﬁ:l.-..-..-..-..-. s I: = 3-' &5 StandardProtocol E@@
! [2] (L4 S'_EHES Nore3 Delete Pratocol Code
L EEJ [CL Series - Std] CL Test Prink r

b
= (CL Seri Stu:n[EJ N Standard Non-Standard
BrlES - = . tandar on-Standar
=] Send SEPL C d
B 5, (703 Series - 5| 2| 5o 5P Commands | T
g EEJ (MB4Pra Series - St sl Save Printer Configuration 5 —
. EEJ {CG4 Series - 5tg E:S Apply Prinker Configuration =
{(2h (GZ Series - St) TE o 3 ESC
] EEJ [THZ Series - Std) T| 1 Firrnware Download 4 ENO
IC EEJ [CGZ Sernes - Std] 2 |‘,qi'7 Mon-3tandard Prokocol . CAN |:|
Mon-Standard Protocaol 6 NULL
Send ] [ Cloze l
Figure 69 Standard and Non-Standard protocol
4.38. Software DIP Switch Setting
Some printer models such as GZ =Y (G2 Series - 5td) TES
Statrt[es sgpgo:ctt SettmgS[B)IIDPLSWItCh ] h[@d [THZ Series - Std] Delete
setting via Software, command. {2 (C62 Series - Std) st Print ,

This feature provides easy way to
setup DIP Switch setting via AlO Tool.
Please note that at present, reading of
current DIP Switch setting is not
supported. That means the setting
displayed upon loading of dialog is just
the default setting which may not be
the same as the current setting of
target printer.

Right click on printer name and select
DIP Switch Setting from context menu
to invoke DIP Switch Panel dialog.

Send SBPL Comrmands
Save Printer Configuration
Apply Printer Configuration
Firrnwate Download

Mon-Skandard Prokocol

RTC Configuration
DIF Switch Setting

BE e % s B i [ 0D X

Figure 70 DIP Switch Setting Context Menu
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Use Mouse to click on DIP Switch as desired and click Set button to send SBPL command to
printer. User could choose the command protocol to use either SBPL or SZPL using radio at the
bottom of dialog. Preset commands listed some other useful preset command to sent to printer.
Please note that last two Reboot command can only be sent when the printer is in Download
Mode. The command will be ignored in Online mode. (Note: At present, only GZ printer support
this feature.)

& DIP Switch Panel (=t

DIP Switch 2

oM

OFF

21 2-2 23 2-4 25 2 27

DIP Switch 3

oM

OFF

3 32 33 34 35 3k a7 38

Frezet Commands
Factory Mode w

Lammand Frotocol "Mote: DIPSW commands are valid

@ SBPL () SZPL Close anly when DIPSW 28 s ON.

Frezet Commands

Factory Mode w

Hex Dump Mode

Diownload Mode commatids are walid
Reboat [In Download tMode] er DIPSW 2-B iz OM.
Reboot with Factory Default [In Download Mode]

Figure 71 DIP Switch Panel
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