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Using the Image Print Server (IPS)
Software with the

KODAK PROFESSIONAL
Digital Multiprinter

This document describes how to use the Kodak Professional Image Print Server 
(IPS) application for Windows NT Workstation 4.0 Systems with the Kodak 
Professional Digital Multiprinter and the Kodak Professional Digital Multiprinter II.

The IPS application enables printing of TIFF images and provides easy, intuitive 
methods for performing simple print management operations that include:

• applying a tone scale correction to images

• inserting new images into the print queue

• stopping or suspending and resuming the processing

• deleting images from the queue

In addition, the IPS application allows you to monitor a specified folder for TIFF 
images to add to the print queue.

Communication Channels

Your computer can print to the Digital Multiprinter through a SCSI connection only.
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Using the IPS Software with the KODAK PROFESSIONAL Digital Multiprinter
Definitions of Terms
The following terms are used in this document and are defined here for your 
convenience.

Source Directory Folder or directory that is designated for holding TIFF 
images to be printed.

Hot Folder Another term for Source Directory.

Attended Mode The mode in which all errors are displayed through a 
dialog box. When the application is in Attended Mode, it 
stops until you exit the dialog box.

Unattended Mode The mode in which the only errors that are displayed in 
dialog boxes are the errors that require user intervention. 
Errors that do not require user intervention, such as 
invalid file format, are logged in the log file.

Enqueue Insert a new image into the print queue.

Dequeue Remove one image from the print queue. Only the top 
entry in the queue is removed.

Flush Remove all images from the print queue.

Suspend Prevent the application from sending another image to 
the printer until the application resumes. When you select 
Suspend, if an image is processing or going to the 
printer, this image will complete before the application 
suspends. When the application is suspended, it will not 
scan for images in the hot folder.

Resume Return the application to normal operation.

Order Punch An indicator on a print to specify that it is the end of an 
order.

Tiff Downloader Another term for the Image Print Server (IPS) application.
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Installing the IPS Application
Before you perform the installation, make certain you are familiar with the 
Windows NT operating system.

Hardware Requirements

The following is the minimum hardware required for the IPS application:

• 64 MB Main System Memory

• 100 MHz PENTIUM Processor

• VGA Monitor (640 x 480 spatial resolution)

Software Requirements

The following must be installed on your computer:

• Windows NT Workstation 4.0

• An ASPI-compliant SCSI interface driver (recommended: Adaptec 2940 SCSI 
card)

Installing the Software

Downloading the Installation Application

1. Place the IPS application CD in your CD-ROM drive.

2. When the Internet Browser appears, select Digital Multiprinter (KPDM).

3. Scroll to Image Print Server and click KPROImagePrintServer.
You may need to enter information such as your name and the serial number 
of your printer. If so,

a. Follow instructions on the screen and click Download Software.

b. Click in the appropriate location on the next screen to continue 
downloading.

4. If a dialog box appears asking if you want to “save this program to disk” 
accept the dialog box (do not launch the program from the browser).

The Save As... dialog box appears.

5. Either accept the path shown or click Browse to select another path for the 
KProImagePrintServer.exe file.

6. Click Save.
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Using the IPS Software with the KODAK PROFESSIONAL Digital Multiprinter
Installing the Application

1. From your Windows Explorer program, double-click the Image Print Server 
application (from the location designated in step 5 under “Downloading the 
Installation Application” on page 3).
The splash screen and setup messages appear.
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The Welcome screen appears.

2. Click Next>.
The License Agreement screen appears.
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3. Read the License Agreement.
• To accept the license agreement, click Yes.
• Or, to cancel the installation, click No.

The Readme information appears.

4. Click Next>.
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The Choose Destination Location dialog box appears, showing the 
destination folder and file name for the IPS application.

The default installation location for both the application and the tone scale 
correction Lookup Table (LUT) that can be used by the IPS application is 
“C:\Eastman Kodak\KPro Applications\Image Print Server.”

5. Either:

a. Leave the destination as is and click Next> or 

b. Click Browse, change the destination, and then click Next>.
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The Setup Complete screen appears.

6. Click Finish to complete the installation.
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Using the IPS Software with the KODAK PROFESSIONAL Digital Multiprinter
Using the Image Print Server 

Before You Begin

When you begin using this application, you need to set Source Directory 
Preferences (see page 15). To do this you need to: 

• know whether printer calibration was performed using Density aims or 
Lightness aims; this will determine whether you apply tone scale correction

• know which printer LUT and Paper Pak files you want to use for each 
magnification you expect to print

• set up a log file on your host computer so the application can log errors

• designate a Source Directory (or hot folder) on your host computer, even if 
you do not send images from the Source Directory and you only enqueue 
(see “Definitions of Terms” on page 2) images one at a time

IMPORTANT:Set up the Source Directory for one use only—as a temporary 
source of images. Do not specify a directory that contains images 
that you want to keep. Once the images are processed from the 
Source Directory, they are deleted from that directory.

Do not specify as a Source Directory any directory that is on a 
read-only volume.

If you will be adding any print devices, you need to know the number of the SCSI 
Host Adapter and the SCSI ID for the devices.

Starting the IPS Application
• From the Start menu of the host computer, select Programs>Eastman 

Kodak>KPro Applications>KODAK PROFESSIONAL Image Print Server.
The display shows the IPS Launcher window.

Add a device if no device icon is in the window or if there is no icon for the 
device from which you want to print. You can also update or delete the device 
information.
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If you do not need to add, update, or delete a device, go to page 13.

Adding, Updating, or Deleting a Printer Device

Adding a Device

1. Click the New icon on the IPS Launcher window or select File>New.

The display shows the Create a New Device screen.

2. Enter a unique identifier as the device name. The device name must be 
alphanumeric with no spaces or special characters. It can contain as many as 
10 characters.

3. Enter the correct SCSI ID information.
The factory default is 2 for KPDM.

NOTE: The value for SCSI Host Adapter is typically 1. Select another value 
only if necessary.
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4. Select the correct Device Type from the menu to correspond to either the 
Digital LED Printer, the Kodak Professional Digital Multiprinter, or the Kodak 
Professional Digital Multiprinter II.

5. Click OK to accept the information (or click Cancel to go to the IPS Launcher 
window without adding a device).
A new device icon appears on the IPS Launcher window.

Updating the Device Name, SCSI Host Adapter, or SCSI ID

1. On the IPS Launcher window, select the icon for the device to update and 
click the Edit icon or select File>Edit.

Device is 
selected
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Using the IPS Software with the KODAK PROFESSIONAL Digital Multiprinter
The display shows:

2. Edit the Device Name, SCSI Host Adapter, or SCSI ID.

3. Click OK to save the changes (or click Cancel to ignore the changes and go 
to the IPS Launcher window).

Deleting a Device

To delete a device and all files associated with the device:

1. On the IPS Launcher window, select the icon for the device you want to delete 
and click the Cut icon or select Edit>Cut.

The display shows:

2. Select Yes to delete the device and associated files (select No to go to the 
IPS Launcher window).

Device is 
selected
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Printing Images

To print images, you:

• select the device from which to print

• start the IPS application for the selected device

• set the Source Directory preferences for the selected device, if not already 
done

• place images in the print queue

• wait for the images to print

1. Select the device from which to print.

2. Click the Start IPS icon (or double-click the icon for the selected device).

The following main menu appears.

Device is 
selected
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Description of Icons on the Main Menu

The icons and their associated menu items allow you to choose the following 
options:

Menu 
Access

Menu 
Item

Icon Description/Function

File Enqueue Displays the Enqueue dialog box and allows you to insert a new 
image into the print queue.

Dequeue Allows you to remove the top entry from the print queue.

Server Suspend Stops the operation of the application. If an image is processing or 
going to the printer, the operation on this image will complete before 
the application suspends.

Resume Resumes the operation of the application; Resume is active only 
when the system is suspended and can only be used if the server 
defaults were initialized (Source Directory preferences were set).

Flush Allows you to delete all entries from the print queue.

Help About Displays the About box that includes version information about the 
Kodak Professional Image Print Server.
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Setting the Source Directory Preferences for a Device

1. Select Server>Defaults from the IPS main menu.

The Source Directory Preferences dialog box appears.
February 2001 15



Using the IPS Software with the KODAK PROFESSIONAL Digital Multiprinter
Below is the top portion of the Source Directory Preferences dialog box.

2. Type the Source Directory name or click Browse to select the Source 
Directory where the TIFF images will be placed.

3. Type the Log File name or click Browse to select the Log File where printer 
error information is to be stored. The log file applies to all devices for the 
application. To edit the log file information, go to “Editing Log File Information” 
on page 18.

4. Enter the number of copies to print of each image in the Source Directory. 
Valid numbers are from 1 through 9999. The default value is 1.

5. If each image is the end of an order, click the box next to Order Punch.

6. To center each image on the paper, leave the Center image box checked. If 
you do not want to center images, click to “uncheck” the box.

To ensure that the complete image file is exposed on the paper, Kodak 
recommends that you always check “Center image.”

7. If the Digital Multiprinter was calibrated using Density, you may apply Tone 
Scale Correction with the g22_fullrange.txt file in the LUTs folder supplied 
with the IPS application.
To apply tone scale correction:

a. Type the path and name of the Correction File or click Browse to select 
the Correction File to be applied to each image.

b. Click the box next to Apply to apply the designated Correction File to each 
image.

Select OK only after both the 
top and bottom portions of 
this dialog box are complete.
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Using the IPS Software with the KODAK PROFESSIONAL Digital Multiprinter
Below is a representative area of the bottom of the Source Directory Preferences 
dialog box.

8. For any one of the magnifications 4R, 5R, 6R, 7R, 8R, 9R, 10R, A4, 11R, or 
12R:

a. Click in the circle next to the magnification at which you want the images to 
be printed (8R is the default).

b. Type the LUT path and file name or click Browse to select the LUT file 
associated with the selected magnification.

c. Type the Paper Pak path and file name or click Browse to select the 
Paper Pak file associated with the selected magnification.

NOTE: After you select the LUT and Paper Pak for a magnification, the IPS 
application saves that information.

The LUT and Paper Pak information must be entered for the selected 
magnification. However, before you start the IPS application, you may 
want to select all the LUTs and Paper Paks you will use. Then, if you 
change the magnification, you will not need to enter the LUT and Paper 
Pak information.

9. When the dialog box is complete, click OK to close the dialog box and save 
the specified values (or click Cancel to close the dialog box without saving the 
values).
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Editing Log File Information

Do this only when you need to edit information about the error log file.

1. With no device selected, select File>Edit from the IPS Launcher window.

The Edit Configuration dialog box appears.

2. Make changes as needed to either the Log Type, number of days to keep log, 
or the Log File Name.

3. Click OK to accept changes (or click Cancel to cancel changes).

Placing Images in the Print Queue

You can submit images by:

• placing images in the “hot folder” (the Source Directory in the Source 
Directory Preferences dialog box)

• using the enqueue function on the application menu bar
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Using Source Directory Insertion

When you place images in the Source Directory, they are automatically placed in 
the print queue. The images are sorted by the date and time they were placed in 
the Source Directory and printed in that order.

IMPORTANT: After the image goes to the printer, the file is removed from the 
Source Directory.

NOTE: The properties of the images placed in the Source Directory are taken 
from the Source Directory Preferences dialog box.

Using the Enqueue Function

To enqueue a single image from the menu bar:

1. Click the Enqueue icon or select File>Enqueue.

Enqueue Icon
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The Enqueue dialog box appears.

NOTE: The Enqueue and the Source Directory Preferences dialog boxes look 
almost identical, but they affect different image files. The information 
in each dialog is independent of the other.

Below is the top portion of the Enqueue dialog box.

2. Type the Image File path and name or click Browse to select the TIFF Image 
File to be printed.

3. Enter the number of copies of the image to print. Valid numbers are from 1 
through 9999. The default value is 1.

4. If the image is the end of an order, click the box next to Order Punch.

Select OK only after both the 
top and bottom portions of 
this dialog box are complete.
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5. To center the image on the paper, leave the Center image box checked. If 
you do not want to center the image, click to “uncheck” the box.

To ensure that the complete image file is exposed on the paper, Kodak 
recommends that you always check “Center image.”

6. If the Digital Multiprinter was calibrated using Density, you may apply Tone 
Scale Correction with the g22_fullrange.txt file in the LUTs folder supplied 
with the IPS application.
To apply tone scale correction:

a. Type the path and file name of the Correction File or click Browse to 
select the Correction File to be applied to each image.

b. Click the box next to Apply to apply the designated Correction File to each 
image.

Below is a representative area of the bottom of the Enqueue dialog box.

7. For any one of the magnifications 4R, 5R, 6R, 7R, 8R, 9R, 10R, A4, 11R, or 
12R:

a. Click in the circle next to the magnification at which you want the image to 
be printed (8R is the default).

b. Type the LUT file name or click Browse to select the LUT file associated 
with the selected magnification.

c. Type the Paper Pak file name or click Browse to select the Paper Pak file 
associated with the selected magnification.
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NOTE: After you select the LUT and Paper Pak for a magnification, the IPS 
application saves that information.

The LUT and Paper Pak information must be entered for the selected 
magnification. However, before you start the IPS application, you may 
want to select all the LUTs and Paper Paks you will use. Then, if you 
change the magnification, you will not need to enter the LUT and Paper 
Pak information.

8. When the dialog box is complete, click OK to close the dialog box and save 
the specified values (or click Cancel to close the dialog box without saving the 
values).

NOTES: You cannot enqueue a file that is in process. You must wait until the 
file is completely processed before you can access the file again.

Images placed in the queue by using the Enqueue function are not 
removed from their original directory after they are sent to the printer.

Removing Images from the Print Queue

Removing the Top Image from the Queue

1. Click the Dequeue icon or select File>Dequeue.

Dequeue Icon
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A dialog box appears.

2. Click OK to delete the first job (or click Cancel to cancel the deletion).
The job at the top of the list is deleted from the print queue.

NOTE: Before you can delete an image from the print queue, the application 
must be suspended and all jobs in progress must be complete.

Removing All Images from the Print Queue

1. Click the Flush icon or select Server>Flush.

A dialog box appears.

2. Click OK to delete all jobs (or click Cancel to cancel the deletion).
All jobs are deleted from the print queue.

NOTE: Before you can delete an image from the print queue, the application 
must be suspended and all jobs in progress must be complete.

Flush Icon
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Using the IPS Software with the KODAK PROFESSIONAL Digital Multiprinter
Suspending and Resuming the IPS Application

When the IPS application starts, it looks for Source Directory Preferences.

If these preferences are initialized, the application will start in the “running” state—
as if the Resume icon was selected.

If the preferences are not initialized, the application is in the “suspended” state—
as if the Suspend icon was selected.

Suspending the IPS Application

To suspend the IPS application, select the Suspend icon or select 
Server>Suspend.

Suspend Icon
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Resuming the IPS Application after a Suspension

To resume the IPS application, select the Resume icon or select Server>Resume.

If the preferences were not initialized, the dialog box below appears.

After you select OK, the Source Directory Preferences dialog box appears and the 
application remains suspended until the preferences are initialized. See “Setting 
the Source Directory Preferences for a Device” on page 15.

Failed Jobs

When an image fails to go to the printer for any reason, an appropriate error 
message is appended to the log. The log file is specified in the Source Directory 
Preferences dialog box.

Images in the Source Directory (hot folder) are moved to the FailedJobs 
Directory. The FailedJobs Directory is created as a subdirectory within the 
Source Directory when the first failure occurs.

Images that fail and were not inserted through the Source Directory (that is, they 
were inserted with the Enqueue icon or menu item) are not moved to the 
FailedJobs Directory.

Resume Icon
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Attended and Unattended Modes

The IPS application allows you to operate in the Attended or Unattended mode.

In Attended mode, all errors are displayed in dialog boxes. The IPS application is 
halted until you respond to the message.

In Unattended mode, only errors that require user intervention are displayed in 
dialog boxes. Errors that do not require user intervention, such as an invalid file 
format, are logged in the log file.

In both Attended and Unattended modes, all errors are written to the log file.

NOTE: If a communication error occurs while the file is going to the printer, the 
image may not be printed. In addition, jobs that fail to print from the Source 
Directory (hot folder) are copied to the failed jobs directory.

To determine if the IPS application is running in Attended mode, pull down the 
Server menu.

If the bullet appears next to Attended, the application is running in attended mode.

• To disable attended mode, select the Server>Attended menu item.

If no bullet appears next to Attended, the application is not running in attended 
mode.

• To enable attended mode, select the Server>Attended menu item.

 Application is in 
Attended mode

 Application is not in 
Attended mode
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Changing the Number of Image Buffers

To improve throughput of the application, you may select the number of image 
buffers the application uses. To maximize, select the greatest number of buffers 
for which the computer has available RAM (each buffer requires 18 megabytes 
RAM for KPDM or 34 megabytes RAM for KPDM II).

To edit the number of buffers for holding images:

1. Select File>Options from the KPDM Image Print Server main menu.

2. The Options dialog box appears.

3. Change the value as needed (the value can be from 1 to 5).

4. Select OK.
A dialog appears stating that the application must be restarted if the number 
of image buffers is changed.

5. Exit and restart the application.
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File Format Details
The data portion of the TIFF file must contain RGB byte interleaved data.

Supported Tags
The Image Print Server supports the TIFF tags listed below. The range of valid 
values for TIFF tags 256, 257, 258, 273, 278 and 279 are image dependent and 
are indicated by a “*” in the Valid Range column. If these values are incorrect, an 
error will occur when the application is reading the image data and an appropriate 
error message will be placed in the log file.

*indicates an image-dependent value

LZW Compression
The IPS application does not support LZW compression.

TIFF Tag ID Name Valid Range

256 Image Width *
257 Image Length *
258 Bits per Sample *
259 Compression 1
262 Photometric Interpretation 2
273 Strip Offset *
277 Samples per Pixel 3
278 Rows per Strip *
279 Strip Byte Count *
284 Planar Configuration 1
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