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Preface
Today, millions of people are already doing their shopping online. With the number of online shoppers set to explode
as Internet access becomes more affordable and Internet infrastructure more available to the masses, businesses cannot
afford not to have an online presence to cater to such demand.

Contrary to popular belief, you do not have to spend loads of money just to establish an online store. With this book, you
will learn how to use the free and open source Zen Cart software to start building and running your own online store.

This practical book provides a step-by-step guide to on how to perform all the necessary tasks required to run an online
store. Many screen shots are also included to help reinforce your learning experience and help you visualize the steps
even when you are away from a computer.

Why this book was written
This book serves to address two major concerns for store owners who are using Zen Cart to run their online stores.

Firstly, it goes into detail on how to manually set up a Zen Cart store on a remote computer.

With this approach, store owners can avoid the use of automated installation wizards that their web hosting providers
offer for quickly and silently installing a Zen Cart store. This is because the use of automated installation wizards often
lead to strange problems when running a Zen Cart store.

Secondly, this book acts as a form of structured documentation for Zen Cart.

Now, anyone can start learning how to use this powerful piece of software in a structured manner and see how the
different pieces fit together. This "proactive" approach is in stark contrast to the "reactive" approach that current users
employ: asking questions in the forums, reading the Wiki or browsing the FAQs on Zen Cart’s site.

Ultimately, store owners can save themselves the time, effort and headaches of sifting through the forums to look for
answers to most of their problems. The developers of Zen Cart can then have more time to continue enhancing this
wonderful software and not repeatedly answering the same questions that keep popping up ever so often on the forums.

Audience
This book is aimed at anyone who wants to use Zen Cart to set up an online store to sell products or services. It is not
a book for programmers learning how to program Zen Cart!

It assumes you are comfortable with using a web browser (Internet Explorer, Mozilla Firefox, etc) and already familiar
with your operating system (Microsoft Windows, Mac OS X, etc). This would allow you to install and set up your
online store comfortably.

You should also be familiar with commonly used Internet terms like web server, web hosting provider, HTTP, FTP,
etc. Knowledge of programming languages like HTML, CSS and PHP is not strictly necessary but does allow you to
customize your store in greater detail.

Finally, you need a large dose of patience and perseverance. Setting up an online store is relatively easy, but tailoring
it to suit your business requirements will require time and effort.
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Preface xv

How to use this book
This book covers Zen Cart version 1.5.4 which is the latest version at the time this book goes to print. This book is
divided into 6 parts. If you are reading this book for the first time, you should go through the book in sequence from
Part 1 to Part 5. After that, you can jump around the different chapters to accomplish a specific task.

Part I, “Getting started”

▪ Chapter 1, “Introduction to Zen Cart” - Introduces you to Zen Cart’s history and features and why you should
use Zen Cart to set up your online store.

▪ Chapter 2, “Installing Zen Cart on your remote server” - Goes into details on how to install a Zen Cart store
on a remote computer.

▪ Chapter 3, “Store quick tour” - Brings you on a quick tour of Zen Cart’s Admin Console and Store Front
interfaces. Also covers the creation of sample data for use in later chapters.

Part II, “Setting up your store”

▪ Chapter 4, “Email” - Shows you how to connect Zen Cart to a mail server for sending emails. Also breaks down
the various email options into manageable sections for you to understand and configure.

▪ Chapter 5, “Location” - Helps you understand and configure location-related information which will be used
throughout the online store.

▪ Chapter 6, “Store details and contact information” - Shows you the different mediums in which your store
contact information will be displayed to customers; email, packing slips, invoices, etc.

▪ Chapter 7, “Currency” - Covers how to setup multiple currencies and also how to update these currencies in
real time without you having to deal with exchange rates manually.

▪ Chapter 8, “Weighting unit”- Discusses how to change the unit of measure for weight.

▪ Chapter 9, “Taxes” - Discusses the concepts behind sales tax configuration and then shows you how to set up
sales tax for any region.

▪ Chapter 10, “Shipping” - Discusses the various shipping concepts before going through the configuration of
various shipping options.

▪ Chapter 11, “Payment” - Goes through the configuration of various payment options.

Part III, “Managing your store catalog”

▪ Chapter 12, “Working with catalog restrictions and categories” - Discusses how restrictions can be placed on
your entire store or on the product catalog. Also talks about how categories can be manipulated.

▪ Chapter 13, “Working with product types and products” - Goes through the concepts related to product types
and products. Different ways of manipulating products are then presented.

▪ Chapter 14, “Working with product attributes” - Discusses how to add new attributes to your products and also
how to tie pricing and weighting information to these attributes.

▪ Chapter 15, “Advanced product attribute configuration” - Discusses more advanced uses of attributes when
configuring downloadable products or making use of attributes to support customer uploads.

▪ Chapter 16, “Additional product manipulation techniques” - Shows you how to add multiple product images
and make use of sample clips for your goods.
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▪ Chapter 17, “Order totals, surcharges and discounts” - Discusses how order totals affect a customer’s order
pricing during checkout. Also examines the different surcharges and discounts you can apply to specific goods,
categories or the entire store.

Part IV, “Customizing your store”

▪ Chapter 18, “Customizing common page elements” - Introduces you to the layout components in your Zen Cart
store and shows you how to customize your store’s look mainly from your web browser.

▪ Chapter 19, “Altering the shopping flow” - Goes through some lesser known ways in which the standard shop-
ping flow can be altered via settings in the Admin Console.

▪ Chapter 20, “Working with Store Front templates” - Explains how to use the Override System to make changes
to your store. You will also be shown how to change templates and add multiple language support to your store.

Part V, “Managing your store”

▪ Chapter 21, “Managing customers” - Shows you how to manage common and individual customer information.

▪ Chapter 22, “Managing orders” - Covers how to deal with orders and understand the order statistics generated
by Zen Cart. Also shows you how to generate invoices and packing slips from the orders.

▪ Chapter 23, “Managing stock” - Discusses how to interpret and make use of stock-related information including
setting low-stock warnings and configuring low stock email alerts.

▪ Chapter 24, “Marketing” - Discusses the use of various marketing techniques like discount vouchers, gift cer-
tificates, newsletters, banners, etc, for attracting customers to your store and helping them with their purchasing
decisions.

▪ Chapter 25, “System administration” - Covers the non-business related functions like backup, security, perfor-
mance and upgrades which ensure the smooth operation of your online store.

Part VI, “Appendixes”

▪ Appendix A, “Utility software” - Covers the various computer programs like text editors, FTP programs and
file comparison programs that you will need to properly configure and customize Zen Cart.

▪ Appendix B, “Choosing a web host” - Deals with the details of getting your Zen Cart store hosted on a remote
server on the Internet.

▪ Appendix C, “Working with your remote computer” - Goes through some common web hosting features that
will be helpful to a store owner working with Zen Cart.

▪ Appendix D, “Zen Cart file structure” - Explains Zen Cart’s directory layout and some of the important files
you should take note of.

Conventions used
This book makes use of various typefaces and graphics to help you distinguish between regular text and what you
see on your screen.

Light Bold type is used for words or objects on the screen that you are to do something with. For example, "Click on
Configuration > My Store to access general store settings".

Italic type is used for a word or phrase that is being defined or otherwise deserves special emphasis.
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Monospaced Underline type is used for text that you are to type from the keyboard. For example, enter false
into the Enable Images field.

Monospaced type is used to illustrate directories or files on your OS. For example, the directory path C:\apache
\htdocs\store\docs holds documentation that comes with Zen Cart.

File contents will be contained in blocks as follows.

<html>
  <head><title>Greeting</title></head>
  <body><h1>Hello World</h1></body>
</html>

Examples are contained in blocks as follows.

Area of Rectangle = Length x Breadth Area of Triangle = ½ x Length x Breadth

Furthermore, there are several graphic elements to bring your attention to specific items in the book.

Expects you to pay particular attention to how something is done or why something is done in
a specific manner.

Provides a faster means of accomplishing the same task.

Be wary of how something is done or what can happen if you do not follow the instructions
carefully.

Contacting us
We want to know what we are doing right and how we can do better. So if you have any comments regarding this book
or wish to suggest other titles we should publish, you can reach us by using the "Contact Us" page on our site or replying
to the email address in our exclusive customer newsletter if you have signed up for it after purchasing this book.
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Part I

Getting started

This section introduces you to Zen Cart’s history and features. Next, you will walk through how to set up Zen Cart
on your web host’s remote computer. Finally, you will be introduced to how a Zen Cart store functions and how to
set up sample test data for use in the later parts of the book.

This section covers the following topics:

▪ Chapter 1, “Introduction to Zen Cart”

▪ Chapter 2, “Installing Zen Cart on your remote server”

▪ Chapter 3, “Store quick tour”
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Chapter 1:

Introduction to Zen Cart

What is Zen Cart?
Zen Cart (http://www.zen-cart.com) is a piece of shopping cart software that allows you to create an online, e-com-
merce store for selling your goods and services. It is written in PHP and requires a MySQL database to work. You can
use Zen Cart to create an online store to sell physical goods like shoes, pianos or digital goods like gift certificates,
music downloads, etc. You can even sell services like insurance policies, IT support plans, etc.

The developers of Zen Cart have adopted the line, "The Art of E-Commerce", as their goal when developing the
software. Hence, you will find that the software is designed to cater specifically to the requirements of store owners
and shoppers first. Store owners do not need an IT degree to set up and administer their websites, and shoppers can
navigate the online store and check out their items easily. Programmers are also not forgotten, as the code for Zen Cart
is well-structured and well-designed for easy maintenance and custom logic.

Zen Cart comes absolutely free with many e-commerce features available out-of-the-box. Therefore, you do not have
to invest a lot of money to establish an online, robust and professional e-commerce presence. All you need is to pay
the web hosting fees and possibly some web design fees if you want to give your online store a more polished look.

The source code for Zen Cart is distributed under the GNU General Public License (GPL). In essence, this license
gives anyone the right to modify the source code to suit their needs. However, derivative works that modify the source
code have to adhere to certain restrictions if they are to be re-distributed. More information on the GNU GPL can be
found at http://www.fsf.org/licensing/licenses/gpl.html.

Features
Zen Cart has a wide user base and is currently deployed across many 'live' sites around the world. Due to input from this
user base and a very active forum, Zen Cart is able to offer many useful and robust e-commerce features out-of-the-box.

A list of the features that come with a default Zen Cart distribution is shown below.

Simple Web-Based Installation
Once you have the necessary supporting software (i.e. PHP and MySQL) ready, installing Zen Cart is easily
performed using a web browser.

Supports Physical and Virtual Goods
Physical goods (computers, cars, flowers, etc) and virtual goods (digital music, e-books, etc) can be sold. Product
samples like brochures or music clips can also be provided together with these goods.

Product Customization through Attributes
Product attributes can be added to further customize products. For example, customers can specify the colors, size
and wordings for T-shirts that are being sold.

Simple Checkout Process
Customer checkout is a simple three-step process which is designed to reduce the occurrence of shopping cart
abandonment. Customers only need to specify their shipping and billing information and then confirm their orders
to complete the checkout.
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Multiple Payment Options
Check/Money Orders, Cash-On-Delivery, PayPal and many other payment options are supported by default. Pay-
ment options can also be enabled for customers based on their locations.

Multiple Shipping Options
Flat Rate, Per Item, Free Shipping and many other shipping options are supported by default. Shipping options
can also be enabled for customers based on their locations.

Multiple Languages, Currencies and Taxes
To cater for customers from different geographical and cultural backgrounds, additional currencies and languages
can be defined to smoothen their shopping experience. Taxes are calculated based on zone information and tax
rates which store owners define.

Wide Array of Marketing Tools
To help store owners promote their products and retain their customers, many marketing tools like newsletters,
product reviews, customer referrals, banners, etc are available.

Advanced Pricing Options
Discounts based on store-wide, category-wide or product-specific selections are possible. Surcharges can also be
applied for customer orders below a certain amount, cash-on-delivery payment options, etc.

Order Total Calculation
Customers can choose to use discount coupons, gift certificates or their group discount status to offset their order
total amounts either partially or fully.

Order Management
Store owners can easily manage orders by assigning order statuses to them. Customers can then log in to their
individual accounts to view the status of their orders. Invoices and delivery orders can also be automatically
generated by Zen Cart at the click of a button.

Custom Look-and-Feel
A store’s look-and-feel can be changed dramatically just by modifying some CSS and HTML. Maintenance efforts
are also reduced with the use of the Override System in Zen Cart. Additional web pages can also be easily added
using the EZ-Pages feature.

The above features are only the tip of the iceberg when it comes to what Zen Cart can do for store owners. Additional
features that do not come bundled with the default Zen Cart distribution are easily downloaded from the Zen Cart site
and plugged-into an existing store. No programming experience is required to use these third-party downloads.

The list of third-party downloads can be accessed via the downloads area at Zen Cart’s website.

History
Zen Cart was borne out of another shopping cart software known as osCommerce (http://www.oscommerce.com) back
in June 2003. Since then, it has undergone major code enhancements and several releases to make it stand out from
osCommerce and other e-commerce software.

Although anyone can contribute to Zen Cart’s development, there is a group of core developers churning out the code
and ensuring the quality of the overall product. This team of developers (in alpabetical order) include:

▪ Chris Brown (DrByte)
▪ Ian C Wilson (wilt)
▪ Kim Elliott (Kim)
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▪ Linda McGrath (Ajeh)

Their nicknames are in brackets and you will usually encounter them in the forums where they can be seen answering
questions on Zen Cart.

Support
If you are worried about the fact that Zen Cart does not offer any support because it is not commercial software, you
can put your mind at ease. The great number of Zen Cart users have given rise to a lively community of users which
include programmers, graphic designers and store owners. These people, and the developers of Zen Cart, provide an
excellent source of support for most of your queries.

Before you consider seeking help from the community, do spend some time familiarizing yourself with Zen Cart’s
site. If you are a non-English speaking user, you might even be able to locate a Zen Cart support site which is in your
native language.

To help you seek help from the community more effectively, you might like to follow this approach when using Zen
Cart’s site at http://www.zen-cart.com.

1. Check the Tutorials/FAQs section to see if an answer already exists for a question you are about to ask.

2. Go to the Wiki section to find out if your area of concern has already been addressed in one of the write-ups.

3. Check the Plugins section to see whether any of the third-party contributions like content boxes, payment and
shipping modules serve your particular needs.

4. Go to the community Forum if you still do not find a satisfactory answer to your problems. Before you post any
queries, spend some time reading through other people’s posts or simply do a search of the forums to see if a
question similar to yours might have been answered before.

Besides seeking help from the community, you are also encouraged to sign up for our newsletter using the email we
sent you after you have purchased this book.

Our newsletter is exclusive to our customers only and includes a mini-course on working with Zen Cart, notifications
about errata and updates to this book, as well as other insider tips and tricks to help you get the best results out of
your Zen Cart store.
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Chapter 2:

Installing Zen Cart on your remote
server

Introduction
This chapter guides you through the process of manually installing a Zen Cart store on your remote host. It assumes
you have already signed up for a hosting plan with your web host and are already familiar with how to work with your
remote server. If this is not the case, review the software requirements you require in this chapter and then refer to
Appendix B, “Choosing a web host” and Appendix C, “Working with your remote computer” for more information.

Even if you already have a Zen Cart store installed, you should still browse through this chapter
as it presents information that will be used later in this book.

In this chapter, we shall:

▪ Look at different installation approaches.

▪ Highlight technical requirements required to run Zen Cart.

▪ Run through a list of pre-installation activities.

▪ Go through the steps in performing an actual installation.

▪ Run through a list of post-installation tasks.

Overview of different installation approaches
Zen Cart can be installed on your local computer or on a remote web host. Both approaches have their pros and cons
and having an overview of both approaches will allow you to understand why different groups of Zen Cart users may
prefer one approach over another.

Installing Zen Cart on your local computer is great for development and testing purposes. You can test most third-
party plugins and templates for Zen Cart on your local computer before actually uploading the plugins and templates
to your remote server. This saves a lot of time because you do not need an internet connection for these tasks. You can
also delay the purchase of a hosting account if you have not yet decided on which one to sign up for.

However, one big drawback of a local Zen Cart installation is that you will need to set up and configure all the
necessary server software before you can begin Zen Cart installation. Another drawback is that Zen Cart functionality
that requires connection to third-party sites (e.g. shipping quotes and payment gateway interactions) may not work
because some of these third-party sites require that your site be located on the publicly accessible internet.

Installing Zen Cart on a remote server is the preferred approach because all the necessary server software required for
normal Zen Cart operation is already in place. Communications between your Zen Cart store and third-party sites will
usually not pose problems as well. Unlike a local Zen Cart store which will ultimately need to go through the laborious
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task of being transferred to a remote server in order for your customers to access it, a remotely installed Zen Cart store
has the added benefit of not having to adjust settings done for a local computer to suit the remote server’s configuration.

The main drawback for a remote Zen Cart installation is that you will need to have an existing web hosting account in
place already. Choosing a good web host can be a time-consuming process because you need to ensure that the web
host is reliable and has the expertise and tools to help you when you encounter problems working with Zen Cart.

As you can see, a local installation is more suitable for programmers and template designers as they can edit Zen
Cart’s files directly on their local computer without having to download the files first. An internet connection is also
optional. For store owners, a remote installation makes more sense because they do not need to deal with the technical
aspects of setting up and updating their own server software just to have a web store set up quickly in order to process
customer orders.

With the preceding points in mind, we will show you how to manually install Zen Cart on your remote host. The
steps we highlight in this book are rather detailed because we need to make sure they can work on different web
hosting servers which are configured differently. With practice, most installations can be done within 15 minutes or
less. Therefore, do not be disappointed if you take a longer time than that for your first manual installation.

There is one important point to note after you have decided to install Zen Cart on your remote host though. Nowadays,
many web hosts provide automated installation wizards (e.g. Fantastico, SimpleScripts, Softaculous) for the different
software applications they host on their servers. Although an automated installation wizard may allow you to quickly
and conveniently set up a Zen Cart store, you are strongly urged to avoid using any of them. This is because automated
installers offer limited installation options and can cause various problems which you may not be aware of until much
later when you start running your store.

If you are interested in installing Zen Cart on your local computer, look up the following re-
sources after browsing through the installation steps in this chapter.

▪ To install Zen Cart on a Mac OS computer, refer to http://www.zen-cart.com/fo-
rum/showthread.php?t=96011.

▪ To install Zen Cart on a Windows computer, refer to http://www.zen-cart.com/index.php?
main_page=product_contrib_info&products_id=586.

Technical requirements
To ensure the smooth running of your Zen Cart installation, you will need to check that your web host complies with
Zen Cart’s requirements. Furthermore, you may want to get some client software ready on your local computer as they
will come in handy when going through Zen Cart’s installation.

Server software requirements
Before you begin installing and configuring Zen Cart, you need to make sure that your web host fulfills the following
software recommendations.

Table 2.1: Server software requirements for Zen Cart

Server software Minimum version Recommended version

PHP 5.2.10 or higher 5.3.7 or higher
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Server software Minimum version Recommended version

Apache 2.0 or higher 2.0 or higher

MySQL 4.1.13 or higher 5.0.90 or higher

Zen Cart is able to run on any operating system (i.e. Windows, Linux, and Mac) that supports the aforementioned
software. However, for security and reliability reasons, it is highly recommended that your web host runs on Linux
instead of Windows.

To understand the interaction between the different pieces of software mentioned previously, refer to the following
figure which shows what happens when a user requests a web page from a web browser to a remote computer running
Zen Cart on the Internet.

Figure 2.1: Interaction between Apache web server, MySQL database and PHP

PHP

Web Address: http://www.php.net/

PHP is a programming language widely used for developing web-based applications. It is free and open source and is
one of the most popular computer languages with web developers because of its simplicity and power.

Zen Cart is written in PHP but you do not need to know much about it to run your online store successfully. All you
need is some basic information (PHP version, PHP settings, etc) to help you troubleshoot any problems you might
face when running your online store.

Apache web server

Web Address: http://httpd.apache.org/

Theoretically, you should be able to use any web server (e.g. Microsoft IIS) that supports PHP. However, most people
run PHP with Apache so you are strongly suggested to do the same. This will save you lots of time and frustration if
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you encounter set up or performance problems because most people are familiar with Apache and should be able to
answer any questions you have relatively faster.

MySQL database

Web Address: http://www.mysql.com/

Zen Cart uses a database to store all product, customer, order and configuration details. Currently, MySQL is the only
supported database. It is a robust and popular database; and is used to power high traffic sites like Yahoo Finance
and Google.

The developers of Zen Cart have also begun work on supporting another open source database called PostgreSQL
(http://www.postgresql.org) although it will not be ready anytime soon. Do check with your web hosting provider on
whether they provide this database if you intend to use it as your Zen Cart database in future.

Client software requirements

Besides the server software which Zen Cart requires in order to run properly, you will also need to have some software
programs available on your local computer. For example, you will likely need a GUI-based FTP client software to
transfer files between your local computer and your remote host and a proper text editor to edit Zen Cart’s files.

For more information on the list of client software that will come in handy for you when working with Zen Cart, refer
to Appendix A, “Utility software”.

Pre-installation activities
Before Zen Cart can be installed, you will need to first create a database for Zen Cart to hold information related to
your online store. You will also need to transfer a set of files to your web server in order to run Zen Cart’s web installer
during the installation process later.

Creating your store’s database

Zen Cart uses a database to store most of your store’s information such as your store’s configuration settings, customer
and product information, etc.

To create a new database, refer to your web host’s documentation. You can also refer to the section “Setting up a new
database” to get an idea how a new database can be created using cPanel.

While going through the database creation process, remember to note down the following information so that Zen Cart
can connect to the database during installation.

▪ MySQL Database Name

▪ MySQL Server Address (often "localhost" or the server IP address)

▪ MySQL Username

▪ MySQL Password
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Placing Zen Cart files on your web server

Zen Cart comes in a compressed archive which contains a set of installation files. These files need to be transferred to
your remote host and have their file permissions properly set in order for the Zen Cart web installer to run smoothly
during installation at a later stage.

Obtaining the Zen Cart software package

To obtain the latest Zen Cart installation package:

1. Go to Zen Cart’s home page at http://www.zen-cart.com.

2. Click on the Download hyperlink on the right-side of the screen and you will be redirected to the SourceForge
website (http://sourceforge.net) to download Zen Cart’s installation file.

3. Follow the on-screen instructions to begin your download. After your download completes, you should end
up with a zip file with the version and date of release in its name. For example, at the time this book is writ-
ten, the latest version of Zen Cart is version 1.5.4 and hence the downloaded zip file’s name is zen-cart-
v1.5.4-12302014.zip.
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4. Verify that the zip file you downloaded is not corrupted by using a file decompression program (e.g. WinZip,
StuffItExpander) to unpack it into a folder on your local computer. If the unpacking operation fails, re-download
the zip file again.

If you are looking for a particular version of Zen Cart, you can go directly to http://
sourceforge.net/projects/zencart/files/.

Transferring Zen Cart program files to your server

Before you begin, make sure you are familiar with how to set file permissions and how to manipulate files on your
server. We shall be using cPanel for most of the file manipulation screen shots in our illustration. Refer to Appendix
C, “Working with your remote computer” if you need more information on working with cPanel.
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For the sake of convenience and consistency when working through this book, we shall use the
term [doc-root] to refer to the document root of your remote server and www.example.com
to represent where your site is located on the Internet.

To transfer the downloaded Zen Cart program files to your server, you can use either of the following approaches
depending on whether your web host provides a file decompressing functionality in their control panel software.

▪ If your web host does provide a file decompressing function, follow these steps for a faster transfer:

a. Use your client FTP program or control panel’s file manager to upload the Zen Cart zip file from your local
computer to your remote server’s document root directory.

b. Using your control panel’s file manager application, extract the zipped file on your remote host into [doc-
root]. This would result in a folder [doc-root]/zen-cart-v1.5.4-12302014.

c. Delete the file [doc-root]/zen-cart-v1.5.4-12302014.zip which you uploaded previously as we
won’t be using it anymore.

▪ If your web host does not provide a file decompressing function, then follow these steps:

a. On your local computer, unzip zen-cart-v1.5.4-12302014.zip and you should end up with the directory
zen-cart-v1.5.4-12302014.

b. Use your FTP client program to upload the entire zen-cart-v1.5.4-12302014 directory and its contents to
the [doc-root] directory of your web host.
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The process may take quite some time due to the many files that need to be uploaded.

After the files are uploaded, you should have a directory structure similar to the following screen shot which
shows the uploaded file contents in the [doc-root]/zen-cart-v1.5.4-12302014 directory.

After your Zen Cart files are uploaded to your remote server, you will need to prepare the files and directories for
subsequent installation.

1. Decide on what web address you want to use for your store and use your control panel’s file manager to manipulate
the unpacked files as follows:

▪ If you are installing Zen Cart for testing purposes, it is recommended that your web store be accessed via
http://www.example.com/store.

In this case, rename [doc-root]/zen-cart-v1.5.4-12302014 to [doc-root]/store. We shall use
store for the renamed unpacked folder for examples used in this book. You are free to rename the unpacked
folder to something else (e.g. shop or demo) if you like.

▪ If you intend to run your business on Zen Cart immediately, it is recommended that your web store be accessed
via http://www.example.com.

In this case, move all the files and directories from [doc-root]/zen-cart-v1.5.4-12302014 into [doc-
root]. Delete the empty [doc-root]/zen-cart-v1.5.4-12302014 folder after moving the files and di-
rectories.

2. Rename the following two files that reside under the main Zen Cart directory from dist-configure.php to
configure.php. Also make sure their permissions are set to writeable (e.g. chmod 644 or chmod 777).
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▪ /admin/includes/dist-configure.php

▪ /includes/dist-configure.php

This step may not be necessary depending on how your web host has configured your server. This is because the
Zen Cart web installer is able to automatically rename the preceding two files and set their permissions correctly
in most cases. However, we highlight the instructions here in order to make sure your installation goes without
a hitch on all servers.

3. Ensure the following directories that reside under the main Zen Cart directory have their permissions set to write-
able (e.g. chmod 755 or chmod 777).
▪ /cache/

▪ /images/ (and all its sub-directories)
▪ /includes/languages/english/html_includes/

▪ /logs/

▪ /media/

▪ /pub/

▪ /admin/backups/

▪ /admin/images/graphs/

For the rest of this book, we shall use [zc-home] to represent the top-most directory containing
all your Zen Cart files.

That means if your Zen Cart files were placed in the store folder under your server’s document
root, then [zc-home] would represent the [doc-root]/store folder. Similarly, if you had
placed all your Zen Cart files in your server’s document root directory, then [zc-home] would
represent the [doc-root] folder.

The [doc-root] directory on most web hosts usually comes with default files (e.g.
505.shtml) and sub-directories (e.g. cgi-bin) which may be unfamiliar and confusing to
someone who has just signed up for a new web hosting account.

Hence, it is preferable to install Zen Cart into a [doc-root] directory’s sub-folder (e.g. store)
in order to avoid mixing Zen Cart files with those default files in the [doc-root] directory.

If you want to switch the web address of your Zen Cart store from http://www.example.com
to http://www.example.com/store or vice versa, see http://tutorials.zen-cart.com/
index.php?article=122.

Performing the installation
Installation of Zen Cart will be performed via a web browser. After the installation is completed, you will need to do
some manual manipulation of some files and directories to prevent warning messages from appearing.

Running the Zen Cart web installer
The Zen Cart web installer provides a wizard-style interface which guides you through every step of the installation.
If you are unsure about the purpose of any field during installation, just click the "more info" link next to the field and
a pop-up window will appear explaining the purpose of that particular field.

To begin installation of Zen Cart via the web installer, follow these steps:

1. From your web browser, navigate to the URL you specified in the previous section.
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For example, if you had transferred your files to your server’s document root directory (i.e. [doc-root]), use
http://www.example.com. On the other hand, if your files reside in a sub-directory under your server’s root
directory (e.g. [doc-root]/store) then use something like http://www.example.com/store. A welcome
screen should appear as shown in the following screen shot.

2. Click on either the Click here or zc_install/index.php hyperlinks to proceed to the Welcome screen.
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3. Click on Continue to proceed to the License screen.

4. Agree to the license by clicking on the top radio button. Next, click on Continue to proceed to the Prerequisites
screen.

If your server is not properly configured to work with Zen Cart, you may encounter errors or warning messages
which are highlighted in red or yellow. Approach your web host on what you can do to resolve those issues before
proceeding with the installation.
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5. Click on Install to proceed to the Database Setup screen. Pay attention to the following points while filling in
the values for the fields.

▪ You should choose UTF-8 for the Database Character Set / Collation field. UTF-8 is an encoding scheme
that is commonly used to support multiple languages in a software application.

▪ The values for the Database Host, Database Username, and Database Password fields are what you specified
earlier in the section “Creating your store’s database”.

▪ Specify a value for the Store Identifier (Table Prefix) field only if you will be running another application
(e.g. WordPress) that will be using the same database. This is usually required only in rare instances when your
hosting account allows only one database per account or per domain.
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6. Click on Save Database Settings and a screen will appear showing the progress of data population in your
database.

After the database installation completes, the System Setup screen appears. Verify the default settings automati-
cally picked up by Zen Cart. Avoid setting the Enable SSL and Enable SSL in Admin Area fields to Yes unless
you have a dedicated SSL certificate set up on your web server already. We will explain how to configure SSL
for use with your Zen Cart store in a later part of this book.
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7. Click on Save System Settings and the Store Setup screen will appear. Pay attention to the following points while
filling in the values for the fields. Also note that values entered in all the fields, except that for the Store Demo
field, can be changed later when we work through the book.

▪ You are strongly encouraged to enter YES for the Store Demo field if this is the first time you are running Zen
Cart. This action will cause the installer to populate your database with sample data that contains many product
and feature configuration possibilities, some of which may not be covered in this book.

▪ You may want to choose United States for the Store Country field and Florida for the Store Zone field
if you have chosen YES for the Store Demo field. This is because the sample data has a default tax setup for
the Florida zone which you can use to test out different scenarios where taxes will be tabulated when customers
purchase goods from your store.
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8. Click on Save Store Settings to proceed to the Admin Setup screen. The values you enter here will be used to
log in to your Zen Cart administration area later. Therefore, make sure you note down the values somewhere first
before proceeding to the next step.

9. Click on Save Admin Settings to complete the running of the web installer. You should see the Finished screen
if the installation goes well.
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To verify that the web installer has completed correctly, click on either of the buttons at the end of the page.

If you click on the Click here to go to the Store button, you will see a collection of products appearing as shown in
the following screen shot if you had chosen to install the sample data earlier.
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A warning message should also appear at the top of the page prompting you to delete the zc_install directory.

If you click on the Click here to go to the Admin area button, you should see the following screen which prevents
you from logging into your Admin area. We will learn how to get rid of the warning message in the next section.

The web address for your Store Front should either be something like http://

www.example.com/store or http://www.example.com depending on whether you have
installed Zen Cart under a sub-folder.

Similarly, the web address for your Admin Console should either be something like http://
www.example.com/store/admin or http://www.example.com/admin. If you have re-
named the admin folder according to the instructions in the following section, then replace the
admin in your web address to the name of your renamed admin folder (e.g. myadmin).

In both cases, the www prefix in the web address may or may not apply depending on how you
have it set up for your hosting account.

Cleaning up the installation files and directories
If you had attempted to visit either the Store or Admin areas of your Zen Cart store after running the web installer,
you will encounter warning messages informing you about security concerns that the Zen Cart software has detected.

To get rid of the warning messages appearing in your Store area, follow these steps:

1. Delete the [zc-home]/zc_install directory to prevent malicious hackers from re-running the web installer
and messing up your store’s database and other settings.

2. Set the permission of the [zc-home]/includes/configure.php file to read only (e.g. chmod 444 or chmod
400).

This step may not be necessary because the Zen Cart web installer will automatically attempt to set the permis-
sions of the [zc-home]/includes/configure.php file to read only, it may not work on all web hosts due
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to configuration differences and requirements between them. Therefore, it is recommended that you check with
your web host on the correct read only permissions to use.

3. Go to your Store area again and refresh the page to make sure that the warning messages have disappeared.

To get rid of the warning message appearing in your Admin area, follow these steps:

1. Rename the [zc-home]/admin directory to a less common name (e.g. [zc-home]/myadmin). This is important
because it reduces the likelihood that malicious users are able to access the administration area of your store.

In this book, we shall use [admin] to refer to your renamed admin folder. For example, if you had renamed the
admin folder to myadmin, then [admin] would represent the myadmin folder.

2. Set the permission of the [zc-home]/[admin]/includes/configure.php file to read only (e.g. chmod 444
or chmod 400).

3. Access your Admin area by utilizing the renamed admin folder name in your URL. For example, if your previous
Admin URL was http://www.example.com/store/admin, then your new Admin URL might be http://
www.example.com/store/myadmin instead.

If your changes are correct, you should see a Log In screen similar to the following screen shot instead of the
earlier warning message.

Troubleshooting your installation

If you encounter problems during your Zen Cart installation, go to http://tutorials.zen-cart.com/index.php and click on
the Installing Zen Cart hyperlink to see if you can find any solutions. Alternatively, type some keywords related to
your problem in the Search box to find articles that match your problems.

If your problems have not been addressed, post a question in the "Installing Zen Cart" forums. Do remember to read
through the posting guidelines carefully before composing your question so that other users on the forum are able to
understand your situation better and thus offer more timely help.
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Post-installation activities
After you have completed your Zen Cart installation and verified that it is working, you should run through a list of
actions in order to ensure that your online store is up-to-date and secure.

Helping search engines index your site correctly
The [zc-home]/robots_example.txt file is a sample file which you can modify to help search engines go through
the contents of your site according to your preferences.

If you already have a pre-existing [doc-root]/robots.txt file and are satisfied with it, you can safely delete [zc-
home]/robots_example.txt.

On the other hand, if you do not have a [doc-root]/robots.txt file, then download the [zc-home]/
robots_example.txt file from your remote server to your local computer and open it with a text editor. Read
through the comments inside the file and edit the file contents to suit your needs. After that, rename the file from
robots_example.txt to robots.txt and upload the file to your remote server’s [doc-root] directory. Finally,
remember to delete the obsolete [zc-home]/robots_example.txt file from your server.

Applying code updates and bug fixes
Bugs and security patches may be reported since the release of your installed Zen Cart version. Occasionally, code
changes may also be required because a service provider has changed its advertised rates or programming interface.
You are thus advised to go through the "Bug Reports" and "Zen Cart Release Announcements" forums at Zen Cart’s
website to see if you need to make any changes to your site after successfully completing your Zen Cart installation.

While going through the preceding forums, you are also strongly encouraged to subscribe to them so that you can be
notified automatically via email whenever bug fixes, security patches or Zen Cart version upgrades become available.

Complying with Zen Cart security recommendations
Besides general security measures like choosing strong passwords and setting the appropriate permissions for the files
and folders on your server according to your web host’s requirements, you should also aim to adhere to Zen Cart’s
security recommendations as much as possible.
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Zen Cart’s security recommendations can be found in the /docs/

important_site_security_recommendations.html of your Zen Cart directory. Alternatively, you can refer to
the online version which tends to be more up-to-date and can be found at http://www.zen-cart.com/wiki/index.php/
Important_Site_Security_Recommendations.

If you are a newcomer to Zen Cart and have problems understanding some of the terminology or following the instruc-
tions in the security recommendations, do not be overly concerned. We will be covering most of the security recom-
mendations throughout the rest of this book so that you have an opportunity to confirm your settings and understand
the context in which these security recommendations apply.

Now is also a good time to take a quick glance at Appendix D, “Zen Cart file structure” to understand the purposes
behind some of the directories and files in a Zen Cart installation and the changes made to them.

Summary
After working through this chapter, you should be familiar with how to manually install Zen Cart on a remote server.
As you work through the installation, you should also have recorded some information about your Zen Cart store (e.g.
database log in credentials, Zen Cart Administrator login credentials). Keep this information updated and in a safe
place as you may need to refer to it from time to time.

Before we go, take note of the shortcuts (i.e. [admin], [zc-home], and [doc-root]) we have used to represent
certain commonly used directories when you installed your Zen Cart store. They will be used throughout this book to
refer to your actual Zen Cart installation on your remote host.
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Chapter 3:

Store quick tour

Introduction
A Zen Cart store is segmented into two different access areas. Site visitors and customers access the Store Front to
do their shopping or manage their personal accounts. Store owners (also known as administrators) access the Admin
Console to add products to the store’s catalog and configure other business rules.

In this chapter, we shall:

▪ Understand how a customer interacts with your Store Front to purchase goods.

▪ Set up some test customer accounts for use in later chapters.

▪ Highlight some useful navigational tips in your Admin Console.

▪ Set up some test products for use in later chapters.

The Store Front
The Store Front acts as the front-end to your store and is where your customers go to perform their shopping activities.
A sample customized Store Front is shown in the following screen shot.
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If you had opted to include the demo data during Zen Cart installation, you might think the Store Front is very cluttered
because too many elements are present. However, all these elements are enabled in order for you to get an idea of the
many possibilities and options that are available to you when presenting your products for sale.

On the other hand, if you had chosen not to install any demo data, then your store will appear very empty. This book
can be used as a guide to set up your store according to your requirements.

A typical shopping flow

To help you understand how Zen Cart works, we shall go through a typical set of activities that customers perform
when doing their online shopping. This entire process constitutes a workflow and enables you to visualize which part
of your store will be affected when you start configuring your own online store. For simplicity’s sake, the illustrated
workflow is shown in sequence. In actual fact, customers can opt to skip to certain pages without having to follow
the sequence. Store owners can also alter the standard shopping flow to suit their business needs as we will learn in
Chapter 19, “Altering the shopping flow”.
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Figure 3.1: A typical shopping flow

An explanation of the different steps in the illustrated shopping flow is shown in the following table.

Table 3.1: Explanation of each step in the shopping flow

Step Comments

1 A customer learns about your site through a marketing campaign (Search Engine, Gift Certificate, etc) you
have implemented. She picks up your site’s web address and types it into her web browser to reach your Store
Front. The first page she encounters is known as the Home Page (which is also known as the Index Page or
Main Page).

The customer browses through your store’s products via the Categories side-box. If your store sells docu-
ments, she may see a Documents side-box as well. Optionally, she can perform a search for a product she is
interested in.

An example of a Home Page was shown in the first screen shot in this chapter.

2 As the customer clicks through the list of products, she will ultimately reach the Product Info page which de-
tails the price, weight, discounts and any other information related to the product.

Once she decides to purchase the product, she enters the desired quantity into the "Add to Cart" text box and
then clicks the "add this to my cart" button to proceed to the Shopping Cart page.
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Step Comments

3 On the Shopping Cart page, the number of items that the customer has purchased and the price breakdown for
all items will be displayed. Products can be removed and the quantity of items changed by clicking the rele-
vant icons on the screen.

Once the customer is satisfied with her purchase, she can click the "go to checkout" button to begin the
checkout process.

4 Before the customer enters the checkout process, she will be redirected to the Login page if she has not
logged in to her account. If she does not have an account, she will need to sign up for an account at the same
page.

Zen Cart is smart enough to make sure that items in the customer’s shopping cart will not be lost even if she
transitions from an anonymous visitor to a logged-in customer.
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Step Comments

5 Once the customer is logged in, she will automatically be redirected to the Delivery Information page.

The customer will choose her desired shipping option and confirm her delivery addresses. After making her
selection, she will click on the "continue checkout" button to proceed to the Payment Information page.
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Step Comments

6 At the Payment Information page, the customer will choose her desired payment option and confirm her
billing addresses.

The customer can also use the monetary values contained in her discount coupons or gift certificates to offset
a portion of the order amount. After she is satisfied with her selection, she will click on the "continue check-
out" button to proceed to the Order Confirmation page.

7 At the Order Confirmation page, all applicable costs (shipping charges, sales taxes, etc) for the customer’s or-
der are tallied and displayed. Previously selected values for the Delivery Information page and Payment In-
formation page will also be displayed.

Once the customer is satisfied with the details of her order, she will click on the "confirm the order" button.
After the order is processed by Zen Cart (send out order confirmation emails, set order status to Pending, save
order in database, etc), the customer will be redirected to the Checkout Success page.
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Step Comments

8 At the Checkout Success Page, the customer will be given an opportunity to opt-in to receive any email up-
dates for the products she just purchased.

If the customer has purchased gift certificates from your store or received gift certificates from her friends,
the balance in her gift certificate account will also be displayed. This brings an end to the shopping flow.

Optionally, if the customer wants to view her order history, she can click the My Account hyperlink to pro-
ceed to the My Account Information page.
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Step Comments

9 At the My Account Information page, the customer will be able to view her order history and check on each
order status.

Sample customer
If you have installed the sample data when creating your Zen Cart store, you would already have a customer present
in your store. To prevent your store from being accessed by malicious users who are familiar with Zen Cart, use the
following steps to reset the sample customer’s password.

To change the sample customer’s password:

1. Go to your Store Front (e.g. http://www.example.com/store/index.php or http://www.example.com/
index.php) and click on the Log In hyperlink at the top of the page.

2. You should be presented with a screen for you to log in and/or sign up for a new account depending on the settings
in your Admin Console.

3. Log in to the sample customer’s account using the following credentials. Note that both fields are case-sensitive.
▪ Email Address = root@localhost.com
▪ Password = password

4. Click the Enter button when you are done. Notice that the navigation bar containing the Log In hyperlink has
changed to that shown in the following screen shot.

5. Click on the My Account hyperlink and you will be re-directed to the My Account Information page of the
customer.

6. Click on Change my account password hyperlink and you will see something similar to the following screen shot.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 3. Store quick tour 33

7. Enter the details of your new password and write the new password down in case you forget it.

8. Click submit after you have set up your new password.

9. Click on the Log Out hyperlink at the top of the page to log out of the sample customer’s account.

After you have reset the sample customer’s password, log in again with the new password to verify the change has
taken effect.

Setting up a test customer
We shall now set up a test customer account in your online store. With this test customer, you will be able to experience
the impact of different store settings which we will learn to configure from the next chapter onwards.

Note that even if you have a test customer already present in your store, you are still encouraged to add more test
customers with different addresses. This will help you test the tax, shipping, and payment calculations later. It will
also give you a feel of what your customers will need to go through to create accounts in your store as well.

To create a test customer account:

1. Go to your Store Front and click on the Log In hyperlink at the top of the page.

2. You should be presented with a screen for you to log in and/or sign up for a new account depending on the settings
in your Admin Console.

3. Enter the values for your test customer account. To save time, you can make use of the following values for the
time being. Leave the other fields at their default values.
▪ Mr. Ms. = Mr.
▪ First Name =Jacques
▪ Last Name =Pires
▪ Street Address = 200, rue de Tolbiac
▪ City = Paris
▪ State/Province = Paris
▪ Post/Zip Code = 75015
▪ Country = France
▪ Telephone = (33)-01-40-80-82-11
▪ Date of Birth = 05/21/1970
▪ Email Address = jacques@example.com
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▪ Password = abcdefg
▪ Confirm Password = abcdefg

4. Click on submit once all the relevant data has been entered. The test customer will be created and automatically
logged in to his account.

5. Click on the Log Out hyperlink at the top of the page to log the test customer out of his account.

Repeat the above steps to create a few more test customers; preferably belonging to different countries and states.

The Admin Console
The Admin Console acts as the back-end to your store and is where you will spend most of your time looking through
orders, adding shipping and payment options, and configuring discounts, etc.

Logging in to the Admin Console
To access the Admin Console of your store, enter something similar to http://www.example.com/store/myad-
min/login.php or http://www.example.com/myadmin/login.php in your web browser. Refer to the previous
chapter if you are still unsure about the actual web address to use.

To log in to your Admin Console, use the values you entered for the Administrator Username and Administrator’s
Password fields in the Admin Setup screen during Zen Cart installation earlier.

If you have forgotten the password but still remember the email address of the administrator, click the Forgot password
hyperlink to begin the process of retrieving your password in the email. On the other hand, if you have forgotten your
password and cannot remember which email address was specified for the administrator username, refer to http://
tutorials.zen-cart.com/index.php?article=2 for instructions on resetting your Admin Console login credentials.

As part of Zen Cart’s security features, an email will be sent to an admin user if the admin user’s
username was entered in four consecutive failed login attempts. To disable the sending of such
emails, change the value of the following line in the [zc-home]/[admin]/login.php file
from "Yes" to "No".

define('ADMIN_SWITCH_SEND_LOGIN_FAILURE_EMAILS', 'Yes');

Moving around the Admin Console
After you log in, you will arrive at the Admin Home page. The Admin Home page acts as a dashboard that allows you
to control how you want your Zen Cart store to behave.

To give you an idea of the amount of information that is available from the Admin Console’s home page, refer to
the following screen shot.
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To navigate around the different areas in the Admin Console, hover over the menu entries at the top of your screen
and click on a selected sub-menu entry. The complete list of menu entries that come with a default installation of Zen
Cart is shown in the following screen shot.

For the rest of this book, we shall use the following syntax Localization > Currencies to indicate that you should
click on the main menu entry Localization and then click the sub-menu Currencies.
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Zen Cart allows several admin users to log in and access the Admin Console at the same time.
For security reasons, these admin users can be given different access rights to different pages in
the Admin Console which in turn affects the actual menu entries they will see. For more infor-
mation on how to configure admin access for different admin users, refer to the section “Man-
aging access to the Admin Console”.

From any page in your Admin Console, you can easily jump back to the Admin Home page by clicking on the Admin
Home hyperlink on the navigation bar above the row of main menu entries.

The admin user account
From time to time, admin users may need to change their email addresses or passwords. Zen Cart allows them to do
so without having to trouble a system administrator to do so on their behalf.

To change the email address or password of the current admin user:

1. Click on the Account hyperlink on the navigation bar to access the Admin Account Maintenance screen.

2. To change the current admin user’s email address:

a. Click on Edit and you should see something similar to the following screen shot.

b. Enter a valid email address into the Email field.

c. Click Update to save your changes in the database. Simultaneously, Zen Cart will automatically send an
email to the email address that is found in the Email Address (Displayed to Contact you) field in the E-
Mail Options screen which you can access via Configuration > E-Mail Options.

3. To reset the current admin user’s password:

a. Click on reset pwd and you should see something similar to the following screen shot.

b. Type in the new password you want to use in both the New Password and Confirm Password fields. Note that
passwords in Zen Cart are case-sensitive and must follow the PA-DSS requirements for admin user passwords

c. Click Update to save your changes to the database. No emails are sent when an admin user’s password is
changed.
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Using rich-text editors
Several areas in the Admin Console allow the input of HTML (i.e. HyperText Markup Language) to spruce up the
look of otherwise plain looking content. These areas include email newsletters, product and category descriptions, etc.

The following screen shot shows the difference in appearance when HTML formatting is added to a simple product
description. Notice that the product description on the right contains text that is formatted with an underline and a
background color while the one on the left does not have any extra formatting. The extra formatting that appears in
the product description on the right is achieved using some HTML code while the product description on the left does
not use any HTML code at all.

By default, text boxes in Zen Cart that allow the use of HTML content requires admin users to manually type in the
required HTML content in the Admin Console and then visit the relevant page in the Store Front to view the affected
content. Such default text boxes are commonly known as plain-text editors.

An example showing the input that needs to be manually entered into a plain-text editor in order to display our earlier
HTML formatted product description in the Store Front is shown in the following screen shot. Besides the need for
the admin user to be familiar with HTML code, notice how difficult it is to read the relevant content as it is jumbled
up with HTML code.

An alternative to using plain-text editors to write content containing HTML code is to use rich-text editors instead.
A rich-text editor, also known as an HTML editor in Zen Cart, provides a WYSIWYG (i.e. What-You-See-Is-What-
You-Get) interface consisting of toolbars and buttons to format HTML content without having to manually type in
any HTML code.

An example of a rich-text editor showing the input that is used to display our earlier HTML formatted product de-
scription in the Store Front is shown in the following screen shot. Notice the similarity between the content that is
displayed in the rich-text editor and the content in the Store Front. The appeal of a rich-text editor is obvious as it
offers immediate visual feedback when formatting content and does not require the admin user to know HTML.

However, there are several drawbacks to using a rich-text editor. One drawback is that it becomes cumbersome to
change a group of content with similar formatting. For example, imagine that all your product descriptions contain
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the words "Satisfaction Guaranteed" and the words are formatted in bold and highlighted with a yellow background.
If you now decide to format the words in italic and highlight their backgrounds in green, imagine the work you will
need to do if you have tens or hundreds of products. The solution to the problem is to use HTML and CSS code in
conjunction with external CSS stylesheets. However, we shall not discuss the solution here as it will require deeper
knowledge of HTML and CSS and can get very technical.

Prior to Zen Cart version 1.5.0, a default rich-text editor by the name of HTMLarea (http://www.dynarch.com/projects/
htmlarea) came pre-packaged with Zen Cart. That rich-text editor has now been removed because it has not been
updated in a long time and renders HTML code that does not meet present day web standards.

Therefore, you must now install a third-party add-on in order to use a rich-text editor. The rich-text editor seen in
this book goes by the name of CKEditor (http://ckeditor.com) and can be downloaded from http://www.zen-cart.com/
index.php?main_page=product_contrib_info&products_id=1626. Instructions for its installation are contained within
the downloaded ZIP file. You are, however, advised to hold off installing the add-on until you are more familiar with
the workings of Zen Cart.

If you have installed a rich-text editor for your Zen Cart installation, you can choose to use it as the default text editor
in your Admin Console by clicking on Configuration > My Store and editing the HTML Editor field as shown in
the following screen shot. Individual admin pages can still choose to use a different rich-text editor or the plain-text
editor as we will see in later chapters.

Sample categories and products
If you have opted to install the sample data during your Zen Cart installation, you will find a list of products in the
Categories/Products screen when you click on Catalog > Categories/Products as shown in the following screen shot.

The sample products are very useful in helping you understand how certain product features are set up. Try referring
to them if you are unsure of a setting or functionality that is covered in this book.
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There is currently no way to remove the sample categories, products, and files (e.g. images and
media samples) automatically by running a script or clicking a button in the Admin Console.

Therefore, if you intend to use your demo store as the actual store to serve real-world customers
later, you should manually disable or remove the sample categories and products via the Admin
Console. You may also want to run through the various files in the following directories (and
their sub-directories) to remove any sample files you do not need.

▪ [zc-home]/images

▪ [zc-home]/pub

▪ [zc-home]/download

▪ [zc-home]/media

Setting up your own test products
We shall now set up some test products in your online store. Although you may not understand some of the fields as we
start creating the products, do not worry as we will cover these fields in greater depth as we proceed through the book.

Setting up the test products here in this section is recommended even if you already have the sample data installed.
This is because it provides consistency when troubleshooting problems in your store as you can counter check against
the contents of this book. Furthermore, some store owners may have inherited a store from someone else but the store
does not contain any sample data for testing or verifying Zen Cart’s functionality.

Before we can create any test products, we need to create a category to hold our test products. To create a test category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the new category button to bring up the next screen where you can specify your category details. Enter
the following values for the following fields on the screen. Ignore all other fields.
▪ Category Name = Test

▪ Categories Description = To hold all test products for our testing purposes.

▪ Sort Order = 2000

3. Click save after you have entered the relevant fields. You will be redirected back to the Categories/Products screen
where your newly created category will be displayed; most likely at the bottom of the screen if your store contains
other categories or products because we have specified a very high sort order for the category.

Now that we have created our test category, we shall begin adding our test products.

Normal Test Product

This product shall be used for testing multiple scenarios (shipping modules, payment modules, sales taxes, etc) in
our store.

To create a Normal Test Product:

1. Click on the "Test" folder icon in your Categories/Products screen and you should see something similar to the
following screen shot.
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2. Select Product-General from the drop-down list box and then click on the new product button to bring up the
next screen where you can specify your product details. We shall call this screen the Product Details screen.

3. Enter the following values for the respective fields on the screen. Ignore all other fields.
▪ Products Name = Normal Test Product
▪ Tax Class = Taxable Goods
▪ Products Price (Net) = 200.00
▪ Products Description = A generic test product that can be used for many scenarios.
▪ Products Quantity = 1000
▪ Products Shipping Weight = 0.2
▪ Sort Order = 10

4. Click preview after you have entered the values for the relevant fields and you will see the following screen which
shows you all the data you have previously entered.

5. Click insert to create your product. You will be redirected back to the "Categories/Products - Test" screen which
will contain your newly created product.

Free Test Product with Free Shipping

This product is used to test a particular payment module which we will cover later. A free product in Zen Cart has
to be specifically marked as "Product is Free". If you specify the product as $0.00, Zen Cart will not automatically
recognize the product as a free product although customers do not have to pay for the product in both instances.

To create a "Free Test Product with Free Shipping" product, follow the same steps when creating the "Normal Test
Product" but specify the following values instead when you reach Step 3.

▪ Products Name = Free Test Product with Free Shipping
▪ Product is Free = Yes
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▪ Tax Class = -- none --
▪ Always Free Shipping = Yes, Always Free Shipping
▪ Products Description = For testing the Payment Module - Free Order
▪ Products Quantity = 1000
▪ Products Shipping Weight = 0.2
▪ Sort Order = 20

Ignore all warning messages when previewing your product as they only serve to ensure that you have configured your
settings correctly. After your product is created, your "Categories/Products - Test" screen will contain the "Free Test
Product with Free Shipping" product as shown in the following screen shot.

Summary
You should now have a better picture of how customers perform their shopping activities and the various screens
involved. With this mental picture, you should find the configurations for your store much easier to understand.

If you have installed the sample data, you will find that the test customer account and test products will come in handy
when you begin testing out your store configurations.
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Part II

Setting up your store

This section shows you how to set up the business infrastructure for your online store. It helps you define all the
necessary settings you need to make before you can start adding products to your catalog and welcoming customers
to your store.

This section covers the following topics:

▪ Chapter 4, “Email”

▪ Chapter 5, “Location”

▪ Chapter 6, “Store details and contact information”

▪ Chapter 7, “Currency”

▪ Chapter 8, “Weighting unit”

▪ Chapter 9, “Taxes”

▪ Chapter 10, “Shipping”

▪ Chapter 11, “Payment”
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Chapter 4:

Email

Introduction
Email is the main communication channel used by your store. It can be configured to notify customers of their order
statuses, to notify you of different conditions (e.g. low stock level) in your store, and also as part of your marketing
campaign (e.g. newsletters).

In this chapter, we shall:

▪ Learn how to set up Zen Cart to send emails.

▪ Specify the recipients for different email notifications.

▪ Cover miscellaneous email options.

▪ Learn how to customize your email message templates.

The E-mail Options screen
All email configurations in Zen Cart, except for email templates, are configured via the E-Mail Options screen. To
access the E-Mail Options screen, click on Configuration > E-Mail Options. A screen shot of an E-Mail Options
screen is shown on the following page.
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Figure 4.1: E-Mail Options screen

The large number of settings in the E-Mail Options screen may make the screen overwhelming at first sight. Do not
worry about it as you will find that the settings can be broadly categorized as follows:

▪ Email connection settings.
▪ Email message recipient(s).
▪ Other email options.

We will be using the above categorization to explain the different fields on the screen.

Email connection settings
For emails to be sent from your Zen Cart store, you will need to obtain the settings for the mail server with which
you will use to connect to and send messages from. Contact your web host or mail service provider (e.g. Gmail) for
the relevant information. After that, refer to the following fields in the E-Mail Options screen to set up the email
connection settings for your store.

Table 4.1: Email connection settings

Field Comments

Send E-Mails Set this field to true in order to enable Zen Cart to send emails. A warning
message will be displayed at the top of your Admin Console screen if you have
set this field to false.

E-Mail Transport Method The method that is used to connect to a mail server. Check with your web host if
you are unsure which method to use.
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Field Comments

For web hosts running on Windows/Mac platforms, this is usually smtp or
smtpauth. On Unix/Linux platforms, this is usually sendmail, sendmail -f
or Qmail.

The default value PHP uses PHP’s "mail()" function to send emails. It allows
Zen Cart to use whatever mail-sending method that is already configured by
your web hosting provider on the server hosting your store. In many cases, this
may be the best option.

SMTP Email Account Mailbox This is the user name that is used to log in to the email account on the mail serv-
er.

Required if E-Mail Transport Method value is smtpauth. In some cases, may
also be required if using smtp.

SMTP Email Account Pass-
word

This is the password that is used to log in to the email account on the mail serv-
er.

Required if E-Mail Transport Method value is smtpauth. In some cases, may
also be required if using smtp.

SMTP Email Mail Host This is either the domain or IP address of the mail server.

Required if E-Mail Transport Method is set to smtp or smtpauth.

SMTP Email Mail Server Port This is the mail server port which Zen Cart will connect to when sending out
emails. The usual value is 25.

Required if E-Mail Transport Method is set to smtp or smtpauth.

To test whether your mail server settings can work with Zen Cart, send an email to the test customer in your store. To
send an email from the Admin Console using the connection settings you have specified:

1. Click on Tools > Send Email to access the Send Email To Customers screen.
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2. Fill in the details in that screen. Click preview to bring up the next screen to preview your email message.

3. Click send to send the email to the test customer.

4. Log in to your test customer account to see if the email has been received.

If you encounter any problems sending emails, refer to http://www.zen-cart.com/wi-
ki/index.php/Troubleshoot_-_Email_Problems for a discussion on the possible solutions before
you post on Zen Cart’s forum.

Email message recipient(s)
Zen Cart is able to automatically send carbon copy (cc) or low stock emails to your designated recipients whenever
an email is sent from your online store. Most emails are sent when a customer takes a specific action (e.g. signs up for
an account) or when the system detects an extraordinary condition (e.g. a low stock level).

Note that you can set multiple recipients for each email notification by using a comma and a space as the separator
for multiple email addresses as shown in the following example:

Jacques <jacques@example.com>, Nicole <nicole@example.com>, Alan <alan@example.com>

To specify the recipients of different emails sent by Zen Cart, concentrate on the following fields in the E-Mail Options
screen.

Table 4.2: Email message recipient(s)

Field Comments

E-Mail Address (Displayed to
Contact you)

Displayed in email messages that customers receive. Used as a means for cus-
tomers to contact you if they have any questions.

Zen Cart itself will also send emails to this email address whenever certain se-
curity-sensitive activities take place in your store. For example, when admin
users change their admin names or associated email addresses; or when pay-
ment, shipping or order total modules are installed, updated or removed.

Refer to Figure 4.2: “Sample email message received by a customer” to see the
location of this field in an email.

E-Mail Address (sent FROM) Displayed in email messages that customers receive so they know who sent
them the relevant emails.

Refer to Figure 4.2: “Sample email message received by a customer” to see the
location of this field in an email.

Send Copy of Order Confirma-
tion Emails To

Specifies the CC recipient(s) for the order confirmation email that a customer
receives after completing the checkout process.

Send Copy of Create Accounts
Emails To - Status

Enables the sending of CC emails for the following field.
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Field Comments

Send Copy of Create Accounts
Emails To

Specifies the CC recipient(s) for the welcome email which a customer receives
on signing up with your store.

Send Copy of Customer GV
Send Emails To - Status

Enables the sending of CC emails for the following field.

Send Copy of Customer GV
Send Emails To

Specifies the CC recipient(s) for an email (containing the Gift Certificate
amount) which a customer sends to another person.

Send Copy of Admin GV Mail
Emails To - Status

Enables the sending of CC emails for the following field.

Send Copy of Customer Admin
GV Mail Emails To

Specifies the CC recipient(s) for an email (containing the Gift Certificate
amount) which the store owner send to his/her customers.

Send Copy of Admin Discount
Coupon Mail Emails To - Sta-
tus

Enables the sending of CC emails for the following field.

Send Copy of Customer Admin
Discount Coupon Mail Emails
To

Specifies the CC recipient(s) for an email (containing the Discount Coupon
amount) which the store owner sends to his/her customers.

Send Copy of Admin Orders
Status Emails To - Status

Enables the sending of CC emails for the following field.

Send Copy of Admin Orders
Status Emails To

Specifies the CC recipient(s) that should receive a copy of the updated order sta-
tus emails sent to a customer.

Send Notice of Pending Re-
views Emails To - Status

Enables the sending of emails for the following field.

Send Notice of Pending Re-
views Emails To

Specifies the recipient(s) for an email which indicates that a new product review
by a customer is ready for moderation.

Send Low Stock Emails Enables the sending of emails for the following field.

Send Low Stock Emails To Specifies the recipient(s) for an email which indicates that a product’s stock lev-
el has fallen below a threshold level.

A sample email that a customer receives on signing up with your store is shown in the following screen shot. It clarifies
the difference between the Email Address (Sent FROM) field and the Email Address (Displayed to Contact you)
field. Although the email addresses are the same in the screen shot, they can be different for your situation.
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Figure 4.2: Sample email message received by a customer

Enable all CC emails in your store so that you have the necessary documents to back you up
in case of disputes with customers.

Other email options

We shall now touch upon other email options that do not fall into the previous two categories but are also contained
in the E-Mail Options screen. Refer to the following table for their explanations.

Table 4.3: Message formats and composition

Field Comments

E-Mail Linefeeds Specifies what character(s) should be used to terminate a line in email messages.
On a Windows machine, a line feed is specified via a carriage return (CR) fol-
lowed by a line feed (LF) which results in a "CRLF". For a Unix/Linux ma-
chine, it is specified as a "LF". You can set this to CRLF if your website is run-
ning on a Windows server else set this to LF.

Enable HTML Emails If set to false, emails can only be composed in TEXT format. All customers
will receive TEXT emails regardless of the email format they choose to receive
from your store.
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Field Comments

If set to true, emails can be composed in both TEXT and HTML formats.
However, customers who have chosen to subscribe to Text-Only emails will still
receive emails in TEXT format.

Email Archiving Active? Allows you to keep copies of sent emails in your store’s database. You might
need to set this to true to comply with your country’s laws. However, this can
take up a lot of disk space and become a performance problem. Recommended
value for testing purposes is true.

E-Mail Friendly-Errors If set to true, an easier to understand error message will be displayed when
sending of emails fail. If set to false, PHP errors which are not easily under-
stood by non-programmers will be shown instead.

Do not rely on this setting to determine whether email messages have been sent.
It is better that you CC yourself a copy of an email when you send out email
messages to your customers.

Emails must send from known
domain?

Some mail servers require that a valid email address from a known domain (e.g.
example.com) be used for the FROM field when sending out an email. If you set
this field to Yes, Zen Cart will disregard any other email address you use which
is not from the recognized domain (e.g. experiment.org). Instead, Zen Cart will
use the E-Mail Address (sent FROM) field to send the email.

Note: For store owners who choose to use Gmail for the E-Mail Address (sent
FROM) field, it is recommended to set this field to No.

Email Admin Format? Indicates whether email messages carbon copied (cc) to store owners should be
in plain-text format or HTML format.

Set "Contact Us" Email Drop-
down List

If this field is left blank, all emails sent via the Contact Us page will be sent to
the email address you configured in E-Mail Address (sent FROM) field.

If this field is not empty, customers can direct their emails to specific parties
in your store by choosing from a drop-down list box. Refer to the section “The
Contact Us page” to see a screen shot of how the list of email recipients will ap-
pear if this field is not empty.

When adding email addresses to this field, make sure that the angle brack-
ets are included as well. An example value would be Store Owner
<storekeeper@example.com>. Remember to use the format shown in the
section “Email message recipient(s)” if you intend to specify multiple recipients
for this field.

Contact Us - Show Store Name
and Address

Toggles the display of your store’s contact information in the Contact Us page.

Your store’s contact information is taken from the Store Address and Phone
field found under Configuration > My Store. Refer to the section “The Contact
Us page” to see a screen shot of where this information is displayed.

Display "Newsletter Unsub-
scribe" Link?

If enabled, the Information side-box in your Store Front will display a Newslet-
ter Unsubscribe hyperlink.
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Field Comments

Audience-Select Count Display This setting only affects the screens in the Admin Console. If enabled, the num-
ber of email recipients in each mailing group will be displayed. To see an exam-
ple of the number of customers displayed in each mailing group, click on Tools
> Send Email and look at the Customer field.

If this setting is set to true, the display of admin email pages may slow down
on large or poorly tuned servers due to the extra database work to calculate the
relevant numbers.

Convert currencies for Text
emails

When you compose TEXT emails, you are not able to specify certain currency
symbols properly. For example, the English Pound ( £ ) or the Euro ( € ). Zen
Cart is able to help you overcome this problem by letting you use a replacement
text (e.g. &euro; ) that will automatically help you do the conversion to the ap-
propriate symbol (e.g. € ).

Customizing email messages
Email messages that are delivered to customers can appear in either HTML format or plain-text format. To get an idea
of how the same email message may be presented in either format, refer to the following screen shots. Notice that both
screen shots show the same Welcome Email message but differ only in their appearance.

Understanding how email messages are formed
Each email sent from Zen Cart is actually constructed from several components. These components include the various
"define() statements in the many possible language files in your store, the data stored in your database, the email layout
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templates, etc. To visualize all these components, we shall use the preceding Welcome Email sample screen shots
together with the following explanations to give you a rough idea how an email is constructed before being delivered.

The structure of an email is taken from one of the email template files located under the [zc-home]/email directory.
For a Welcome Email, it is the file [zc-home]/email/email_template_welcome.html. If you open up that file
and look at the contents, you will see something similar to the following snippet of code.

 <div class="content">
   <div class="content-line">$EMAIL_GREETING</div>
   <div class="content-line">$EMAIL_WELCOME</div>

Text preceded by a dollar sign are known as template tags. The HTML source code in the file gives HTML emails
their structure. The template tags are placeholders for static custom text taken from "define()" statements contained
in various language files, database values for settings you configured for your store, and dynamic content generated
by Zen Cart.

To understand how template tags act as placeholders for content, open up the file [zc-home]/includes/lan-
guages/english/create_account.php and you should see something similar to the following snippet of code.

define('EMAIL_WELCOME', 'We wish to welcome you to <strong>' . STORE_NAME .
'</strong>.');

Notice that the words EMAIL_WELCOME in the "define()" statement actually corresponds to the template tag
$EMAIL_WELCOME in the email template file. Another thing you will notice is that the words We wish to wel-
come you to corresponds exactly to the second sentence in the sample email screen shots you saw earlier. The word
STORE_NAME is a variable that holds the value for the Store Name field found under Configuration > My Store.
This value is taken from the database although it is configured in the Admin Console.

We shall not talk about dynamic content generated from Zen Cart for template tags because it requires knowledge of
PHP to understand the logic behind how dynamic content is generated for a particular situation. In any case, there is
seldom a need to change the dynamic content generation code.

So how do you get plain-text emails since only HTML email layout templates are available? Well, the answer is Zen
Cart retains all the values taken from template tags and just strips away all HTML and CSS codes from an email layout
template before sending out the relevant plain-text emails.

Changing text in emails

From our discussion in the previous section, you can see that the only thing that you are likely to customize besides
the various store settings is the "define()" text found in various language files. Store settings are covered throughout
the book so there is no point talking about them here. Instead, we will show you how to locate the necessary language
files holding the "define()" text you want to change.

To locate and edit a "define()" text:

1. Look at a copy of an email containing some text you want to change.

2. Look at the names and contents of the various files under the [zc-home]/email directory and you should be
able to identify the email layout template containing the "define()" text you need to change.
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3. Identify the template tag in the email layout template that is likely to contain the "define()" text you need to change.
For example, $EMAIL_WELCOME.

4. Go to your Admin Console and click Tools > Developers Tool Kit to access the Developers Tool Kit screen.
This screen allows you to look for text appearing in certain files used by Zen Cart.

5. Enter the template text (without the dollar sign) you identified in Step 3 into the first text box under the Key or
Name field on the screen. For example, enter EMAIL_WELCOME.

6. Experiment with the values in the adjacent drop-down list box to specify the search scope. For example, choose
All Current Selected Language Files.

7. Click search to begin the search.

8. After some time, your screen should refresh with search results displayed on top of your screen. If something is
found, you will see something like the following screen shot.
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9. Based on the file name and line number of the file(s) found, use the Override System to change the custom text
accordingly.

To take a quick glance at some common text that appears across all email templates (e.g. copy-
right information and disclaimer in the footer), look inside the following files:

▪ [zc-home]/[admin]/includes/languages/english/email_extras.php

▪ [zc-home]/includes/languages/english/email_extras.php

Email layout templates cannot be overridden using the Template Override System at the present
time. Therefore, make sure you back up a copy of the email layout template you intend to change
before performing any edits on the relevant file.

Changing the header image used in HTML emails
The image that appears in the header of your HTML emails is the file [zc-home]/email/header.jpg. If you open
up any of the email template files, you will notice the following snippet of code which refers to that file.

  <!-- Header Section -->
  <div class="header">
  <img src="email/header.jpg" alt="logo" />
  </div>

Hence, to change the header image used in your HTML emails. You can use either of the following approaches:

▪ Upload a new file with the name header.jpg to your server’s [zc-home]/email directory to overwrite the
original file.

▪ Upload a file with a different name or file extension (e.g. my_header.jpg to your server’s [zc-home]/email
directory. Then edit all the email templates in the directory to change the earlier snippet of code to use your custom
image file name instead.

Summary
Email is the communications lifeline for any e-commerce store. Thus, we have covered the meanings of every email
setting available in Zen Cart to allow you to troubleshoot most problems you might experience in your own online
store. Armed with this knowledge, you should be able to set up your email preferences confidently.
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Chapter 5:

Location

Introduction
Location plays a very important role in the correct functioning of your store. It affects how your shipping, payment
and tax rules will be applied based on the supplied geographical information from your customers and your store.

In this chapter, we shall:

▪ Understand how the different pieces of location information (i.e. Countries, Zones and Zone Definitions) are used
together to determine the taxes, shipping and payment charges that a customer incurs.

▪ Configure Countries information.

▪ Configure Zones information.

▪ Configure Zone Definitions information.

▪ Specify your store location.

Understanding the use of location information
In Zen Cart, location information is divided into the following categories:

▪ Countries

▪ Zones

▪ Zone Definitions

Countries is self-explanatory. Zones allow you to segregate a country into different areas. For example, you might
use zones to specify states for America, provinces for China, etc. Zone definitions, on the other hand, allow you to
segregate different geographical areas according to how you conduct business. Thus, you can have a zone definition
that spans several countries or several states.

To appreciate the relationship between Countries, Zones and Zone Definitions, consider the case where you run your
business in England and you have recently set up an online shop to sell vintage guitars. Since your shop is online
and caters to customers from all over the world, you will have to consider the impact of taxes, shipping and payment
charges that apply to each customer.

If you expect the bulk of your customers to come from the United States, you might want to provide overnight FedEx
delivery only to this set of customers to entice them to buy from you. In that case, you might want to use zones in Zen
Cart to represent the states in the United States. You would then set up a shipping zone definition which encompasses
all these zones of the United States. When you configure your Shipping options, you can then choose to have the
FedEx option show up only when customers are from the shipping zone definition you created.

Similarly, you can set up a payment zone definition to support customers in certain regions where you want to offer
a specific Payment option. For example, you can offer a Check/Money Order payment option only to customers in
the United Kingdom and United States. Customers who belong to other geographic locations will not be able to see
this option as a result.
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Finally, you can also set up a tax zone definition to encompass the different counties that make up the United Kingdom
so that you can apply a suitable Value Added Tax to charge customers from this region.

The preceding example is rather simplified but it does give you an idea of how Zen Cart provides the flexibility for
you to specify the settings you want. Do not worry if you cannot get the full picture now because we will be going
through this topic again in later chapters. For the next few sections in this chapter, we shall look at how to configure
these individual pieces of location information.

Countries
By default, Zen Cart comes with a complete set of countries in your database. You will not need to add any more
countries unless there are major political upheavals in certain parts of the world. However, you might want to consider
removing some of the countries which you do not intend to or cannot support.

For example, if your store location is in the United States and you sell hardware with strong encryption software, you
are unlikely to be allowed to export your hardware to certain countries which the United States deem to have terrorist
links. In that case, you might want to remove those countries from the list of countries available in Zen Cart.

To manage the countries in your online store, click on Locations/Taxes > Countries to access the Countries screen.

The options to add, update, remove, and toggle the status of the countries in your store are very obvious from the
screen and also quite self-explanatory. However, you need to take note of the following three points while making
your changes.

▪ Country status.

▪ ISO country codes.

▪ Address formats in each country.

When you click on the edit button next to a country in the Countries screen, you will see a side-panel similar to the
following screen shot. We shall use this screen shot to discuss the above three points.
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Country status
The value of the Status (Active for shipping?) field in the preceding screen shot corresponds to the color of the button
displayed for that country under the Status column in the Countries screen.

Despite the field’s name, it actually affects both the shipping and billing addresses of a customer and not just the
shipping address alone.

New customers will not be able to use any inactive countries when registering for new accounts or to create shipping or
billing addresses. Existing customers with addresses within inactive countries will be prompted to create new addresses
that are outside those inactive countries.

ISO country codes
Zen Cart uses both the ISO Code (2) and ISO Code (3) fields to represent different countries in its database as seen
in the preceding screen shot. These are internationally recognized abbreviations of country codes according to the
ISO-3166 standard. This standard defines both two-letter and three-letters codes for different countries in the world.

The ISO 3166 Country Codes Reference hyperlink in the Countries screen points to a list of ISO country codes on
the official ISO website. Make sure you refer to that list when adding or updating country codes in Zen Cart.

Address formats used in different countries
Each country in the world defines a fixed format for the addresses in their respective countries. This address format
is available via the post office of each country.

Zen Cart comes with a default of six address formats which are used to format the addresses contained in your invoices,
packing slips, etc, when you send goods to other countries.

As seen in the preceding screen shot, only the Address Format field is shown but not the exact pattern of the address
format. Therefore, you will need to rely on the following table to understand which option to choose for the Address
Format field. Note that the example addresses shown are purely fictitious and used only for illustration purposes.

Table 5.1: Address format patterns used in Zen Cart

Address
format

Pattern Default coun-
tries affected

Address format examples

1 $firstname $lastname

$streets

$city, $postcode

All other coun-
tries not stated
below.

James Logan

496 Victoria Street

Sydney, 2010
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Address
format

Pattern Default coun-
tries affected

Address format examples

$statecomma$country New South Wales, Australia

2 $firstname $lastname

$streets

$city, $state $postcode

$country

United States John Doe

123 Magnolia Street

Dallas, TX 55803-0034

United States

3 $firstname $lastname

$streets

$city

$postcode - $statecomma$country

Spain Martina Gonzalez

General Castanos, 86

Barcelona

08003 - Barcelona, Spain

Note: Assumes both city and state are
"Barcelona". Although Spain uses
"province" instead of "state".

4 $firstname $lastname

$streets

$city ($postcode)

$country

Singapore John Low

16 Whampoa Drive

Singapore (260042)

Singapore

5 $firstname $lastname

$streets

$postcode $city

$country

Austria,
Germany

Heidi Kohler

Lentzeallee 194

14195 Berlin

Germany

6 $firstname $lastname

$streets

$city

$state

$postcode

$country

United Kingdom James Watson

1 St.Georges Business Centre

Portsmouth

Portsmouth

PO1 3AX

United Kingdom

Note: Assumes both city and state are
"Portsmouth".

7 $firstname $lastname

$streets

$city $state $postcode

$country

Australia Jane Carter

10 Elizabeth Street

Sydney NSW 2000

Australia

Zones
In Zen Cart, Zones are defined as geographical regions within a country. Zen Cart comes with a default set of zones
configured for the following countries: Australia, Austria, Canada, Germany, Palau, Spain, Switzerland and United
States.
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Purpose of zones

To understand the purpose of Zones, let us first look at what happens when a customer signs up for an account with
your store. We shall assume you have set the State/Province field to be displayed as a drop-down list box in your Sign
Up page. For more information on how to configure the look of the State/Province field on the Sign Up page in your
Store Front, refer to Step 3 in the section “Common customer settings”.

If customers come from a country that does not have any Zones configured in Zen Cart, they will have to manually
enter a value in the State/Province field. On the other hand, customers who come from a country with Zones defined
in Zen Cart can choose the required information from the State/Province field’s drop-down list box instead.

So why does Zen Cart want to enforce this rule of restricting the State/Province information for countries that have
Zones configured in Zen Cart’s database? The answer is because Zen Cart may need to make use of this information
to allow you to fine-tune your shipping, payment and tax charges. For example, you can apply different sales tax rates
based on whether the shipping addresses of customers fall within certain Zones.

Adding a zone

To add a zone to a country:

1. Click on Locations/Taxes > Zones to access the Zones screen.

2. Click on new zone and concentrate on the side-panel.
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3. Enter the name of a state or province in the relevant country into the Zone Name field. Alternatively, if your
country does not have a state or province defined, you can use any logical grouping you can think of that will
make sense to customers from that country.

4. Enter the code representing the state or province into the Zone Code field. For example, the United States uses
"TX" to represent the state of Texas in that country. If your country does not have such a definition or you are
using a logical grouping, you can use the same value as the one used for the Zone Name field.

5. Choose the country containing the zone you want to define from the Country field.

6. Click insert to save the zone to the database.

Zone Definitions
A Zone Definition is a logical grouping of zones. You may need to create separate zone definitions for payment,
shipping or tax purposes. Additionally, discount coupons usage can also be restricted based on which zones your
customers' billing addresses fall under.

Purpose of zone definitions
When you add a shipping option, payment option, sales tax rate or discount coupon in your store, you have the option
of selecting a Zone Definition to link to it. This Zone Definition allows you to restrict a shipping or payment option
only to customers from a specific area in the world. Similarly, you can use a Zone Definition to specify a specific tax
rate for customers from a specific location in the world.

A Zone Definition is a logical grouping of Zones. A Zone Definition can cover a small area such as a State in a country
(e.g. Paris) or several countries in a federation (e.g. European Union). It all depends on what you want to achieve
with the Zone Definition.

For example, if your business operates in the European Union (EU) and your store is required to collect Value Added
Tax (VAT), you may want to create a Zone Definition for all countries in the EU. This is because VAT is collected only
for customers in the EU. You can then specify a tax rate that applies to all the EU countries uniformly. Similarly, you
can create a Zone Definition which contains your local state only. You can then offer free shipping to those customers
from your local state only.

Ultimately, you have to understand your own business needs before you can set up a zone definition.

Adding a zone definition
To add a zone definition:

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 5. Location 60

1. Click on Locations/Taxes > Zone Definitions to access the Zone Definitions screen.

2. Click on insert and concentrate on the side-panel.

3. Enter the relevant information and click insert to save your changes to the database. You will be redirected back
to the Zone Definitions screen, but with your changes shown instead.

4. Select the zone definition you created in the preceding step and click details in the side-panel to proceed to the
next screen. This screen displays all the sub-zones belonging to the selected zone definition. It should be empty
if you have not created any sub-zone.

5. Click on insert and concentrate on the side-panel with the heading "New Sub Zone".

6. Choose the relevant information and then click insert to save your changes. Note that the Zone field is dynamically
populated with information after you have selected a particular country from the Country field.

For example, the following screen shot shows what would be displayed if you had chosen United States for
the Country field and All Zones for the Zone field.

7. Repeat Steps 5 and 6 to continue adding more sub-zones.
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8. Click back after you have finished specifying all your sub-zones.

Specifying your store location
We have postponed the discussion of setting your store location until now because you need to have the proper country
and zone information set up in your store before you can configure this setting.

Although you have a virtual online store, you still need to provide Zen Cart with details of where you are located. This
is because Zen Cart may need this information to determine how certain charges are to be calculated. For example,
you can specify that shipping tax and product tax be calculated based on your store location (see the section “Basis
for tax calculation” for details).

To specify your store location, click on Configuration > My Store to access the My Store screen and change the
following fields accordingly.

▪ Country
▪ Zone

Make sure that you specify the Country field first then the Zone field. Values in the Zone drop-down list box are
populated based on the Country specified.

Summary
Location information provides the basis for you to specify shipping, payment and tax rules. Although they are easy
to setup, they are not easy to understand. Therefore, you have to think through your business needs and plan properly
before specifying this information.

A slight misconfiguration here and it could affect the charges that a customer should pay for your product or service;
ultimately it might hurt your revenue and possibly your reputation. Make sure you test your shipping, payment and
tax settings thoroughly, with test customers from different geographical regions.
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Chapter 6:

Store details and contact information

Introduction
Research has shown that customers prefer to deal with businesses that display their contact information prominently.
This gives them the impression that the business is legitimate and they will have a response if something goes wrong
with their orders.

In this chapter, we shall:

▪ Specify your store contact information.

▪ See how your store information is displayed in your online store.

▪ See how your store information is displayed in printable documents generated by your store.

▪ See how your store information is displayed in emails sent to customers.

Specifying store contact information
To specify your store’s contact information for online and printed documents:

1. Click on Configuration > My Store to access the My Store screen.

2. Edit the Store Address and Phone field and concentrate on the side-panel.

The information displayed in the side-panel corresponds to the values you entered in the Store Address field in the
Store Setup screen. Any information entered here is used purely for display purposes and has no effect on shipping
options, payment options or tax calculations. The default text (as shown above) gives you an idea of the information
you might want to make available to your customers. You should consider adding any pertinent information (fax
numbers, pager numbers, etc) for your business here as well.

Store contact information displayed online
Your store contact information is available in the following places online:
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▪ Contact Us page.
▪ Order Confirmation page if Check/Money Order payment option chosen by customer.

The Contact Us page
To view your store’s contact information in the Contact Us page, go to your Store Front and click on Contact Us
from the Information side-box.

If you do not see your store’s contact information displayed on the top-left corner of the screen, click on Configuration
> E-Mail Options and check that the Contact Us - Show Store Name and Address field is enabled.

The Order Confirmation page
If customers have chosen the Check/Money Order payment option when checking out their purchases, they will see
your store’s contact information displayed under the Mail your payment to section in their Order Confirmation screens.
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Store contact information displayed in print-
able documents
Your store’s contact information will also appear in the following printable documents - invoices and packing slips.
These documents can then be printed and sent together with your goods when preparing your orders. More information
on how to generate these documents will be covered in a later chapter. For now, just concentrate on the display of
your store’s contact information.

Invoices
Your store contact information will be displayed on the top-left corner of an invoice.

Packing slips
Similarly, your store contact information will also be displayed on the top-left corner of a packing slip.

Store information appearing in emails
Unlike the information displayed in online and printed documents, contact information presented in emails sent out
from your store will only contain the store name and store owner’s name as shown in the following sample screen shot.
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To change the contact information displayed in emails, click on Configuration > My Store and edit the following
fields.

▪ Store Name
▪ Store Owner

Notice that the values for the preceding fields correspond to the values you entered in the Store Name and Store
Owner fields in the Store Setup screen.

The Telephone - Customer Service field found in the My Store screen allows you to speci-
fy a contact phone number that may appear in emails sent to customers as part of a payment
transaction.

Currently, the only payment module in a default Zen Cart installation that makes use of the field
is the PayPal Express Checkout payment module.

Hence, you can ignore that field for now unless you are using the aforementioned payment
module or a third party add-on that makes use of the field.

Summary
Your contact information is available through several mediums: online store, printed documents and in emails. Always
keep your contact information updated as it is important for the image and credibility of your business.
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Chapter 7:

Currency

Introduction
Zen Cart provides you with the ability to configure your store to accept multiple currencies. Customers can then switch
to their desired currency when they view product prices via the Currencies side-box in your Store Front.

By offering customers the ability to switch to their desired currencies when viewing product prices, you aid them in
their buying decisions since they do not need to perform any manual or mental exchange rate conversions.

In this chapter, we shall:

▪ Add new currencies to your Zen Cart store.
▪ Update currency exchange rates in real-time.
▪ Specify the default currency for your store.

The Currencies screen
All currency configurations in Zen Cart are configured via the Currencies screen. To access this screen, click on
Localization > Currencies.

The default currency used in a store is the US dollar. The important point you need to take note is that the default
currency (US dollar) has a value of 1.00000000. All other currencies will be relative to this currency when specifying
the exchange rate.

Depending on your situation, you may not want to specify 1.00000000 as the value for your default currency. For
example, if your default currency is the Indonesian Rupiah, you might want to specify 100.00000000 as the value
instead.

If you intend to accept online payments via a payment gateway (e.g. PayPal, 2CheckOut, etc),
check whether these payment gateways are able to accept the currency you specify in your Zen
Cart store.
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Adding a new currency
To add a new currency:

1. Click on new currency in the Currencies screen to bring up the following side-panel.

2. An explanation of the different fields on the screen is shown in the following table. Go through them before you
start setting their values in your screen.

3. Check the Set as default (requires a manual update of currency values) option if you intend to set your new
currency as the default currency.

4. Click insert to save your changes to the database.

Table 7.1: Meanings of fields in the New Currency side-panel

Field Meaning

Title You can assign any name you like to a currency. This should, however, be intuitive because
it is displayed in the Currencies side-box in your Store Front.

Code This represents an abbreviated code assigned to a currency. You should use a currency code
that conforms to the ISO 4217 standard which is available from http://en.wikipedia.org/wi-
ki/ISO_4217#Active_codes.

If you use a currency code that is not in the ISO 4217 list, you might have problems doing a
real-time update of the exchange rate later.

Symbol Left The symbol that will appear on the left-side of a currency value. For example, in the case of
US dollars, the symbol will appear as a ($) sign on the left of the amount 17.99 as $17.99.

Symbol Right The symbol that appears on the right-side of a currency value. For example, in the case of
Euros, the symbol would appear as a (€) sign on the right of the amount 17.99 as 17.99€.

Note: You can display a Euro sign (€) in your browser by specifying &euro; for this field,
However, the symbol might not be displayed properly in all browsers because it is still con-
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Field Meaning

sidered a relatively new currency and requires that the symbol exists on the customer’s op-
erating system.

Decimal Point This is a separator to indicate hundredths of the currency. For example, $100.99 has a "." as
a separator.

Thousands Point This is a separator before each thousand. For example, $1,000,000 has a "," as a thousand
separator.

Decimal Places Specifies the number of decimals you want for a particular currency. For example, if a prod-
uct costs ten dollars and you specify 2 decimal places for this field, then the price of that
product will appear as $10.00.

Value Specifies the exchange rate relative to the default currency. If you are not sure, you can
leave this field blank. You can update exchange rates in real-time after a currency is created.

Setting a default currency for use in your store requires careful consideration. This is because
when you add products to your store’s catalog, you will have to specify all currencies based
on this default currency.

If your product catalog contains hundreds of goods and you decide to change your default cur-
rency at a later date, you will need to manually adjust each product price to reflect the value
of the new default currency.

Updating exchange rates in real-time
If you want your currencies to be updated with the latest exchange rates, you just need to click on the update
currencies button in the Currencies screen. Zen Cart will immediately fetch the latest exchange rates from http://
www.ecb.europa.eu. If this site is down or the exchange rates you want are not available there, Zen Cart will automat-
ically switch to another currency exchange site (http://www.bankofcanada.ca) to retrieve the required exchange rates.
Once the exchange rates are updated, messages will be displayed at the top of your screen.

Exchange rates can also be retrieved from http://www.oanda.com and http://www.xe.com. How-
ever, the use of these two sites requires that you subscribe to their services as per their Terms
of Service. If you are sure you want to do that, you can edit the following two lines in the [ad-
min]/includes/init_includes/init_general_funcs.php file and replace the values
of ecb or boc with oanda or xe.

define('CURRENCY_SERVER_PRIMARY', 'ecb');
define('CURRENCY_SERVER_BACKUP', 'boc');

Using the Currency Conversion Ratio to achieve realistic
exchange rates
If you were to visit the aforementioned currency exchange sites and compare the rates displayed online with the
exchange rates displayed in Zen Cart, you may notice a discrepancy between the two sets of values. This discrepancy
is caused by the Currency Conversion Ratio field which is accessible via Configuration > My Store.
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Because the actual exchange rates retrieved from the currency exchange sites assume forex transactions in very large
amounts, they are not realistic for most businesses. To alleviate this situation, Zen Cart first multiplies a retrieved
exchange rate with the value of the Currency Conversion Ratio before updating the affected currency’s exchange
rate in your store’s database.

The default value for the Currency Conversion Ratio field is 1.05. This ratio may not be appropriate for your area,
always check the exchange rates available at your local banks or money changers and adjust the field accordingly.

Note that exchange rates which are entered manually (instead of updated real-time online) into
the Currencies screen are not subjected to the Currency Conversion Ratio calculation.

Configuring the displayed default currency
Whenever visitors arrive at your site, the default currency will be displayed in the Currencies side-box. If your store
supports only English, the default currency displayed in the Currencies side-box in your Store Front, will be the default
currency you specified in the Currencies screen of the Admin Console. However, if your store supports multiple
languages, the default currency displayed in the Currencies side-box can either be the default currency specified in
the Currencies screen of the Admin Console or another currency associated with the language the visitor is using to
view your store.

If your store does not support multiple languages, you can safely skip this section. For more
information on making your Zen Cart store work with multiple languages, refer to the sec-
tion “Adding a language pack” for details.

Before we discuss how to specify the default currency for a store that supports multiple languages, you need to know
what is the default currency associated with a language pack. We shall term the default currency associated with a
language pack as the native currency for that language. For example, the French language pack will have a file [zc-
home]/includes/languages/french.php. If you view the contents of that file, you will find the following piece
of code.

define('LANGUAGE_CURRENCY', 'EUR');

This means the native currency for the French language is the Euro (EUR ). This currency must be defined in the
Currencies screen of your Admin Console. Similarly, other language packs will have their native currency defined in
a file [zc-home]/includes/languages/[language].php.

A store that supports multiple languages can choose to have the default currency in the Currencies side-box in your
Store Front displayed in the following ways:
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▪ Always use the default currency specified in the Currencies screen of the Admin Console regardless of the language
chosen by a customer in the Store Front. To achieve this, click on Configuration > My Store and set the Switch
to Default Language Currency field to false.

▪ Switch to the native currency of the particular language that a customer has chosen in the Store Front. To achieve
this, click on Configuration > My Store and set the Switch to Default Language Currency field to true.

Summary
You have seen how you can easily support multiple currencies in your store. Although exchange rates can easily be
updated in real-time, you need discipline to constantly update your currency exchange rates to reflect current market
conditions. You have also learned how to properly configure the default currency to be displayed to customers viewing
your store in different languages.
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Chapter 8:

Weighting unit

Introduction
An often overlooked point for most store owners when setting up their stores is the issue of which unit of measure
to use for weight. For simplicity’s sake, we shall refer to the unit of measure for weight as "weighting unit" for the
rest of this book.

The default weighting unit in Zen Cart is the pound (lb). This weighting unit is used in countries that follow the Imperial
system of measurements. For countries that follow the Metric system, they would be more accustomed to the kilogram
(kg) instead. Whatever the case, Zen Cart offers much more flexibility than that to specify your weighting unit. You
can use anything to identify your weighting unit. For example, carat, stone, horse, rock, etc. Why is that so? Because
to Zen Cart, the weighting unit is just a "label"!

The weighting unit issue is an abstract concept for most new store owners so we will examine it closely. Whenever
a weight is specified, two things need to be mentioned: weighting unit and weightage. For example, 5 kgs of flour or
10 lbs of pork. When you learn to create products in your store, you will only be asked to key in the weightage. When
a product’s weight is displayed, Zen Cart automatically puts the weighting unit and weightage information together
so the weight makes sense to customers. That is why you can customize the weighting unit to anything you want in
Zen Cart.

Note that the weighting unit you decide to use is applied globally throughout the store. You cannot mix multiple
weighting units. For example, specifying the weighting unit of product X in kilograms and the weighting unit of
product Y in grams.

Implications of changing the weighting unit
Although the weighting unit is used purely as a label for display in your store, when it comes to shipping your goods
you will most likely need to take into account the real weighting unit that needs to be used. Some shipping modules
expect the weight to be expressed in a certain weighting unit. For example, the United States Postal Service (USPS)
shipping module expect weight to be in pounds (lbs) and no other weighting unit. If you need to use the USPS or any
other shipping module that expects weight to be in pounds, my advice would be not to customize the weighting unit.

If you already have products in your store created with pounds as the weighting unit, then changing your weighting
unit may also be a concern. This is because when you specified the weightage (e.g. 20) for your products, you had
the intention of using pounds (lbs). If you change the weighting later to kilogram (kgs), your products will not display
weight correctly. For example, a product will now display "20 kgs" instead of "20 lbs" previously. Making the required
manual changes is a simple task if you have very few products but it can be very tedious changing an entire catalog
with thousands of products.

Changing the weighting unit
Changing the weighting unit to anything other than the default pound (lb) is not a trivial task. For readers who are
new to Zen Cart, you should skip this chapter and come back to it after you have gone through the rest of the book.
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You would then be in a better position to decide whether you want to perform any weighting unit customizations; and
if you do, you can easily change the weightage for the few example products that are in your store and also edit all
affected files properly using the Override System.

There are two steps to perform in order to change the default weighting unit used in your store.

1. Search for source files that have weighting unit information contained in them.

2. Apply the changes to these files.

Step 1 of 2: Search for files to change
As mentioned earlier, the default weighting unit in Zen Cart is the pound. This unit is represented as either "lb" or
"lbs". Therefore to change the weight unit, you will have to search for these values and replace them with your own
weighting unit; e.g. "kg" or "kgs".

To search for files containing the value "lb", "lb(s)" or "lbs":

1. Click on Tools > Developers Tool Kit to access the Developers Tool Kit screen. This screen is helpful in locating
any text contained within the physical files that make up your Zen Cart store.

2. Concentrate on the Look-up in all files portion of the screen.

3. Type the weighting unit which you would like to replace into the Key or Name field. For example, type lb.

4. Choose All Files - Catalog/Admin from the All Files Look-ups field to maximize your search scope.

5. Choose .php only from the File type field to search only files that contain code which could affect the display
of the weighting unit.

6. Leave the Case Sensitive checkbox unchecked.

7. Click search and a list of files containing the keyword you typed in Step 3 will be displayed at the top of the
screen if the search was successful.
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8. Take down the names of the files and their line numbers as you will need to edit these files later. Ignore those
files that contain words that match your keyword but are not related to weighting unit. For example, the words
"callback" and "fallback" both contain the keyword "lb" but are not related to weight.

9. Repeat your search for the weighting unit you want to change with other forms of the previous keyword you typed
in Step 3. For example, type lbs or lb(s).

As you can see in Step 8, it can be very tedious to single out files that contain the weighting unit you want to change.
You need to be patient and thorough or else you may encounter strange problems later on. For example, a certain
screen may display weight in "kgs" but another screen in your store may display the same weight in "lbs".

Step 2 of 2: Edit the relevant file(s)
After you have consolidated all the file names containing the weighting unit you want to change, you need to edit
the relevant files and change the weighting unit contained in them. You have two options for changing the contents
of those affected files:

▪ Use Zen Cart’s Override System to edit the relevant files. This is the preferred way and the methodology is covered
in the section “The Template Override System”.

▪ Directly edit the relevant files. Back up those files which cannot be overridden using Zen Cart’s Override System.

Whatever option you choose, make sure you use a proper text editor when editing the contents of any file. Refer to the
section “Text editors” for more information on choosing a text editor.

Since the editing of file contents only involves a straightforward search and replace for the relevant keywords, we will
not discuss it further here. Just be careful not to accidentally replace keywords that may be embedded in other words.

Summary
As you have just seen, it is not easy to change the unit of measure for weight without touching a lot of files. To
compound the problem, some shipping modules (e.g. USPS) require that a specific unit of measure for weight (e.g. lb)
be used. Therefore, you should consider carefully whether you really need to change the unit of measure for weight
before undertaking the task.
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Chapter 9:

Taxes

Introduction
Taxes are a part and parcel of everyday life. If you run a business, you would most likely have to deal with sales
taxes. Sales taxes are taxes levied on consumption of goods and/or services and are a form of indirect taxation which
is different from income tax. In Zen Cart, sales taxes can be applied to shipping as well as to goods and/or services.

Sales taxes vary across different countries and sometimes even across states within a country. What’s more, you could
have different tax rates apply to different classes of goods. Sales taxes can even be compounded. That means you
might have to charge an assortment of taxes on even a single item you will be selling in your store!

Indeed, the topic of taxation is a complex and wide-ranging one. Since you are planning on setting up your online store
to conduct business, do check with your accountant on how taxation works for your line of business.

Tax rates used in this book are purely fictitious and intended only for illustration purposes.

In this chapter, we shall:

▪ Understand how the different elements of Zen Cart are used to configure tax rates.

▪ Decide on the basis of your sales tax collection.

▪ See the impact of different settings on the display of tax-related prices.

▪ Add a tax class.

▪ Add a tax rate.

▪ Understand the impact of customer zone information on tax calculation.

Understanding how taxes are configured
Before you start configuring taxes in Zen Cart, you need to have an overall picture of how Zen Cart implements tax
calculations. Let us use an example of an online store that sells guitars and is located and registered in Australia. The
tax setup for the store is shown in the following illustration and will be used to explain the concept of tax configuration
in Zen Cart.
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Figure 9.1: Tax configuration overview

Looking at Figure 9.1: “Tax configuration overview”, the different components of Zen Cart (i.e. Zone, Zone Definition,
Tax Class, Tax Rate) used to calculate the tax charged on goods sold by the store are shown in bold whereas example
values for each component are shown in italics.

Zone Definitions and Zones are used to identify the geographical regions where a tax rate should apply.

A Tax Class allows different products to be separated into different groups so that each group can be taxed at a different
rate. For example, if Item A is to be taxed at 5% while Item B is non-taxable, you can set up two different tax classes
(i.e. Taxable Goods and Non-Taxable Goods) to hold each item.

A Tax Rate defines the percentage of a product’s retail price or shipping charges that should be collected as sales
tax. It ties together the information you have defined for a Zone Definition and a Tax Class to trigger the collection
of a sales tax.

After looking at the building blocks of tax calculation above, we can now interpret the tax setup in the preceding
illustration as follows: customers from the relevant Zones (i.e. Queensland, Victoria and New South Wales) in a Zone
Definition (i.e. the country of Australia) who purchase goods (of Tax Class "Taxable Goods") will be liable to pay
sales taxes (at a rate of 10%) on those goods.

Zen Cart gives you a lot more flexibility than the simple illustration we have just seen. For example, you could specify
that the tax calculation be based on store location instead of shipping address. You can also specify whether different
tax rates should be added or compounded (Federal Taxes added to State Taxes, etc). We shall cover all these different
permutations in the rest of this chapter.

Store owners who need to set up sales taxes for either the United States, United Kingdom or
Canada can refer to the FAQ section at Zen Cart’s site for examples.

Basis for tax calculation
Usually, sales tax is collected based on a customer’s shipping addresses when a purchase is made. However, there may
be times where a store owner would like to have the sales tax calculated based on the store address or a customer’s
billing address instead.

To specify the basis for sales tax calculation:

1. Click on Configuration > My Store to access the My Store screen.

2. Set the following fields to either Shipping, Billing or Store.
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▪ Basis of Product Tax
▪ Basis of Shipping Tax

Shipping and Billing addresses are determined by a customer during the checkout process. Store address is based on
the following fields in the My Store screen.

▪ Country
▪ Zone

Display of tax information
Before you configure your tax information, you need to take note of a few settings that might affect whether you get
to see tax calculations being displayed and how these tax calculations are derived.

All the relevant display settings can be found in the My Store screen available by clicking Configuration > My Store.
We shall go through each of those fields in the following table.

Table 9.1: Explanation of tax settings in My Store screen

Field Comments

Tax Decimal Places Specifies how many decimal places will be used to display a tax rate. Let us use
the following example screen shot to illustrate its use where we assume we have
already set this field to 0.

Notice that we have specified a Tax Rate of 17.5% for the EU zone. When we
try to delete this tax rate, the side-panel actually shows a tax rate of 18%!

Do not worry because this setting only affects the display of tax rates. Actual tax
rates will still be used in any tax calculation. To avoid confusion, set this value
to use the same number of decimal places as your expected tax rate.

Display Prices with Tax If this field is true, your product prices will be displayed inclusive of tax. For
example, if your product price is $100 and a tax rate of 10% is applied. The
product price will be displayed as $110 instead of the usual $100.

There are two cases where this setting will have an effect on the display of
prices in the Store Front:

▪ Product Price
▪ Order Total

When looking at product prices in the Store Front, even if you have enabled this
field, whether you will see the price of $110 or $100 will depend on what you
set for the Basis of Product Tax field. If the address for the Basis of Product
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Field Comments

Tax field falls within a Zone defined in the tax rate you set up, then you will see
$110, if not, you will still see $100.

Note that Zen Cart will not know a customer’s location if the customer has not
logged in. Hence, whether the customer sees the price with or without tax is also
subjected to this scenario.

At the final step of the check out process, customers will be presented with their
order totals. Depending on the value of this field, the display of prices with tax
information is different, as shown in the following screen shots.

Display Prices with Tax: false.

Display Prices with Tax: true.

Note that the tax calculations in the above orders only apply to the product price
and not to the shipping charge (Flat Rate).

Display Prices with Tax in Ad-
min

This setting will affect the display of prices in customer orders and invoices
generated by Zen Cart in the Admin Console. To look at an invoice generated
by Zen Cart, click on Customers > Orders and choose an order. Click on in-
voice to see a dynamically generated invoice.

Take note of the differences in the Price (inc) and Total (inc) columns for the
two sample invoices shown in the following screen shots.

Display Prices with Tax in Admin: false.

Display Prices with Tax in Admin: true.
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Field Comments

Note that the tax calculations in the above orders only apply to the product and
not to the shipping (Flat Rate). The number of decimals displayed is dependent
on the number of decimal places you set for that particular currency.

Sales Tax Display Status If enabled, it will force the display of sales tax even if the amount is $0.00. It
is recommended that you set this value to 1 during testing so you can check
whether your tax calculations are in order.

Show Split Tax Lines This field is relevant only when multiple taxes apply to an order. As its name
implies, it allows a store owner to configure how multiple taxes which apply for
an order are displayed during checkout.

For example, if the field is set to 1, then multiple tax rates would be displayed in
separate lines during checkout as shown in the following screen shot.

On the other hand, if the field is set to 0, then multiple tax rates would be dis-
played in a single line as shown in the following screen shot.

Adding a tax class
A tax class allows you to classify your goods into a specific category so that tax rates can be applied. When you
configure a shipping module or create a new product (which you will learn about in a later chapter), you will be given
the option of specifying a tax class for that particular product or shipping module.

To add a tax class:

1. Click on Locations/Taxes > Tax Classes to access the Tax Classes screen.

2. Click on new tax class to bring up the tax class detail panel.
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3. Enter your desired values for the Tax Class Title and Description fields.

4. Click insert to save your changes into the database.

Adding a tax rate
A tax rate specifies a percentage of a product’s sales price to be added as tax. A product can incur several tax rates at
once so Zen Cart gives you the option of adding or compounding the different tax rates together.

To add a tax rate:

1. Click on Locations/Taxes > Tax Rates to access the Tax Rates screen.

2. Click on new tax rate to bring up the New Tax Rate side-panel.

3. Choose the tax class which you want to apply a tax rate to by selecting from the Tax Class Title field.

4. Choose a zone definition to which the tax rate should apply from the Zone field.

5. Specify the tax rate you want to charge in the Tax Rate (%) field.

6. Specify a meaningful description for the Description field. Preferably, state the tax rate since this field will be
displayed to the customer in the Order Confirmation screen during check out. For example, enter Value Added
Tax (VAT) @ 10%.
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7. Specify how you want different tax rates to apply by entering a number into the Priority field. An explanation
of this field is found in the following section.

8. Click insert to save your changes.

Compounding or adding different tax rates
In some cases, different tax rates need to be applied to a product. The final tax rate that applies for the product will
depend on whether these tax rates are compounded or added. Zen Cart allows you to perform the compounding or
addition of tax rates by way of the Priority field which you encountered earlier. Notice that the Priority field states
that "Tax rates at the same priority are added, others are compounded".

We will use the following examples of a single product which has two tax rates (3% and 5%) applied to it to understand
the meaning of compounding versus addition.

Example 9.1: "Compounded" Tax Rate

Net Price of Product = $100.00

Priority = 1, Tax Rate = 5%

Priority = 2, Tax Rate = 3%

Compounded Tax Rate = (1.05 x $100.00) x (1.03) = $108.15

Example 9.2: "Added" Tax Rate

Net Price of Product = $100.00

Priority = 1, Tax Rate = 5%

Priority = 1, Tax Rate = 3%

Added Tax Rate = (1 + 0.05 + 0.03) x $100.00 = $108.00

Impact of customer zone information
One of the things that can cause problems when Zen Cart calculates taxes is when no State/Province information exists
for a customer. This happens when they are not required to enter the State/Province field when they sign up for an
account with your online store.

Zen Cart needs the State/Province information in order to determine which Zone a customer is located in so that it can
decide whether the customer is liable for sales tax. If your store chooses not to collect any zone information during
customer registration, then the only way to assess taxes on those customers would be to set the tax basis to Store
(refer to the section “Basis for tax calculation” for configuration details). Note that the Zone used when using a store-
based tax basis is taken from the Zone field under Configuration > My Store.

To make sure that customers specify a state or province when they sign up for an account:

1. Click on Configuration > Customer Details to access the Customer Details screen.
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2. Make sure the State field is set to true.

Summary
Configuration of sales taxes needs to be carefully done as there are many steps to perform and also several dependencies
with other modules as well. The main thing before you start configuring your taxes is to have an understanding of how
your business is required to handle taxation issues. Since tax rules can change overnight, you also need to stay abreast
of current affairs and update your tax settings in a timely manner.

Do contact your local tax authority or consult a tax accountant to review your business needs, including taxation issues
related to zones outside the jurisdiction of your local tax authority (since you can sell to anyone anywhere if you are
selling online).
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Chapter 10:

Shipping

Introduction
Any store that deals with physical goods will likely need to ship those goods to their customers. Zen Cart provides
various shipping modules to cater to the different ways in which store owners ship their goods. Each shipping module
that is enabled will then appear as a shipping option to customers based on the delivery addresses they select when
they check out their items.

In this chapter, we shall:

▪ Understand important shipping considerations like tare weight, shipping boxes calculation and shipping/packing
details.

▪ Run through the common shipping screen and shipping settings.

▪ Go through each shipping option separately.

To keep the explanation of each shipping module independent, we shall discuss how to test each
shipping module immediately after learning how to configure it.

Default shipping modules
Use the following table to help you decide which shipping options you want to offer your customers. Shipping modules
are classified according to the methods they employ to calculate shipping charges, such as:

▪ Online - Shipping charges are calculated in real-time by an external shipping processor and sent back to your
store for display to customers.

▪ Offline - Shipping charges are calculated based on the rates a store owner sets for a particular shipping module.

Table 10.1: Default shipping options

Modules Methods Comments

Flat Rate Offline Adds a fixed shipping cost to a customer’s order regardless of
how many items were bought.

Per Item Offline Adds a fixed shipping cost to each item in a customer’s order.

Per Unit Offline A different shipping cost is applied for each item based on the
item’s unit weight and quantity.

Note: The unit weight of an item is the weight you specified
when creating a product in the store’s catalog.
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Modules Methods Comments

Store Pickup Offline Charges a fixed shipping cost for customers who choose to
collect their goods from your store instead of having you de-
liver it to them.

Table Rate Offline Applies different shipping charges for items that fall within
different bands for weight, price or number of items. For ex-
ample, charge $2 for orders below 5 lbs and charge $5 for or-
ders between 5 lbs to 10 lbs.

Zone Rates Offline Behaves similarly to Table Rate but has the added ability to
define different table rates for different countries in different
zones.

FREE SHIPPING Offline Allows you to specify extra charges that should apply although
free shipping is offered to customers.

Note: If this module is active and shown to the customer dur-
ing checkout, all other modules automatically disappear. To
enable free shipping for customers and at the same time offer
other shipping options to customers, use the Free Shipping Op-
tions module instead.

Free Shipping Options Offline Allows you to specify different conditions for a customer to
qualify for free shipping. For example, when the total order
exceeds a certain amount or weight, or when the total number
of items bought is above a certain threshold value.

Enabling network access to third-party sites

For some shipping modules which require access to third-party sites to acquire real-time shipping quotes, you will
need to ensure that your PHP settings are properly configured to work with cURL. cURL support in PHP allows Zen
Cart to communicate properly with external websites.

To check whether cURL functionality is enabled in your server’s PHP settings:

1. Click on Tools > Server/Version Info to access the Server Information screen.

2. Make sure that the CURL support field is enabled.

If your store is hosted with a web hosting provider, you should check with them if you encounter problems with
network access when configuring those shipping modules which require cURL access.
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Important shipping considerations
Before you can start configuring any shipping module, you need to take note of several factors that will affect your
shipping destinations and costs.

Shipping destinations
If your local laws impose certain export regulations on your business or you have valid fraud concerns about shipping
your goods to certain countries, go to Locations/Taxes > Countries and disable the status of the relevant countries
accordingly. Customers will then be unable to specify those countries as their shipping locations during checkout.

Tare weight and calculation of shipping boxes

What is tare weight?

You might need to enclose your product within a box and maybe add some layers of foam for protection when shipping
your items. The additional weight (i.e. packing box, foam, etc) added to the actual weight of your item is known as
the tare weight. This variable should be the first thing you check when you find that the calculation for your shipping
charges do not add up.

Calculating the number of shipping boxes required

Whenever you ship items, you need to pack them nicely into suitable boxes, tubes, etc. Zen Cart can help you determine
the number of boxes you require based on the weight of your orders. However, the way the number of shipping boxes
is calculated can be wrong!

The formula for the calculation of the number of shipping boxes required is:

Number of shipping boxes =
     (total weight of all items in an order) / (maximum package weight)

Note: maximum package weight is the maximum weight that each shipping box can hold.

We shall use the following two examples to show how this formula actually works. For simplicity, both examples
assume the tare weight is zero. Example 10.1: “Correct shipping boxes calculated” gives you an idea of how the
formula works. Example 10.2: “Impractical shipping boxes calculated” illustrates why you have to be very careful if
you decide to use this feature to determine your shipping boxes.

Example 10.1: Correct shipping boxes calculated

Assume the maximum package weight is 0.4 lbs and a customer buys several items of the same product.

Product A = 0.2 lbs

Customer buys 4 units of Product A = 4 x 0.2 = 0.8 lbs

No. of Shipping Boxes required = (0.8) / (0.4) = 2

Note: Each box weighs 0.4 lbs, and contains 2 units of Product A each.
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Example 10.2: Impractical shipping boxes calculated

Assume the maximum package weight is 2.5 lbs and a customer buys the following three products from your store.

Product A = 2 lbs
Product B = 1 lb
Product C = 2 lbs

No. of Shipping Boxes required = (2+1+2) / (2.5) = 2

Note: You can’t ship your goods with only 2 boxes because the maximum weight for each box is 2.5 lbs! You
would need 3 boxes to ship the goods properly.

Due to the potential miscalculation of shipping boxes above, it is advisable that you do not show customers any
information on shipping boxes when they are checking out their items. You will see how to disable the display of this
information when we discuss "display-related information" in later.

Shipping and packaging details
Before you configure your shipping modules, you should set some general settings for all your shipping-related activ-
ities. We will go through all the settings here to give you a firm grounding in how Zen Cart deals with these issues.

Click on Configuration > Shipping/Packaging to access the Shipping/Packaging screen.

The information in this screen can be split up into several categories to help you appreciate how they impact your
shipping configuration.

▪ “Shipping origin information” on page 85.

▪ “Weight-related information” on page 86.

▪ “Display-related information” on page 88.

Shipping origin

The following fields are required if you are shipping physical items anywhere in the world.

▪ Country of Origin

▪ Postal Code

The information collected may be used to determine your shipping rates. For example, if you choose to use online
shipping modules (USPS, UPS, etc) which prepare shipping quotes in real-time, then this information will be used to
calculate the shipping charges based on the distance between your shipping origin and the shipping destination.
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Weight-related information

The following fields are related to weight information and will affect the calculation of your shipping weights when
you configure your shipping modules later.

▪ Enter the Maximum Package Weight you will ship

▪ Package Tare Small to Medium - added percentage:weight

▪ Larger packages - added packaging percentage:weight

▪ Order Free Shipping 0 Weight Status

The values for the Package Tare Small to Medium - added percentage:weight and Larger
packages - added packaging percentage:weight fields do not represent ratios.

Enter the Maximum Package Weight you will ship tells Zen Cart the maximum weight that you will allow in a
shipping package’s box, tube, envelope, etc. This is the maximum package weight that will be used for calculating the
number of boxes to pack the items contained in a customer’s order. Refer to the section “Calculating the number of
shipping boxes required” for calculation details. You should check with your shipping company in order to get an idea
what should be the correct value you should enter in this field.

Package Tare Small to Medium - added percentage:weight and Larger packages - added packaging
percentage:weight both allow you to specify a tare weight in addition to the total weight of your orders. You need to
pay close attention to these two options because store owners tend to forget that they affect the order weight calcula-
tions and spend a lot of time trying to figure out where the phantom weight came from.

Order Free Shipping 0 Weight Status allows you to specify whether you want to allow customers to enjoy free
shipping when they purchase a product for which you did not specify a weight. If you enable this option by setting its
value to 1, you will need to enable the FREE SHIPPING! module under Modules > Shipping.

The value for the Enter the Maximum Package Weight you will ship field acts as a switch used to determine whether
the value for the Package Tare Small to Medium - added percentage:weight field or the Larger packages - added
packaging percentage:weight field is used in your shipping calculations.

To better understand the relationships between the three preceding fields, let us assume you have the following values
set up in your Shipping/Packaging screen.

▪ Enter the Maximum Package Weight you will ship = 20 lbs

▪ Package Tare Small to Medium - added percentage:weight = 0:3

▪ Larger packages - added packaging percentage:weight = 10:0

Let us further assume you have the following three products in your store:

▪ Product X = 20 lbs

▪ Product Y = 10 lbs

▪ Product Z = 5 lbs
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Example 10.3: Larger packages - added packaging percentage:weight value used

If a customer buys products X, Y and Z, then the total items weight will be:

= 20 + 10 + 5 = 35 lbs.

Since total items weight (i.e. 35 lbs) is greater than the value (i.e. 20 lbs) for the Enter the Maximum Package
Weight you will ship field, Zen Cart determines that you will not be able to fit all your products within one
shipment box and will need to split your shipment into multiple boxes. Thus, Zen Cart uses the value for the
Larger packages - added packaging percentage:weight to add tare to your total items weight before it goes on
to calculate how many boxes you will actually need to ship all your products.

Based on the above values, your total shipping weight for multiple boxes is now:

= total items weight
  + (total items weight x large tare percentage)
  + large tare weight
= 35 lbs + (35 lbs x 10%) + 0 lbs
= 38.5 lbs.

The calculation for the number of boxes used for shipping your products is now:

= (total shipping weight) / max. package weight

Based on the above values, you will get:

= (38.5)/20 = 1.925 = 2 boxes (rounded up)

The weight for each box will be:

= (total shipping weight) / no. of boxes

Based on the above values, you will get:

= (38.5)/2 = 19.25 lbs

Thus, you will arrive at the following configuration for your shipping calculations:

= 2 x boxes @ 19.25 lbs each.
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Example 10.4: Package Tare Small to Medium - added percentage:weight value used

If a customer buys product Y and Z, then the total items weight will be:

= 10 + 5 = 15 lbs.

Since total items weight (i.e. 15 lbs) is less than the value (i.e. 20 lbs) for the Enter the Maximum Package
Weight you will ship field, Zen Cart determines that you will only need a single box to ship your product. Thus,
Zen Cart uses the value for the Package Tare Small to Medium - added percentage:weight field to add tare
to your total items weight.

Based on the above values, your total shipping weight for a single box is now:

= total items weight
  + (total items weight x small and medium tare percentage)
  + small and medium tare weight
= 15 + (15 x 0%) + 3
= 18 lbs.

Thus, you will arrive at the following configuration for your shipping calculations:

= 1 x box @ 18 lbs.

Display-related information

The two fields related to display information for shipping are:

▪ Display Number of Boxes and Weight Status

▪ Shipping Estimator Display Settings for Shopping Cart

Display Number of Boxes and Weight Status allows you to choose how you want to display the number of boxes
and weight when customers are prompted to choose a shipping option during the checkout process. The following
example screen shot shows what is displayed if you set this option to Both Boxes and Weight.

It is recommended that you set this value to off to prevent customers from witnessing any possible impractical cal-
culations as shown in Example 10.2: “Impractical shipping boxes calculated”. You certainly do not want to confuse
your customers and explain the discrepancies over and over again.

Shipping Estimator Display Settings for Shopping Cart toggles the display of the Shipping Estimator option when
customers view their shopping cart details. The following example screen shots show what customers can expect to
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see for the values of Display as Button on Shopping Cart and Display as Listing on Shopping
Cart Page respectively.

Figure 10.1: Shipping estimates displayed on Shopping Cart page

Common shipping information
Before we start adding shipping options, you need to know certain common shipping information that will help ease
your configuration later.

The Shipping Modules screen
All shipping modules in Zen Cart are configured via the Shipping Modules screen. To access this screen, click on
Modules > Shipping.

A shipping module can only be used if it is:

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 10. Shipping 90

▪ Installed.

▪ Enabled.

Therefore, you should automatically perform the above steps if you are asked to configure a shipping module later
in the chapter.

The colors of the buttons under the Sort Order column have the following meanings:

▪ Red - Shipping module is not installed.

▪ Green - Shipping module is installed and enabled.

▪ Yellow - Shipping module is installed but disabled or the Shipping Zone field is enabled only for a particular zone.

Avoid having your shipping module set to installed but disabled (i.e. Yellow) as it reduces
Zen Cart’s program efficiency because the affected shipping module’s code is still processed
although it will not be used. It is only recommended when you have custom code for the shipping
module that will enable itself at a later time.

Automatic email alerts
Whenever a shipping module is installed, updated or removed, an email will automatically be sent to the email address
as specified in the E-Mail Address (Displayed to Contact you) field of the E-Mail Options screen.

The contents of the email will include which particular shipping module was affected, which admin user made the
change and what kind of change (i.e. installed, updated or removed) was made.

The email alerts provide a good security safeguard against malicious or unintended changes to your shipping module
settings and there is currently no option in the Admin Console to turn off the sending of such email alerts.

Common shipping settings
Certain fields which are common across most of the different shipping modules are highlighted in the following table
so we do not have to explain them again later.

Table 10.2: Explanation of common shipping settings

Field Comments

Tax Class Assigns a tax class to the calculated shipping cost of an order. Refer to the
section “Understanding how taxes are configured” if you have forgotten how
taxes work.

Tax Basis Specifies which of the following addresses to use for calculating tax charges -
Shipping, Billing or Store. Refer to the section “Basis for tax calculation” for
more information.

Handling Fee Adds an extra charge to the final shipping cost. For example, if you have to buy
special packaging materials for your goods, you might want to add the cost of
those materials here.
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Field Comments

Handling Per Order or Per Box If you had entered a value for the Handling Fee field, select the Order radio
button so that handling fees are based on the value entered in the Handling Fee
field only.

If your shipping method is weight-based, you can select the Box radio button so
handling fees will be charged by multiplying the amount specified in the Han-
dling Fee field against the total number of shipping boxes required to fulfill the
order.

Shipping Zone For shipping modules that have selected a particular zone definition for this
field, customers will only see the corresponding shipping option if their delivery
addresses fall within the selected zone definition.

Specifying --none-- for this field for a particular shipping module will make
the corresponding shipping option appear to all customers.

For testing purposes, set this field to --none--.

Sort Order Indicates the sequence in which shipping options appear to a customer when
checking out. A shipping option with a lower value will appear above a shipping
option with a higher value.

You can leave this field set to 0 for all shipping modules to let Zen Cart sort the
shipping options automatically when customers view them.

If you choose to specify a non-zero value for this field, make sure you also spec-
ify a non-zero value for all other shipping modules. In addition, all non-zero val-
ues must be different.

Adding shipping options

Flat rate

This shipping option adds a fixed charge to a customer’s order regardless of the number of items, total weight or total
price of the order. For example, if a customer orders 5 lamps, 2 tables and 3 chairs, you still charge a flat rate of $50
for the whole order.

This type of shipping option is a good choice for stores that sell goods which can be hand-carried by customers. In
such cases, if the customers wish to have the items delivered, then the store will charge a flat rate for any deliveries.
An example would be furniture shops which typically do delivery if customers buy items above a certain amount.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Flat Rate module. If required, install the module first.
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3. In the Shipping Cost field, specify the fixed amount you want to charge for customers who choose this shipping
option.

4. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a "Normal Test Product" product to your cart and check out the item.

3. At the Delivery Information screen, you should see "Flat Rate" appear as a shipping option under the Shipping
Method section.

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

Per item
This shipping module adds a fixed charge to each item in a customer’s order regardless of the number of items, total
weight or total price of the order. For example, if a customer orders 5 lamps, 2 tables and 3 chairs, you decide to charge
a per item rate of $10. Your total shipping cost will work out to be (5+2+3) x 10 = $100.
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This shipping module is a good choice for stores that sell a single item or items that have uniform shipping attributes.
An example would be shops selling DVDs, CDs and books, etc.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Per Item module. If required, install the module first.

3. In the Shipping Cost field, specify the amount you want to charge for each item in a customer’s order.

4. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add two or more "Normal Test Product" products to your cart and check out the items. By adding multiple items,
you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see "Per Item" appear as a shipping option under the Shipping
Method screen.

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 10. Shipping 94

Per unit
This shipping module applies a different charge to each item in a customer’s order based on the item’s unit weight and
quantity. The unit weight of an item is the weight you specified when creating a product in the catalog. Essentially, it
provides you a way of specifying different shipping charges based on the products that are being shipped.

Consider this scenario: You decide to sells pots and pans which weigh 0.5 and 0.25 pounds respectively. You have
further decided that the shipping cost is $10 per pound. Therefore, if a customer orders 2 pots and 3 pans, the total
shipping cost will work out to be (2 x 0.5 x 10) + (3 x 0.25 x 10) = $17.50.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Per Unit module. If required, install the module first.

3. In the Shipping Cost per Unit field, specify the amount you want to charge per unit weight for each item in
a customer’s order. If you have trouble understanding this field, think of it as how much you would charge per
pound ($/lb) or how much you would charge per kilogram ($/kg), etc.

4. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

Before you test this module, you can turn off tare weight to simplify the interpretation of the test results. Click on
Configuration > Shipping/Packaging and set the following fields to 0:0.

▪ Package Tare Small to Medium - added percentage:weight
▪ Larger packages - added packaging percentage:weight

To test this module:

1. Log in to your test customer account in your Store Front.
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2. Add two or more "Normal Test Product" products to your cart and check out the items. By adding multiple items,
you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see "Per Unit" appear as a shipping option under the Shipping
Method section.

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

Repeat the test with different values for the tare weight to better understand how shipping charges for this shipping
module are calculated by Zen Cart.

Do check that you have set the value of Enter the Maximum Package Weight you will ship in
Configuration > Shipping/Packaging to a value that is higher than your expected total order
weight. If not, you might find that your shipping cost is limited to the weight of the maximum
package weight instead of the total weight of the order.

Store pickup

This shipping module gives customers the benefit of picking up their items at your store instead of incurring any
delivery charges. Similarly, it saves store owners the hassle of having to pack and deliver the goods. If you use this
option, do consider defining a shipping Zone Definition that covers your local vicinity so that only customers with
shipping addresses in the vicinity can see this shipping module.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Store Pickup module. If required, install the module first.
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3. Enter one or more physical locations where customers can pick up their purchases in the Pickup Locations field.
Alternatively, you can leave the field as it is.

4. In the Shipping Cost field, specify the amount you would like to charge for customers who choose to pick up
their goods from your store. Usually, this amount is left at 0.00 unless there is some warehousing costs to the
store owner.

5. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

6. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a "Normal Test Product" product to your cart and check out the item.

3. At the Delivery Information screen, you should see "Store Pickup" appear as a shipping option under the Shipping
Method section.

4. Check that the amount appearing next to the Walk In radio button is correct based on your settings for this module.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 10. Shipping 97

Table rates
This shipping module allows you to apply different shipping charges based on either the weight, price or number of
items bands. For example, you can charge $10 for orders above $50 and $2 for orders above $100. Specifying table
rates based on price or number of items is entirely up to how your business operates. To specify table rates by weight,
you can usually obtain a copy of the shipping rates table from your local post office to help you get started.

Understanding the shipping table

Before we go any further, you need to understand the syntax of the Shipping Table field which you will encounter later.

Example 10.5: Table Method = Weight

In this example, you have specified that the value of the Shipping Table represents weight. Let us assume that
the total weight of a customer’s order is "x" and that the default unit of measure for weight is in "lbs". If the value
of the Shipping Table field is 25:8.50,50:5.50,1000:0.00, it essentially means the following:

         x <= 25 lbs   : Shipping Rates = $8.50
25 lbs < x <= 50 lbs   : Shipping Rates = $5.50
50 lbs < x <= 1000 lbs : Shipping Rates = $0.00 i.e. Free Shipping for
                                                    total weight above 50 lbs.

Example 10.6: Table Method = Price

In this example, you have specified that the value of the Shipping Table represents price. Let us assume that the
total price of a customer’s order is "y" and that the default currency is in "$". If the value of the Shipping Table
field is 25:8.50,50:5.50,1000:0.00, it essentially means the following:

      y <= $25   : Shipping Rates = $8.50
$25 < y <= $50   : Shipping Rates = $5.50
$50 < y <= $1000 : Shipping Rates = $0.00 i.e. Free Shipping for purchases
                                              above $50

Example 10.7: Table Method = Number of Items

In this example, you have specified that the value of the Shipping Table represents number of items. Let us
assume that the total number of items in a customer’s order is "z". If the value of the Shipping Table field is
25:8.50,50:5.50,1000:0.00, it essentially means the following:

     z <= 25   : Shipping Rates = $8.50
25 < z <= 50   : Shipping Rates = $5.50
50 < z <= 1000 : Shipping Rates = $0.00 i.e. Free Shipping for more than
                                             50 items bought

The value for the last entry in the Shipping Table field can be specified as a percentage of an
order total instead of a flat charge. This additional calculation flexibility is applicable regardless
of whether weight, price or number of items is chosen as the basis for the shipping rate.
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Using Example 10.5: “Table Method = Weight” as an illustration and further assuming the
order total for an order is $100.00. If the entry was 25:8.50,50:5.50,1000:5%, then the
calculation for the shipping charges based on weight will be as follows:

         x <= 25 lbs  : Shipping Rates = $8.50
25 lbs < x <= 50 lbs  : Shipping Rates = $5.50
50 lbs < x <= 1000 lbs: Shipping Rates = $5.00  i.e. 5% of $100.00

Make sure you understand how the Shipping Table works before you begin configuring this shipping module.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Table Rate module. If required, install the module first.

3. Change the value of the Shipping Table field according to your preference and then specify what the Shipping
Table field represents by clicking the appropriate radio button in the Table Method field.

4. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

5. Click update to save your changes to the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

The following test uses weight for illustration. You should substitute it with either price or number of items to suit your
own needs. Before you test this module, you can turn off tare weight to simplify the interpretation of the test results.
Click on Configuration > Shipping/Packaging and set the following fields to 0:0.

▪ Package Tare Small to Medium - added percentage:weight

▪ Larger packages - added packaging percentage:weight
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To test this module:

1. Log in to your test customer account in your Store Front.

2. Add two or more "Normal Test Product" products to your cart and check out the items. By adding multiple items,
you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see "Table Rate" appear as a shipping option under the Shipping
Method section.

If your table method calculation is based on weight, you will see the number of shipping boxes and weight per
box fields next to the "Table Rate" heading.

4. Check that the amount appearing next to the Best Way radio button is correct based on your settings for this
module.

If you use a Table Method of weight when configuring this shipping module, make sure you
check that the tare weight values you have configured in Configuration > Shipping/Packaging
makes sense to you.

Zone rates

Zone Rates can be considered a superset of Table Rates. Both shipping modules operate on the same underlying
concept using band rates for weight, price or number of items in an order. Whereas the Table Rates shipping module
has only one shipping table for an entire shipping zone, the Zone Rates shipping module provides different shipping
tables for multiple shipping zones.

To look up the ISO country code for a particular country while configuring this module, you may want to refer to the
Countries screen by clicking on Locations/Taxes > Countries.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Zone Rates module. If required, install the module first.
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3. Select an appropriate value for the Calculation Method field.

4. If you do not want this shipping option to appear for shipping addresses in specific countries, add the necessary
ISO country codes in the Skip Countries field.

Customers with shipping addresses in countries not specified in the Skip Countries field and also not specified
in all the Zone Countries field will see a message displayed under the "Zone Rates" shipping option as shown
in the following screen shot.

5. For each zone, fill in the necessary details for the Zone Countries, Zone Shipping Table and Zone Handling
Fee fields.

6. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

7. Click update to save your changes into the database.

You can change the number of zones available to you by editing [zc-home]/includes/mod-
ules/shipping/zones.php and changing the value of this->num_zones=3 to something
else; e.g. this->num_zones=5.

We shall use the Normal Test Product (refer to the section “Normal Test Product” for details) for the purpose of our
test. The following test uses weight for illustration. You should substitute it with either price or number of items to
suit your own needs.

In addition, we shall use the test customer we created in the section “Setting up a test customer” for our test. Note that
the ISO country code for the test customer’s country of France is "FR".
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To simplify the interpretation of test results, you can turn off tare weight for the time being. Click on Configuration
> Shipping/Packaging and set the following fields to 0:0.

▪ Package Tare Small to Medium - added percentage:weight

▪ Larger packages - added packaging percentage:weight

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add two or more "Normal Test Product" products to your cart and check out the items. By adding multiple items,
you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see "Zone Rates" appear as a shipping option under the Shipping
Method section.

4. Check that the amount appearing next to the Shipping to radio button is correct based on your settings for this
module.

If you use a Calculation Method of weight when configuring this shipping module, do check
the tare weight values you have configured in Configuration > Shipping/Packaging makes
sense to you.

Free shipping
This shipping module allows you to offer free shipping to your customers. Note that it is compulsory to enable this
module if you decide to do the following:

▪ Offer discount coupons which are marked as free shipping. Refer to the section “Creating discount coupons”
for details.

▪ If you have a product configured for free shipping in your store.

▪ If you sell downloadable products.

When this shipping option appears in the Delivery Information page during check out, all other shipping options
(except Store Pickup, if enabled) will automatically disappear. To enable free shipping to appear simultaneously with
other shipping options (besides Store Pickup, if enabled) in the Delivery Information page during check out, use the
"Free Shipping Options" module instead.

You can choose from the following list of conditions to trigger the appearance of the Free Shipping option when
customers check out their purchases:

▪ The total price of a customer’s order exceeds a threshold value.

▪ If a product does not have any unit weight associated with it.

▪ If all products in a customer’s order are configured for free shipping as follows:
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▸ Product is Virtual field is not set to Yes, Skip Shipping Address.

▸ Always Free Shipping field is set to No, Normal Shipping Rules.

To trigger the appearance of the Free Shipping option when the total price of a customer’s order exceeds a threshold
value:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Click on Shipping and edit the item.

3. Specify true for the Allow Free Shipping field.

4. Set the threshold amount to trigger free shipping in the Free Shipping For Orders Over field.

5. Specify whether free shipping should apply for international or national delivery addresses in the Provide
Free Shipping For Orders Made field. Choose both for testing purposes.

To trigger the appearance of the Free Shipping option when a product does not have any unit weight associated with it:

1. Click on Configuration > Shipping/Packaging to access the Shipping/Packaging screen.

2. Set the Order Free Shipping 0 Weight Status field to 1.

I would recommend that you do not allow free shipping to be activated based on the fact that
a product does not have a weight attached to it. If you are careless and forget to input a weight
for a product, you might end up having to pay yourself to ship the goods.

To trigger the appearance of the Free Shipping option when all products in a customer’s order are configured for free
shipping, you need to first make sure that you have a product that is configured to take advantage of such a scenario
first. To configure such a product:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Navigate to the the category containing the product you want to configure for free shipping. If you do not have
such a product, you can create one first.

3. Edit the details of the product. Make sure the following fields are set as follows:

▪ Product is Virtual field is not set to Yes, Skip Shipping Address.

▪ Always Free Shipping field is set to No, Normal Shipping Rules.

If all products in a customer’s order are virtual products or downloadable products, then the
Delivery Information page will be skipped altogether. In both cases, the Free Shipping modules
should still be enabled as it is used to drive the checkout process.

Now that you understand the conditions that will trigger the appearance of the Free Shipping option during check out,
you can start configuring the Free Shipping module.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the FREE SHIPPING! module. If required, install the module first.
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3. In the Free Shipping Cost field, specify the amount to charge customers who choose this option. Specifying a
fee here is discouraged because customers expect Free Shipping to be literally free!

4. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

5. Click update to save your changes to the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

We shall assume that you have chosen to trigger Free Shipping based on price.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a "Normal Test Product" product to your cart and check out the item.

3. At the Delivery Information screen, you should see "Free Shipping" appear as the only shipping option under the
Shipping Method section if your free shipping threshold value is below the order price.

4. Note that the threshold value for free shipping is shown on the screen as well.

Free shipping options
This shipping module allows you to offer free shipping to customers side-by-side with other shipping options. This is
not possible with Free Shipping which causes all other shipping modules (except Store Pickup, if enabled) to disappear
when it appears. Furthermore, you can choose to have this shipping option appear based on the total price, total weight
or total number of items in a customer’s order.

To configure this module:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Edit the Free Shipping Options module. If required, install the module first.
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3. Carefully read the instructions on the side-panel before you start configuring this module.

4. Specify how Free Shipping Option should be triggered based on the corresponding Total, Weight and Item Count
fields.

5. Avoid entering a value for the Shipping Cost field because customers expect Free Shipping Options to be literally
free!

6. Fill in the rest of the details for the module. Refer to the section “Common shipping settings” for explanations
for the rest of the fields.

7. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

We shall assume that you have chosen to trigger Free Shipping based on number of items in an order. Thus, you should
have entered 2 for the Item Count >= field when configuring this module.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add three or more "Normal Test Product" products to your cart and check out the items. By adding multiple items,
you can better visualize and verify the accuracy of the shipping charges calculation.

3. At the Delivery Information screen, you should see "Free Shipping Options" displayed as a shipping option under
the Shipping Method section.

4. Check that the amount appearing next to the Free Shipping radio button is correct based on your settings for
this module.

Do check the tare weight values you have configured in Configuration > Shipping/Packaging
if you use weight as a trigger for activating this shipping module.
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Summary
Shipping options are an important aspect of an online store. Finding the best option for your situation will require some
planning and creative experimentation. Make sure you spend some time to understand how the module you choose
actually works. It could save you a lot of embarrassing questions from customers later.
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Chapter 11:

Payment

Introduction
Zen Cart provides various payment modules to cater to the different ways in which store owners intend to process
customer’s payment information. Each payment module that is enabled will then appear as a payment option to cus-
tomers based on the billing addresses they select when they check out their items.

Before offering any payment option to your customers, make sure you find out more about the legal and accounting
requirements of your country. For example, in most countries, you need to ensure that customers credit card information
must be transmitted over a secure channel and such credit card information must be stored securely.

Zen Cart comes with a number of default payment modules. For payment modules that require interaction with third-
party payment processors, we will only be covering the PayPal Payments Standard module as it is the most popular
and widely accepted form of online payment at the moment. After you are familiar with how the PayPal Payments
Standard module works, you should be able to adapt the concept to other payment modules that require access to a
third-party payment processor.

In this chapter, we shall:

▪ Explain the meanings of PCI-DSS and PA-DSS.

▪ Run through the common payment screen and payment settings.

▪ Go through each payment option separately.

To keep the explanation of each payment module independent, we shall discuss how to test each
payment module immediately after learning how to configure it.

Making sense of PCI-DSS and PA-DSS
To counter credit card fraud and identity theft, several major payment card brands (American Express, MasterCard
Worldwide, Visa Inc, etc) have grouped together to form an organization known as the Payment Card Industry Security
Standards Council (PCI SSC) to develop a set of security standards pertaining to the protection of cardholder account
data.

The main security standard that was developed is the Payment Card Industry Data Security Standard (PCI DSS). It is
a set of policies and procedures intended to optimize the security of credit, debit and cash card transactions and protect
cardholders against misuse of their personal account information.

As PCI DSS applies whenever cardholder data is stored, transmitted or processed by merchants or card processors,
several parties can be affected when a card payment transaction takes place. For example, if a customer enters card
data on your site when paying for a purchase, that data may be transmitted by your online store to a payment gateway
through your web host’s servers. As a result, your site, the payment gateway and your web host all have to be PCI
DSS compliant.
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Another security standard that was developed is the Payment Application Data Security Standard (PA-DSS). This
standard was derived from PCI DSS and has a narrower focus as it applies more to payment applications (e.g. shopping
cart software and payment gateways).

As Zen Cart version 1.5.4 is already PA-DSS certified, it helps reduce the workload of store owners aiming for PCI
DSS compliance. For detailed information on Zen Cart and PCI DSS compliance, refer to [zc-home]/docs/im-
plementation-guide-v154.pdf.

For store owners who need to adhere to PCI DSS and fail to do so, penalties from individual card companies include
punitive fines to termination of the right to accept credit cards. If a credit card breach occurs, store owners could also
end up facing lawsuits. Hence, it is important that you find out whether you need to be PCI DSS compliant.

The general rule with regards to whether you need to be PCI DSS compliant depends on whether your store has a
web page that collects cardholder data.

For example, if your customers enter their credit card details on your payment gateway’s site when making a purchase,
then you likely do not need to be PCI DSS compliant. However, if customer’s enter their credit card information
directly on your site and that information is captured by your site, then there is a very strong likelihood that you will
need to be PCI DSS compliant.

If you are unsure whether you need to be PCI DSS compliant, consult your credit card processor, payment gateway
or a qualified professional familiar with PCI DSS standards.

Due to the evolving nature of PCI DSS and the important effects it might have on your business, you are strong-
ly encouraged to find out more information about it by referring to the standard’s official website at https://
www.pcisecuritystandards.org/index.php.

Default payment modules
Before you decide which payment options to offer your customers, you can consult the following table to get an idea
of the various default payment modules that come with Zen Cart. These payment modules are classified according to
the methods they employ to process payments, such as:

▪ Online - Processing is done in real-time with an external payment processor.

▪ Offline - Processing is done when information is collected and the store owner has to take action to complete
the payment process.

▪ Special - This is a special case where no action is taken to process payment.

Table 11.1: Default payment options

Modules Methods Comments

Cash on Delivery Offline Payment is received on delivery of goods. Not advisable for
global e-commerce!

Check/Money Order Offline Customers will mail in their checks or money orders separate-
ly after placing their orders.

Authorize.net Online Integrates with Authorize.net payment processor. See http://
www.authorize.net/ for details.

Authorize.net (AIM) Online Same as above but uses Authorize.net’s Advanced Integration
Method (AIM) for integration.
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Modules Methods Comments

Due to PCI-DSS requirements, this module requires SSL to be
configured for your Zen Cart store before the module itself can
be enabled.

Authorize.Net - eCheck Online Integrates to Authorize.Net payment processor to process elec-
tronic checks. To sign up for an Authorize.Net account, go to
http://reseller.authorize.net/application.asp?id=131345 for de-
tails.

Due to PCI-DSS requirements, this module requires SSL to be
configured for your Zen Cart store before the module itself can
be enabled.

FirstData/Linkpoint/YourPay API Online Integrates to the LinkPoint payment gateway. For more infor-
mation on signing up for a merchant account and using this
module, go to http://www.zen-cart.com/partners/linkpoint for
details.

Due to PCI-DSS requirements, this module requires SSL to be
configured for your Zen Cart store before the module itself can
be enabled.

PayPal Payments Standard Online Integrates to PayPal payment processor. To sign up for a Pay-
Pal business account and obtain more information on PayPal,
go to http://www.zen-cart.com/partners/paypal for details.

The name of this module will appear as PayPal Website Pay-
ments Standard if the Country field is not set to United
States in the My Store screen. This is due to PayPal’s brand-
ing guidelines for different countries.

PayPal Express Checkout Online Also integrates to PayPal payment processor but has the added
benefit of shortening the checkout process for customers. For
more information on this payment module, turn to the PayPal
Express Checkout sub-forum on Zen Cart’s site.

PayPal Payments Pro Online Also integrates to PayPal payment processor but unlike the
other PayPal modules, it allows customers to enter their cred-
it card details on your site without having to visit Paypal’s site
thus providing a seamless checkout process.

The name of this module will appear as PayPal Website Pay-
ments Pro if the Country field is not set to United States
in the My Store screen. This is due to PayPal’s branding
guidelines for different countries.

Due to PCI-DSS requirements, this module requires SSL to be
configured for your Zen Cart store before the module itself can
be enabled.
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Modules Methods Comments

To sign up for a PayPal business account and obtain more
information on PayPal, go to http://www.zen-cart.com/part-
ners/paypal for details.

Note that PayPal Express Checkout needs to be installed and
enabled before you can use this module.

Free Order Special Allows you to specify that customers from a specific zone are
able to buy things from your store for free.

All online payment gateways require SSL (Secure Sockets Layer) to be configured for your
store in order to proess 'live' payment transactions. This is irrespective of whether your online
store is PCI DSS compliant.

Refer to Chapter 20, “Working with Store Front templates” for more information on configuring
your store to work with SSL.

Enabling network access to third-party sites
If you have enabled a payment module (e.g. Linkpoint/YourPay API) which requires access to a third-party site to
process payments, you may need to enable cURL support on your server. Refer to the section “Enabling network
access to third-party sites” for more details on this issue.

To check whether cURL settings are properly configured on your server and whether cURL is
working properly with some of your online payment modules, you can make use of the [zc-
home]/extras/curltester.php file. For instructions on doing so, refer to http://www.zen-
cart.com/forum/showpost.php?p=434187&postcount=2.

Common payment information
Before we start adding payment options, you need to know certain common payment information that will help ease
your configuration later.

The Payment Modules screen
All payment options in Zen Cart are configured via the Payment Modules screen. To access this screen, click on
Modules > Payment.
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▪ Installed.

▪ Enabled.

Therefore, you should automatically perform the above steps if you are asked to configure a payment option later in
the chapter.

The colors of the buttons under the Sort Order column have the following meanings:

▪ Red - Payment module is not installed.

▪ Green - Payment module is installed and enabled.

▪ Yellow - Payment module is installed but disabled or the Payment Zone field is enabled only for a particular zone.

Avoid having your payment module set to installed but disabled (i.e. Yellow) as it reduces
Zen Cart’s program efficiency because the affected payment module’s code is still processed
although it will not be used. It is only recommended when you have custom code for the payment
module that will enable itself at a later time.

Automatic email alerts
Whenever a payment module is installed, updated or removed, an email will automatically be sent to the email address
as specified in the E-Mail Address (Displayed to Contact you) field of the E-Mail Options screen.

The contents of the email will include which particular payment module was affected, which admin user made the
change and what kind of change (i.e. installed, updated or removed) was made.

The email alerts provide a good security safeguard against malicious or unintended changes to your payment module
settings and there is currently no option in the Admin Console to turn off the sending of such email alerts.

Common payment settings
Certain fields which are common across most of the different payment options are highlighted in the following table
so we do not have to explain them again later.

Table 11.2: Explanation of common payment settings

Field Comments

Payment Zone For payment modules that have selected a particular zone definition for this
field, customers will only see the corresponding payment option if their billing
addresses fall within the selected zone definition.

Specifying --none-- for this field for a particular payment module will make
the corresponding payment option appear to all customers.

For testing purposes, set this field to --none--.

Set Order Status Specifies the status of an order after a customer has made payment. The default
installation of Zen Cart comes with four order statuses defined - Pending, Pro-
cessing, Delivered, Updated.
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Field Comments

The default value in the drop-down list box refers to the default order status
defined in Localization > Order Status. For more details on order statuses, re-
fer to the section “Working with order statuses”.

Sort Order of Display Indicates the sequence in which payment options appear to a customer when
checking out. A payment option with a lower value will appear above a payment
option with a higher value.

You can leave this field set to 0 for all payment modules to let Zen Cart sort the
payment options automatically when customers view them.

If you choose to specify a non-zero value for this field, make sure you also spec-
ify a non-zero value for all other payment modules. In addition, all non-zero val-
ues must be different.

Displaying a list of accepted credit cards
Zen Cart gives you the option of displaying the credit cards you want to accept in your store when a customer is on
the Payment Information page. This option is available unless a particular payment modules requires special checkout
handling (e.g. PayPal Express Checkout and PayPal Payments Pro).

To display a list of credit cards in the Payment Information page when a customer is checkout out:

1. Click on Configuration > Credit Cards to access the Credit Cards screen.

2. Set the Credit Card Enabled - Show on Payment field to either 1 or 2.

3. To toggle the display of each individual credit card, edit the respective Credit Card Enabled Status - xxx field
accordingly.

Images representing the credit cards are contained in the [zc-home]/includes/tem-

plates/template_default/images/icons directory. The credit card image names are specified in the [zc-
home]/includes/languages/english/credit_cards.php file. Refer to Chapter 20, “Working with Store
Front templates” to learn the proper way to change the images.

The displayed cards you want to accept may not necessarily correspond to the actual cards
accepted by a particular payment module. Therefore, use this display option only when you are
sure your payment modules will be accepting the credit cards you enabled.
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AJAX checkout experience
One of the requirements of PA-DSS compliance is that the HTML forms rendered by certain payment modules that
collect credit card information from customers be rendered using a technology known as AJAX (i.e. Asynchronous
JavaScript and XML).

AJAX is what allows information on fragments of a web page to be collected and displayed without having to reload the
entire web page. Currently, the default payment modules that implement AJAX form rendering are PayPal Payments
Pro, FirstData/Linkpoint/YourPay API and Authorize.net (AIM).

If your store does not require PA-DSS compliance and you do not want to use AJAX to render the credit card forms,
you can go to Configuration > My Store and set the PA-DSS Ajax Checkout field to Non-compliant as seen in
the following screen shot.

Adding payment options

Cash on delivery
Generally, this method is not recommended for e-commerce. However, if you are just beginning to add an online
presence on top of your current brick-and-mortar shop; and you already have a base of loyal customers, then this would
be an excellent option for you.

To discourage customers from choosing this payment option, you can consider charging customers an extra fee if they
choose this payment option during checkout. Refer to the section “Cash on Delivery (COD) fee” for more details.

To configure this module:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Edit the Cash on Delivery module. If required, install the module first.
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3. Fill in the details for the module. Refer to the section “Common payment settings” for explanations for all the
fields.

4. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a "Normal Test Product" product to your cart and check out the item.

3. At the Delivery Information screen, choose any shipping method and click continue checkout to proceed to the
Payment Information screen.

4. At the Payment Information screen, you should see "Cash on Delivery" appear as a payment option under the
Payment Method section.

Check and money order
This method is not recommended for e-commerce because it takes time both for the check or money order to arrive
and for them to clear with the banks. However, it is a safer means of collecting payment as it avoids online fraud.
In any case, certain businesses will always need to have this means of receiving payment, so we shall discuss how
this can be done in Zen Cart.

To configure this module:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Edit the Check/Money Order module. If required, install the module first.

3. Enter the name of the person or entity that should receive the check or money order in the Make Payable to field.
Do not use the default text displayed in the text box.
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4. Fill in the details for the module. Refer to the section “Common payment settings” for explanations for all the
fields.

5. Click update to save your changes into the database.

Before you begin to test this module, you need to create a product in your store. We shall use the Normal Test Product
(refer to the section “Normal Test Product” for details) for the purpose of our test.

To test this module:

1. Log in to your test customer account in your Store Front.

2. Add a "Normal Test Product" product to your cart check out the item.

3. At the Delivery Information screen, choose any shipping method and click continue checkout to proceed to the
Payment Information screen.

4. At the Payment Information screen, you should see "Check/Money Order" appear as a payment option under the
Payment Method section.

5. Click the radio button next to Check/Money Order and then click on continue checkout to proceed to the Order
Confirmation screen.

Free order
Unlike all other payment modules in Zen Cart, this payment module does not involve any monetary transaction. Its
main purpose is to offer customers a smoother checkout experience. When this payment option appears, all other
payment options will disappear thus speeding up the checkout process because customers do not have to spend time
choosing between different payment options.

This payment option is available only for products that satisfy the following criteria:

▪ Product price is marked as Free.

▪ Product comes with Free Shipping.

Note that this payment option will only appear if all items in the customer’s shopping cart satisfy the above criteria.

In addition, if an order happens to qualify for free shipping because a free shipping coupon was redeemed, then this
payment option will appear as well.
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You may ask why anyone would offer a free item? Well, you could do this to gain some publicity to your site or build
goodwill among your customers. For example, if your store sells hard-copy magazines; you can offer readers a free
electronic download of a particular magazine’s article to entice them to sign up for a subscription to that magazine.
Most customers would also have a better impression of your store since you have given them a "try-before-you-buy"
option.

Before you begin to configure this module, you need to enable the Free Shipping option in Zen Cart:

1. Click on Modules > Shipping to access the Shipping Modules screen.

2. Click on FREE SHIPPING and make sure it is installed and enabled.

3. Make sure both the Free Shipping Cost and Handling Fee fields are set to 0.

4. You can specify Tax Class, Shipping Zone and Sort Order according to your preferences.

To configure this module:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Edit the Free Order module. If required, install the module first.

3. Fill in the details for the module. Refer to the section “Common payment settings” for explanations for all the
fields.

4. Click update to save your changes into the database.

Before you begin to test this module, you need to have a free product that also offers free shipping. Do take note
that the product has to be marked as Product is Free and not just specified as having a price of $0.00! We shall use
the "Free Test Product with Free Shipping" (refer to the section “Free Test Product with Free Shipping” for details)
product for the purpose of our test.

To test this module:

1. Log in to your test customer account in the Store Front.

2. Add a "Free Test Product with Free Shipping" product to your cart and check out the item.

3. The Delivery Information screen will only appear if you have specified No, Shipping Address Required for
the Product is Virtual field when you created your product. Only the Free Shipping and Store Pickup shipping
options will be visible regardless of whether other shipping modules are available.

Choose any shipping option and click continue checkout to go to the Payment Information screen.
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4. At the Payment Information screen, you should see "Free Order" appear as the only option under the Payment
Method section.

PayPal Payments Standard
PayPal is one of the most popular and widely-accepted payment methods on the Internet. It charges merchants a very
low fee for its transactions and comes with an excellent fraud detection service. Furthermore, it does not levy any extra
charge to open an account with them.

PayPal offers several payment solutions to online merchants in order to help them process their customer payments.
Although Zen Cart offers three different PayPal payment modules, we shall only be going through the "PayPal Pay-
ments Standard" payment module as it is the one most commonly available to online merchants and also the least
confusing to customers who are new to online shopping. Refer to http://tutorials.zen-cart.com/index.php?article=28 if
you want to know the differences among the three PayPal payment modules.

Note that the name of the "PayPal Payments Standard" payment module will appear as "PayPal Website Payments
Standard" if the Country field is not set to United States in the My Store screen. This is due to PayPal’s branding
guidelines for different countries. For the remainder of this book, we shall refer to this payment module as "PayPal
Payments Standard".

Before attempting to set up the PayPal Payments Standard payment module in Zen Cart, you should go through the
rest of the book and be sufficiently familiar with Zen Cart. The following steps will assume you are setting up PayPal
Payments Standard for the first time on a remote host.

Further PayPal setup and troubleshooting information is available at http://www.zen-cart.com/
wiki/index.php/PayPal.

There are essentially three things you need to do to get PayPal working with your online store.

▪ “Set up PayPal Payments Standard in your store” on page 116.

▪ “Set up your PayPal Business Account at PayPal’s site” on page 118.

▪ “Test your PayPal Payments Standard setup” on page 121.

Set up PayPal Payments Standard in your store

1. Go to the Admin Console of your online store.

2. Click on Modules > Payment to access the Payment Modules screen.
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3. Click on the PayPal Payments Standard module. If this module is not installed, the side-panel should look
similar to the following screen shot.

4. Take note of the following fields in the side-panel as you will need them later.

Notice that the URLs of the fields in the above screen shot are preceded by "https". If you have not enabled SSL
support for your store, the URLs will display "http" instead.
▪ Instant Payment Notification Preferences URL
▪ Automatic Return URL

5. After you click install, you should see a side-panel similar to the following screen shots.

6. Make sure that Enable PayPal Module is set to True.

7. Specify an email address for the Business ID field. If you already have a PayPal account, this should be the
Primary Email Address for that account. If not, enter an email address first and then set it as the Primary Email
Address after registering for an account at PayPal’s site.

8. Take note of the value for the Mode for PayPal web services field. It should match the one you see in your
PayPal account later.
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9. Choose live for the Live or Sandbox field since this book assumes you will be creating a real-world account
and testing against that account. If you are familiar with programming and have signed up for a test account with
PayPal, you can choose the sandbox instead.

10. Leave all the other fields at their default values while testing this module. Only change them later after you are
more familiar with how the PayPal module works.

11. Click update to complete your PayPal settings in Zen Cart.

Set up your PayPal Business Account at PayPal’s site

Before we begin, make sure you have signed up for a PayPal Business Account (PBA). If you have not done so, you
can go to http://www.zen-cart.com/partners/paypal to start creating your account.

Over time, PayPal’s website might be re-designed or may appear differently to users from dif-
ferent countries. Thus, the screen shots that you see may not match the site’s look on your com-
puter screen as you are reading this book. Do not worry; the general concepts presented in this
book remain valid so use the screen shots that you see here only as a guide.

There are actually three main things you need to configure on PayPal’s site.

1. Specify a Primary Email so that PayPal can notify you when payments are made.

2. Set up Instant Payment Notification so that PayPal can send payment notification back to your Zen Cart store.

3. Set up Website Payment Preferences to allow PayPal to redirect customers back to your site after making their
payments at PayPal’s site.

To begin configuring your PBA to accept payments from your store:

1. Log in to your PBA and the top of your screen should look similar to the following screen shot.

2. Hover over the Profile tab with your mouse and choose Add or Edit Email from the drop-down menu. Look for
an email that has its Status set to Primary. Make sure it is exactly the same as the email you entered previously
in Step 7 of the section “Set up PayPal Payments Standard in your store”.

3. Click on the Profile tab, and then click My Selling Preferences in the side menu. Concentrate on the Getting
paid and managing my risk section.
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Click on Instant payment notifications and you will be presented with a screen similar to the following screen
shot.

a. Click the Turn On IPN button to activate PayPal’s Instant Payment Notification (IPN) feature.

b. Click the Edit settings button to begin adding your PayPal IPN URL. Refer to the Instant Payment Notifica-
tion Preferences URL you obtained in Step 4 of the section “Set up PayPal Payments Standard in your store”
and enter it into the Notification URL field. Make sure you check the Receive IPN messages radio button as
well. Note: Change the URL to start with "https" instead of "http" if your store has SSL configured already.
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c. Click Save to complete the configuration of the IPN feature in your PayPal account.

4. Click on the Profile tab, and then click My Selling Preferences in the side menu. Concentrate on the Selling
online section.

Click on Website preferences and you will be presented with another screen. We are only interested in the portion
of the screen that is similar to the following screen shot.
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a. Set the Auto-Return radio button to On to activate this feature for your PayPal account.

b. Refer to the Automatic Return URL you obtained in Step 3 of the section “Set up PayPal Payments Standard
in your store” and enter it into the Return URL field. Note: Change the URL to start with "https" instead of
"http" if your store has SSL configured already.

c. Optionally, set the Payment Data Transfer radio button to On and copy the value of the Identity Token
field onto your system clipboard and then paste it into the PDT Token (Payment Data Transfer) field of
your PayPal Payments Standard module.

d. Optionally, set the PayPal Account Optional field (not shown in the preceding screen shot) to On. By doing
so, customers without PayPal accounts can still pay using their credit card information.

e. Leave the other fields at their default values for now. You can change them later when you are more com-
fortable with how PayPal works.

f. Click Save to commit all your changes.

5. You can now log out from your PayPal account.

Test your PayPal Payments Standard setup

Before you begin testing your PayPal Payments Standard module:

▪ Make sure you have created a product in your store with a value of $0.01. This amount minimizes any monetary
loss if unforeseen problems occur with your tests.

▪ Make sure you use several test customer accounts from different regions to test your PayPal settings.

To begin testing your PayPal Payments Standard module:

1. Log in to your Store Front as a test customer and purchase your test product.

2. Choose PayPal as your payment option in the Payment Information screen.

3. Proceed to the Order Confirmation screen and after you click Confirm the order in that screen, you will be
redirected to PayPal’s site to complete your payment details.

4. After you have completed payment at PayPal’s site, you should be redirected back to your online store.

5. Log in to your Admin Console.

6. Click on Customers > Orders to see what your order looks like.

7. Click on Customers > PayPal IPN to check that your order has been processed successfully by PayPal and the
customer’s order information has indeed been returned to your store.

8. Log in to your PayPal Business Account.

9. You should see a payment received from your test order if everything goes well.

10. Do a refund for the test product’s amount if you are satisfied with your testing.
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11. Log in to your Admin Console again.

12. Click on Customers > PayPal IPN to check whether the order status has been updated after your order has been
refunded.

Zen Cart keeps records of all PayPal IPN transactions centrally. You can access these records
by clicking on Customers > PayPal IPN to access the PayPal Instant Payment Notifications
screen.

Summary
Do not overwhelm your customers with too many payment options. Research has shown that customers who ponder
too long on a payment option eventually end up not buying at all! Use the following criteria when deciding whether
to offer a particular payment option to your customers:

▪ Benefit your customers and convenient for them to use.
▪ Suitable for your business and be easy to administer.

Besides offering your customers suitable payment options, you should also make sure your store uses Secure Sockets
Layer (SSL) when processing payment details from them. Refer to the section “Secure Sockets Layer (SSL)” for more
information on how you can set up SSL for your store.
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Part III

Managing your store catalog

This section discusses how you can add goods and services to your store catalog. It also shows you how to customize
your products using product attributes. You will also learn different ways to manipulate your product catalog to allow
you to sell downloadable goods, list your products in multiple categories, etc.

This section covers the following topics:

▪ Chapter 12, “Working with catalog restrictions and categories”

▪ Chapter 13, “Working with product types and products”

▪ Chapter 14, “Working with product attributes”

▪ Chapter 15, “Advanced product attribute configuration”

▪ Chapter 16, “Additional product manipulation techniques”

▪ Chapter 17, “Order totals, surcharges and discounts”
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Chapter 12:

Working with catalog restrictions and
categories

Introduction
The ultimate aim of any online store is to showcase a merchant’s goods and services for sale or offer. Zen Cart achieves
this by providing a dynamic catalog which groups categories of products into a hierarchical tree structure. This allows
customers to quickly and easily browse through the store’s catalog to get to their desired items.

For the purposes of this book, we shall use the word "Product" to refer to both "Goods" and
"Services" collectively. Goods can be tangible (e.g. a water bottle) or intangible (e.g. an ebook).

In this chapter, we shall:

▪ Learn how to place restrictions store and catalog functions.
▪ Highlight useful tips for navigating the category and product manipulation area of the Admin Console.
▪ Go through the the different ways to work with categories.

Working with store and catalog restrictions
Under normal circumstances and for most online stores, the store catalog will display all goods with their prices on
each page for all users who visit the store.

However, some online stores require that certain information be limited to only customers who have logged into the
store or who have been granted the necessary permissions from the store owner to access product prices.

Therefore, before we look into adding products and categories to our store catalog, let us examine the different ways
whereby we can control access to some of our catalog information.

The three ways to restrict the shopping functions and access to information displayed in your store catalog are as
follows:

▪ “Store-wide catalog restriction” on page 124.
▪ “Login-based catalog restriction” on page 125.
▪ “Authorization-based catalog restriction” on page 126.

Store-wide catalog restriction
To specify the shopping function of your store on a store-wide basis:

1. Click on Configuration > My Store to access the My Store screen.
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2. Edit the Store Status field and concentrate on the side-panel.

3. Explanations for the different values are as follows:

▪ Under normal circumstances, you will choose the value 0. This means your store functions as a normal online
store where users can browse and purchase your goods.

▪ If you choose option 1, your store will function as a product showcase. Visitors to your site will only see your
products without the prices and not be able to make any purchase. Only a Contact Us hyperlink which leads
to the Contact Us page is shown in place of an Add to Cart button. Visitors will also not be able to create an
account with your store because the Log In hyperlink at the top of the Store Front will not be displayed.

▪ If you choose option 2, your store will function as if you chose option 1. The only difference being that prices
are displayed to visitors in this case.

Login-based catalog restriction
To control your store shopping function based on the login status of your customers:

1. Click on Configuration > Customer Details to access the Customer Details screen.

2. Edit the Customer Shop Status - View Shop and Prices field and concentrate on the side-panel.

3. Explanation for the different values are as follows:

▪ Not required - The store functions normally. Users are able to view products and their prices and also to
make purchases.

▪ Must login to browse - Visitors to your site who are not logged in will only see the Log In screen with
both side columns disabled. Upon log in, the store functions normally.

▪ May browse but no prices unless logged in - Visitors to your store who are not logged in will still
see your products. However, no prices will be displayed and a "Login for price" message will be displayed in
place of the Add to Cart button. Upon login, the store functions normally.
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▪ Showroom Only - Regardless of the login status of customers, a "Show Room Only" message will be displayed
in place of the Add to Cart button. Customers will still be able to see the products and prices in your store but
will not be able to make any purchases.

4. Click on update to if you have made any changes.

Individual customers can be banned from your store and prevented from logging in. To do this,
edit a customer’s details (refer to the section “Editing a customer’s details”) and select Banned
- Not allowed to login or shop from the Customer’s Authorization Status field
on that screen.

Authorization-based catalog restriction
Customers to your store can have different authorization statuses assigned to them as we shall see when we discuss
this in the section “Individual customer settings”. To control your store shopping function based on the authorization
status of your customers:

1. Click on Configuration > Customer Details to access the Customer Details screen.

2. Edit the Customer Approval Status - Authorization Pending field and concentrate on the side-panel.

3. The effects of the above fields in the side-panel are similar to those mentioned in the previous section. The dif-
ference being that one depends on the login status while the other depends on the authorization status.

4. Click on update if you have made any changes.

Individual customers can be banned from your store and prevented from logging in. To do this,
edit a customer’s details (refer to the section “Editing a customer’s details”) and select Banned
- Not allowed to login or shop from the Customer’s Authorization Status field
on that screen.

Catalog navigation tips
Let us now turn our attention to populating your store catalog with products and categories. However, before we do
so, it is important that you familiarize yourself with some commonly used tips for quickly navigating the store. This
will save you a lot of time if your store catalog is very big.
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Navigating the Catalog menu

Many functions for dealing with the different elements of your store catalog will be available via the Catalog menu
as shown in the following screen shot. Always turn to the menu entries here to give your brain a jolt if you want to
manipulate a product feature but are not sure what to do.

Navigating the Categories/Products screen

Manipulating the products and categories in your store catalog will require that you deal with the Categories/Products
screen most of the time. Therefore, it is important that you gain a firm grasp of the capabilities and short cuts available
in this screen.

When you click on Catalog > Categories/Products to access the Categories/Products screen, the initial display will
only show categories and not products as shown in the following screen shot.

The row of brightly colored buttons near the top of the screen is the legend and it is used to provide a quick reference
point to the buttons that are shown next to each row of products or categories that appear in your catalog.
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The available options for sorting the categories are available via the Categories/Products Display Order field.

As you click through the categories to get to deeper categories, you will eventually reach a category that contains only
products and no categories. We shall refer to a category containing only products as a leaf category in this book. We
will talk more about the leaf category in the section “Category and product setup rules”.

By looking at the following screen shot, you will notice other differences between a Categories/Products screen con-
taining only categories versus one that contains only products. Products have the "C" button which allows them to
be copied whereas categories do not have this button and hence cannot be copied. For products, they have extra "$"
and "A" buttons which are not shown in the legend. The "$" button is used to configure additional pricing properties
for your products while the "A" button is used to specify attributes for your products. The uses for these buttons will
become clear as we work through the rest of this book.

The available options for visually sorting products and categories are available via the Categories/Products Display
Order field. The "+" and "-" signs that appear in the options signify whether you want to sort the results in ascending
or descending order. Furthermore, if two or more terms appear, it means the sort order is performed with the first term
followed by the second term.

Using different text editors

If you have installed a rich-text editor in your Admin Console, you can use the Text Editor drop-down list box in
the Categories/Products screen to choose which editor to use when composing content for your category or product
descriptions. For more information on the use of rich-text editors, refer to the section “Using rich-text editors”.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 12. Working with catalog restrictions and categories 129

Jumping between categories

To quickly get from one category to another category in your catalog, make use of the Go To drop-down list box as
shown in the following screen shot. Notice that the options available in the Go To drop-down list box are indented
with an offset to help you differentiate the different nesting levels that categories can be grouped under.

The red cross and green tick icons toggle to display the Go To drop-down list box when clicked.

Searching the catalog

Another less utilized but very helpful feature when navigating your store catalog is to use the search feature. When
you enter a search term (e.g. sale) inside the Search input box, a search is performed against all category names and
the product ID, product name, product description, and product model fields of all products.

Products and categories that meet the search criteria are both displayed within the same page as shown in the fol-
lowing example screen shot. The Reset button which appears after a search is done will bring you to the main Cate-
gories/Products screen when clicked.

Only the Category Sort Order, Category Name and Category Name options are available in the Display
Order after your search is completed.
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Working with categories

Category and product setup rules
Categories allow you to group different sub-categories and products together. However, each category is only allowed
to contain either products or sub-categories but not both at the same time. Therefore, do not place your products on
the top-most level. This is because once you do that, you will not be able to create any categories!

There are several other points you need to take note of when manipulating the categories and products in your store
catalog. Some of the terminology introduced here will also be used in the rest of the book so it is very important that
you pay careful attention to what is being mentioned here.

1. A store catalog contains products that you group into categories. This grouping follows a hierarchical structure
with a single parent at the top of the structure.

2. The Top category refers to the top-most level in your product catalog. This is a pseudo category that is created
by Zen Cart. No products or categories can be added at the same level or any level above the Top category.

Only categories can exist below it. Hence, even if your store sells only one product, you must create a category
to house that single product. This rule is in place because of performance reasons, future expansion of your store
to accomodate more products and also to fulfil the needs of custom shopping rules that are applied on a per-
category basis.

3. A category can only contain child categories or products as its immediate children and not both at the same time.

4. Branch categories are those categories that contain only sub-categories as immediate children. Hence, Branch
categories cannot contain both child categories and child products at the same level. The term "Branch" category
is coined by me for easy reference in this book.

5. Leaf categories are those categories that contain only products. Again, the term "Leaf" category is coined by me
for easy reference in this book.

6. A product can only be listed in one master category. A "master category" is used to determine the pricing rules
for a product that is linked to different categories. More information on master categories will be covered in the
section “Listing products in multiple categories”.

A summary of the rules you need to follow when creating categories and products in your catalog is shown in the
following diagram.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 12. Working with catalog restrictions and categories 131

Note that you can break the rule of each category holding either categories or products only. This
is possible when moving categories and also when you are in a disabled category. Nevertheless,
do not mix products and categories under a parent category. This will cause Zen Cart to behave
strangely.

Creating new categories
To create a new category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on new category to proceed to the Category Details screen.

3. Enter a name for the category in the Category Name field.

4. Enter a description for the category in the Category Description field.

5. To specify an image for the category, choose one of the following two methods:

▪ The first method is to upload your image to the server via your browser.

a. Search an image file from your local computer by clicking the Browse button next to the Category Image
field. For a discussion on image file sizes, refer to the section “Optimizing image sizes” for more infor-
mation.

b. Choose a directory which you want to use to store the image from the Upload to Directory drop-down list
box. The default value of categories refers to [zc-home]/images/categories under the web server.
The other values in the drop-down list box refer to sub-directories located under [zc-home]/images.

▪ The second method is to upload your image via FTP to your server.

a. The image you upload via FTP should be placed in the [zc-home]/images directory or its sub-directory.
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b. After your image is uploaded, type in the name of the file in the filename field. If the file on the server
is [zc-home]/images/beverage.gif, type the value beverage.gif. If the file on the server is [zc-
home]/images/drinks/beverage.gif, then type the value drinks/beverage.gif instead.

Note that you can type none into the filename field to remove an image you have uploaded previously.
However, this method does not work with Internet Explorer.

6. Enter a number for the Sort Order field which specifies the sequence which this category will be displayed with
respect to other categories.

7. Click save to save your information. Your new category will appear in the Categories/Products screen.

Restricting categories to certain Product Types only
After you have created a category, you can choose to restrict the product types that the category can hold. In this way,
you reduce errors by ensuring uniformity of products while adding products to the category.

For example, if your store sells music CDs. You will likely choose to use the Product-Music product type when creating
a music CD in your store catalog because this is the only product type in Zen Cart that contains the following fields:
music genre, artist and record company. By restricting the category you wish to hold the music CD to contain only
products of Product-Music product type, you will not make the mistake of using another product type when creating
music CDs in that category.

Note that category restrictions based on product types only affects the creation of new products in the affected cate-
gories. Any products created based on other product types currently in the affected categories will not be affected.

To restrict a category to allow only products of a particular Product Type to be added:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the green "e" icon in the row containing the category which you want to set up a restriction. The category’s
details screen should appear.

3. Navigate to the bottom of the screen and you should see something similar to the following screen shot.

4. From the Restrict to Product Type drop-down list box, choose the product type you wish to restrict this category
to.

5. Click on Add include SubCategories if you want the restriction to apply to all sub-categories under this category.
Click on Add without SubCategories if you want the restriction to apply only to the immediate sub-category
instead of subsequent sub-categories after the immediate sub-category. All additions are immediately saved in
the database.

Note that sub-categories created after restrictions have been applied to the parent categories will not inherit the
restrictions of the parent categories.

6. Repeat Steps 4 and 5 to restrict this category to other Product Types.

Note that there is no visual cue to indicate that a category contains restrictions. You should check the parent category
whenever you do not see a full list of product types available to you when creating a product. Furthermore, there
is no way you can tell whether a category contains restrictions via Add include SubCategories or Add without
SubCategories. Therefore, it is always a good idea to write down your changes and keep a manual record.
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Moving and deleting categories
Zen Cart provides you the flexibility of re-arranging your categories by moving them around. When you move a
category to another category or sub-category, all the products under the category will be moved as well.

This feature allows you to quickly come up with a rough product catalog when you begin ex-
perimenting with your store setup and then you can slowly refine it according to your business
requirements.

To move a category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the purple "m" icon in the row containing the category which you want to move. You should see a screen
similar to the following screen shot.

3. Choose the destination category to move to from the drop-down list box.

4. Click on move to move the category to the destination category.

The process of deleting a category is straightforward. However, there are a few things to note before deleting a category.
If the category contains linked products, then the original products will not be deleted. On the other hand, if the original
products are deleted, then any linked products in other categories will also be deleted.

To delete a category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the red "x" icon in the row containing the category which you want to move. You should see a screen
similar to the following screen shot.

Enabling and disabling categories
The status of a category is immediately visible via the the "red" or "green" status buttons next to the product in the
Categories/Products screen.

When a category is disabled, it will not show up in the product catalog of your Store Front. Neither will any products
(linked or otherwise) under that category show up in the catalog as well.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 12. Working with catalog restrictions and categories 134

To enable or disable a category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Navigate to the desired category you wish to enable or disable.

3. Click the Status button (either "green" or "red") to toggle the status of that category in the catalog.

Summary
This chapter covered how you can control access to your store’s catalog by placing access restrictions at the store
level or the customer level. You were also given tips on navigating the category and product manipulation area of the
Admin Console so that you can perform commonly utilized functions faster and more efficiently. Finally, you learned
how to create and maipulate the categories in your catalog.
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Chapter 13:

Working with product types and
products

Introduction
While it is easy to describe a product in the physical world where we live, we need to put in more thought and effort
when setting up products in our online store. This is because the capabilities offered by an online store requires that
a product be set up properly in the store’s catalog in order to make use of the different features that Zen Cart offers
in showcasing and manipulating them later.

In this chapter, we shall:

▪ Learn product-related concepts specific to Zen Cart.

▪ Run through the workings of different product types.

▪ Learn the different ways to manipulate products.

▪ See how we can list products in different categories.

Important product-related concepts
Creating products and manipulating the many different properties and aspects of its functions often leaves store owners
losing themselves in the details and not seeing the full picture. In order to avoid this situation, we shall discuss some of
the key terms that you will often encounter when browsing the Zen Cart forums or when creating the products later on.

Product types

The main reason for the use of Product Types stems from the fact that different product types will need to be displayed
differently.

Most products in a store will have similar fields like title, description, price and weight. However, there will be situa-
tions in which certain products require different or additional fields that deviate from the norm. The existence of such
extra fields may sometimes require custom code to handle them as well.

For example, if your store sells cars, then the standard product fields like title, description and price would be sufficient.
However, if your store sells songs, then you may need an extra field to represent the artist(s) who recorded the songs.

Furthermore, cars are generally associated with a manufacturer or model. A song would definitely not be associated
with those fields and would more likely be associated with a recording company instead. Moreover, a song may provide
a short music sample whereas a manufacturer may not do that. All these extra features will need to be handled by
different sets of programming logic as well.
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In order to cater to the above situations, Zen Cart’s developers came up with the concept of a Product Type. A Product
Type defines the different fields that a particular type of product will have. In addition, custom programming logic is
also developed to handle products belonging to different product types.

By default, Zen Cart comes with the following five different product types which easily caters to the needs of most
store owners.

▪ Product-General

▪ Product-Music

▪ Product-Free-Shipping

▪ Document-General

▪ Document-Product

However, business situations differ; so if you need a custom product type to meet your needs, you can either code it
yourself or look for one from the contributions area on Zen Cart’s site.

If you are interested in coding your own Product Type, refer to http://tutorials.zen-cart.com/index.php?article=114.
The article provides some very good background information on the impetus behind the creation of the Product Type
entity and also the general steps required on how to create your own Product Type.

Comparing standard products with variant products

Let us suppose that your store sells three different types of study desks that differ only in the wood used to construct
them (e.g. teak, pine and rosewood).

You can either choose to create three different products to represent each desk; or you can choose to create one product
to represent the desks but with three different options each representing a different construction material which a user
can choose from. The former approach would require creating three ‘standard’ products while the latter approach will
only require creating one ‘variant’ product.

In short, a ‘variant’ product is one which gives customers the freedom to make choices in customizing a product to
fit their needs before making their purchases. A ‘standard’ product, on the other hand, does not offer customers any
choices in customizing the product.

Product attributes can also be configured to have price, weight and other information attached to them. They also
form the basis for creating downloable products. Due to the power and flexibility of product attributes, they can affect
the workings of several different store functions simultaneously. Thus, they will be covered in the chapters following
this one.

A Product Type defines the properties (i.e. fields) that a store owner would need to enter when
creating a product. A Product Attribute defines the properties (i.e. options) that customers can
use to create or select different variations of a product during purchase.

Physical, Virtual, Downloadable and Combo products

The terms ‘Physical’, ‘Virtual’, ‘Downloadable’ and ‘Combo’ are often encountered when browsing through the Zen
Cart forums. However, these terms are often misunderstood or misused and hence we shall discuss them here in order
to clear up the confusion. Strictly speaking, these terms refer to the shipping aspect of a product.
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‘Physical’ products will require some sort of shipping option set up because it deals with tangible goods. ‘Virtual’
products will not require shipping as it deals mainly with intangible goods. ‘Combo’ products deal with products that
possess both a ‘Virtual’ and ‘Physical’ component to them.

The similiarities between the terms ‘Virtual’ and ‘Downloadable’ is often the main source of confusion for newcomers
to Zen Cart when discussing electronically delivered products.

In Zen Cart parlance, a ‘Virtual’ product means a product that does not need to be delivered to a customer. For example,
an accounting service has nothing to be shipped to a customer because the service is performed by a person going to
a client’s site to tabulate the financial statements. Similarly, an electronic gift certificate with its value automatically
kept in the online store will not need to be shipped to a customer as well. We shall cover the functions of an electronic
Gift certificate in the section “Gift certificates”.

On the other hand, a ‘Downloadable’ product requires the product to be shipped electronically to a customer. Hence,
a customer will need to log in to your online store to download the electronic product. Downloadable products are
covered in the section “Selling downloadable products”.

Working with Product Types
As you have learned earlier, all products created in Zen Cart must belong to a Product Type. Product types define the
default properties of a product and whether these properties are shown to a customer.

Hence by changing a single property of a Product Type, you can effectively influence the field display and logic of
all products that belong to that particular Product Type. For example, if you turn off the weight display field for a
particular Product Type, then all products that belong to that Product Type will not display their weight in the store
catalog. This is actually one of the most commonly asked questions in the forums and understanding this example
alone will save you a lot of time later.

Choose your Product Type carefully. It usually takes a lot of effort and code changes to migrate
from one Product Type to another due to the differences in database table structures and rela-
tionships between different Product Types.

Editing a Product Type
Each Product Type has two sets of properties:

▪ Definition properties.

▪ Layout properties.

I have coined the term ‘Definition Properties’ because there is currently no literature in Zen
Cart on how to differentiate between the two types of properties for a Product Type.

Editing definition properties
Definition properties specify the characteristics of a product type. It is of interest mainly to people who want to cus-
tomize a product type or to create new product types in Zen Cart. As there is seldom any need to edit the definition
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properties of a Product Type unless you are a programmer, we shall only go through the meanings of the fields for
those who are curious.

To edit the definition properties of a particular Product Type:

1. Click on Catalog > Product Types to access the Product Types screen.

2. Choose a product type and click on edit to bring up a side-panel similar to the following screen shot.

Most of the fields are self-explanatory except the following:

▪ Handler Page - This field is used to indicate which PHP program should be used to process this particular
product type. Do not edit this field unless you are very sure you know what you are doing!

▪ Product Type Default Image - If you upload an image here, Zen Cart will use this default image if you do not
specify an image when creating products belonging to this Product Type. It is reserved for future use, therefore,
do not specify anything here.

▪ Upload to Directory - This option is useful only if you have specified something for the Product Type Default
Image field.

▪ This Product can be added to cart - If unchecked, it means users cannot purchase this product because they
cannot add it to the shopping cart.

3. Click on save if you have made any changes.

Editing layout properties
Layout properties affect the display of certain product-related properties either in the Store Front or Admin Console.
Different product types might even have different sets of product-related properties. For example, the Product-Mu-
sic product type has a unique "recording company" property which is non-existent in other product types. The Prod-
uct-General product type has a "manufacturer" property not found in the Product-Music product type.
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To edit layout properties of a particular Product Type:

1. Click on Catalog > Product Types to access the Product Types screen.

2. Choose a product type and click on edit layout to access the layout properties screen. A screen shot of the layout
properties available to a Product-General product type can be seen in Figure 13.2: “Product-General product type”.

The Product Free Shipping Image Status - Catalog field and properties beginning with "Show" affect the
display of a product’s properties in the Store Front. Other properties relate to the default status of certain fields in
a product when you start customizing the product in the Admin Console.

3. Select any field you wish to change and then click edit when the corresponding side-panel appears.

4. If you have made any changes to a field, click on update in the side-panel to effect your changes.

Refer to the following screen shots to compare the different fields belonging to different product types.

Figure 13.1: Product-Free-Shipping product type
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Figure 13.2: Product-General product type

Figure 13.3: Product-Music product type
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Figure 13.4: Document-General product type

Figure 13.5: Document-Product product type

Creating products manually
Creating products in your store typically involves five major steps; out of which Step 1 and Step 3 are compulsory.
If you follow all the steps, you may find yourself lost in the process if you are a new comer to Zen Cart. However,
once you have gone through the process a few times, it will be much easier. That’s because although the steps here are
listed in sequence, they may not necessarily need to be followed in this particular order. As you shall see, many parts
of the product catalog (e.g. manufacturers) can be pre-defined earlier and then re-used when creating new products.

Step 1 of 5: Decide on a Product Type
Before you add a product to your store, you must first determine what product type you want the product to belong to.
As we have discussed earlier in this chapter, you will need to choose between the five different product types.
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For most occassions, you will usually choose to have products belong to either the ‘Product-General’, ‘Product-Music’
or ‘Document-Product’ product types.

The reason why the ‘Document-General’ product type is not usually chosen is because products created using this
product type cannot be added to a shopping cart and thus customers cannot purchase the product.

The ‘Product-Free Shipping’ product type allows you to have products set up in your online store to automatically
allow free shipping. Its use will depend on the needs of your business.

Step 2 of 5: Set up Product Type dependencies
Each product type may have separate dependencies which can be set up to help your customers better filter and search
your products. For example, products belonging to the ‘Product-General’ product type can be linked to specific man-
ufacturers whereas products belonging to the ‘Product-Music’ product type can be linked to the record companies.
These dependencies should be set up before any data is entered for a product because they will be linked from the
Product Details screen.

Product-Music dependencies

Zen Cart provides explicit support for music-related products via the Product-Music product type. Products that are
of Product-Music product type will have an additional three fields available to them.

▪ Recording Artist
▪ Record Company
▪ Music Genre

To have these three fields appear in the Product Info page in your Store Front, make sure that the layout properties of
the Product-Music type under Catalog > Product Types has the following fields enabled:

▪ Show Artist
▪ Show Music Genre
▪ Show Record Company

The Record Companies and Music Genre fields give rise to the following two side-boxes. The Record Artist field
currently has no effect but a side-box might be added in future.

To specify the information for the Record Artists, Record Companies and Music Genre fields, look into the screens
accessible by clicking the following menu entries.

▪ Extras > Record Artists
▪ Extras > Record Companies
▪ Extras > Music Genre

Product-General and Product-Free Shipping dependencies

Most products that you create will usually belong to the Product-General product type. This product type has the most
number of fields and many of those fields also appear in other product types as well. Therefore, we shall make use of
it to help explain and point out the differences between it and other product types.
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What if your store sells services (accounting, legal or insurance, etc) instead of physical products which need to be
delivered? Well, one way is to treat a Service as a General product and set its Product is Virtual field to Yes,
Always Free Shipping. If all items in a customer’s shopping cart are virtual products and you have enabled the Free
Shipping shipping module, Zen Cart will automatically skip the Delivery Information page and bring the customer
to the Payment Information page.

Another way is to use the Product-Free-Shipping product type when creating your service. By default, products that
belong to this product type do not have their weights displayed in the Store Front and are set to free shipping. Most
services do not require any physical delivery of goods, so you will also want to consider turning off the display of the
Free Shipping icon when displaying products of this product type.

To disable the display of the Free Shipping icon in the Store Front for products of Product-Free-Shipping product type:

1. Click on Catalog > Product Types to access the Product Types screen.

2. Click Product-Free-Shipping under the Product Types column and concentrate on the side-panel.

3. Click the edit layout button on the side-panel to proceed to a screen containing definition properties for this
product type.

4. Edit the Product Free Shipping Image Status - Catalog field and set the value to No.

5. Click update to save your changes.

When creating products belonging to either the Product-Free-Shipping or Product-General product types, you will
have the option of linking to a specific manufacturer for the product. Before you can link to a manufacturer, you will
need to create the manufacturer first.

If you have manufacturers set up in your store, there will be two side-boxes available to your customers as shown in
the following screen shot.

By clicking a hyperlink in the Manufacturers side-box, a list of products belonging to the same manufacturer will be
displayed. Thus, customers can quickly locate a product they are interested in based on information they have on the
name of the manufacturer.

For example, if your store sells mobile phones and accessories, you might decide to place your products into two
separate categories: Phones and Accessories. However, most people are loyal customers of a particular brand and will
only purchase accessories and phones of a common brand due to interoperability issues. For these customers, getting
to their choice of products is easier via the Manufacturers side-box rather than browsing the Categories side-box.

The Manufacturer Info side-box appears only when you are at the Product Info page of a product. By clicking on
the Other products hyperlink in this side-box, you will also be shown a list of products that come from the same
manufacturer.

To create manufacturers in Zen Cart:

1. Click on Catalog > Manufacturers to access the Manufacturers screen.
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Notice that there is a number next to the words Products underneath the product image. This indicates the number
of products that are linked to this manufacturer. By default, if the value is zero, this manufacturer will not be
shown in the Manufacturers side-box.

2. Click on insert to access the New Manufacturer side-panel.

3. Enter the name of a manufacturer into the Manufacturers Name field.

4. To specify an image for the manufacturer, follow the same instructions as you did in the section “Creating new
categories” when you specified an image for a category. The difference this time is the default directory where files
are uploaded is manufacturers, which corresponds to the [zc-home]/images/manufacturers directory on
the server.

5. Optionally, specify the web address of the manufacturer in the Manufacturers URL field; e.g. http://
www.clubs-handphones-technologies.com.

6. Click on save to save your changes.

Document-General and Document-Product dependencies

To create documents in your store, you can make use of either the Document-General or Document-Product product
types. Products that belong to the Document-General product type cannot be purchased by customers. You can use
such products to offer free information to your customers: FAQs, free articles, brochures, etc. On the other hand,
products that belong to the Document-Product product type act like normal products which can be sold at a price.

Only products that belong to the Document-General and Document-Product product types can be displayed in a sepa-
rate Documents side-box in your Store Front. This allows your customers to easily separate normal products (displayed
in the Categories side-box) from document products in your store.
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Step 3 of 5: Enter product details
When you are ready to enter your product details, you will need to navigate to a category within which you want to
create your product. Select your desired product from the product type drop-down list box and click the new product
button to access the Product Details screen. The new category button will only appear if the category currently has
no products.

Except for products belonging to the Document-General product type, the large number of settings may seem over-
whelming to a newcomer to Zen Cart. To help you better visualize the relationships between the settings, we will
categorize the settings into the following groups:

▪ “General settings” on page 146.

▪ “Stock settings” on page 147.

▪ “Pricing settings” on page 148.

▪ “Shipping settings” on page 149.

▪ “Purchase quantity settings” on page 150.

The categorization we are using here may seem cumbersome at first because it differs from the arrangement of the fields
on your actual screen. However, when it comes time to troubleshoot problems in your product setup, this categorization
will come in handy as you are able to quickly narrow down a problem to a group of settings instead of going through
every single setting on the screen.

As products belonging to the Product-General product type are the most commonly used by store owners and they
have the most number of settings which also appear across different product types, we shall use the Product Details
screen settings of a Product-General product to explain the meaning of each setting.

Before we begin looking at each product field in depth, let us take some time to examine the differences in product
fields for a Product Details screen between that of a Product-General product type and a products belonging to the
other product types. In this way, you will not feel lost if you do not find a field you are looking for when entering
your product details.

Table 13.1: Field differences between Product-General products and other product type products

Product type Field differences with Product-General products

Product-Free-Shipping The only difference between products belonging to the two product types is
that the Free Shipping field of a Product-Free-Shipping product is set to a de-
fault value of Yes, Always Free Shipping unlike that of a Product-General
product which is set to a default value of No, Normal Shipping Rules.

Product-Music Product-Music products do not have the Manufacturers field. Instead, there are
three extra fields: Recording Artist, Record Company, and Music Genre. Re-
fer to the section “Product-Music dependencies” to learn how to populate the
three drop-down list boxes with suitable values.

Document-Product There is no difference in the number and nature of fields between products be-
longing to the two product types.
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Product type Field differences with Product-General products

Document-General Document-General products contain only a subset of Product-General product
fields. The other minor difference is that some of the field names of the Docu-
ment-General products start with the word "Document" instead of "Product".

General settings

The following fields are general and apply to all products regardless of product types in your store.

Product Master Category
Master categories allow products to be linked to multiple categories but managed as a single stand-alone product.
It is also the category that determines the price of a product if discounts are applied on a per-category basis.

When creating a new product or when editing a product that belongs to only one category, then the master category
is the category that the product is created or currently existing in.

If you are editing a product that belongs to multiple categories, then you will have a choice of re-assigning the
master category via the Product Master Category drop-down list box.

Products Status
If a product is marked as Out of Stock the product will not appear in your store.

Each time a product is sold, the value in the Products Quantity field will be decremented. When the Products
Quantity field reaches zero, this field will automatically switch to Out of Stock.

For further discussion on how Out of Stock settings can be customized, refer to the section “Configuring stock
settings”.

Date Available
If the product is already in stock, leave this field empty.

If you specify a future date, a customer is still able to view and purchase the product. The product will be displayed
in the "Upcoming Products" list in your Store Front and the product’s Product Info page will also highlight the date
that the product will be in stock. For a screen shot of the "Upcoming Products" listing, refer to the section “Up-
coming products summary-list”.

Products Name
This is the name of the product that customers see.

Products Description
Enter the description for your product here.

Products Image
To specify an image for the product, follow the same instructions as you did in the section “Creating new cate-
gories” when you specified an image for a category. Note the existence of two extra options for a product image
compared to a category image.
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For the Delete Image option:
▪ Set to Yes if you want to disassociate the current image with the product. No new product image will be

uploaded.
▪ Set to No if you want to use another image with the product.

For the Overwrite Existing Image on Server option:
▪ Set to Yes if you need to upload an image which has changed but still maintain the previous name or you simply

want to upload a new image after clicking the Browse button.
▪ Set to No if want to use an image which has already been uploaded via FTP to the desired directory on your

server. You can type the name of the uploaded file in the filename field.

Products URL
Used to point a customer to another website which might contain more information for the product. For example,
you can type in a URL in the following form: www.greatphones.com/pico.html.

If a value is entered for this field, the following line will appear under a product in the Product Info page in your
Store Front.

Note that the words "webpage" is a hyperlink and it points to the URL you specified for this field.

Sort Order
Specifies the sequence in which this product should be displayed. Default is 0.

Stock settings

The following fields are related to an individual product’s stock settings. We shall examine more general product stock
settings in Chapter 23, “Managing stock”.

Products Manufacturer
Allows you to specify the manufacturer of a product; e.g. if you sell cars, you can have Ford, Toyota, etc as the
manufacturers.

You need to enter the list of manufacturers first before you can see any of your choices. Refer to the section “Prod-
uct-General and Product-Free Shipping dependencies” for details.

Products Model
Used to specify a model for your product. Customers can perform a search in your store based on a product’s
model. If you intend to sell Gift Certificates in your web store, the value of this field will need to meet a certain
syntax. For more information on Gift Certificates, refer to the section “Gift certificates”.

Products Quantity
Indicates the amount of stock you have for the particular product. If you do not specify a value, it defaults to 0.

If a customer places an order (e.g. 4 units) for a product that has limited stock available (e.g. 1 unit left), a warning
message will be displayed in the Shopping Cart page as shown in the following screen shot.
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If all your units are sold, then Zen Cart automatically marks the Product Status field as Out of Stock and
disables the product.

The customer will not be able to see the product in your product catalog or anywhere in your Store Front if it
is disabled.

If you enable the product by toggling the red button in the Categories/Products screen but still leave its Product
Status as Out of Stock, then the customer will see a Sold Out sign instead of the usual Add to Cart button when
viewing the product. An example of what the Sold Out sign looks like is shown in the following screen shot.

Either way, customers will not be able to make any purchases once a product is out of stock.

By default, all quantities specified in the Product Details screen must be in whole units. To allow
customers to buy products in fractional units, click on Configuration > Stock and change the
Product Quantity Decimals field accordingly. For more information on other stock settings,
turn to the section “Configuring stock settings”.

Pricing settings

The following fields affect how your product is basically priced. The final purchase price of a product may vary due
to other pricing mechanisms which we shall discuss in Chapter 17, “Order totals, surcharges and discounts”.

Product is Free
Marking Yes will override all prices and discounts you have applied for the product and cause the product to be
free! The customer will still see whatever discounts that were applied but will not be charged anything for the
product during the checkout process.

Try not to specify a value for Products Price (Net) field if you do not want to confuse your customers when you
set this field to Yes. This feature is good for occasions when you want to give away product samples to customers
for them to try before they buy.

Product is Call for Price
Behaves similarly to "Product is Free" except that the product will have a "call for price" image instead. Customers
also cannot add the product to the shopping cart.
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Try not to specify a value for Products Price (Net) field if you do not want to confuse your customers when
you set this field to Yes.

Product Priced by Attributes
You will see in the next chapter that you can add extra, self-defined attributes to your products to create different
product variations.

Set this option to Yes and your Product Price field to 0.00 if you want your product’s price to be dependent
entirely on the prices of your attributes. For example, if you sell tickets to a gala event and have set your tickets to
have no base price. You can use product attributes to specify different ticket options (e.g. "Luxury", "Premium",
"Regular") available for purchase. A price is then attached to each ticket option and customers need only pay the
price quoted for each ticket option they choose.

Set this option to No if your product price involves a base price with additional attribute pricing variations. For
example, if you sell a standard arrangement of roses at $50.00. You can provide your customers more choices
when it comes to the gift wrapping used for the flowers by quoting additional prices for different variations of
gift wrappings.

Avoid entering a value in the Product Price field and then setting this option to Yes as price calculations in your
store may not work correctly!

Tax Class
Allows you to automatically calculate the Products Price (Gross) value using the value you specify for the
Products Price (Net) field. Refer to the section “Adding a tax class” for details on setting up a tax class.

The default tax class can be specified in the Product Price Tax Class Default - When adding new products
field under the layout properties of this product type in Catalog > Product Types.

Products Price (Net)
This is the base price of your product. It is usually your selling price. Set the value to 0 if you have set the Product
Priced by Attributes field to Yes.

Products Price (Gross)
This is the price of your product after applying the tax rate specified in the Tax Class field. If you find that your
value looks strange, check whether it has to do with multiple tax rates by referring to the section “Compounding
or adding different tax rates”.

Shipping settings

This section deals with how your products will be shipped.

Product is Virtual
Normally you would specify No, Shipping Address Required if you need to ship any physical goods to
your customers. However, if your store offers professional services (accounting, law consultation, etc) to your
customers and you do not need to ship any physical products, then you can specify Yes, Skip Shipping
Address.

If you specify Yes, Skip Shipping Address for this field, you are implying Always Free Shipping is marked
Yes, Always Free Shipping, even if you set it to No, Normal Shipping Rules!

Special, Product/Download Combo Requires a Shipping Address is used only if you want to provide
both a downloadable product and a physical product to be sent to your customers.
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The default virtual status can be specified in the Product Virtual Default Status - Skip Shipping Address -
When adding new products? field under the layout properties of this product type in Catalog > Product Types.

Always Free Shipping
Indicates whether you want to offer Free Shipping for this product. If you set it to No, Normal Shipping
Rules, then all the rules you specified in your shipping modules will kick in.

Note: If you specified Product is Virtual to be Yes, Skip Shipping Address, then this field is automatically
assumed to be Yes, Always Free Shipping regardless of what you specify for it.

The default free shipping status can be specified in the Product Free Shipping Default Status - Normal Shipping
Rules - When adding new products? field under the layout properties of this product type in Catalog > Product
Types.

Products Shipping Weight
Allows you to specify a weight which is used for shipping calculations. The default weight is 0 if you leave this
field blank. The default unit of measurement is pounds (lbs).

If weight is 0, you might accidentally cause shipping to be free if you have enabled Order Free Shipping 0
Weight Status under Configuration > Shipping/Packaging. Therefore, make sure you check that setting if you
intend to set this field to 0 or leave it blank.

Purchase quantity settings

Products Quantity Box Shows
If set to Yes, Show Quantity Box, the customer sees:

If set to No, Do not show Quantity Box, the customer sees:

In the second case, each customer is restricted to purchasing the quantity specified in the Product Qty Minimum
field. This feature comes in handy if you offer digital downloads for sale. Customers will only need one copy of a
digital download because they can easily make extra copies themselves. Thus, you can save customers the trouble
of entering the number of items they want to purchase by specifying Product Qty Minimum as 1 in this case.

Product Qty Minimum
Indicates the minimum number of items of a product a customer must buy. It is also commonly known as the
"minimum order quantity" in layman terms.

If a customer enters less than the minimum quantity allowed, the system will display an error message prompting
the customer to adjust the quantity.

This option is useful when you are offering an extremely low priced product which will only turn in a profit if
a minimum number of items are sold.
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Product Qty Maximum
Indicates the maximum number of items of a product a customer is allowed to buy.

If a customer enters more than the maximum quantity allowed, the system will automatically adjust the quantity to
be equal to the maximum allowed quantity. This option is useful when you have products that are in high demand
and you want to avoid angering your customers if one of them buys a large amount at one go thus depriving other
customers of a chance to buy the product.

Product Qty Units
This option limits customers to purchasing in fixed quantities. For example, if you specify the value to be 5, then
customers can only order in quantities of 5, 10, 15, etc.

The wording to potential customers may not be very intuitive though. You can see this in the screen shot below
where it states "Units: 5" which limits your customers to purchasing in quantities of 5.

This option is useful when you have goods already packed neatly in fixed quantities. By not taking out the goods
and selling separately, you can save yourself any leftover goods and maybe help your shipping costs as well.

Product Qty Min/Unit Mix
If you have defined custom attributes for a product, you can make use of this field to control what quantities of
a product (based on attributes) customers are allowed to buy from your store.

Let’s say you sell canned tuna and have defined an attribute "flavor" with three possible values: curry sauce,
tomato sauce and olive oil. Assume you have set up the following fields as follows:
▪ Product Qty Minimum = 4
▪ Product Qty Maximum = 12
▪ Product Qty Units = 1

The above quantity settings mean the customers can only buy the canned tuna in quantities of: 4, 5, 6, 7, 8, 9,
10, 11 or 12.
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If Product Qty Min/Unit Mix is No. Besides adhering to the above quantity settings, customers are also limited
to ordering tuna packed in one of the flavors only.

If Product Qty Min/Unit Mix is Yes. Although they still have to adhere to the above quantity settings, they are
now allowed to mix-and-match the different flavors of tuna in different quantities e.g. 2 cans in curry sauce, 3
cans in tomato sauce and 7 cans in olive oil.

Step 4 of 5: Set up and attach product attributes
If you are creating a ‘variant’ product, you will need to set up product attributes which can be linked to your product.

Product attributes are extremely powerful and flexible and will be covered in Chapter 14, “Working with product
attributes” and Chapter 15, “Advanced product attribute configuration”. If you do not need any product attributes, you
can safely skip to the next step.

Step 5 of 5: Attach additional product information
After creating your product in your store, you are essentially done with product creation. However, there might be
other features that will allow you to enhance your product offering further and which you should take advantage of.

Music samples

For products belonging to the Product-Music product type, you have the option of adding music samples to the product
so customers can have a preview of the music before actually purchasing from you.

The process is rather involved and will be covered in the section “Providing media samples for Product-Music prod-
ucts”.

Additional product images

Although you are only allowed to upload a single product image via your web browser when creating your product.
You have the option of displaying several different images for each product.

Again, the process is rather involved and will be covered in the section “Providing multiple images for a product”.

Creating products via duplication
After going through how to add products and services to your catalog in this chapter, you will find the process very
tedious and repetitive if your products have similar attributes and values. You can alleviate this problem and save time
for yourself by duplicating products you have created.

By duplicating your products, you save time and effort because you only need to customize selected portions of the
copied product instead of having to create a new product each time. Duplicating products work best when your products
have fairly generic properties with few differences.

For example, T-shirts have a limited selection of sizes and mostly differ in terms of color, pictures and wordings.
Therefore, you can easily create a skeletal product of your T-shirt with some generic attributes like color and size
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attached to it. By duplicating this skeletal product within the same category or to other categories, and customizing
only those properties (description, images, etc) that change, you can save yourself a lot of time and repetitive effort.

To duplicate a product within a category or to another category:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the blue "C" button next to the product you wish to duplicate. This product shall be referred to as the
source product because it is used to create other duplicated products.

3. A side-panel should appear as shown in the following screen shot.

4. Choose the target category you want the duplicated product to reside in from the Categories drop-down box.

5. Choose Duplicate product for the Copy Method field.

6. Choose Yes for the Copy Product Attributes to Duplicate field if you have product attributes which you wish
to copy to the duplicated product. This field only appears if your source product has attributes attached to it.

7. Choose Yes for the Copy Product Discounts to Duplicate field if you have any discounts tied to this product
that you wish to copy to the duplicated product. This field only appears if your source product has discounts
attached to it.

8. Click on copy to begin duplicating the product. You should be redirected to the target category you specified in
Step 4 once product duplication completes.

9. By default, your duplicated product is disabled to allow you to make changes. This is shown by a red button icon
appearing under the Status column of the duplicated product in the Categories/Products screen.

10. Make any required changes to your duplicated product and then enable it so that it is available for sale in your
online catalog.

Editing products
Editing a product’s details is straightforward, just navigate (i.e. search, jump, or page through) to the category con-
taining the product and click the green "e" button. Click update when you are done.
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Note that you cannot edit a product to re-assign its product type. This is a major operation which requires code and
database changes.

Moving and deleting products
To move a product, navigate to the category containing the product and click the purple "m" button next to the product.
You will be presented with a side-panel as shown in the following screen shot. Follow the on-screen instructions to
accomplish your aim. Remember to check or uncheck the relevant checkbox(s) depending on your needs.

To delete a product, navigate to the category containing the product and click the red "x" button next to the product.
You will be presented with a side-panel as shown in the following screen shot. Follow the on-screen instructions to
accomplish your aim. Remember to check or uncheck the relevant checkbox(s) depending on your needs.

Deleting products will not delete any order information pertaining to the product if the product was sold some time
back. This is because Zen Cart’s database keeps a snapshot of the product’s information at the time it was sold.

Enabling and disabling products
Whether a product is enabled or disabled depends on the Status field in a product’s Product Details screen.

This status can be set manually either in the Product Details screen or via the green/red button when viewing the list
of products in a leaf category of the Categories/Products screen as shown in the following screen shot.

Alternatively, it can be automatically disabled for inventoried products. Refer to Table 23.1: “Meaning of selected
Stock fields” and read up on the Products status in Catalog when out of stock should be set to field to see how
this can be done.
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There is currently no way to automatically enable a product via an Admin Console setting. This is because an inde-
terminate number of custom business scenarios would need to be catered for in order to make it work in a general way.

Listing products in multiple categories
Product linking allows you display a product in multiple categories. You also get the benefit of greater product exposure
with only a single copy to maintain. For example, if you have a medicinal pill that has the ability to act as a sleeping
pill and a pain killer, you can list that pill under both the "sleeping pills" and "pain killers" categories.

The important thing to remember about linked products is this: Although they appear in multiple categories, there is
always only one product. The rest of the products that are linked to different categories are just ghost images of this
one product. This is a great maintenance advantage because you only have to make changes to your linked product
in one place and all the changes will appear concurrently in all the categories it is displayed in. Note that deleting the
linked products will not remove the main product they linked to from the catalog.

Linked products are easily identified in the Categories/Products screen via a yellow button icon (on the right of the
green icon) under the Status column as shown in the following sample screen shot.

This yellow button icon also appears next to any categories that contain linked products. For example, if your product
originally resides in Category A and is then linked to Category B, you should see the yellow button icons appearing
next to both Category A and Category B in the Categories/Products screen.

If you do not see any yellow buttons even if you have already set up linked products, go to Configuration > My Store
and make sure the Show linked status for categories field is set to true as shown in the following screen shot.

The importance of the Master category
Whenever you deal with products that are linked, you will come across the term Master category. The purpose of a
Master Category is to allow your product to take advantage of any pricing mechanisms you have tied to a category.

For example, if you have created a 10% sale for all products in the Christmas Sale category. By linking a Product
X under another category to the "Christmas Sale" category and making the "Christmas Sale" category the Master
Category, Product X will automatically be subjected to a 10% discount as well.

So how do you know what Master Category a linked product belongs to? Well, you can edit any linked product which
has the yellow button icon next to it in the Categories/Products screen. You will notice a Product Master Category
field appearing on top of the Product page as shown in the following sample screen shot.
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Notice from the preceding screen shot that the Master Category of the product is the "Computers" category but we are
viewing the product from within the "Test" category.

In essence, when a product is linked, take note of the following points:

▪ Only one copy of the product actually exists in the database regardless of how many categories the linked product
appears under.

▪ Only one Master Category exists for a linked product regardless of how many categories the linked product
appears under.

There are two ways to configure product linking in Zen Cart:

▪ Simple product linking - only one category can be linked to at any time.

▪ Advanced product linking - many categories can be linked to at any time, bulk copy/delete operations, etc, can
be performed from a single location.

Simple product linking
To list a product under different categories by using the simple product linking approach:

1. Click on Catalog > Categories/Products to access the Categories/Products screen.

2. Click on the blue "C" button next to the product you wish to link from. This product shall be referred to as the
master product because it is under the master category.

3. A side-panel should appear as shown in the following screen shot.

4. Choose the target category you wish to link to from the Categories drop-down list box. This category must be
different from the current product’s category.

5. Choose Link product for the Copy Method field.
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6. Ignore the Copy Product Attributes to Duplicate field if it appears.

7. Ignore the Copy Product Discounts to Duplicate field if it appears.

8. Click on copy to create a linked product. You should be redirected to the target category you specified in Step
4 once product linking completes.

9. If you go to both the target category and the master category, you will notice both a green button icon and a yellow
button icon appearing next to your linked product. Furthermore, any category that contains a linked product will
also have the green and yellow button icons displayed next to them.

Advanced product linking
Besides the simple linking you have just seen in the above section, you can employ another technique that is even
faster and more powerful using the Multiple Categories Link Manager screen. This screen allows you to immediately
link a product to multiple categories and perform bulk manipulation of linked products across categories.

Note that the Multiple Categories Link Manager screen is not immediately accessible via any menu options in the
Admin Console. You can only reach the screen via the following two methods:

▪ Click on the Multiple Categories Link Manager button that appears at the bottom of a Copy To side-panel of a
product when you click on the blue "C" button of a product in the Categories/Products screen.

▪ Click on the Multiple Categories Link Manager hyperlink appearing near the top of any Attributes Controller
screen of a product.

There is a lot of information contained in the Multiple Categories Link Manager screen. To help you understand this
screen and simplify your configuration approach, think of the screen as being broken up into the following sections:

▪ Product selection

▪ Product linking

▪ Mass operation

Product selection

This portion of the screen allows you to navigate to the product which you want to link to several categories. You
should be familiar with how this portion of the screen works since it behaves similarly to what you saw in the Catalog
> Attributes Controller.

Product linking

This portion of the screen allows you to change the Master Category of a linked product by choosing from the Product
Master Category drop-down list box. You can also link a product to multiple categories simultaneously by selecting
the desired check-boxes and then clicking the Update Category Links button.
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Mass operation

This portion of the screen allows you to perform bulk copying, deleting and resetting of product linkages. Instructions
on how to perform these operations are displayed prominently on the screen. Make sure you read and understand them
before performing any operations as these operations can affect many products simultaneously.

Summary
We have covered important product-related concepts that you will need to grasp in order to work with Zen Cart. You
also learned the different ways to work with product types and to manipulate products. Finally, you saw how products
can be listed in multiple categories and the importance of the master category when doing that.
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Chapter 14:

Working with product attributes

Introduction
Personalization and customization have become buzzwords of modern businesses that seek to pander to the needs and
tastes of individual customers. For example, allowing customers to choose whether they want extra toppings to go
with their pizzas on top of their standard order.

To cater to such scenarios, Zen Cart uses the concept of product attributes to create different product variations and
allow your customers to choose how their products can be customized according to their wishes.

A word of caution and encouragement is in order here. Product attributes offer extremely flexible configurations of
your products but at the same time they can be confusing to novice users. Hence, it may take some time for the concepts
and instructions in this chapter to sink in and be applied appropriately.

In this chapter, we shall:

▪ Learn concepts related to product attributes.
▪ Add and configure product attributes individually.
▪ Run through examples that show how attributes can be applied as a whole.
▪ Manipulate multiple attributes simultaneously.
▪ Learn different ways to sort product attributes.

General attribute concepts
Product attributes are not easy to grasp for newcomers to Zen Cart and so it is important that you have a proper
understanding of its ability and makeup before you actually create your own product attributes.

Understanding different aspects of a product attribute
Attributes are formed by three properties: Option Type, Option Name , and Option Value. Option Type determines
how attributes will be presented to the customer. Option Name identifies an attribute. Option Value represents one
or more values that are associated with an Option Name.

Take a look at the following illustration which consists of a single attribute to understand these concepts better. Notice
that the Option Name is Color and this is usually how we refer to an attribute (i.e. the Color attribute). There are three
Option Values consisting of Green, Blue and Silver respectively. The Option Type for this attribute is Radio because
this attribute is presented with three radio buttons but the user can only choose one of them.

For each option value, you will also be able to add one or more additional pieces of information to it. These additional
pieces of information could include prices, weights, images; thus allowing you to alter the basic details of your base
product.
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Take a look at the following illustration which consists of four option values: Red, Blue, Yellow, and Green. Notice
that each option value is associated with a price and an image.

Identifying the available types of product attributes
The different Option Types available for defining attributes are as follows: Dropdown, Text, Radio, Checkbox, File,
and Read Only. We shall take a closer look at them here.

Dropdown

Customers will need choose one of the choices listed.

Text

Customers specify their own words. No choices will be provided even if they are defined. We shall use the term
"text-field" to refer to the top screen shot and the term "text-area" to refer to the one at the bottom.

A "text-field" only allows a single line for text input while a "text-area" allows multiple lines for text input.

Note: If this attribute is compulsory and you want to force your customers to enter something before allowing
them to add products to the cart, enable the Attribute Required for Text field when we talk about Attribute
Flags later in this chapter.

Radio

Customers can choose only one of the choices listed. Note that once a radio button is selected, none of the radio
buttons can be de-selected.

Checkbox

Customers can choose zero or more choices.
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File

Customers can specify a file on their local computers to upload to your store. Besides the standard steps to con-
figure an upload attribute, additional steps are required for file uploads to work properly. We shall cover these
additional steps in Chapter 15, “Advanced product attribute configuration”.

Read Only

Customers can only view the available choices but they are not allowed to choose any values. This option is
usually used to inform customers of something instead of telling them to take a specific action.

How product attributes are created and configured
It is easy to get lost whilst in the process of creating your attributes due to the great number of options available in
the main Attributes Controller screen which you will encounter later. Therefore, it is important that you get a grasp
of how attributes are created in Zen Cart.

The main idea is this - based on your business needs, come up with a set of attributes (options and values) that are
likely to apply to all the products in your store. After that, assign each attribute and its corresponding value(s) to the
desired products. During the assignment process, you can attach specific information (e.g. price, weight) to each value.

Let us use the following illustration of what we mean.

Notice that we have created an attribute Color with five option values: Red, Blue, Green, Pink, and Yellow. We
then assign a different subset of these values to the blouse and the skirt respectively. The common color being Blue.
Assuming that Blue is a less popular color among customers of our store, we can assign an extra cost to each blue
blouse or blue skirt as we would need to specially order them from our suppliers. We can also assign different prices
to the same attribute value depending on which product the attribute is assigned to. This is evident from the higher
cost of a Blue skirt compared to a blue blouse.

Adding attributes to a product
Zen Cart allows you to create attributes for all Product Types. Each attribute is defined by an option name and several
option values. Because the addition of other attribute properties (pricing, images, etc) can be very confusing, we shall
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start off with how to create a product attribute first. Once you are familiar with this step, you will be more confident
in tackling the topics on attribute properties.

Before you begin adding a product attribute, make sure you have already created the product to which you want to
add an attribute.

There are essentially two steps to creating an attribute for a product.

1. Create the attribute.
2. Assign the attribute to a product.

Step 1 of 2: Create the attribute
Create attribute option name

1. Click on Catalog > Option Name Manager to access the Product Options screen.

2. To simplify the look of the screen, choose Display Global Features - OFF from the drop-down list box
near the top of the screen as shown in the preceding screen shot.

3. Scroll down the screen and concentrate on the last row in the list. Enter suitable values for the fields as follows:
▪ en - Your attribute name as it appears in English.
▪ Order - The sequence in which your attribute will be arranged next to other attributes. By default, a lower value

will make your attribute appear before any attributes with a higher value.
▪ Option Type - Determines how your attribute will be displayed. Refer to the section “Identifying the available

types of product attributes” for more information.

4. Click on insert to create your option name. The screen should be refreshed with your option name saved in the
database.

5. To set additional properties for the option name you just created, click on the edit button of the next to the option
name and you should see something similar to the following screen shot.
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6. If you have specified the Option Type to be Text, you can specify a non-zero value for the Rows field and a
multi-line "text-area" will appear to the customer instead of the default single-line "text-field". The Display Size
field controls the number of visible character columns to display whereas the Maximum Length field limits the
number of characters a customer can enter.

7. Make any other changes you require and click on update to save your settings.

Create attribute option value

If you have chosen File or Text for the Option Type field of your attribute name in the Option Names screen, you will
not need to specify an option value. For all other option types, use the following steps to create your option value(s).

1. Click on Catalog > Option Value Manager to access the Option Values screen.

2. To simplify the look of the screen, choose Display Global Features - OFF from the drop-down list box
near the top of the screen as shown in the preceding screen shot.

3. Scroll down the screen to the the last row in the list.

4. Select the option name to which you want to add your option value from the drop-down list box under the Option
Name column. Specify the option value name and sort order in the respective Option Value and Default Order
columns.

5. Click on insert to associate the option value with the option name. Your screen should be refreshed with your
option name and option value saved in the database.

The number of option names and option values appearing on the Product Options screen and
Option Values screen are controlled via the Products Attributes - Option Names and Values
Display field under Configuration > Maximum Values.

Step 2 of 2: Assign the attribute to a product
1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Select a category from the drop-down list box which contains the product to which you want to add an attribute.
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3. Choose your desired product from the product list and click display.

4. Concentrate on the portion of the screen with the words "Adding New Attributes" as shown in the following
screen shot.

5. Select your choice of Option Name and Option Value to link with the product. Note: You must choose both
an option name and an option value. Many people make the mistake of choosing either an option name or an
option value only.

If the value you selected in the Option Name list is of File or Text type, you should only choose TEXT [RE-
SERVED FOR TEXT/FILES ONLY ATTRIBUTES] in the Option Value list.

6. You can associate other information to the selected attribute using the following portion of the screen. More
information on the settings of this portion of the screen will be covered in later sections.

7. Click on insert to save the association between the attribute and the product. Your newly created attribute should
appear in the list after the screen refreshes.
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Configuring individual attribute values
You should now have a good overview and firm grasp of how to add an attribute to a product. The power and flexibility
of attributes comes into play when you configure each attribute to take on additional information like price, weight,
image, etc. All these attributes can further behave differently depending on how you want them to appear relative to
each other (e.g. mark an attribute as a default instead of others).

We shall now go through how each piece of information (e.g. price, weight, or image) can be added to an attribute.
Do remember that each attribute can have multiple pieces of information attach to it at anytime. You will need to be
creative when working with attributes in order to set them up to meet your requirements.

The important thing is not to lose sight of the whole picture when setting up your attributes. That means you need to
understand how your product is set up before you configure your product attributes as there is a dependency between
them.

Understanding how attribute flags work
After having gone through the Attributes Controller screen, you may have noticed some attribute flags (as shown in
the following screen shot) appearing in a multi-colored row while you were linking an attribute with a product. These
flags control further properties of each attribute so it is important that you do not overlook them.

You can change the default values for these flags by clicking on edit layout for the respective product types under
Catalog > Product Types. Using a sample layout setting from the Product-General product type, you can see that the
settings match the attribute flag’s default settings exactly.

The status of the attribute flags are also displayed next to each individual attribute value after it has been attached to
a product. You can quickly toggle the status of each attribute flag by clicking on its corresponding button.
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The purpose of each individual attribute flag is explained in the following table.

Table 14.1: Meaning of individual attribute flags

Attribute flag Meaning

Used for Display
Purposes Only

Indicates that this option value is meant for informational purposes only.

For example, if this option value belongs to the option type Dropdown, Radio, or Checkbox,
and its flag is set to Yes, when customers click on the attribute choice and then select Add
to Cart, an error message will be shown indicating that the attribute cannot be chosen. Other
attributes, however, can be chosen.

If this option value belongs to the Text option type, then customers are not allowed to enter
a value into text box in your Store Front or an error message will also appear when attempt-
ing to add the product to a cart.

This flag has no effect on attributes that are of Read Only or File option type.

Attribute is Free
When Product is
Free

If you have specified a price for an attribute but marked your product as free, you can spec-
ify whether that makes the whole product free or whether you still want to charge your cus-
tomers based on the price of the attributes alone.

For example, you sell old tower clocks and you have specified that they come with at-
tributes like gold or silver needles which each cost money. If you decide to make your old
tower clocks free, you should then decide whether you should charge your customers extra
if they choose the gold or silver needles.

Default Attribute to
be Marked Selected

Applicable only if your attribute is of option type Dropdown, Radio or Checkbox. This will
automatically set this option value as the default option selected from the list of option val-
ues.

For example, if you have option values of "white", "red", "blue" and "green" for a T-shirt.
You can set the option value of "white" to be the default selected attribute by setting this
field to Yes.

Apply Discounts
Used by Product
Special/Sale

Indicates whether the same discount percentage should be applied to this attribute as it ap-
plies to a product. Refer to Chapter 17, “Order totals, surcharges and discounts” for details
on Specials and Sales.

For example, if the price of a product is $30 and a sale of 50% is given. That means the
product costs $15. If an attribute is originally priced at $5, then if this flag is set to Yes, the
attribute price after discount would be $2.50.

However, if this flag is set to No, then the attribute price will remain at $5 although the
product is at the discounted price of $15.

Include in Base
Price When Priced
by Attributes

This flag indicates whether the current option value should be considered when calculating
the base price of a product.

It is only taken into consideration if the product has the its Product Priced By Attributes
value set to Yes and the Products Price (Net) set to 0.00 in the Product Details screen.
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Attribute flag Meaning

If the Product Priced By Attributes value is set to No, then this flag has no effect and will
be ignored. The products base price in this case will always be the product’s price as entered
in the Products Price (Net) field in the Product Details screen.

To visualize the effect of this flag, we shall assume a product has a single attribute with the
following option values with the status of this flag indicated next to their prices:

Attribute "X"
========================
option A = +$1.00  (No)
option B = +$2.00  (Yes)
option C = +$3.00  (No)
option D = +$4.00  (Yes)

With the preceding configuration, the product will show a base price of "Starting at: $2.00"
in the Product Info page in the Store Front. The base price is calculated based on the lowest
value of all option values in an attribute with this flag set to Yes.

Now consider the case where the product has two attributes with the following option val-
ues with the status of this flag indicated next to their prices:

Attribute "X"               Attribute "Y"
========================    =========================
option A = +$1.00  (No)     option W = +$10.00  (No)
option B = +$2.00  (Yes)    option X = +$20.00  (No)
option C = +$3.00  (No)     option Y = +$30.00  (Yes)
option D = +$4.00  (Yes)    option Z = +$40.00  (Yes)

With the preceding configuration, the product will show a base price of "Starting at: $32.00"
in the Product Info page in the Store Front. The base price is calculated based on the addi-
tion of the lowest value of all option values in each attribute with this flag set to Yes.

Attribute Required
for Text

If your attribute is of option type Text, you can make it into a compulsory field. Users will
be forced to enter some text before they are allowed to add the product or service to the cart.

An example would be the wordings on a cake. You can force users to enter the wordings
they want on the cake by setting this option to Yes.

Attaching images

You can specify different images for your attributes to help your customers better visualize the end-product or service.
For example, you can have a different color T-Shirt represent your T-Shirt’s color attribute as shown in the following
screen shot.
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Attributes of option type Read Only cannot have images associated with them. Even if you have
defined an image for this type of attribute, it will not be displayed.

Before you specify images to represent your product or service:

▪ Make sure you have created the product and its required option names and option values.

▪ Make sure that Enable Attribute Images is set to true under Configuration > Attribute Settings.

To specify an image to represent each attribute:

1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category. The (*) symbol appearing next to certain categories in the drop-down list
box indicates that they contain products.

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen.

Your area of the screen may contain less information if you do not have an existing attribute image present.
Nevertheless, the fields behaves similarly to the screen used for creating a product so we shall not waste time
explaining them again.

4. Upload the appropriate image to your store by specifying the required values and then click the insert button.

If you go to your Store Front and look at your product, you might not be satisfied with the way the attributes are laid
out on the screen. There are several layout options open to you as well. You can take a look at a few of them in the
following screen shots.
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Before you change the layout of your image attributes:

1. Click on Configuration > Product Info to access the Product Info screen.

2. Check the value of Product Info - Show Option Values Name Below Attributes Image. This field will cause
the text to disappear if the text appears below an image. For example, if the text "Blue" appears below the blue
square, then the text "Blue" will disappear if this option is disabled.

To change the layout of the image attributes:

1. Click on Catalog > Option Name Manager to access the Product Options screen.

2. Click edit for the option name you used for your image attribute previously.

3. Concentrate on the following portion of the screen which specifies how the attribute should be laid out.

4. Edit the Attribute Images per Row and Attribute Style for Radio Buttons/Checkbox fields accordingly.

5. Click update to effect your changes.

6. Go to your Store Front to see whether the attribute layout suits your preference.

Attaching price information
Zen Cart provides you the ability to price your products by attributes. For example, if you sell computers, you can set
a base price and then increment the price for each separate accessory or component that is added. If you sell T-shirts,
you can specify different color options and tag a separate price for each color.

While you are going through this section, take note of the effects the following attribute flags might have on your
pricing options:

▪ Attribute is Free When Product is Free
▪ Apply Discounts Used by Product Special/Sale
▪ Include in Base Price When Priced by Attributes

Also keep in mind that although we are going through the attribute properties (price, weight, etc) individually, these
attribute properties can actually be combined to yield the desired effect for your products.

All the pricing examples shown in this section assume the following settings in the Product
Details screen of a product in your Admin Console:
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▪ Product Priced by Attributes is set to No.
▪ Products Price (Net) is the value shown in the respective screen shots.

This should remove any confusion if the values in your screen appear different from those shown
in this book.

By absolute value

The simplest way to price your attributes is to specify a price for selecting the attribute and indicating whether the
price should be incremented or decremented for each product that is bought. The following example screen shot shows
a hotel charging different rates based on the room type specified by a customer.

Before you specify the pricing for an attribute:

▪ Make sure you have created the product and its required option names and option values.

▪ Click the edit layout button of the product type that is linked to this attribute and look at the PRODUCT Attribute
Price Prefix - Default field. This field specifies whether the attribute price should be incremented or decremented
by default.

To specify a price for an attribute:

1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category.

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen.

4. To add the attribute price to the product price, specify a "+" or a blank space in the first box under the Price field.
To subtract the attribute price from the product price, specify a "-" in the box instead.

5. Enter your desired price in the empty box under the Price field.

6. If you want your attribute price to be charged only once regardless of how many items of the product a customer
buys, enter a value in the One Time field.
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7. Enter a number into the Order field. This field indicates the sequence in which the attributes will be displayed
to a customer.

For example, assume you have three attributes (X, Y, Z) in their original sequence as follows: 1, 2, 3. If you
change the sequence to: 3, 1, 2. Then the attributes will be displayed in the order Z, X, Y to a customer.

8. Click insert to save your changes to the database.

One Time Charges

The One-Time field which you saw in Step 6 of the previous section allows you to charge a customer only once for
a product attribute when several items of a product are bought. An example is provided below to help you understand
its use.

If you have a product that retails for $20 and a single attribute that adds $1 to the product. You have also specified
that this attribute has a one-time charge of $5.

Then if the customer buys a total of 3 of your products with the same attribute, the total price charged to the
customer will be:

($20 + $1 + $5) + ($20 + $1) + ($20 + $1)  = $68

This option is usually applied to one-time setup charges. For example, when you first sign up for a web hosting account
with a web hosting provider, they usually charge you a one-time setup fee and not for subsequent renewals for the
hosting plan.

By percentage

This pricing mechanism works similarly to attribute pricing by numbers except that it is based on percentage rather than
numbers. It makes use of the concept of price factor and offset to achieve a percentage-based attribute pricing scheme.
Nevertheless, the attribute prices that are displayed are in absolute numbers instead of percentages. The following
example screen shot shows a poster of Einstein which is priced by size and color.

Before you specify percentage pricing for your attribute:

▪ Make sure you have created the product and its required option names and option values.
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▪ Make sure that Enable Price Factor is set to true under Configuration > Attribute Settings.

To price your attributes by percentage:

1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category.

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen.

To understand the meanings and syntax for the above fields, refer to the section after these steps.

4. To add the attribute price to the product price, specify a "+" or a blank space in the first box under the Price field.
To subtract the attribute price from the product price, specify a "-" instead.

5. To specify a constant price factor and offset for your attribute, enter your desired values in the first two boxes of
the left column under the Price Factor and Offset headings.

6. To specify a one-time price factor and offset for your attribute, enter your desired values in the last two boxes of
the left column under the One Time Factor and Offset headings.

7. Commit all your changes to the database by clicking the insert button.

Price Factor, One Time Factor and Offset

The Price Factor and Offset pricing mechanism calculates the attribute price based on a percentage of the product
price. The formula is as follows:

Attribute Price = (Price Factor - Offset) x Product Price

The above formula can optionally be combined with the Price field as follows:

Attribute Price = Price + [(Price Factor ) x Product Price]

The Offset field is a bit of an abstract concept and thus is not quickly understood without some explanation. We shall
use an example to show why this is so. For example, you might want to add 1% (i.e. 0.01) to the price of a car if a
customer chooses a custom paint attribute.

Car Price = $30,000

Price Factor = 0.02

Offset = 0.01

Attribute price: (0.02 - 0.01) x $30,000 = $300
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However, you could achieve the same result using a Price Factor of 0.01 and Offset of 0. This seems to be the easier
and logical way and is shown below.

Car Price = $30,000

Price Factor = 0.01

Offset = 0

Attribute price: (0.01) x $30,000 = $300

So what is the purpose of the Offset field when you can accomplish the same pricing strategy with or without it? Well,
the answer boils down to personal preference. The Offset field is provided to certain store owners who prefer to enter
their attribute pricing according to a "fixed pattern".

For example, take the screen shot of the poster of Einstein that was shown initially in this section. If your store sells
posters that come in various sizes and color, then you can implement an attribute pricing strategy based on the pattern
shown below. Notice that there are two main variables that decide the pricing strategy - Print Size and Print Color.

 Print Size   Price Factor   Print Color   Offset
 ----------   ------------   -----------   ------
 8" x 10"     0.4            B/W           0.2
11" x 14"     0.6            Color         0.1
16" x 20"     0.8

Now that you understand the Price Factor and Offset fields, we shall move on to discuss the One Time Factor field.
The difference between the Price Factor and One Time Factor fields is in how the final product price is arrived at
for product quantities greater than 1. Take a look at the following examples to understand their differences.

Qty  Product Price  Price Factor  Attr. Price  Total Product Price
---  -------------  ------------  -----------  -------------------
1    10             0.2           2            (10 + 2) = 12
3    10             0.2           2            (10 + 2) x 3 = 23

Qty  Product Price  One Time Factor  Attr. Price  Total Product Price
---  -------------  ---------------  -----------  -------------------
1    10             0.2              2            (10 + 2) = 12
3    10             0.2              2            (10 x 3) + 2 = 32

The justification for the Offset field is not easy for most people to accept, especially to those
who cannot think of a need for this. If that is the case with you, just use the Price Factor field
and ignore the Offset field.
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By quantity

Quantity discounts for a product attribute can also be specified in Zen Cart. Once a product attribute contains a quantity
discount, Zen Cart will show a hyperlink on the Product Info page in the Store Front. The pop-up window which
appears on clicking the hyperlink allows a customer to see the bulk discounts that apply for the product. An example
of an optical mouse with a bulk discount for each type of connector chosen is shown in the following screen shots.

Before you specify bulk discounts for your attribute:

▪ Make sure you have created the product and its required option names and option values.

▪ Make sure that Enable Qty Price Discount is set to true under Configuration > Attribute Settings.

To specify bulk discounts for an attribute:

1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category.

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area on your screen.

To understand the meanings and syntax for these two fields, refer to the section after these steps.

4. To specify a constant quantity discount for your attribute, enter your desired values in the Attributes Qty Price
Discount field.

5. To specify a one-time quantity discount for your attribute, enter your desired values in the Onetime Attributes
Qty Price Discount field.

6. Commit all your changes to the database by clicking the insert button.

Attributes Qty Discount and Onetime Attributes Qty Discount

The Attributes Qty Discount field allows you to specify bulk discounts for a particular attribute. For simplicity’s
sake, we shall assume that this attribute has no other prices attached to it. Consider the case where your store sells an
optical mouse at a price of $29 and a customer chooses only the USB Connector attribute.
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You can specify the bulk discounts for the optical mice with the USB Connector option value as follows:

1:1.00,3:0.75,5:0.50

Customers at the Product Info page in your Store Front can click on a Quantity Discount hyperlink which opens a pop-
up window showing a Quantity Discount Table as follows:

QTY        1       2-3     4+
PRICE      $1.00   $0.75   $0.50

The above table values translate into the following scenarios based on the number of optical mice a customer buys
assuming only the USB Connector attribute is selected.

No. of Optical Mouse bought = 1,   Total Price: ($29 + $1.00) x 1 = $30.00
No. of Optical Mouse bought = 2,   Total Price: ($29 + $0.75) x 2 = $59.50
No. of Optical Mouse bought = 3,   Total Price: ($29 + $0.75) x 3 = $89.25
No. of Optical Mouse bought = 4,   Total Price: ($29 + $0.50) x 4 = $118.00
No. of Optical Mouse bought = 5,   Total Price: ($29 + $0.50) x 5 = $147.50
No. of Optical Mouse bought = 6,   Total Price: ($29 + $0.50) x 6 = $177.00

The Onetime Attributes Qty Discount field allows you to specify bulk discounts for a particular attribute but the
calculation is slightly different from the Attributes Qty Discount field. For comparison sake, we shall use the same
example above but with the values entered into the Onetime Attributes Qty Discount field instead of the Attributes
Qty Discount field.

Customers at the Product Info page of your Store Front can click on a Quantity Discount hyperlink which opens a pop-
up window showing a Quantity Discount Table as follows:

QTY        1       3       5
PRICE      $1.00   $0.75   $0.50

The above table values translate into the following scenarios based on the number of optical mice a customer buys,
assuming the USB connector attribute is selected.

No. of Optical Mouse bought = 1,   Total Price: (1 x $29) + 1.00 = $30.00
No. of Optical Mouse bought = 2,   Total Price: (2 x $29) + 0.75 = $58.75
No. of Optical Mouse bought = 3,   Total Price: (3 x $29) + 0.75 = $87.75
No. of Optical Mouse bought = 4,   Total Price: (4 x $29) + 0.50 = $116.50
No. of Optical Mouse bought = 5,   Total Price: (5 x $29) + 0.50 = $145.50
No. of Optical Mouse bought = 6,   Total Price: (6 x $29) + 0.50 = $174.50

By words or letters

This pricing mechanism is applicable only to attributes that are of the Text option type. It allows you to price your text
attribute according to the number of letters or words that a customer specifies. An example of a cake which allows
customers to specify the wordings they want on the cake and a corresponding greeting card is shown in the following
screen shot to give you an idea of the use of this pricing mechanism.
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Before you specify the pricing for words or letters in your attribute:

▪ Make sure you have created the product and its required option names and option values. The option name must
be of option type: Text.

▪ You can adjust the text box layout settings by clicking on the edit button of the option name in the Product Options
screen. Refer to the section “Create attribute option name” if you have forgotten how to do this.

▪ You can also force the customer to enter a value into the text area before adding the product to a cart by checking
the Attribute Required for Text flag in the Attributes Controller screen.

▪ Make sure that Enable Text Pricing by word or letter and Text Pricing - Spaces are Free are set to true under
Configuration > Attribute Settings.

To specify a price for the number of words or letters in each attribute:

1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category.

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area on your screen.

4. To price an attribute based on words, enter your desired values in the Price Per Word and Free Words headings.

5. To price an attribute based on letters, enter your desired values in the Price Per Letter and Free Letters headings.

6. Commit all your changes to the database by clicking the insert button.
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Attaching weight information
If your shipping charges are affected by the weight that your product attributes introduce, you can optionally choose
to increase the product weight based on the attribute instead. An example would be if your store sells gym equipment.
A customer can choose to buy a set of basic dumbbells and add more weight to the dumbbells by using weight plates.
This example is shown in the following screen shot.

Before you specify weight to represent your product or service:

▪ Make sure you have created the product and its required option names and option values.

▪ Click the edit layout button of the product type that is linked to this attribute and take note of the PRODUCT
Attribute Weight Prefix - Default field. This field specifies whether the attribute weight should be incremented
or decremented by default. In addition, make sure the following fields in the screen are enabled:
▸ Show Weight
▸ Show Attribute Weight

To specify a weight to represent each attribute:

1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Choose the appropriate category from the drop-down list box and your screen will be refreshed with products
from the previously selected category.

3. Choose the appropriate product and attribute from the respective boxes and then concentrate on the following
area in your screen.

4. To add the attribute weight to the product weight, specify a "+" or a blank space in the first box under the Weight
field. To subtract the attribute weight from the product weight, specify a "-" instead.

5. Type in a value for the second box under the Weight field to specify how much weight should be added or
subtracted from the product’s weight.

6. Enter a number into the Order field. This field indicates the sequence in which the attributes will be displayed to
a customer. For example, if you have three attributes X, Y, Z in their original sequence of 1, 2, 3 and you change
the sequence to 3, 1, 2. Then the attributes will be displayed in this order to the customer Z, X, Y.
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7. Optionally, you can enter values into the Price and One Time fields if you want to specify prices along with your
weights. Note that the One Time field applies only to price and not weight!

8. Commit all your changes to the database by clicking the insert button.

Attaching download information

Another piece of information you can attach to attribute values is to signal an attribute as part of a downloadable
product. For example, you can make an attribute represent a PDF document download and another attribute as a Word
document download.

As the attribute configuration for downloadable products involves several different steps, we shall cover it in more
detail in the section “Selling downloadable products”.

Attaching upload information

If your product offerings include letting customers upload files to your store, you can attach one or more file upload
attributes to your products. Several considerations and steps are involved when making file upload functionalities
available to your customers and they shall be covered in the section “Accepting file uploads from customers”.

Examples of using product attributes to config-
ure a product
The multitude of configuration options for each product attribute alone often leads to frustration figuring out the best
approach to use when attempting to attach several attributes to a product at once. The problem seems even more
daunting when you need to configure differing pieces of information per attribute.

To provide you with some inspiration when creating your own attributes and to amalgate all the individual product
attribute configuration information we have presented earlier, you can refer to the following examples.

A word of caution is in order here. The examples may add to your confusion if you try too hard to adapt them to
your needs without first thoroughly understanding your own product set up requirements. In such cases, set up more
attributes with different variations and play with them as you work through your product attribute set up. Although
you will have to spend more time setting up your attributes in this way, you will be surprised by the insight you will
gain into your own product configuration problems as well as how product attributes work.
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Example 1: A television

From the preceding screen shot, we see that the TV is being offered at a base price of $800. By default it comes in
the form of a 40 inch TV screen and a 3 feet HDMI cable. Option values with either a + or "-" sign appearing before
their prices or weights will alter the base price of $800.00 and base weight of 45 lbs. Also note that the default selected
HDMI cable is the "3-ft" one because this is the most popular choice among our customers. We may also offer a
reduction in price for the "1-ft" HDMI cable because we are clearing our stock.

Let us now take a quick look at some of the settings in the Product Details screen. We shall assume that we have used
the ‘Product-General’ product type when creating our product and the rest of the product fields have their values set
at their defaults or according to what is displayed in our preceding screen shot.

Table 14.2: Television product field settings

Field Value

Products Status In Stock

Product Priced by Attributes No

Products Price (Net) $800.00

Products Quantity 100

Products Shipping Weight 45

Here are some of the pertinent points to note in our product detail settings:

1. We have set the Product Priced by Attributes field to No which means that our product will have a base price.
This is because we are offering the product with a default variation of 40-in and a 3-ft HDMI cable. We will be
using attributes later to allow customers to choose how big they want their TV to be or what length of HDMI
cable they want.

2. Since we are offering a default product variation, we set the default values for the Products Price (Net) and
Products Shipping Weight fields too.
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3. The Products Status and Products Quantity field are highlighted here so that you know when to check them
if you do not see your product in your Store Front.

To quickly see what settings we have set up for each attribute in the Attributes Controller screen, refer to the following
screen shot.

Here are some of the more interesting points to note in our attribute settings:

1. We have chosen the "40 in" screen size and "3 ft" HDMI cable option values as the default options to be selected
by having their Default Attribute to be Marked Selected attribute flag set to Yes.

2. For the two option values mentioned in the preceding step, we have also not specified any prices or weight for
them because we want to let customers know that these are the default options that the TV will come with and
so do not incur any charges.

3. A "+" and "-" sign is also placed before the price and weight of some option values to signify whether those chosen
option values will add to or subtract from the product’s base price of $800 or weight of 45 lbs.

Example 2: A video game
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From the preceding screen shot, we see that the game is being offered on different gaming platforms. The delivery
of the product is either in the form of an electronic download or shipped to the customer after purchase. In all the
option values, no "+" or "-" signs appear before the prices or weights. Visually, this may tell the customer that the
price stated in the option value is the price of the product when that particular option value is selected. If we add a
"+" sign next to a option value, it may seem to a customer that the price is added onto a base price and this may not
be what you want to portray.

Let us now take a quick look at some of the settings in the Product Details screen. We shall assume that we have used
the ‘Product-General’ product type when creating our product and the rest of the product fields have their values set
at their defaults or according to what is displayed in our preceding screen shot.

Table 14.3: Video game product field settings

Field Value

Products Status In Stock

Product Priced by Attributes Yes

Products Price (Net) $0.00

Products Quantity 100

Products Shipping Weight 0

Here are some of the pertinent points to note in our product detail settings:

1. Unlike our previous example, we have set the Product Priced by Attributes field to Yes and the Product’s Price
to 0.00. This means that the price of the product will be determined purely by the options selected by the customer.

2. We have not specified any weight for the product because the product is offered either as a shippable item which
has a weight or a downloadable item with no weight. You do not need to follow our example because your product
may need to have a base shipping weight with your attributes adding on additional weight. Or maybe your product
may have a weight which is common across your attributes and so you can simplify the situation by specifying
a product weight here.

3. The Products Status and Products Quantity field are highlighted here so that you know when to check them
if you do not see your product in your Store Front.

To quickly see what settings we have set up for each attribute in the Attributes Controller screen, refer to the following
screen shot.

Here are some of the more interesting points to note in our attribute settings:
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1. We are forcing customers to select an option from one of the drop-down list boxes by creating an option value
"Select one …" and specifying Yes for the Used For Display Purposes Only and Default Attribute to be
Marked Selected attribute flags.

This approach of forcing the customer to make a selection is not compulsory for Radio and Dropdown attributes
because by setting the Default Attribute to be Marked Selected flag to Yes for one of the option values, you
can force one of the choices to be selected already.

However, not only is it aesthetically more pleasing, it also prevents customers from just accepting the default
option values you have set for them if you choose not to use this approach.

Note that this approach is currently only possible for Radio and Dropdown attributes and not possible with Check-
box and File attributes. To force customers to enter a value into a Text attribute, just set the Attribute Required
for Text attribute flag to Yes.

2. We have left the "+" or "-" box blank when we entered their corresponding price and weight information. These
forces the Product Info page in your Store Front not to show the sign when displaying the price or weight.

3. We have set all the Include in Base Price When Priced by Attributes attribute flags to Yes except for the "Select
one …" option which can either be set to No or Yes. That is because the "Select one…" attribute is marked as
Used For Display Purposes Only and will thus not be involved in the determination of the base price for the
product by default.

Note that you do not need to specify Yes for all the Include in Base Price When Priced by Attributes attribute
flags. For instance, if you only want one the Product Info page to display "Starting at $45.00" instead of "Starting
at $15.00" in our example screen shot. Just set the Include in Base Price When Priced by Attributes attribute
flag to Yes for the Microsoft X-Box option value while leaving the rest set to No.

4. Notice that two of the option values are configured as downloadable files and do not have any weight specified
for them. This may make it visually clearer to customers that those option values are only for downloadable
versions that will not be shipped physically. We shall learn more about downloadable files in the section “Selling
downloadable products”.

One limitation in both examples you may have noticed is that stock settings are only available
at the product level but not at the product attribute level. Therefore, you will need to maintain
a separate log of your products if your stock levels are tied to individual attributes.

Manipulating multiple attributes simultaneous-
ly
We shall now talk about how to copy attributes across different products. If you intend to perform all these operations,
remember the two following principles:

▪ Create and price all your attributes beforehand to save you the trouble of propagating the changes afterwards.
▪ Back up your database to prevent accidental replacement of your data. Refer to the section “Database back up”

for details on doing this properly.

Enabling mass attribute copy, add, and delete
To copy or move attributes you have created, you need to turn on the appropriate feature in Zen Cart. You can either
set this as a default for your store or on a per-page basis.
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To enable copying and moving of attributes on a default basis:

▪ Click on Configuration > Layout Settings and set Option Names and Values Global Add, Copy and Delete
Features Status and set the value to 1 to enable it.

To enable copying and moving of attributes on a per-page basis:

▪ Go to either the Product Options screen or the Option Values screen and select Display Global Features - ON from
the drop-down list box near the top of the screen.

Copying attributes to other products
Some situations require that you copy a set of attributes for one product across to all the products you have in a specific
category. For example, suppose your shop sells children’s clothing. You can set up an option name "shirt size" with
the following values "small", "medium" and "large". You can then copy all these option values to another option name
"cap size" easily.

As explained earlier, an attribute is made up of an option name and one or more option values. Therefore, there are
two possible ways by which you can copy attributes to other products.

▪ Copy option values from one option name to another option name
▪ Copy option name with associated values from one product to other products in a category.

To copy all option values from one option name to another option name:

1. Click on Catalog > Option Name Manager to access the Product Options screen.

2. Concentrate on the following portion of the screen.

3. Choose the source option name containing the required option values to copy from the Copy from Option Name
select box.

4. Choose the destination option name for the values you wish to copy to from the Copy All Option Values to
Option Name field.

5. Click on update to complete the copy operation.

All option values copied from one option name to another will not retain their original attribute
pricing, weighting and image properties. You will need to set these attribute properties up again
if you want them to apply to another set of attributes.

To copy selected option values to other products by matching "option name and value":
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1. Click on Catalog > Option Value Manager to access the Option Values screen and concentrate on the following
portion of the screen.

2. To copy to products that contain a certain distinct attribute option name and option value, choose the matching
option name and option value from the first column of select boxes; i.e. Option Name to match and Option
Values to match.

3. Select the option name and option value you wish to copy from by choosing from the select boxes in the second
column; i.e. Option Name to add and Option Value to add.

4. In Step 3, you chose products that contain a matching attribute which will be affected by the copy operation. You
can optionally specify whether these matching products should be restricted to a certain category by specifying
the Category ID in the third column.

5. Click on insert to start the copy operation. A success message will appear at the top of your screen if everything
is successful.

To copy selected option values to other products by matching "option name":

1. Click on Catalog > Option Value Manager to access the Option Values screen and concentrate on the following
portion of the screen.

2. Select the option name and option value you wish to copy from by choosing from the select boxes in the first
column; i.e. Option Name to add and Option Value to add.

3. Optionally, you can enter a Product ID into the blank text box on the left-most column for a source product which
already has its default values.

For example, you may have many different products with the same attribute but one of them has its option value
price and weight set to a specific value already. You can choose to have this specific product’s default option
value and settings copied over to the new product.
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4. To copy to products that contain a certain distinct attribute option name only, choose the matching option name
from the second column of select boxes; i.e. Option Name to add to.

5. In Step 4, you chose products that contain a matching attribute which will be affected by the copy operation. You
can optionally specify whether these matching products should be restricted to a certain category by specifying
the Category ID in the third column’s text box.

6. If you do not want to continue adding an attribute if the target product already contains the attribute you are trying
to add, you should check the Ignore existing attributes and add only new attributes radio button.

7. If you want to update the target attribute with the source attribute values (most likely already changed from the
last time it was added), you can check the Update existing attributes with new settings/prices option instead.
This setting will have an effect only when both the source and target attribute values are the same but the attribute
pricing, weight and other settings are different.

8. Click on insert to start the copy operation. A success message will appear at the top of your screen if everything
is successful.

Adding attributes to other products
You can create an attribute and choose to have it added to other products. The target products (which must have at
least one option value defined) can be restricted to the following types.

▪ All products.
▪ A single product.
▪ A category of products.

To access these options, click on Catalog > Option Name Manager and scroll to the following portion of the screen.

You should have no problems going about adding your own attributes to other products since the fields are self-
explanatory and you have already covered how to copy attributes in the above sections.

Deleting attributes from a selection of products
Zen Cart also allows you to do a mass delete of attributes from a selection of products if the need arises. All the steps
taken and screen options are similar to those in the adding and copying of attributes section. Thus, we shall not be
going through them.
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To delete a matching option value from all products or a category of products, click on Catalog > Option Value
Manager and manipulate the following portion of the screen.

You can also choose to delete an attribute from products by matching an option name only. These products can be
restricted to the following types.

▪ All products.

▪ A single product.

▪ A category of products.

To do so, click on Catalog > Option Name Manager and manipulate the following portion of the screen.

Copying, adding, or deleting attributes from a single
product

To copy, edit, or delete attributes from a single product:

1. Navigate to the Attributes Controller screen of the product.

2. Concentrate on the list of buttons near the top of the screen.
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3. To copy the current set of product attributes to another product, click on the Copy To Product button and you
should see something similar to the following screen shot. Follow the on screen instructions to make your desired
changes.

4. To copy the current set of product attributes to all the products belonging to a category, click on the Copy To
Category button and you should see something similar to the following screen shot. Follow the on screen instruc-
tions to make your desired changes.

5. To delete all the attributes from the current product, click on the delete button. You will be prompted with a
message to confirm whether you are sure you want to perform the delete.

There is another way to perform the same functions as the following steps. Just navigate to the product you want to
perform the desired operation on in the Categories/Products screen. Click on the "A" icon next to the relevant product
and follow the on-screen instructions found in the corresponding side-panel as shown in the following sample screen
shot.
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Sorting attributes
Zen Cart provides several options for you to manipulate the ordering of your product attributes. In this book, we shall
categorize them into three different areas for easier reference:

▪ Default sort order
▪ Custom sort order
▪ Display sort order

Default sort order
The default sort order for an attribute’s option name or option value is the value you entered in the Order field when
you created the option name or option value.

To understand default sort orders better, let us assume that you have created the following two option names with their
corresponding option values in brackets:

▪ Texture (Wood, Granite, Sand)
▪ Dimension (100x200, 200x200, 300x200)

The sort orders of the preceding two attributes in their respective Product Options screen and Option Values screen
are shown in the following screen shots.
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When we attach the option names and option attributes to a product, let us not enter any value into the corresponding
Order field in the Attributes Controller screen. You will notice that the default sort orders are used to fill up the option
values as shown in the following screen shot.

If you go to your Store Front now, you will see that the option values for your attributes are ordered exactly as your
default sort order of your option values.

Although you can change the default sort orders for your option names and option values by going to the Product
Options screen and Option Values screen respectively, there is a faster way to accomplish this.

To quickly re-arrange the default sort order for your option names:

1. Click on Catalog > Option Name Sorter to access the Option Name Sort Order screen.

2. Enter new values into the Sort Order fields corresponding to the option names you want to change.

3. Click on update to save your changes.
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To quickly re-arrange the default sort order for your option values:

1. Click on Catalog > Option Value Sorter to access the Option Values Default Sort Order screen.

2. Select your desired option name from the first drop-down list box and click edit.

3. Enter new values into the Sort Order fields corresponding to the option values you want to change.

4. Click on Update Sort Order to save your changes.

Custom sort order
When you attach attributes to your products, you have the opportunity to make use of custom sort orders to control
how the attributes will be displayed in your Store Front.

Custom option name sort orders are specified based on the order in which you attach them to your product. Custom
option values are specified if you have entered a value in the Sort field when attaching an attribute to a product. If you
have not entered a value in the Sort order field, then Zen Cart makes use of the default sort order of the option value.

Let us study the effects of applying custom sort orders to your option values by adjusting the values for the example
used in the previous section as shown in the following screen shot.
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If you go to your Store Front now, you will see that the option values for your attributes are now ordered according to
your custom sort orders instead of the default sort orders of the option values.

Besides manually re-entering the custom sort orders of your option values to re-arrange their sequences, you can also
use the following methods to quickly override them with the default sort orders instead.

To quickly re-arrange the default sort order for your option values:

1. Click on Catalog > Option Value Sorter to access the Option Values Default Sort Order screen.

2. To override the custom sort orders of option values belonging to a product to use the default sort orders of the
option values instead.

▪ Select your product from the second drop-down list box.

▪ Click on Update to effect the changes.

3. To override the custom sort orders of option values belonging to all products in a category to use the default sort
orders of the option values instead.

▪ Select your product from the third drop-down list box.

▪ Click on Update to effect the changes.

4. To override the custom sort orders of option values belonging to all products in your store to use the default
sort orders of the option values instead, click on the update button next to the Update All Products' Attribute
Sort Orders text.

Note that this same function can be found in the Store Manager screen when you click on Tools > Store Manager
as shown in the following screen shot.

If you happen to be editing a product’s attributes in the Attributes Controller screen, you can also override the custom
sort orders of option values belonging to the product to use the default sort orders of the option values instead by
clicking on the update sort button which appears near the top of the screen.
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Alternatively, you can also click on the "A" icon next to a product in the Categories/Products screen to reveal a side-
panel similar to the following screen shot. Again, the custom sort order of the option values can be manipulated via
the update button as shown in the following screen shot.

You may want to back up your database when doing mass updates of custom attribute option
sort orders with those from your default attribute option sort orders as these mass updates are
irreversible.

Display sort order
To change the sorting preferences for your attributes in the Product Info page of your Store Front:

1. Click on Configuration > Product Info to access the Product Info screen.

2. Change the displayed sort order for your option names by editing the Products Info - Products Option Name
Sort Order field.

3. Change the displayed sort order for your option names by editing the Products Info - Product Option Value
of Attributes Sort Order field.
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Summary
After going through this chapter, you should be comfortable manipulating most product attributes. Product attributes
is one of the most powerful features of Zen Cart although few people utilize its flexibility or power because it requires
some effort and experimentation to understand and apply.

Do not worry if you need to spend a bit more time on this chapter compared to the rest of the book. After you master
the power of attributes, your imagination will allow you to configure almost any product the way you want.
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Chapter 15:

Advanced product attribute
configuration

Introduction
Selling downloadable products and offering customers a way to upload their files to your store are other ways in which
product attributes can be utilized. These product attributes require more steps to set up and require that you be familiar
with how product attributes work already.

In this chapter, we shall:

▪ Set up downloadable products for sale.

▪ Configure your store to accept customer file uploads.

Selling downloadable products
Digital downloads are one of the hottest ways of doing business on the Internet nowadays. There is no inventory to
hold and customers get to enjoy their products sooner.

Zen Cart allows you to easily set up downloadable products for sale in your online store via the use of product attributes.
For example, you can sell individual songs contained in a song album by using a product attribute to represent each
song. Customers can then choose which songs they want to buy and pay only for those songs.

Deciding how download options are structured

The steps to creating a downloadable product are fairly straightforward. The difficult part is in deciding how you want
to "structure" your download options as shown in the following screen shots.
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The figure on the left shows an encyclopedia with several downloadable parts. All the downloadable parts are presented
as radio buttons which have already been pre-selected. Therefore, when customers buy the encyclopedia, they will be
able to download all four parts of the encyclopedia separately. Breaking up large files into smaller parts for download
allow users with limited bandwidth to schedule their downloads according to their own free time.

All three download attributes are implemented using a pair of option name and option value. All option values also
have their Default Attribute to be Marked Selected attribute flag in the Attributes Controller screen set to Yes.
By doing so, customers do not have to explicitly click on each radio button to indicate they want to purchase that
particular download.

The figure on the right shows an instructional manual and the corresponding training videos for download. Here,
customers are given a choice of what they want to download. For the Video attribute, they can choose from any of the
four videos. For the Manual attribute, they will need to choose between the PDF or Word file format. In either case,
each option name has more than one option value attached to it. The price of the final purchase will also depend on
the number of downloads that a customer chooses.

Having seen two examples of how download attributes can be structured, you should be able to utilize the concept
when creating your own downloadable products.

Configuring a downloadable product
The general steps to configuring your downloadable product properly can be summarized as follows:

1. Enable download functionality in Zen Cart.
2. FTP downloadable files to the server.
3. Configure download attributes.
4. Specify when downloads are made available.
5. Test your product download configuration.

Before you begin to configure your downloadable product:

▪ Create a product based on the product type that best matches the downloadable product you want to sell. Due to the
nature of downloadable products, you should pay careful attention to the fields in the following table when creating
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your product. Refer to the section “Step 3 of 5: Enter product details” if you need to refresh your memory on the
meanings of the other fields in the Product Details screen.

Field Comments

Product is Virtual Set to No, Shipping Address Required. Zen Cart will not reduce the stock level
automatically in this case; which is logical for a downloadable product.

Always Free Shipping Set to No, Normal Shipping Rules if your product is offered purely as a down-
loadable file. Zen Cart automatically skips the Shipping Information page if all items in
a customer’s shopping cart are downloadable files.

Set to Special, Product/Download Combo Requires a Shipping Address if
your product is offered both as a downloadable file and a physical good to be delivered
to customers.

Products Quantity
Box Shows

Set to No, Do not show Quantity Box and set the Product Qty Minimum field
to 1 if your product is offered purely as a downloadable file. This setting makes sense
for products offered purely as download files because customers only need one copy of
the product and can easily duplicate multiple copies themselves.

▪ Prepare the files you want customers to download. Try to zip your downloadable files into a compressed format
to save space and speed up the download. For compressed files, most web browsers will open up a dialog box
prompting users to save the files to their local computers.

If your downloadable files are uncompressed and happen to belong to the type that can automatically be "opened"
by a web browser (.jpg, .gif, .pdf, etc), your customers will not have a chance to choose where they want to
save the files and may even have trouble opening the files properly. Therefore, save yourself the trouble of having
to answer support calls by compressing your downloadable files.

Step 1 of 5: Enable download functionality in Zen Cart

1. Click on Configuration > Attribute Settings to access the Attribute Settings screen.

2. Ensure that the Enable Downloads field has a value of true. This will allow Zen Cart to process downloads.

3. Edit the Download by Redirect field to bring up the following side-panel.
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a. Choose true if your Zen Cart store is running on a Linux or Mac operating system. Note that the directory
permission for the [zc-home]/pub directory only needs to be writeable. It may not be chmod 777 depend-
ing on how your web host has configured your server. For more information on how file permissions are
configured on your remote server, refer to the section “Changing file and directory permissions”.

b. Choose false if your Zen Cart store is running on a Windows operating system.

c. Click update to save your changes.

4. The Download by streaming field allows your customers to download their files in smaller chunks from the
server. This is helpful if you have set Download by Redirect to false and the PHP memory limit on your server
has been set to 8MB or less.

Remember to make sure the [zc-home]/pub directory on your server has the correct file permission (e.g. chmod
755) if you have specified true for the Download by Redirect field and your Zen Cart store is hosted on a Linux
or Mac operating system. If your Zen Cart store is running on a Windows server, you can ignore the [zc-home]/
pub directory as it is not used.

Check that the download file type you want to offer is allowed in the list of permitted file types in
[zc-home]/pub/.htaccess and [zc-home]/download/.htaccess in order for the file
to be downloadable by your customers from the Store Front.

For more information on working with the .htaccess file, refer to the section “The .htaccess
files”.

Step 2 of 5: FTP downloadable files to the server

Now we need to FTP some files to the server which we want users to be able to download.

1. Start your FTP client software and connect to the server hosting your Zen Cart store.

2. Make sure that the [zc-home]/download directory exists on the server. If you do not see the directory, check the
following lines in your [zc-home]/includes/configure.php file to see which directory your downloadable
file should be located in. The [zc-home]/pub directory is only useful if you have set Download by Redirect to
True earlier and your remote server is running on a Linux or Mac operating system.
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define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

3. Upload the required file to the [zc-home]/download directory or the directory specified in the previously men-
tioned configure.php file. Uploading to an immediate sub-directory of [zc-home]/download should also
work but it is best to avoid doing so in order to minimize any unforeseen problems.

Avoid using spaces, special characters, extra periods, quote marks, etc, for your filenames as
they can cause strange problems to occur. Also note that filenames are case-sensitive.

Step 3 of 5: Configure download attributes

Different file formats are required for different types of product downloads. For example, if you sell e-books, your
download format might be ".pdf" or ".doc". If you sell music, your download format might be ".mp3" or ".wma".
Whatever the case may be, you need to tell Zen Cart what the attribute used for download is.

Before you begin to configure your download attribute:

▪ Create the attribute you want for a product to allow a specific download. For example, if you are offering e-books
as downloadable files, you can create an attribute with an option name of "File Format" and option values of "pdf"
and "doc" respectively.

▪ Choose either one of the following values for the Option Type field when creating your download attribute’s option
name:
▸ Radio

▸ Dropdown

To configure your download attribute:

1. Click on Catalog > Attributes Controller to access the Attributes Controller screen.

2. Navigate to the product which you want to associate a download attribute with.

3. Choose the option name and option value to be associated with a specific download file. Concentrate on the
following portion of the screen.

4. In the Filename field, type the name of the file which you have transferred to the server via FTP. Note that the
file name is case-sensitive!

5. Enter a value for the Expiry days field to specify the download validity period for the download. You can change
the default value for this field by clicking on Configuration > Attribute Settings and changing the value of the
Download Expiration (Number of Days) field.

6. Enter a value for the Maximum download count field to specify a limit on how many times a customer can
download the same file. You can change the default value for this field by clicking on Configuration > Attribute
Settings and changing the value of the Number of Downloads Allowed - Per Product field.

7. Click on insert to link the downloadable file with the product attribute.
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Step 4 of 5: Specify when downloads are made available

Finally, you need to tell Zen Cart whether the customer is entitled to an immediate download or a delayed download.
This decision is based on the order status of the customer purchase. The default order statuses available in Zen Cart
are as follows:

▪ Pending [1]

▪ Processing [2]

▪ Delivered [3]

▪ Update [4]

Refer to the section “Working with order statuses” for more information related to order statuses.

Click on Configuration > Attribute Settings and concentrate on the following fields which dictate what order statuses
will affect when your products are available for download.

▪ Downloads Controller Update Status Value - The order status value here resets the download days and maximum
download counts for a particular download. This is helpful if your customer’s download period has expired and
you want to enable them to re-download a particular file. The default value is 4 which represents an order status
of "Update [4]".

▪ Downloads Controller Order Status Value >= lower value - The lower bound of order statuses that will make a
download available to customers. The default value is 2, which represents an order status of "Processing [2]".

▪ Downloads Controller Order Status Value # upper value - The upper bound of order statuses that will make a
download available to customers. The default value is 4, which represents an order status of "Update [4]".

Based on the above three fields in the Attribute Settings screen, we can conclude that an order that has an order status
of "Processing [2]" or "Delivered [3]" will mean that file(s) are available for download. An order of "Pending [1]" will
mean that file(s) are not available for download yet. An order of "Update [4]" not only makes a download available,
it resets the download days and maximum download counts too.

Now that you understand how order statuses affect the availability of your downloads to customers, you will need to
specify when you want files to be available for download to customers after they have paid up.

To configure when customers can download a particular file after paying for your goods:

1. Click on Modules > Payment to access the Payment Modules screen.

2. Choose and edit a payment option available to your customers and concentrate on the following portion of the
screen.

3. Choose a value for your Set Order Status field as discussed earlier:

▪ For delayed downloads, you need to set the order status to Pending [1].

▪ For immediate downloads, you need to set order status to Processing [2] or Delivered [3].
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Step 5 of 5: Test your product download configuration

Using a test customer account, go to your Store Front and purchase the downloadable product which you have just
created. Make sure you choose a payment option that allows you to check whether it allows immediate or delayed
download.

If a file is available for immediate download, the test customer will be able to see and download the files immediately
on the Checkout Success page as shown in the following screen shot.

Optionally, you can log in to the test customer account to check whether files are available for download. To give
you an idea of how files that are available for download will appear in a test customer’s account, you can refer to the
following sample screen shots.

Checking and changing download statuses

After a purchase is made by a customer, you can check the availability of your downloadable products to that customer.
This allows you to check on customer complaints regarding download failures or simply to manually reactivate the
downloads of a particular customer’s order.

To check and/or change the download status of your customer orders:

1. Click on Customers > Orders to access the Orders screen.

2. Choose the order which contains purchased downloads and click the edit button on the side-panel. Concentrate
on the following portion of the screen.
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3. To change the download status of a particular file, click on the respective button under the Status column of the
Order Download Status table.

4. To change the status of an order so as to control when files are available for download, choose a suitable order
status from the Status drop-down list box and click the update button.

Managing downloadable products centrally
You can easily lose track of which attributes are tied to which downloadable files if your online store sells a lot of
downloadable products. To alleviate this problem, Zen Cart provides a screen which allows you to manage all your
download-specific information from one place. This screen is available via Catalog > Downloads Manager as shown
in the following sample screen shot.
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Accepting file uploads from customers
Customer file uploads can be handled by using attributes. In Zen Cart, file uploads are handled as part of a purchase
and not after the purchase. That means the upload process occurs when a product with a File attribute option type is
added to a customer’s shopping cart.

How file uploads work in Zen Cart
File uploads are achieved by utilizing File attributes that are attached to a product. Each File attribute results in an
upload file field being rendered in the product’s Product Info page as shown in the following screen shot.

Customers pick their desired files to upload from their local computer by clicking the respective Browse buttons next
to each file upload field. The upload process begins immediately after a customer clicks the "Add to Cart" button.
Messages will then be displayed on the next page indicating whether the upload was successful. For example, the
following screen shots shows the Shopping Cart page when a successful upload is performed. Notice that a number is
prefixed to the original name of each uploaded file if the upload succeeds.

After a file is uploaded onto a remote server, Zen Cart will rename the physical files by assigning a unique and
incrementing number to their original file extensions. For example, if there are already two files on the server
with the names: 1.jpg and 2.jpg. Then, the two files that the customer uploaded (i.e. my_mug_side.png and
my_mug_bottom.png) will be renamed to 3.png and 4.png on the server respectively. Hence, if you were to go to
the directory where the uploaded files are stored, you will see a directory structure similar to the following screen shot.
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This re-naming scheme for uploaded files serves two main purposes. Firstly, it prevents the accidental overwriting
of files when different customers upload files with the same names. Secondly, it prevents customers from uploading
files to your online store and then sharing the links to the uploaded files with other users thus turning your store into
a file sharing website.

Note that the re-naming of uploaded files is opaque to the customer uploading the files. The unique number that is
prefixed to a customer’s uploaded image in the Shopping Cart page is the same running number assigned to the re-
named physical file on the remote server. The prefixed file name appears from the Shopping Cart page all the way to
the Order History page as shown in the following screen shot.

When a store owner processes an order with uploaded files in the Orders screen, the names of the uploaded files will
also appear with their respective running numbers as shown in the following screen shot.

Currently, there is no way to download the files uploaded by a customer directly from within the Admin Console.
Instead, store owners will have to correlate the prefixed file names in a customer’s order with the uploaded physical file
names on the remote server before using an FTP client or cPanel to retrieve the uploaded files to their local computers.

You may want to run a virus scan on the uploaded file when you download it to your local
computer. Optionally, you may want to speak to your web host to see if they offer real-time
virus scanning services for your hosting account.
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Configuring file uploads
We have discussed how you can configure file attributes earlier so you should not have any problems here. There are
several steps that you will need to perform to get file uploads working as they are intended to in Zen Cart. We shall
cover these settings in detail in this section.

Upload directory settings

The directory in which uploaded files are stored is defined in the following two lines of code in the [zc-home]/in-
cludes/configure.php file. By default, it would mean that the file upload directory is [zc-home]/images/up-
loads.

define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);

In order for uploaded files to be placed in the configured file upload directory, you need to make sure that the directory
exists and also that the directory permissions allow files to be stored there. For more information on changing directory
permissions, refer to the section “Changing file and directory permissions”.

Attribute configuration

Before you configure the necessary file upload attributes, you need to make sure that the following conditions are met:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. To control the file names extension that can be used by customers to upload to your server, edit the Allowed
Filename Extensions for uploading field.

The file name extensions are checked against customer uploaded files in a case-insensitive manner by Zen Cart.

3. To limit the size of an uploaded file, enter a value (in bytes) into the Maximum File Upload Size field. The
default value is 2048000 bytes which is almost 2 megabytes (i.e. 2MB).

This value is different from the upload_max_filesize PHP configuration setting covered in the next section.
It is used by Zen Cart to determine whether a file should be allowed on the server after an upload completes
whereas the upload_max_filesize PHP settings is used to determine whether a file size limit has been reached
during upload.
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As you should be very familiar with attribute manipulation after working through the Chapter 14, “Working with
product attributes”, we shall only cover the main steps required for you to set up and configure a file upload attribute
in the following steps.

1. Create an attribute with Option Type = File as shown in the following screen shot.

2. Attach the file upload attribute to the product and configure the attribute’s settings as shown in the following
example screen shot.

3. Go to the Store Front to preview and verify how the attribute will look and behave as shown in the following
example screen shot.
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PHP configuration settings

You will need to be aware of certain PHP configuration settings that could potentially interfere with whether file
uploads work properly for your Zen Cart store.

These settings can be determined when you click on Tools > Server/Version Info to access the Server Information
screen. You will not usually need to change these settings. However, if you are required to do so, speak to your web
host to see how this can be done as it depends on how your remote server is configured by them.

Table 15.1: PHP settings that may affect file upload operations

Option Description

file_uploads Indicates whether file upload operations are allowed. This value must be
set to 1 or true.

upload_tmp_dir This is the directory which PHP will temporarily store any uploaded files.
This value is not used by Zen Cart but is mentioned here so that you do
not waste time checking it.

upload_max_filesize Controls the maximum file size that PHP will accept. This value must be
less than the post_max_size explained later.

max_file_uploads This directive was introduced in PHP 5.2.12 to limit the number of files
that your web application will handle per request. This is to prevent a class
of web hacking activity known as denial-of-service (DOS) attacks.

post_max_size Controls the maximum data size that can be sent from a browser via a
POST request. The data size would include the lengths of form fields and
any attached files to be uploaded to the server. This value must be greater
than the upload_max_filesize mentioned earlier.

max_input_time Limits the amount of time (in seconds) that a POST request may take to
submit all its data, after which the operation will be terminated. Users who
are using slow internet connections may require you to adjust this value
for their uploads to work.

File upload errors and limitations
File uploads may fail for a number of reasons and it is important that you are aware of some of these scenarios so you
will not be clueless when your customers report a problem with their checkout experience.

One of the messages that can appear when a customer experiences a failed upload with an overly large file is shown
in the following screen shot.
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Notice that the product is still added to the shopping cart despite the appearance of the warning message. This is one
way Zen Cart tries to help store owners retain their customers and discourage the affected customers from leaving for
a competing site immediately.

The other error message that may appear occurs when the upload directory does not have the required permissions
settings to allow uploaded files to be placed in it. This error message is shown in the following screen shot.

Besides the errors messages that you have just seen, you may also want to take note of a number of limitations when
working with the file upload functionality in Zen Cart. This will help you decide whether you need to have custom
code developed for your online store in order to meet your business needs.

Currently, if a customer uploads a file successfully when adding it to the cart but does not complete the purchase, the
uploaded file will remain on the remote server indefinitely until you manually remove it. You may want to devise a
schedule to periodically clean up the stray files when you no longer need them.

Another point worth mentioning is that there is currently no way to assign different file type restrictions for each
separate file upload attribute. For example, restricting one attribute to allow only ".png" and ".jpg" files to be uploaded
while another attribute only accepts ".pdf" and ".zip" files.

Summary
As you have seen, configuring downloadable products and upload attributes require a lot more steps due to the extra
security considerations that are in place. Therefore, take your time when setting them up and work with your web host
if you are unsure about certain security measures your web host has configured.
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Chapter 16:

Additional product manipulation
techniques

Introduction
This chapter will show you the additional features that are available when working with certain or all products in
your store. This features enhance your product offerings further and you should take advantage of them to make your
products more compelling to your customers.

In this chapter, we shall:

▪ Specify multiple images for a single product.
▪ Add product samples to music products.

Providing multiple images for a product
There are two scenarios where you might want to provide multiple images for a product:

▪ To showcase a single product using different images, each of which is auto-scaled by Zen Cart.
▪ To use your custom-sized images instead of using Zen Cart’s image auto-scaling feature to cater to a single

product image or multiple product images.

Providing auto-scaled images for a product
There are probably various occasions when you want to display multiple images for a product. For example, a zoom-in
of a specific product detail like the neck-line of a dress or to provide several views (plan, elevation, etc) of a machine.
Refer to the following screen shot to get an idea of how different images for a single product can be displayed.
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Before you add any additional images to your product, you need to understand how Zen Cart recognizes and handles
additional images for a product.

Understanding how additional images are recognized

Zen Cart uses a base name to distinguish the main picture of a product from other additional pictures of the same
product. For example, the main picture of a laptop will usually be the front view. The side and back views might make
up the other pictures for the laptop. In this case, the image names could be named as follows:

▪ laptop.jpg

▪ laptop_backview.jpg

▪ laptop_sideview.jpg

Because the names of a product’s additional images are sorted alphanumerically before their corresponding images
are displayed, you may want to append a number or a letter behind the names of additional product images in order
to display them in your desired sequence. For example, you could modify the preceding additional images to use the
following naming conventions instead.

▪ laptop.jpg

▪ laptop_01.jpg

▪ laptop_02.jpg

In each of the preceding cases, the images are auto-scaled to the required size by Zen Cart. Do note that, typical-
ly, an underscore is used to represent additional product images linked to a base name. You could easily have used
laptopa.jpg, laptop123.jpg, laptoplaptop.jpg, etc. However, the latter naming schemes are difficult to com-
prehend and can lead to a maintenance nightmare if you have many products using images with similar names.

For simplicity’s sake, we shall assume that all additional product images referred to in this book use the underscore
as the separator to distinguish them from the base name of the product’s main picture. Thus, from the list of sample
laptop pictures listed above, the base picture is the one without an underscore (i.e. laptop.jpg). The base picture
is usually uploaded when you create a new product in the Admin Console. For the other pictures, they will need to
be manually uploaded to the server via FTP.

Before we go further, take note of a potential problem that can occur if you are not careful in naming your additional
product images. Consider the following scenario where you have set up two laptops in your store catalog.

Product X: Custom Desktop Computer

Base picture: desktop.jpg
Other picture: desktop_side.jpg
Other picture: desktop_01.jpg

Product Y: NorthStar Desktop Computer

Base picture : desktop_northstar.jpg
Other picture: desktop_northstar_back.jpg
Other picture: desktop_northstar_01.jpg

If customers view Product Y, they will see it normally, with a base image and two additional images for the other
views. If customers view Product X, there will be a problem because all six images are displayed! The problem is due
to the fact that all six images have a base name of desktop. After this example, you should be conscious to avoid
having different images with the same name.
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Make sure that all the images have the same file extensions. If not, your additional images will
not be displayed.

Adding additional images to a product

Make sure you go through the discussion on how additional images are added to a product in the preceding section
before going through the following procedures.

Before you can show additional images for your products, you need to enable this feature for your particular product
type:

1. Click on Catalog > Product Types to access the Product Types screen.

2. Choose the product type for which you want to have multiple images displayed and click on the edit layout button
on the side-panel.

3. Make sure that the Show Product Additional Images field is enabled.

To add an additional image to a product:

1. Make sure your additional image contains an underscore (i.e. "_") after the base name of the main product image
you have already uploaded. For example, if a product’s main image is aaa.jpg, then the base name is simply
aaa. A possible name for the product’s additional image might be aaa_side.jpg or aaa_01.jpg.

Recall that the underscore is the naming convention we are using for this book to identify the additional images
of a product.

2. Upload the additional image via FTP to the same directory where the base product image is located on the server.

To change the layout for the additional product images of a product:

1. Click on Configuration > Images to access the Images screen.

2. Specify the required value in the Product Info - Number of Additional Images per Row field

Providing pre-scaled images for a product
The previous section discussed how multiple images can be added to a product and how each of those images are
auto-scaled by Zen Cart. In this section, we shall learn how you can use pre-scaled images with your products. Before
we proceed, make sure you have gone through the section “Understanding how additional images are recognized” as
we will be making use of some of the concepts discussed there.

Understanding how pre-scaled images are recognized

There are essentially three possible image sizes (small, medium and large) for product images in Zen Cart. As you
probably know by now, Zen Cart automatically scales your images to the correct size if you only supply one image
per product.

Auto-scaling of images can result in images with less than optimum file sizes and thus consume precious bandwidth.
To alleviate this problem, you can use your own pre-sized images to bypass the auto-scaling process to minimize
wasted download capacity and improve page loading times for your customers. With pre-sized images, you also exert
greater control over the exact resolution and size of the images that you want your customers to see.

Let us take a look at where you can see images of the three different sizes in your Store Front. This will give you a
better idea of what you need to supply to Zen Cart for each image size. The following list shows the various Store
Front pages where different image sizes can be seen:
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▪ Product Listings and Shopping Cart page - small versions of your product images or rather the scaled down
versions of your product images if they are quite large.

▪ Product Info - medium sized images are displayed by default.

▪ Product Info - large sized images are displayed in pop-up windows when customers click on the hyperlinked
medium sized images.

Whatever the case, if you want Zen Cart to show your images with the relevant image sizes, you need to provide
additional information to Zen Cart. Zen Cart recognizes the large and medium images by their suffixes of _LRG or
_MED respectively.

The default suffixes can be changed in Configuration > Images by editing the following fields:

▪ Product Info - Image Medium Suffix
▪ Product Info - Image Large Suffix

In addition to the above file naming conventions, you need to put your custom images into the respective directories for
the size desired. These directories should already be on your server and are located immediately underneath the [zc-
home]/images directory with the names of large and medium respectively as shown in the following screen shot.

Now, if you only have one image for your product, you can provide your custom pre-scaled medium and large images
as shown in the following screen shot.

However, if you want to provide custom medium and large size images for your base and additional images, you could
name your images either way as shown in the following screen shot.

Notice that only one medium-sized image for a product (i.e. laptop_MED.jpg) is required regardless of how many
additional images are used to represent a product. This is because the Product Info page is the only page in your Zen
Cart store that uses a medium-sized image. The name of the medium-sized image must also be derived from the base
name of the product’s main image instead of the names of any additional images.

If your base product image resides under a sub-directory of [zc-home]/images, then your medium and large image
directories should be under similarly named sub-directories of the [zc-home]/images/medium and [zc-home]/
images/large directories respectively. The following screen shot shows an example of this arrangement.
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Adding pre-scaled images to a product

Make sure you go through the discussion on how pre-scaled images are added to a product in the preceding section
before going through the following procedures.

To specify medium and large images for your base and additional product images:

1. Click on Configuration > Images to access the Images screen.

2. Check the value of the suffixes for the following fields:

▪ Product Info - Image Medium Suffix

▪ Product Info - Image Large Suffix

3. Make sure your pre-scaled images have the same suffixes as that shown in the previous step.

4. Upload your pre-scaled images to their respective directories on your remote server. For example, [zc-home]/
images/large and [zc-home]/images/medium.

Providing media samples for Product-Music
products
For products belonging to the Product-Music product type, Zen Cart allows you to specify music samples for free
download to users. For example, if your store sells music CDs, you can provide sample music clips for each song
in the CD.

The following example screen shot of a music CD with sample song clips allows you to visualize how sample clips
can appear with a product. The comments on the screen shot will be obvious when you learn to configure product
samples later in this section.
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Music product samples are implemented using the concepts of media type and media manager. A media type specifies
the file type that a product sample belongs to. For example, media types of music clips can be in mp3 or wma file
formats while media types of song lyrics can be in txt or pdf file formats. A media manager contains several files of
possibly different media types that are assigned to a particular product. For example, you can create a media collection
of song clips and lyrics and assign the media collection to a music CD in your online store.

The general steps to configuring product samples can be summarized as follows:

1. Configure media type for product sample.
2. Create a media collection to hold product samples.
3. Assign the media collection to a music product.

Step 1 of 3: Configure media type for product sample
To define the media types for your product samples:

1. Click on Extras > Media Types to access the Media Types screen.

2. Click on insert to begin creating a media type for your product sample.

3. Specify a name whose meaning will be obvious to your customers in the Media Type Name field. This field is
displayed to your visitors telling them the file format of the sample.
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4. Specify a file extension in the Media Type Extension field which corresponds to the product sample file you will
be uploading later. Examples include wma, pdf, mp4 etc.

5. Click on save to create the media type in your database.

Check that the media type you want to offer is allowed in the list of permitted file types in
[zc-home]/media/.htaccess in order for the media file to be accessible by your customers
from the Store Front. For more information on working with the .htaccess file, refer to the
section “The .htaccess files”.

Step 2 of 3: Create a media collection to hold product
samples

To create a media collection of product samples:

1. Click on Extras > Media Manager to access the Media Manager screen.

2. Click on insert to begin creating a new media collection.

3. Type a suitable name into the Media Collection Name field and click save to save this media collection into the
database. Your Media Manager screen will be refreshed.

4. Select the media collection you just created and click on edit to begin specifying the different files that you wish
to associate with the media collection.
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5. If you wish to change the name of the media collection you just created, edit the Media Collection Name field
and click save.

6. For each file that you wish to associate with this media collection, click the Browse button next to the Add Media
Clip field and select a file from your local computer’s hard drive. This file should end with a file extension which
you have defined in the Extras > Media Types screen.

7. Choose a directory from the Upload to Media Directory drop-down list box to indicate where you want your
uploaded file to be placed on the server. The default value of Main Directory points to the [zc-home]/media
directory on the server.

Avoid uploading files with special characters (quotes, exclamation marks, etc) or spaces in their file names to
avoid download problems for your customers. These problems can arise due to how different web browsers work.

8. Choose the appropriate file extension from the Media Clip Type field for the product sample file you intend to
upload. The file extension for the file you upload must match a file extension defined in the Media Types screen. If
both file extensions do not match, Zen Cart will just ignore the product sample you uploaded and thus not display
the product sample in the media collection of the product.

9. Click Add to upload and associate the sample file to your media collection.

10. Repeat from Step 4 to add another product sample to the media collection.

Step 3 of 3: Assign the media collection to a music prod-
uct

To assign the media collection you have created to a music product:

1. Click on Extras > Media Manager to access the Media Manager screen.

2. Choose the required media collection and click on assign to product to begin assigning the media collection to
your desired music products.
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3. Choose the product category from the top drop-down list box and the product from the bottom drop-down list box
for the product that should be assigned the media collection.

4. Click Add to assign the required media collection to the product.

5. Repeat from Step 3 to add the same media collection to another product.

Summary
This chapter showed you how easy it is to add multiple images and sample clips to your product offerings. You should
seek to utilize these techniques to enhance your product offerings so as to entice your customers into making more
purchases.
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Chapter 17:

Order totals, surcharges and discounts

Introduction
An array of pricing mechanisms exist in Zen Cart to help store owners meet their business objectives. Discounts allow
excess stock to be cleared or to increase revenue by enticing customers to buy in greater volume. On the other hand,
surcharges allow businesses to control their costs by charging customers more for extra services. Finally, order totals
allow a store owner to specify how the final price of an order should be derived during the checkout process.

As you go through this chapter, take note of the difference between product pricing and order pricing. Product pricing
only affects products; e.g. discounts. Order pricing affects the total amount of the order which includes the prices of
the products; taxes, surcharges, discounts, etc.

In this chapter, we shall:

▪ Configure how customer order prices are calculated via the Order Totals modules.

▪ Add surcharges to customer orders.

▪ Implement different discounts schemes.

Understanding order totals
The final price charged to customers is known as the order total in Zen Cart. This amount appears in the final step of
the checkout process as shown in the following sample screen shot.

Notice from the preceding sample screen shot that a series of calculations are performed before the final order total
($225.00) is displayed to a customer. Zen Cart gives you the flexibility to configure the sequence in which these
calculations are performed and also some of the logic within each step of a calculation.

The Order Total Modules screen
The Order Total Modules screen allows you to configure how different modules work together to affect an order total.
To access the Order Total Modules screen, click on Modules > Order Total.
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There are two important things to note about this screen:

▪ Each module under the Modules column is used to apply a particular business logic to a calculation. For example,
the Tax module is used to determine whether a customer is liable for tax; and then to apply that tax to the order
if the customer is liable for tax.

▪ Each value under Sort Order column is used to determine the sequence in which the corresponding module is
applied to a calculation. The smallest number being the one which is applied first. If nothing appears under the Sort
Order column, it means the module has been disabled and will not have an effect on an order’s pricing.

The value which appears under the Sort Order column is especially important and can have unexpected results on an
order total’s amount. Look at the following two examples which show the difference in order total amounts just by
switching the sequence in which the Shipping and Tax modules are applied in their calculations.

Example 17.1: Sort Order: Sub-Total, Shipping, Tax, Total = 1, 2, 3, 4

Product A                          = $ 5.00
Product B                          = $15.00
Sub-Total                          = $( 5 + 15)     = $20.00
Add Shipping (@ Flat Rate of $10)  = $(20 + 10)     = $30.00
Add Tax      (@ 5%)                = (5% x 30) + 30 = $31.50

Total                              = $31.50

Example 17.2: Sort Order: Sub-Total, Shipping, Tax, Total = 1, 3, 2, 4

Product A                          = $ 5.00
Product B                          = $15.00
Sub-Total                          = $( 5 + 15)      = $20.00
Add Tax      (@ 5%)                = (5% x 20) + 20  = $21.00
Add Shipping (@ Flat Rate of $10 ) = $(21 + 10)      = $31.00

Total                               = $31.00

One important point to remember when testing your order total settings is to use multiple items in your shopping cart.
This method aids in your understanding of different order total modules by allowing you to scrutinize their calculations
more closely.
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Automatic email alerts
Whenever an order total module is installed, updated or removed, an email will automatically be sent to the email
address as specified in the E-Mail Address (Displayed to Contact you) field of the E-Mail Options screen.

The contents of the email will include which particular order total module was affected, which admin user made the
change and what kind of change (i.e. installed, updated or removed) was made.

The email alerts provide a good security safeguard against malicious or unintended changes to your order total module
settings and there is currently no option in the Admin Console to turn off the sending of such email alerts.

Core modules
Although any order total module can be uninstalled, you should leave some of the core modules as always installed.
If you uninstall these core modules, order total calculations may not make sense and the orders might not even be
processed by Zen Cart after payment is made!

Modules which are optional (Gift Certificates, Discount Coupons, etc) will be discussed in their respective sections
later in the book.

Because taxes have a nasty way of affecting how the prices in your order totals will work out,
enable the Sales Tax Display Status field under Configuration > My Store.

This will force the display of sales tax information in your order totals even if no sales tax is
applicable for a customer.

Before we go on, let us arrange all the modules in their default order assuming they were all enabled. This gives you
a better idea of how these modules act together to impact the prices of your order total.

Table 17.1: Default sort order of each order total module

Order Modules Core Modules

100 Sub-Total Yes

200 Shipping Yes

280 Discount Coupon No

290 Group Discount No

300 Tax Yes

400 Low Order Fee No

840 Gift Certificates No

950 COD Fee No

999 Total Yes

Explanations of the core modules are as follows:
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Sub-Total
Calculates the total prices of all items in a customer’s shopping cart.

Shipping
Applies a shipping charge to a customer’s order based on the shipping module that the customer has selected when
performing the checkout process.

Tax
Adds up all the taxes that apply to the items in a customer’s shopping cart. Whether a product is liable for tax
depends on your tax configuration and also whether you have specified a tax class when creating that product.

Total
Displays the total amount of the order. If you disable this module, customer orders will not be processed by Zen
Cart.

For a discussion on the rest of the non-core order total modules, refer to the following list.

▪ “Discount coupons” on page 337.
▪ “Customer group discounts” on page 228.
▪ “Cash on Delivery (COD) fee” on page 231.
▪ “Gift certificates” on page 347.
▪ “Low order fee” on page 230.

Giving discounts
Discounts are a widely-used technique employed by retail businesses to increase sales or to clear unwanted stock.
When a product has a discount applied to it, the discounted price of the product will be shown in red while the original
price will be crossed out in the Store Front.

To change the way your discounts are displayed in the Store Front, click on Configuration > Product Info and edit
the following fields:

▪ Product Info - Show Sales Discount Savings Status
▪ Product Info - Show Sales Discount Savings Dollars or Percentage
▪ Product Info - Show Sales Discount Savings Percentage Decimals

Choosing a discount type
Before we discuss how to configure the various discount techniques, take a look at the following table to help you
decide which discount type you want to apply for your store.

Table 17.2: Comparison of different discount types

Discount Type Entitlement Comments

Product Specials Single product Applies a percentage or fixed price discount to a product. Op-
tionally, an expiry date can be specified.
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Discount Type Entitlement Comments

Take note of the Apply Discounts Used by Product Spe-
cial/Sale attribute flag when working with this discount type.

Product Quantity Discounts Single product Applies a price discount based on the quantity of a product
bought.

Product Sale Multiple prod-
ucts

Applies product price discounts to the entire store or to specif-
ic categories of products.

Take note of the Apply Discounts Used by Product Spe-
cial/Sale attribute flag when working with this discount type.

Attribute Quantity Discounts Per product at-
tribute

Discount on attribute price based on quantity of a product
bought.

Refer to the section “By quantity” for more details.

Customer Group Discounts Multiple cus-
tomers

Entitles selected customers to an order total discount.

Discount Coupons Single/multiple
customers and
single/multiple
products

Discount coupons can be applied both to an order total or a se-
lection of products.

Refer to the section “Discount coupons” for further details on
how discount coupons work.

The important thing to note is that Group Discount calculations are applied to order totals instead of products. On the
other hand, Discount Coupon calculations can be applied to both order totals and certain selected products depending
on how the order total module is configured. Make sure you are very clear on the difference between order total
discounts and product price discounts before choosing a discount type you want to configure.

Order total discounts apply to the charges (i.e. sub-total, taxes, shipping, etc) that a customer incurs during the checkout
process. Product price discounts apply only to product prices that are configured during the product creation process.

Remember to take into account the Apply Discounts Used by Product Special/Sale attribute
flag if any of your products are set up to use product attributes.

Product specials

Specials allow you to specify a product discount either by percentage or by an exact price. You also have the option
of specifying an expiry date for the discount. When a product is on Special, Zen Cart will increase the exposure of the
product via the various layout components in the Store Front as shown in the following screen shots.
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To put a product on Special:

1. Click on Catalog > Specials to access the Specials screen.

2. Click on new product to bring up the Specials details screen.
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3. Choose the product you want to place on Special from the Product field.

4. Enter a percentage (e.g. 10%) to discount from the product or an absolute number for the new price of the product
(e.g. 10.00) for the Special Price field.

5. Optionally, choose a date for the Available Date field by clicking on the dark icon next to the field to bring up a
pop-up calendar. If no value is specified in the field, the discount takes effect immediately after creation. If a future
date is specified, the product will automatically appear as a Special in the Store Front when the future date arrives.

6. Optionally, choose a value for the Expiry Date field by clicking on the dark icon next to the field to bring up a
pop-up calendar. The discount will run indefinitely unless a value is specified for the Expiry Date field.

7. Click insert to place the product on Special.

To view statistics for products that are on Special, click on Admin Home on the navigation menu to reach your home
page. Look at the Specials Expired and Specials Active fields under the Statistics table as shown in the following
screen shot.

Product quantity discounts

Quantity discounts allow store owners to give discounts for bulk purchases of a product. A product that has a quantity
discount attached to it will be displayed with a discount table in the Product Info page of the Store Front as shown
in the following screen shot.

To customize how the discount table is displayed, click on Configuration > Layout Settings and edit the Product
Discount Quantities - Display how many per row field accordingly.

To create a quantity discount for a product:

1. Click on Catalog > Products Price Manager to access the Products Price Manager screen. There is a lot of
information contained in the screen. To help you understand and manipulate the settings on the screen more
confidently, we shall only show the relevant portions of the screen as we go through the configuration steps.

2. Choose a product to which you want to apply a quantity discount by referring to the following portion of the screen.
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a. From the drop-down list box between the previous and next buttons, choose a category that contains your
desired product.

b. After your screen refreshes, select your desired product from the list box beside the display button.

c. Click display and the details of your desired product will be displayed in the following portion of your screen.

3. To apply a quantity discount to the product you have chosen:

a. Click on any of the two edit buttons on the Products Price Manager screen. After your screen is refreshed,
concentrate on the following portion of the screen.

b. Click on add blank discounts and you should see a discount table as shown in the following screen shot.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 17. Order totals, surcharges and discounts 225

To change the default number of blank discounts displayed whenever the add blank discounts button is
clicked, click on Configuration > Layout Settings and edit the Product Discount Quantities - Add how
many blank discounts? field.

c. If your product has attributes defined, select how you want your quantity discount to be applied via the
Discount Qty Applies to Mixed Attributes field. If you choose Yes, product attributes will be ignored and
only the number of products bought will be used to trigger a quantity discount. If you choose No, all product
attributes must match (e.g. T-shirt with color attribute "Blue" and size attribute "Large") before the total
number of the products will be used to trigger a discount.

d. Do not click the add blank discounts button again unless you wish to create an additional 5 blank discounts.

e. Select how you want your discount to be applied for the product by choosing a value from the Discount Type
drop-down list box. Explanations for the various possible values are as follows:

▪ Percentage - Applies a percentage discount based on the product price.

▪ Actual Price - Specifies a new price as the discount amount.

▪ Amount Off - Subtracts an amount from the product price to arrive at the discounted price.

f. Select the price basis from which your new product price should be derived from the Discounted Price from
field. Choose Price if you want the discount to be applied to the product price. Choose Special if you want
the discount to be applied to an already discounted price of a product on Special.

g. Enter the quantity of products bought that will qualify for a bulk discount together with the corresponding
discount rates into the respective Minimum Qty and Discount Value fields.

4. Click on update once you are satisfied with your settings. Your screen will refresh and Zen Cart will display the
automatically calculated discounted prices in a table as shown in the following screen shot.

To delete the quantity discounts you have created, you need to edit the product again; but this
time, you need to specify all the fields in the Discount Table as 0 and then click update.

Product sale

Zen Cart uses the concept of a "sale" to apply discounts to an entire store catalog or to certain product categories.
Unlike products on Special and products with quantity discounts, Zen Cart does not display the discounted products
with other visual cues other than showing the discounted price in red.

To create a discount for the entire store catalog or to specific product categories:

1. Click on Catalog > Sale Maker to access the Sale Maker screen.
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2. Click on new sale to access the Sale Maker Details screen.

3. Before you configure anything, click on the Click here for Salemaker Usage Tips hyperlink near the top of the
screen. A pop-up window (as shown in the following screen shot) appears with instructions on how to configure
Salemaker properly.
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4. Enter the name you want to assign to this sale in the SaleName field.

5. Enter a positive number into the Deduction field.

6. Select how you want your new discounted price to be derived from the Type field.

7. If you want discounts to be applied only to products within a certain price range, enter your desired values in the
Products Pricerange and To fields.

8. If your product is already on Special, you can decide how your new sale price will be affected by choosing a value
from the If a product is a Special field.

9. If you want the sale to take place immediately, leave the Start Date field empty. If your sale should be automatically
activated on a future date, choose a suitable date from the dark icon next to the Start Date field.

10. If you do not want your sale to expire, leave the End Date field empty. If your sale should automatically expire
on a future date, choose a suitable date from the dark icon next to the End Date field.

11. Choose whether you want your discount to be applied to the entire catalog or to selected categories by checking
the relevant check-boxes. If you check both the Entire catalog field and any other categories, the sale will still
be applied to the entire catalog!

12. Click on insert to create your new sale.

13. After your screen is refreshed, your new sale will be displayed. Note that your sale will only be active if the button
in the Status column is green.

To view statistics for products that are on Sale, click on Admin Home on the navigation menu to reach your home page.
Look at the Sales Expired and Sales Active fields under the Statistics table as shown in the following screen shot.
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Customer group discounts
Sometimes, you may want to offer discounts only to a selected group of customers. For example, if you have a group
of loyal customers who are your main purchasers, you can opt to give them a group discount to recognize their loyalty
and to encourage them to continue doing business with you.

Customer group discounts are only applicable to order totals in Zen Cart. They cannot be restricted to apply only
to certain products in your store. Furthermore, customers will not see any discounted prices based on their discount
groups while shopping. Group discounts are only shown during the checkout process.

The following screen shot shows the details of a shopping cart with a 10% Group Discount applied.

Before you can can create customer group discounts, you need to enable and configure the necessary order total module.

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Group Discount module. Install it if required. The following side-panel will appear.

3. Enter a suitable value for the Sort Order field. Refer to the section “The Order Total Modules screen” if you
have forgotten the purpose of this field.

4. Specify true for the Include Shipping field if you want shipping charges to be covered by a customer group
discount.

5. Specify true for the Include Tax field if you want taxes to be covered by a customer group discount.

6. Choose a suitable value for the Re-calculate Tax field. Usually, you should leave this as none. If you choose
Standard or Credit Note, you will need to play around with different test orders to see whether they suit
your needs.

7. If you have chosen Credit Note for the Re-calculate Tax field, you should choose a suitable option from the
Tax Class drop-down list box.

8. Click update to finish configuration of your Group Discount order total module.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 17. Order totals, surcharges and discounts 229

You should play around with the Sort Order field for all the order total modules if you encounter erroneous or
illogical calculations. If that does not help, your last resort is to refer to the PHP code contained in the [zc-home]/
includes/modules/order_total/ot_group_pricing.php file.

We shall now look at how we can create group discounts for your customers. There are two main steps to creating
discounts for customers:

▪ Create a discount group specifying the discount value.
▪ Specify which customers belong to a specific discount group.

To create a discount group:

1. Click on Customers > Group Pricing to access the Group Pricing screen.

2. Click on insert and concentrate on the side-panel.

3. Enter a name for the group discount you want to create in the Group Name field.

4. Enter a positive value into the Percentage Discount field.

5. Click save to create the discount group.

To attach a discount group to a customer:

1. Click on Customers > Customers to access the Customers screen.

2. Choose a customer to whom you want to assign a discount group and click edit.

3. Select the discount pricing you want to apply to the customer from the Discount Pricing Group drop-down list
box as shown in the following screen shot.

4. Click update to assign the customer to the Discount Group. You will be redirected back to the Customers screen.

Notice that the name of the discount group assigned to a customer is shown under the Pricing Group table header
as shown in the following example screen shot.
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Adding surcharges
Surcharges allow you to add an additional fee to the order total prices. Zen Cart allows you to impose surcharges for
orders that are below a certain amount or when customers choose the Cash-On-Delivery payment method.

Low order fee
A Low Order Fee allows you to charge customers an extra amount of money for orders that are below a certain threshold
amount. This feature is helpful for stores that sell products with very narrow profit margins.

If you intend to set up a low order fee for your store, try to display a message clearly in your Store Front informing
customers about this policy. As the low order fee will only be shown in the final step of the checkout process, customers
might feel your business is out to cheat them and discontinue visiting your store.

To add a surcharge for orders falling below a certain threshold amount:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Low Order Fee module. Install it if required.
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3. Make sure the Allow Low Order Fee field is set to true.

4. All fields are self-explanatory so we shall not go through them here.

5. Click on update to save your changes to the database.

Cash on Delivery (COD) fee

The Cash On Delivery (COD) payment method is not encouraged for online business. This is because there is a higher
risk that you might not get the payment you want. Customers can always regret their purchases and refuse to pay when
you show up at the door or deny the transaction ever took place.

Therefore, to discourage customers from choosing this option and to provide yourself some insurance, you can impose
a charge on customer orders if they choose to pay via the COD payment method in the Billing Information page during
checkout. Note that the wording in red (i.e. COD Fees may apply) will only appear if the COD fees order total module
has been enabled.

COD Fees that are applicable will only be shown in the final step of the checkout process as shown in the screen
show below.

To impose surcharges for customers who choose to pay via the COD payment method:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the COD Fee module and concentrate on the side-panel.
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3. Make sure the Display COD field is set to true.

4. As you can see, you can specify different COD fees for different shipping modules. As all the fields are self-
explanatory, we shall not discuss them further.

5. Click on update to save your changes to the database.

Summary
In this chapter, you have learned to manipulate your product prices and order prices by using the different discounts
and surcharges available in Zen Cart. You have also taken a look at how your order totals can impact the final order
price that is charged to customers.
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Part IV

Customizing your store

Unlike the previous sections which teach you how to configure the business logic in your store, this section deals
mainly with how to customize the look-and-feel of your store. You will learn the different layout elements that make
up a Zen Cart store, how to make your store support multiple languages, etc.

This section covers the following topics:

▪ Chapter 18, “Customizing common page elements”

▪ Chapter 19, “Altering the shopping flow”

▪ Chapter 20, “Working with Store Front templates”
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Chapter 18:

Customizing common page elements

Introduction
Most of the customizations in this chapter are related to the visual elements of your Store Front and can be performed
from within your Admin Console alone. Thus, it is suitable for everyone, regardless of whether you are well-versed
in different web technologies like HTML, CSS, Javascript, PHP, etc.

In this chapter, we shall:

▪ Understand the different layout components.
▪ Run through all the configurations for individual layout components.
▪ Learn to create your own custom web pages.
▪ Understand all the different fields in the Images screen.

Knowing the common layout containers

Figure 18.1: Structural Layout Containers

From the preceding screen shot, you can see that a typical screen in your Store Front is actually broken up into five major
display blocks. Each major display block acts as a container for other layout elements (content boxes, center-boxes,
template text, etc). These child layout elements each hold a specific piece of information. This modular design of
layout elements allows you to quickly and easily manage the display of information by turning on/off or editing certain
settings within the Admin Console.
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To allow you to quickly look up a display element’s configuration setting, we shall group all display elements based
on the display container they belong to.

Header

From the preceding screen shot, you can see that the Header can be divided into four main areas:

Navigation Bar
Provides links for users to perform functions like log in, check out, manage account etc.

Header Main Bar
Usually the place to locate your company logo and put across your sales message.

EZ-Pages Header Bar
For placing links to EZ-Pages. EZ-Pages are custom web pages you create for specific purposes; company press
releases, news articles, etc. We will touch on them in the later part of this chapter.

Categories-Tabs Menu
For placing your top-level category entries.

The Header can be turned off from the Admin Console using the following methods:

▪ Click on Configuration > EZ-Pages Settings and edit the EZ-Pages Pages to disable headers field. Refer to the
section “EZ-Pages” for more information on the use of EZ-Pages.

▪ Click on Configuration > Website Maintenance and edit the Down for Maintenance: Hide Header field. Refer
to the section “Website maintenance” for more information on how to set your site to be temporarily offline.

To turn off the Search box on the Navigation Bar, click on Tools > Layout Boxes Controller and edit the sidebox-
es/search_header.php field. Make sure you set both the Left/Right Column Status and Single Column Status fields
to OFF.

To turn off the Categories-Tabs Menu, click on Configuration > Layout Settings and set the Categories-Tabs Menu
ON/OFF field to 0.

To turn off the EZ-Pages Header Bar, click on Configuration > EZ-Pages Settings and set the EZ-Pages Display
Status - HeaderBar field to 0. Edit the EZ-Pages Header Link Separator if you want to change the separator
between appearing between hyperlinks of the EZ-Pages.

Footer
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The Footer contains the following elements:

Top half
Contains the Home hyperlink and possibly some hyperlinks to the EZ-Pages you have created.

Bottom half
Contains the IP address of a site visitor accessing your store and the copyright message from Zen Cart.

The Footer can be turned off from the Admin Console using the following methods:

▪ Click on Configuration > EZ-Pages Settings and edit the EZ-Pages Pages to disable footers field. Refer to the
section “EZ-Pages” for more information on the use of EZ-Pages.

▪ Click on Configuration > Website Maintenance and edit the Down for Maintenance: Hide Footer field. Refer
to the section “Website maintenance” for more information on how to set your site to be temporarily offline.

To turn off the display of EZ-Pages hyperlinks, click on Configuration > EZ-Pages Settings and set the EZ-Pages
Display Status - FooterBar field to 0. Edit the EZ-Pages Footer Link Separator if you want to change the separator
between appearing between hyperlinks of the EZ-Pages.

To turn off the display of IP address of your site visitor, click on Configuration > Layout Settings and set the Footer
- Show IP Address status field to 0.

To change the copyright text, override the [zc-home]/includes/languages/english.php file and edit the fol-
lowing code:

define('FOOTER_TEXT_BODY', 'Copyright &copy; ' . date('Y') . ' <a href="' .
 zen_href_link(FILENAME_DEFAULT) . '" target="_blank">' . STORE_NAME . '</a>.
 Powered by <a href="http://www.zen-cart.com" target="_blank">Zen Cart</a>');

The following logging information is not part of the footer but appears just below it.

To turn on/off the display of the logging information, click on Configuration > Logging and
edit the Display The Page Parse Time field.

Center column
The center column contains the most important information in a page and there are many ways in which its contents
can appear as we shall soon see.

Breadcrumbs

Breadcrumbs are navigational links that provide customers with a visual cue as to their current location in your store.
They are located on the top-left corner of the center column.

To alter the appearance of the breadcrumb:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.
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2. Edit the the following fields accordingly:
▪ Define Breadcrumb Status
▪ Bread Crumbs Navigation Separator

While editing the Bread Crumbs Navigation Separator, you might encounter the character sequence " ". This char-
acter sequence represents a white space in HTML. It is required because HTML interprets any number of normal white
spaces which you type as a single white space.

For example, if you type "Thank     You" with five white spaces in between the words in an HTML document, you
will only see "Thank You" with only one white space between the words in your browser. To force the five spaces to
appear in a web browser, you need to type as follows: "Thank&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;You".

Multi-product layout elements
How products are displayed plays an important role in the buying decisions of customers. Therefore, we need to
look closely at the different product layout elements that can appear in your Store Front. To help you with your CSS
customizations (which you will learn in a later chapter), the product layout elements we are about to discuss will be
grouped according to their appearance.

Before we begin, take note that most of the product layout elements we will discuss require that some of your products
meet certain conditions (Featured Product, Specials, etc) before you will see them in your Store Front:

▪ Featured Products will be discussed in the section “Featured Products”.
▪ Product Specials were discussed in the section “Product specials”.
▪ New Products will be shown depending on the elapsed time since they were added to your catalog. You can

configure the elapsed time setting by editing the New Product Listing - Limited to field under Configuration
> Maximum Values.

▪ Upcoming Products are products that have their Date Available fields in their respective Product Details screen
set to a future date.

New, All and Featured product listings

On clicking one of the following hyperlinks in the Categories side-box, you will be redirected to product listings similar
to the following screen shots.

▪ New Products
▪ Featured Products
▪ All Products

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 18. Customizing common page elements 238

To limit the number of products appearing in any of the preceding product listings:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the relevant field for your desired product listing:
▪ New Products Listing - Number Per Page

▪ Maximum Display of Featured Products Page

▪ Maximum Display of Products All Page

To configure the appearance of individual product listings, you can take the following actions.

▪ For New Products listing, click on Configuration > New Listing.

▪ For Featured Products listing, click on Configuration > Featured Listing.

▪ For All Products listing, click on Configuration > All Listing.

We have chosen to discuss these three product listings together because their configuration fields are the same although
they are located in different screens in the Admin Console. The meanings of the fields are mostly self- explanatory
but their syntax can be quite confusing. To help you understand the syntax better, we shall use the Display Product
Name field under All Listing screen as an example.

From the preceding screen shot, the default value for Display Product Name has 4 digits and is shown as 2101. The
explanation for the individual digits will be explained next.

The first digit specifies the location of the product name as shown in the following illustrations. Notice that the product
name will only be displayed if you specified either "1" or "2" as the value for the first digit.

The second and third digits are taken together to represent the order in which different pieces of information are
displayed next to each other. Let us take a look at the second and third digits of Display Product Price (middle 2
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digits = "40") and Display Product Name (middle 2 digits = "10") and see what happens if we swap the values as
shown in the following illustrations.

The fourth digit indicates how much "clearance" or white space will separate one displayed field from another displayed
field. Look at the following illustrations to better appreciate the visual impact of this setting.

If you have turned off the display of images for a product listing, you might find that images with
the words "NO PICTURE AVAILABLE" are still displayed for products with no associated
pictures. To solve this problem, click on Configuration > Images and set the Product Image
- No Image Status field to 0.

Search, Product Type and Category product listings

A Search product listing appears when a customer performs a search in any of the search boxes in your store. A
Product Type listing appears when a customer clicks on a link in either the Manufacturers, Music Genres or Record
Companies side-box.

A Category product listing appears under the following conditions:

▪ When a category or sub-category with several products is chosen from either the Categories or Documents side-
box.

▪ When a customer is on a Product Info page and clicks on the listing button which is between the previous and
next buttons.

Examples of Search, Product Type and Category product listings are shown in the following screen shots respectively.
Note that a drop-down list box for manufacturers will only appear for a specific Category product listing if there are
two or more manufacturers associated with the entire list of products in that category.
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The main difference between the Category product listing and the other two product listings is the presence of the
category information in the Category product listing which is missing from the other two product listings.

Nevertheless, the configuration for the appearance of these three product listings (other than the above difference) are
done via the same screen in the Admin Console. Therefore, we have chosen to group them together in our discussion.

To change the display of the Search, Product Type and Category product listings simultaneously:

1. Click on Configuration > Product Listing to access the Product Listing screen.

2. Click on a field you would like to change and follow the instruction in the corresponding side-panel to make
your changes.

3. If you have edited any property, click on update to save your changes.

To change the number of items to display in the Category product listing:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Products Listing - Number Per Page field and click update to save your changes.

Center-boxes

Product center-boxes have the ability to appear across several places in your Store Front as shown in the following
screen shots.
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The screen shots on the left are product center-boxes that appear in the Home page of your Store. The middle screen
shot shows a product center-box appearing in a category with child categories defined while the one on the right shows
a product center-box appearing under a Product Listing. There is also an Also Purchased product center-box but we
will discuss that in a later chapter.

Note that there is another center-box which contains upcoming products to your store. We will cover that center-box
in the section “Upcoming products summary-list” because it looks totally different from the center-boxes you see in
the preceding screen shots.

The following table summarizes some general characteristics of product center-boxes.

Table 18.1: Characteristics of different product center-boxes

Location in Store Front Type of Center-Box Products Displayed

Home page (also known as Index
page or Main page)

New Products, Featured Products,
Specials

All eligible products in the store can be dis-
played here.

Category page with sub-cate-
gories

New Products, Featured Products,
Specials

Only eligible products from sub-categories
will be displayed.

Product Listing page New Products, Featured Products,
Specials

All eligible products within the parent cate-
gory.

Product Info page Also Purchased Products Will be discussed in the section “Also Pur-
chased Products”.

With the exception of the Product Info page, we shall now discuss how we can configure the different product cen-
ter-boxes in your store.

To turn on/off or specify the sort order of a particular product center-box in your Home page:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Note down the value of the Categories - Always Show on Main Page field. This field is primarily used to
control whether category images should be displayed in your main page or not. However, its value can affect the
configuration of product center-boxes in your Home page as well.
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3. Click on Configuration > Index Listing to access the Index Listing screen.

4. If the value you obtained in Step 2 is 1, then edit the following fields accordingly.
▪ Show New Products on Main Page - Category with SubCategories

▪ Show Featured Products on Main Page - Category with SubCategories

▪ Show Special Products on Main Page - Category with SubCategories

5. If the value you obtained in Step 2 is 0, then edit the following fields accordingly.
▪ Show New Products on Main Page

▪ Show Featured Products on Main Page

▪ Show Special Products on Main Page

To turn on/off or specify the sort order of a particular product center-box in your Category with sub-categories page:

1. Click on Configuration > Index Listing to access the Index Listing screen.

2. Edit the respective field for your desired product center-box:
▪ Show New Products on Main Page - Category with SubCategories

▪ Show Featured Products on Main Page - Category with SubCategories

▪ Show Special Products on Main Page - Category with SubCategories

To turn on/off or specify the sort order of a particular product center-box in a Product Listing page:

1. Click on Configuration > Index Listing to access the Index Listing screen.

2. Edit the respective field for your desired product center-box:
▪ Show New Products - below Product Listing

▪ Show Featured Products - below Product Listing

▪ Show Special Products - below Product Listing

To simultaneously control the number of products appearing in each product center-box for all pages:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Specify the number of products you wish to display for a particular product center-box by editing the relevant
fields.
▪ New Products Module

▪ Maximum Display of Featured Products - Main Page

▪ Maximum Display of Specials Products - Main Page
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Note: The Maximum Display of Featured Products Page field applies to Product Listings and not product cen-
ter-boxes.

To control the number of columns appearing in each product center-box for all pages:

1. Click on Configuration > Index Listing to access the Index Listing screen.

2. Edit the respective field for your desired product center-box:
▪ New Products Columns per Row
▪ Featured Products Columns per Row
▪ Special Products Columns per Row

Note: The Special Products Columns per Row setting also affects the Product Specials Grid, which we shall talk
about in the next section.

Specials grid

Besides appearing in product center-boxes, products on Special can also appear in a grid layout as shown in the
preceding screen shot. We shall refer to this layout as the Product Specials Grid. The Product Specials Grid only
appears when a customer clicks on the Specials hyperlink in the Categories side-box.

To control the number of products appearing in the Product Specials Grid:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Products on Special field.

Note: Do not confuse this setting with the one in the Specials product center-box.

To change the number of columns for the Product Specials Grid:

1. Click on Configuration > Index Listing to access the Index Listing screen.

2. Specify a value for the Special Products Columns per Row field.

Note: The Special Products Columns per Row setting also affects the Specials product center-box.

Upcoming products summary-list

Whenever the Date Available field in a Product Details screen is set to the future, the affected product will be displayed
in the Upcoming Products summary-list in Zen Cart.
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To control which field to sort by and the sorting order of the products in the summary-list:

1. Click on Configuration > My Store to access the My Store screen.

2. Edit the Expected Sort Field field to control whether you want to sort the products in the summary-list by product
name or expected date.

3. Edit the Expected Sort Order field to control whether you want the product name or expected date to be sorted
in ascending or descending order.

Although the appearance of the Upcoming Products summary-list is different from that of the product center-boxes,
its other configuration settings are similar to those of the product center-boxes. Therefore, refer to the section “Cen-
ter-boxes” for details on how to configure other display aspects of your Upcoming Products summary-list.

Custom pages
Besides the standard web pages you see in the Store Front, you can also create entirely new custom web pages to
suit your particular needs. For example, if you want to display your company financial statements in a separate part
of your store or add a page to explain to customers how your company ensures product quality by going through a
rigorous manufacturing process.

There are essentially two methods you can use to create your custom web pages.

▪ Define Pages
▪ EZ-Pages

The Define Pages feature is good for creating a few simple web pages which do not necessarily have any relationships
among them. They are located at specific locations in your online store. The EZ-Pages feature is better suited for situ-
ations which require a greater number of custom web pages. Furthermore, EZ-Pages allow you to define relationships
between pages and gives you greater control over how and where you want to place them in your store.

Define Pages

A Define Page refers to the template text on a screen which store owners can customize to fit their needs. A Define
Page can either be an entire page by itself (e.g. Privacy Notice) or appear as part of a page (e.g. the text appearing
in the Checkout Success page).

Most Define Pages can be accessed via hyperlinks in the Information and More Information side-boxes as shown in
the following screen shots.

They are also found in various parts of your standard store pages where you can leave instructions for your customers
to follow. For example, in the Page Not Found page and Checkout Success page as shown in the following screen shots.
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To turn on or off a Define Page:

1. Click on Configuration > Define Page Status to access the Define Page Status screen.

Notice that other than the "Define Page-Not-Found Status", "Define Checkout Success" and "Define Main Page
Status" Define Pages, the rest of the Define Pages are mapped to the hyperlinks in the Information and More
Information side-boxes in your Store Front.

2. Edit any field and you will see a side-panel similar to the preceding screen shot. Choose your desired choice out
of the four possible combinations of Link and Define Text options.

The meaning of the Link and Define Text options are as follows:
▪ The display of a hyperlink in the relevant side-box is controlled by setting Link to either ON or OFF.

▪ The display of template text in a Define Page is controlled by setting Define Text to either ON or OFF.

3. Click update if you have made changes to a field.

The "Define Page-Not-Found Status" Define Page is displayed as part of a Site Map page when
a customer accesses a page in your store that does not exist. It is the only one in the Define Page
Status screen that has Define Text options but no Link options in the side-panel.

There are two ways in which Define Pages can be changed. One way is via the use of the Admin Console and the other
way involves the use of the Template Override technique which we shall present in a later chapter.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 18. Customizing common page elements 246

To change the template text displayed in a Define Page via the Admin Console:

1. Click on Tools > Define Pages Editor to access the Define Pages Editor screen.

2. Select the Define Page you wish to change from the ENGLISH drop-down list box and choose an appropriate
value for the TEXT EDITOR field as shown in the following screen shot.

Take note of the path that leads to the Define Page that is being edited. If you have multiple Zen Cart templates, it
will automatically choose the Define Page from the currently active template (e.g. "magic") for editing. It is never
a good idea to edit a Define Page that belongs to the "classic" template as we will learn in a later chapter.

3. Make your desired changes to the template text in the text-area. If you are unable to make any changes to the
template text, make sure the template file has its permissions set to writeable. For more information on file per-
missions, refer to the section “Changing file and directory permissions”.

4. Click on save to save all your changes.

The preferred way to change the template text displayed in a Define Page is via the Overrides System and the technique
is presented in the section “The Template Override System”.

For your quick reference, the list of Define Page files that can be overridden with your custom text is shown in the
following screen shot.
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For readers who are familiar with HTML, note that you must not include the enclosing <head>
and <body> tags in a Define Page. This is because all contents of a Define Page are automati-
cally rendered between the <body> tags.

EZ-Pages

EZ-Pages allows you to create additional pages or hyperlinks from within the Admin Console alone. There is no need
to manually create or edit any files. Instead, the contents of all EZ-Pages you author are stored in the database.

Additional pages can either be standalone or grouped together to form a hierarchical structure that can be presented
as a table of contents. Hyperlinks can point to either internal content (e.g. Privacy Page) or external sites (e.g. Yahoo
Finance). The following screen shot gives you an idea of how EZ-Pages can be structured in your store and how
hyperlinks to them can appear in the header, footer, and Important Links side-box.

To create an EZ-Page:

1. Click on Tools > EZ-Pages to access the EZ-Pages screen.

The default number of EZ-Pages you see listed on your screen can be changed by clicking on Configuration >
Maximum Values and editing the Maximum Display EZ-Pages field in the Maximum Values screen.
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Do not overlook the Display Order drop-down list box as it allows you to quickly preview how hyperlinks to
your EZ-Pages will be arranged in different areas of your Store Front according to their sort orders.

2. Click on new file to access the EZ-Pages Details screen.

3. Enter the name of your EZ-Page into the Page Title field. The value you enter will also be used as the name of
the hyperlink that customers will see in your Store Front.

4. Set the Open New Window field to Yes if you want a new web browser window to open when customers click
on the EZ-Page hyperlink to view its contents. If you are linking to another page in your Store Front, you will
likely want to set this field to No.

5. Set the Page is SSL field to Yes if you want the EZ-Page to be displayed over a secure connection (i.e. your web
browser address area will display a "https" instead of a "http"). This would be useful for cases where your EZ-
Page contains sensitive information and you want customers to view the contents securely. For example, if you
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are creating an EZ-Page as a hyperlink to the My Accounts page of your customers in the Store Front. This setting
does not apply to pages which are hyperlinks to external sites.

6. For the Header section, enable the Yes radio button and enter a positive number into the corresponding Order
field if you want a hyperlink to the EZ-Page to be created in your Store Front’s header. Set the radio button to No
if you do not want the hyperlink to appear in the header.

7. For the Sidebox section, enable the Yes radio button and enter a positive number into the corresponding Order
field if you want a hyperlink to the EZ-Page to be created in your Store Front’s Important Links side-box. Set the
radio button to No if you do not want the hyperlink to appear in the side-box.

8. For the Footer section, enable the Yes radio button and enter a positive number into the corresponding Order
field if you want a hyperlink to the EZ-Page to be created in your Store Front’s footer. Set the radio button to No
if you do not want the hyperlink to appear in the footer.

9. Enter a number in the Chapter field if your EZ-Page is to be linked together with other EZ-Pages. This number
should be the same among all other EZ-Pages that belong to the same group. For EZ-Pages that are grouped
together, a Table of Contents and corresponding navigational links can be automatically generated by Zen Cart
in the Store Front.

10. For the TOC section, enable the Yes radio button and enter a positive number into the corresponding Order field
if you want a hyperlink to the EZ-Page to be created in the Table of Contents.

11. To specify the contents of an EZ-Page, you can only choose either one of these three fields:

▪ HTML Content - Type something into this field if you are specifying your own content to display to your
customers. For example, if you are writing your own press release.

▪ Internal Link URL - Type the portion of the URL that links to a page that currently exists in your online
store. For example, if you would like the Privacy Notice page to be displayed when users click on this EZ-Page
hyperlink in your Store Front then enter index.php?main_page=privacy.

▪ External Link URL - Type the URL of an external hyperlink which a customer will be redirected to once
they click this EZ-Page hyperlink. For example, if you want to link to Yahoo’s Finance page, enter http://
finance.yahoo.com.

12. Click on insert to save your changes and you will be redirected back to the EZ-Pages screen. A unique number
will automatically be generated by Zen Cart as an identifier for your newly created EZ-Page.

Because many store owners tend to make the same mistake repeatedly, it is important to stress
that hyperlinks to EZ-Pages will only appear in the Store Front if they meet the following con-
ditions:

▪ A non-zero number is entered into the Order field of the corresponding display area (e.g.
side-box)

▪ The EZ-Page must be enabled (i.e. "green" button shown) in the corresponding column of
the EZ-Pages screen.

After you have created your EZ-Pages, you can specify where and how they should appear in your Store Front as
follows:

1. Click on Configuration > EZ-Pages Settings to access the EZ-Pages Settings screen.
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2. Many of the settings are self-explanatory as they control how hyperlinks to EZ-Pages should be displayed in either
the side-box, header, or footer in your Store Front. However, the following two fields deserve more attention.

▪ The EZ-Pages Prev/Next Buttons field controls how buttons within EZ-Pages that have linked content are
displayed.

▪ The EZ-Pages Table of Contents for Chapters Status field controls whether the Table of Contents will be
displayed.

3. After you edit a field, click on update to save your changes.

As you can see, EZ-Pages offer a very powerful and flexible solution for store owners to easily create their custom
content. The only drawback with EZ-Pages is the lack of support for content rendered in multiple languages unless
a language pack supports this feature. This drawback will be clearer to you when you learn how to add additional
language support to your Zen Cart store.

Standard store pages
Standard store pages refer to Store Front pages that come with a default Zen Cart store. They appear as customers go
around the various areas in your Store Front.

The Index/Home, Product Info and Shopping Cart pages play an integral part in a customer’s shopping experience.
This is because most customers will encounter them even if they choose not to sign up with your store or make a
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purchase. As such, we will talk about them here as store owners usually want to customize these pages to increase
their chances of making a sale.

The Index/Home/Main page

The page where a customer first interacts with your store is known as the Home, Index, or Main page in Zen Cart. The
various areas available for customization is shown in the preceding screen shot and we shall be making use of these
areas to explain the different customization options available to you.

To change the text appearing in the Custom Text area, override the following code in the [zc-home]/in-
cludes/languages/english/index.php file. Note that the file contains two sentences with the same code be-
cause your main page will appear differently depending on whether you choose to display only top category products
or have it display a sub-category.

define('HEADING_TITLE', 'Congratulations! You have successfully installed your Zen
 Cart&trade; E-Commerce Solution.');

There are two ways to go about altering the appearance of the Welcome Guest Greeting area.

To toggle the display of the greeting message:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Edit the Customer Greeting - Show on Index Page field.
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To change the wording of the greeting message, override the following code in the [zc-home]/includes/lan-
guages/english/index.php file. Notice that the wording of the message is programmed to change according to
whether the store is currently in Showcase mode or Store mode or whether a customer is logged in or not. If you have
forgotten how to set a store to Showcase mode, refer to the section “Store-wide catalog restriction”.

// Showcase vs Store
if (STORE_STATUS == '0') {
  define('TEXT_GREETING_GUEST', 'Welcome <span class="greetUser">Guest!</span>
 Would you like to <a href="%s">log yourself in</a>?');
} else {
  define('TEXT_GREETING_GUEST', 'Welcome, please enjoy our online showcase.');
}

define('TEXT_GREETING_PERSONAL', 'Hello <span class="greetUser">%s</span>! Would
 you like to see our <a href="%s">newest additions</a>?');

To change the text appearing in the Define Page area, override the [zc-home]/includes/languages/en-
glish/html_includes/define_main_page.php file.

The look of the Category Images Display area can be configured as follows:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. To toggle the display of the area, edit the Categories - Always Show on Main Page field.

3. To control whether only top-level categories or a particular sub-category should be displayed, edit the Main Page
- Opens with Category field.

To control the display of the center-boxes in the Home page, refer to the section “Center-boxes”.
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The Product Info page

This is the most important page in your entire store because it contains detailed product information which customers
usually base their purchasing decisions on.

To alter the display of certain fields (Shipping Weight, Units in Stock, etc) in the Product Info page that are common
to products belonging to the same product type:

1. Click on Catalog > Product Types to access the Product Types screen.

2. Select the Product Type that the product belongs to and click edit layout to access a list of product details for the
Product Type. The following screen shot shows the fields in a Product Info page that can be turned on or off for
products belonging to the Product-General product type.

3. Choose a field you wish to change and click edit to bring up the relevant side-panel.

4. After making your changes, click update to save your changes. Note that this change affects all products belonging
to the same product type.

Toggling the display of a field in the Product Types screen will also affect the display of that
field in product listings for products of that particular product type.
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To alter other visual aspects of the Product Info page:

1. Click on Configuration > Product Info to access the Product Info screen.

2. Fields that begin with the words "Previous Next" affect the following area in the Product Info page.

3. Fields that begin with the words "Product Info - Show Sales Discount Savings Status" affect the following area
in the Product Info page.

4. The following fields affect the display of attributes on the Product Info page.
▪ Products Info - Products Option Name Sort Order
▪ Products Info - Product Option Value of Attributes Sort Order
▪ Product Info - Show Option Values Name Below Attributes Image

5. The following fields control whether an image or text should be displayed when a product is configured as either
free or call for price in the Product Details screen. Note that besides the Product Info page, the display of products
in the various product listings will also be affected.
▪ Product Info - Price is Free Image or Text Status
▪ Product Info - Price is Call for Price Image or Text Status

6. The Product Quantity Box Status - Adding New Products field is used to set the default radio button for the
Products Quantity Box Shows field in the Product Details screen of your Admin Console. It does not alter the
display of the Product Info page in your Store Front.

7. For more information related to the Product Reviews Require Approval field, refer to the section “Product
reviews”.

8. The following fields affect the display of meta tags within the Product Info page. For more information related
to these fields, refer to the section “Meta tags”.
▪ Meta Tags - Include Product Model in Title
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▪ Meta Tags - Include Product Price in Title
▪ Meta Tags Generated Description Maximum Length

9. For more information related to the Also Purchased Products Columns per Row field, refer to the section “Also
Purchased Products”.

The Shopping Cart page

The Shopping Cart page displays all the items that a customer intends to purchase. Prices are added to allow customers
to decide whether they should proceed to check out or whether they should alter their shopping list to meet their budget
constraints.

To change the custom text appearing just below the "Your Shopping Cart Contents" page title, override the [zc-
home]/includes/languages/english/shopping_cart.php file and modify the following code.

define('TEXT_INFORMATION', 'You may want to add some instructions for using the
 shopping cart here. (defined in includes/languages/english/shopping_cart.php)');

To customize how the item count, weight and amount at the top of the table are displayed:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Edit the Shopping Cart - Show Totals field.

To change the display of the "estimate shipping" button:

1. Click on Configuration > Shipping/Packaging to access the Shipping/Packaging screen.

2. Edit the Shipping Estimator Display Settings for Shopping Cart field. To see the effects of changing this
setting, refer to Figure 10.1: “Shipping estimates displayed on Shopping Cart page”.

To change the display of other parts of the page:

1. Click on Configuration > Stock to access the Stock screen.

2. To customize the display of the "update" and "delete" buttons. Edit the following fields accordingly:
▪ Show Shopping Cart - Delete Checkboxes or Delete Button
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▪ Show Shopping Cart - Update Cart Button Location

3. To toggle the display of center-boxes in the Shopping Cart page when the shopping cart is empty, edit the following
fields accordingly.
▪ Show New Products on empty Shopping Cart Page
▪ Show Featured Products on empty Shopping Cart Page
▪ Show Special Products on empty Shopping Cart Page
▪ Show Upcoming Products on empty Shopping Cart Page

Side columns
The left and right columns that appear next to the main content area of a Store Front page act purely as containers
for side-boxes.

To change the display properties of the left and right columns:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. To turn on or off the relevant columns, edit the following fields:
▪ Column Left Status - Global
▪ Column Right Status - Global

3. To alter the width of the relevant columns, edit the following fields:
▪ Column Width - Left
▪ Column Width - Right

The side columns can also be turned off from the Admin Console using the following methods:

▪ Click on Configuration > EZ-Pages Settings and edit the following fields accordingly. Refer to the section “EZ-
Pages” for more information on the use of EZ-Pages.
▸ EZ-Pages Pages to disable left-column
▸ EZ-Pages Pages to disable right-column

▪ Click on Configuration > Website Maintenance and edit the following fields accordingly. Refer to the sec-
tion “Website maintenance” for more information on how to set your site to be temporarily offline.
▸ Down for Maintenance: Hide Column Left
▸ Down for Maintenance: Hide Column Right

Side-boxes
Side-boxes are rectangular blocks that appear on the left and right columns of your Store Front. Each side-box provides
a specific functionality. For example, the Categories side-box functions as an online catalog for visitors to browse your
products. The Currencies side-box allows your site visitors to view your products in a currency of their choice.

To change the width of all side-boxes:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. To specify the width of the side-boxes appearing in each column, edit the following fields accordingly:
▪ Column Width - Left Boxes
▪ Column Width - Right Boxes
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To change the display properties (excluding width) of individual side-boxes:

1. Click on Tools > Layout Boxes Controller to access the Column Boxes screen. The text "Classic" in the screen
refers to the name of the currently active template. We shall talk more about templates in Chapter 20, “Working
with Store Front templates”.

Notice that the list of side-boxes in the screen is split into two halves. The top half represents side-boxes that
are located on the left column of your Store Front whereas the bottom half represents side-boxes that are located
on the right column.

2. To edit the display properties of any side-box, click on its adjacent green "e" icon and concentrate on the corre-
sponding side-panel.

3. To turn on or off the display of a side-box, edit the Left/Right Column Status field.

4. The Single Column Status field is ignored by Zen Cart except for the Search Header side-box which we shall
talk about in the section “Search Header”.

5. To place a side-box either on the right or left column, edit the Location: (Single Column ignores this setting)
field.

6. To specify the order in which side-boxes should appear next to each other in a column, edit the Left/Right Column
Sort Order field.

7. Note that the Single Column Sort Order field is currently ignored by Zen Cart. Do not waste time setting any
values for it.

Make sure you are familiar with how to manipulate side-boxes in the Column Boxes screen because we will be dis-
cussing each side-box in detail from the next section onwards. We will also assume that you have enabled a side-box
everytime you want to configure its display.
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Banner Box, Banner Box 2, Banner Box All

These side-boxes are used to display banners you have configured in your store. For more information on setting up
banners and making them display in the relevant side-boxes, refer to the section “Banners”.

Documents

This side-box displays a list of categories which are separate from the Categories side-box.

Categories that appear in this side-box must have a Document-General product type restriction. Other product type
restrictions may apply to the categories but they do not force the appearance of the Documents side-box unlike the
Document-General product type.

The following screen shot of the bottom part of a Category Details screen shows the product type restrictions that
apply to an example category. Notice the Document-General product type restriction is the reason why this category
will appear in the Documents side-box.

To toggle the display of the category count (i.e. the number of products contained in a category and all its sub-cate-
gories):

1. Click on Configuration > My Store to accecss the My Store screen.

2. Edit the Show Category Counts field.
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The look of this side-box can be configured as follows:

1. Click on Configuration > Layout Settings to acccess the Layout Settings screen.

2. If the Show Category Counts field in the My Store screen is set to true, then you control whether you want
categories with zero products to show the zero category count by editing the Categories with 0 Products Status
field.

3. To change the default "->" separator between the category name and category count, edit the Categories Sepa-
rator between the Category Name and Count field.

4. To control the opening and closing brackets surrounding the category count, edit the following fields accordingly.
▪ Categories Count Prefix
▪ Categories Count Suffix

Categories

This side-box displays all the product categories in your store unless you have set a Document-General product type
restriction on a category. In that case, this side-box will not display any categories with the said product type restriction
as they will be shown in the Documents side-box instead.

A horizontal line separates the top-half containing your product categories from the bottom-half which contains hy-
perlinks to different product listings in your store.
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Before we configure the look of this side-box, take note that the previous methods of configuring the look of the
Documents side-box applies to this side-box as well.

The look of this side-box can be configured as follows:

1. Click on Configuration > Layout Settings to acccess the Layout Settings screen.

2. To toggle the display of the horizontal line that separates the top-half from the bottom half, edit the Categories
Separator between links Status field.

3. To toggle the display of the "Specials" hyperlink, edit the Categories Box - Show Specials Link field.

4. To toggle the display of the "New Products" hyperlink, edit the Categories Box - Show Products New Link field.

5. To toggle the display of the "Featured Products" hyperlink, edit the Categories Box - Show Featured Products
Link field.

6. To toggle the display of the "All Products" hyperlink, edit the Categories Box - Show Products All Link field.
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7. To change the display of the separator between parent and child categories, edit the Categories Separator be-
tween the Category Name and Sub Categories field.

8. To control the distance between the top category and child category, edit the Categories SubCategories Indent
field.

9. To control how the hierarchy of categories should be displayed depending on which category level a customer
has navigated to in your Store Front, edit the Categories - Always Open to Show SubCategories field.

Best Sellers

This side-box displays a random list of best sellers in your store.

This side-box will not appear if a logged-in customer is on the Product Info page and has his Global Product Notifi-
cations option unchecked in the Product Notifications page of his account.
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Note that if a customer is currently viewing a list of products in a specific category, then the list of best sellers is
taken from that specific category. Hence, if no product purchases were made from that specific category, then this
side-box will also not appear.

To control how the product names will be displayed in the side-box:

1. Click on Configuration > Layout Settings to acccess the Layout Settings screen.

2. To limit the number of characters used to display product names, edit the Bestsellers - Truncate Product Names
field.

3. To specify how you want the text that was truncated to be displayed, edit the Bestsellers - Truncate Product
Names followed by field.

To specify the maximum number of best sellers to display:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Best Sellers For Box field.

To control the number of items of a product to have been bought before being considered as a best seller.

1. Click on Configuration > Minimum Values to acccess the Minimum Values screen.

2. Edit the Minimum number of best sellers to display field.
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Featured

This side-box displays a random list of featured products in your store.

To specify the maximum number of featured products to display:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Random Featured Products for SideBox field.

For more information on putting products on Featured, refer to the section “Featured Products”.

Specials

This side-box displays a random list of products which are on Special in your store. It will not be displayed if the
customer happens to be on the Product Info page.

To specify the maximum number of Specials products to display:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Random Products On Special For Box field.
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For more information on putting products on Special, refer to the section “Product specials”.

New Products

This side-box displays a random list of products which are deemed as new in your store.

The look of this side-box can be configured as follows:

1. Click on Configuration > Maximum Values to acccess the Maximum Values screen.

2. To specify how new products are determined, edit the New Product Listing - Limited to field.

3. To specify the maximum number of new products to be displayed, edit the Random New Products for SideBox
field.
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Important Links

This side-box displays hyperlinks to EZ-Pages which are active and have positive sort orders.

To control when this side-box will appear:

1. Click on Configuration > EZ-Pages Settings to access the EZ-Pages Settings screen.

2. Edit the EZ-Pages Display Status - Sidebox field.

For more information on working with EZ-Pages, refer to the section “EZ-Pages”.

Information

This side-box displays a list of hyperlinks to Define Pages, gift certificate FAQ, discount coupons lookup, and newslet-
ter unsubscribe pages.

To control whether the first five hyperlinks to Define Pages will be displayed:

1. Click on Configuration > Define Page Status to access the Define Page Status screen.

2. Set the relevant field to either 0 or 1 accordingly.
▪ Define Shipping & Returns
▪ Define Privacy Status
▪ Define Conditions of Use
▪ Define Contact Us Status
▪ Define Site Map Status

For more information on working with Define Pages, refer to the section “Define Pages”.

The "Gift Certificate FAQ" hyperlink will only be displayed if you have enabled the Gift Certificates module in
the Order Total Modules screen. For more information on working with gift certificates, refer to the section “Gift
certificates”.
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The "Discount Coupons" hyperlink will only be displayed if you have enabled the Discount Coupon module in the
Order Total Modules screen and set the Define Discount Coupon field to either 0 or 1 in the Define Page Status
screen. For more information on working with discount coupons, refer to the section “Discount coupons”.

The "Newsletter Unsubscribe" hyperlink will only be displayed if you have set the enabled the Newsletter Unsub-
scribe field in the E-Mail Options screen which you can access by clicking on Configuration > E-Mail Options.

More information

This side-box displays hyperlinks to the Define Pages you have created.

To control which Define Page hyperlinks should be displayed:

1. Click on Configuration > Define Page Status to access the Define Page Status screen.

2. Set the relevant field to 0 or 1 for the hyperlink to appear.
▪ Define Page 2
▪ Define Page 3
▪ Define Page 4

For more information on working with Define Pages, refer to the section “Define Pages”.

Languages

This side-box allows a customer to choose the language in which the current contents of the store should be viewed
in. It will not appear if customers are in any of the checkout pages because it may distract customers from completing
their purchases.

To control the number of flags that should appear in each row:

1. Click on Configuration > Maximum Values to acccess the Maximum Values screen.

2. Edit the Maximum Display of Language Flags in Language Side Box field.

For more information on how additional languages are set up, refer to the section “Supporting multiple languages”.

Currencies
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This side-box allows a customer to select the currency which will be used to display prices in your store. It will not
appear if the customer is in any of the checkout pages.

For more information on how currencies are set up and how it can affect the display of this side-box’s content, refer
to the section “Configuring the displayed default currency”.

Manufacturers

This side-box displays the manufacturers defined in your store. It was discussed when we talked about Product-General
and Product-Free Shipping products in an earlier chapter.

The look of this side-box can be configured as follows:

1. Click on Configuration > Maximum Values to acccess the Maximum Values screen.

2. To change the display style or number of rows to display in the drop-down list box, edit the Manufacturers List
- Scroll Box Size/Style field.

3. To control the maximum length of characters used to represent the manufacturers, edit the Length of Manufac-
turers Name field.

4. To display a manufacturer only when at least one active product is linked to it, edit the Manufacturers List -
Verify Product Exist field.
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Manufacturer Info

This side-box displays additional information related to a manufacturer. It will only be displayed when a customer is
on the Product Info page. It was discussed when we talked about Product-General and Product-Free Shipping products
in an earlier chapter.

There is currently no Admin Console setting for this side-box.

Music Genres

This side-box displays the music genres defined in your store. It will only appear if you have created at least one music
genre. It was discussed when we talked about Product-Music products in an earlier chapter.

The look of this side-box can be configured as follows:

1. Click on Configuration > Maximum Values to acccess the Maximum Values screen.

2. To change the display style or number of rows to display in the drop-down list box, edit the Music Genre List
- Scroll Box Size/Style field.

3. To control the maximum length of characters used to represent the genres, edit the Length of Music Genre Name
field.

Record Companies
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This side-box displays the record companies defined in your store. It will only appear if you have created at least one
record company. It was discussed when we talked about Product-Music products in an earlier chapter.

The look of this side-box can be configured as follows:

1. Click on Configuration > Maximum Values to acccess the Maximum Values screen.

2. To change the display style or number of rows to display in the drop-down list box, edit the Record Company
List - Scroll Box Size/Style field.

3. To control the maximum length of characters used to represent the record companies, edit the Length of Record
Company Name field.

Notifications

This side-box allows a customer to choose whether to subscribe to or unsubscribe from email notifications related to
a product. A customer’s product notification preferences can be edited by clicking on "My Account > View or change
my product notification list" in the Store Front. The relevant choices in the Product Notifications page are shown in
the following screen shot.

Note that this side-box will only appear if the customer happens to be on the Product Info page and has not enabled
the checkbox in the "Global Product Notifications" area on the Product Notifications page.
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The option to subscribe is represented by a green "tick" image and is displayed under the following conditions:

▪ If a customer is not logged in.
▪ If a customer is logged in and has not subscribed to the particular product’s notification.

The option to unsubscribe is represented by a red "stop" image and is displayed when a customer is logged in and has
already subscribed for notifications for the product.

For more information on the workings of email notifications in general, refer to the section “Newsletters”.

Shopping Cart

This side-box displays the current items in a customer’s shopping cart. If a customer currently has a balance in his
Gift Certificate account, then that balance will also be shown.

To control when this side-box will appear:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Edit the Shopping Cart Box Status field.

Quick re-order

This side-box displays a list of previously purchased items by the customer. It will only appear if the customer is
logged-in and has previously made a purchase in your store.

To specify the maximum number of previously ordered items to be displayed:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Recent Purchases Box- NOTE: box is disabled field.
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Reviews

This side-box is used to display a random list of reviews or allow customers to write a review for a product.

The contents of the Reviews side-box will change according to the following conditions:

1. The words "There are currently no product reviews" will appear if there are no reviews written for any of the
products in your store.

2. A random set of reviews will be shown under the following conditions:
▪ A customer is not on a Product Info page and at least one product in the store already has a review written for it.

▪ A customer is on a Product Info page of a product with at least one review already written for it.

3. The words "Write a review on this product" will appear if a customer is on a Product Info page of a product
without any reviews written for it.

To specify the maximum number of random reviews to be displayed:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Random Product Reviews for SideBox field.

Note that reviews need to be enabled and approved in order to be available for display in the Reviews side-box. For
more information on the workings of product reviews, refer to the section “Product reviews”.

Search

This side-box allows a customer to search your store for products by matching the customer-supplied keyword against
the product name, product model, manufacturer name, product meta tag keywords and product meta tags description.

One aspect of the search algorithm you can change is to edit the Default Search Operator field in the My Store screen
which you can access by clicking Configuration > My Store.
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A thorough discussion of the search algorithm is not discussed in this book due to its complexity. Interested readers
who are comfortable dealing with SQL and PHP can go through the algorithm by consulting the code in the [zc-
home]/includes/modules/pages/advanced_search_result/header.php file.

Search Header

The Search Header refers to two different search boxes that are configured via the sideboxes/search_header.php
field under the Box File Name column of the Layout Settings screen. Both search boxes perform the same functionality
as the Search side-box shown in the preceding section.

The first search box appears in the top navigation menu of your Store Front as shown in the following screen shot.
We shall refer to this search box as a top-box in this book.

The second search box appears as a side-box in one of the side columns. However, its appearance is markedly different
from other side-boxes. This is evident from the following screen shot which shows a Search Header side-box placed
above a Search side-box.

To control the presence of the Search Header side-box and Search Header top-box, refer to the following table when
configuring the relevant fields in the side-panel of the Layout Settings screen.

Table 18.2: Search Header top-box and side-box display settings

Side-Box Top-Box Left/Right Column Status
field

Single Column Status
field

Not displayed Not displayed Off Off

Displayed Displayed On Off

Not displayed Displayed Off On

Displayed Displayed On On

From the preceding table, you may notice that as long as either the Left/Right Column Status or Single Column
Status field is set to On, then the Search Header top-box will be displayed.
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Who’s Online

This side-box shows the number of logged in customers and anonymous users on your site.

For more information on the workings of the Who’s Online feature, refer to the section “Viewing who’s online infor-
mation”.

Images
Although images are scattered throughout your store, you can manage their dimensions and other aspects centrally
within the Images screen by clicking on Configuration > Images.

Explanations for the various settings in the Images screen are covered in the following table.

Table 18.3: Image settings

Field(s) Comments

Small Image Width, Small Image Height Sets the designated dimensions for images that appear in the follow-
ing Store Front locations:

▪ product images that appear in all side-boxes.
▪ product images in the "Specials" listing page.
▪ product additional images that appear in the Product In-

fo page. We have already covered these settings in the
section “Providing multiple images for a product”.
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Field(s) Comments

▪ product images that appear in the Customers who bought this
product also purchased center box.

Some parts of the Admin Console (mainly the preview screens for
Product Detail, Reviews, Specials, and Featured) will also use this
dimension.

Heading Image Width - Admin, Heading
Image Height - Admin

Currently only used for spacing the screen title against the Admin
Console navigation menu and a screen’s main contents. Has nothing
to do with any image dimension.

Image - Shopping Cart Status, Image -
Shopping Cart Width, Image - Shopping
Cart Height

Sets the display status and designated product image dimensions in
the Shopping Cart page.

Subcategory Image Width, Subcategory
Image Height

Sets the designated dimension of all category icon images if Cate-
gories - Always Show on Main Page is 1 and Main Page - Opens
with Category is 0.

Also sets the designated dimension of category icon images repre-
senting child categories if a page were to display a top category and
all its child categories.

Top Subcategory Image Width, Top Sub-
category Image Height

Sets the designated dimension of icon images representing a parent
category if a page were to display a top category and all its child cat-
egories.

Category Icon Image Width - Product In-
fo Pages, Category Icon Image Height -
Product Info Pages

Sets the designated dimension of category icon images in Category
listing pages that show only products or in Product Info pages.

Product Info - Image Width, Product Info
- Image Height

Sets the designated dimension of the product image in the Product
Info page.

Product Info - Image Medium Suffix,
Product Info - Image Large Suffix and
Product Info - Number of Additional Im-
ages per Row

Controls how additional product images are handled. We have al-
ready covered these settings in the section “Providing multiple im-
ages for a product”.

Image - New Products Width, Image -
New Products Height

Sets the designated dimensions for product images in the "New
Products" center-box but not for "New Products" listing page.

Image - Product New Listing Width, Im-
age - Product New Listing Height

Sets the designated dimensions for product images in the "New
Products" listing page but not for "New Products" center-box.

Image - Featured Products Width, Image -
Featured Products Height

Sets the designated dimensions for product images in both the "Fea-
tured Products" center-box and listing page.
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Field(s) Comments

Image - Product All Listing Width, Image
- Product All Listing Height

Sets the designated dimensions for product images in the "All List-
ings" listing page. Note that there is no "All Listings" center-box in
Zen Cart.

Image - Product Listing Width, Image -
Product Listing Height

Sets the designated dimensions for product images in page listings
that are a result of a customer search or filter (e.g. when a customer
clicks one of the hyperlinks in the Manufacturer, Record Companies,
or Music Genres side-boxes).

Image - Use Proportional Images on Prod-
ucts and Categories

If you have specified an image in the Product Detail or Category De-
tail pages of a product or category in the Admin Console, and the
image is not missing from where it is supposed to be located (e.g.
[zc-home]/images/), then you can use this field to control how
the original image should be scaled with respect to its designated im-
age dimension. Recommeded value is true.

Image Required If you have specified an image in the Product Detail or Category De-
tail pages of a product or category in the Admin Console, and the
image is missing from where it is supposed to be located (e.g. [zc-
home]/images/), then you can use this field to decide how you
want the missing image area to be displayed.

If set to true, some text (e.g. the product name) will be displayed in
place of the missing image. If set to false, nothing will appear in
place of the missing image. Recommended value for debugging pur-
poses is thus true.

Product Image - No Image Status If you have not specified an image in the Product Detail or Category
Detail page of a product or category in the Admin Console, you can
use this field to control whether you want a default image to be dis-
played or not.

Product Image - No Image picture If Product Image - No Image Status is true, the default image
used will be the one specified in this field.

Summary
We have seen the many settings in Zen Cart which allows you to easily manipulate the look of your store. You should
always look to see if a setting exists to change the look of your store before editing any files as we shall learn when
we look at Zen Cart templates in a later chapter.
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Chapter 19:

Altering the shopping flow

Introduction
The standard shopping flow that comes with Zen Cart can usually be altered via settings in the Admin Console.
However, the uses for those settings may be multi-fold and not immediately obvious when the shopping flow is taken
into consideration. Therefore, we have chosen to present some common scenarios here for your reference.

In this chapter, we shall:

▪ Enable the display of shipping and privacy information to adhere to local regulations.
▪ Control the ability of customers to check out based on your stock settings.
▪ Delay the display of the shopping cart when customers add products to their online shopping cart.
▪ See how messages can be displayed when customers re-visit your store when they had a previous non-empty

shopping cart.
▪ Utilize split Login/Sign-Up screens.
▪ Skip single-product categories for a smoother shopping experience.

Complying with local regulations
In certain countries, customers need to explicitly agree to privacy statements before they sign up for an account with
your online store. In other instances, it is also a legal requirement that customers be shown the shipping regulations
before they are directed to buy any product from you.

Both the above scenarios are not the default way Zen Cart is configured to work. Implementing the above scenarios
can be done by simply enabling the relevant fields in the Regulations screen which you can access by clicking on
Configuration > Regulations.

Controlling checkout based on stock status
By default, Zen Cart allows customers to check out even if there is insufficient stock thus allowing them to purchase
goods on back order. Although this works great for certains types of businesses, other businesses may require that
customers are only able to buy whatever is currently in stock.
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To stop customers from checking out if there is insufficient stock:

1. Click on Configuration > Stock to access Stock screen.

2. Set the Check stock level field to true.

3. Set the Allow Checkout field to true.

Delaying the display of the shopping cart
The standard shopping flow in Zen Cart displays the shopping cart whenever an item is added to it. Sometimes, this
may not be the behavior you want. For example, you have already customized your site to display that information
in another part of the store.

You can change the standard behavior by making Zen Cart display a success message instead of showing the shopping
cart’s contents whenever an item is added to the shopping cart.

To disable the display of the shopping cart after an item is added to it:

1. Click on Configuration > My Store to access the My Store screen.

2. Set the Display Cart After Adding Product field to false.

If you choose not to display the contents of the shopping cart after customers add items to them, you should plan to
enable the Shopping Cart side-box. The Shopping Cart side-box displays the items currently in the customer’s shopping
cart and also the total amount for all the items. Clicking on the "Shopping Cart [more]" hyperlink in the side-box will
bring customers to the Shopping Cart page.

Persisting shopping cart items between visits
When customers log in to their accounts, the contents of their current shopping cart will be merged with those from a
previous visit; if any. When this happens, a message will be displayed to customers informing them of this event.
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To control the appearance of the message indicating the merging of shopping cart items:

1. Click on Configuration > Stock to access Stock screen.

2. Edit the Show Notice of Combining Shopping Cart on Login field accordingly.

To better understand the consequences of setting the Show Notice of Combining Shopping Cart on Login field to
either 1 or 2, let us take a look at the following cases.

Consider the case when the field is set to 1. For customers who have previously added something (e.g. Beginner Drum
Lessons) to their shopping carts and not checked out. If they return to your store to continue shopping, add additional
items (e.g. T-shirt) to their cart and then log in; they will see a message informing them that the contents of their current
shopping cart has been merged with the contents of their previous shopping cart which was not checked out.

Consider the case when the field is set to 2 and using the preceding example. This time, the message to the customer
will be displayed at the top of the page instead of on the Shopping Cart page as shown in the following screen shot.

Currently, there is no Admin Console setting to turn off the option to merge shopping cart
contents between visits.
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Using split Login/Sign-Up screens
The default screen that is displayed when a customer clicks the Log In hyperlink in your Store Front allows the customer
to either sign up for an account or to log in to his or her own account using that screen alone. You should be familiar
with that screen since you have already set up several test customer accounts already.

If you prefer to split the sign-up and login information of that screen into two screens instead, you can do so via a switch
in the Admin Console. After enabling the display of sign-up and login information in different screens, customers who
click the Log In hyperlink in your Store Front will encounter the following screen instead.

To split the display of sign-up and login information into different screens:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Set the Use split-login page field to True.

Skipping single-product categories
If a category contains only a single product, you can easily display the product immediately instead of showing the
category first. This saves your customer from clicking twice to reach the Product Info page and smoothens their
shopping experience.

To configure this option, click on Configuration > Layout Settings and edit the Skip 1-prod Categories field.
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Summary
We have taken a look at the different settings which can affect the default shopping flow for customers visiting your
store. Although these capabilities are there, you should examine your own needs carefully before utilizing them as
they deviate from the standard shopping flow which customers are usually more familiar with.
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Chapter 20:

Working with Store Front templates

Introduction
Traditionally, and in very simple situations, a single HTML file is used to render a single web page. However, this
approach proved to be a management nightmare for web masters when dealing with sites that have a lot of web pages
and require dynamic content to be rendered based on user input and other contextual information as well.

To solve the preceding problems, server-side programming languages (such as PHP) generate separate portions of
HTML code separately before combining them into a complete HTML document to be sent to a user’s web browser
for rendering.

Zen Cart uses the same approach of breaking the logic of displaying sections of HTML using separate files. In addition
to that, Zen Cart is able to choose the correct images and stylesheets to use when rendering a particular page on a
user’s web browser.

The collection of files (PHP files, CSS stylesheets, images, etc) that work together to change how your store looks
in Zen Cart is known as a template.

We shall now go into the guts of Zen Cart to learn how to properly customize your store’s look
and functionality with minimum impact on future upgrades. This will mean having to deal with
HTML, CSS and a little bit of PHP along the way.

Do not be disheartened if you do not have the necessary knowledge. Online tutorials on HTML
and CSS are freely and easily available on the Internet (e.g. http://www.w3schools.com). PHP
and Javascript knowledge will take more time to master but are usually not required unless you
need to overhaul a large part of the business logic in certain sections of code.

In this chapter, we shall look into the following the following topics:

▪ Take note of precautions when working with files and directories.

▪ Run through the steps needed to create your own templates and make changes to them.

▪ Understand how the Override System works.

▪ Learn what to do to make your store support multiple languages.

Precautions when working with files and direc-
tories
First of all, remember to avoid editing any file directly on your remote computer using your control panel software
due to the likelihood of file encoding problems. Instead, download and edit any file you want to change on your local
PC. After you are satisfied with your changes, upload the changed files to your remote server.
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Other conventions when editing files are covered in the following sections so that you can avoid some common mis-
takes made by new Zen Cart users.

Displaying file extensions

There are many different types of files that are used by Zen Cart to run your site. In order to avoid mistakes such as
editing a wrong file or saving a file using a wrong file extension, you should make sure your local computer has file
name extensions turned on. Look at the following screen shots to see how the display of a file extension can make
them unambiguous and more easily sorted.

As Windows-based computers do not have file extensions turned on by default, we shall go through an example on
how to turn on file extensions for Microsoft Windows 7. If you are using another version of Windows or another
operating system, do a search on the Internet or refer to your operating system manual for help.

To enable the display of file extensions on a computer running Microsoft Windows 7:

1. Click on Windows Start Menu > Control Panel to bring up the Control Panel window.

2. Type folder options into the search box on the top right corner of the screen as shown in the following screen
shot.

3. Click on Folder Options and a dialog box will appear.

4. Click the View tab on the dialog box and uncheck the "Hide extensions for known file types" option as shown
in the following screen shot.
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5. Click OK to save your changes.

Notes on file and directory names
When you create new files and directories, avoid any spaces in their names. Also try to keep program file names and
directory names you create in all lower-case as software programs tend to interpret names in a case-sensitive manner.
For example, instead of having a file named testLOOK.php or test look.php, use test-look.php.

Another thing to watch out for is with regards to file names prefixed by a period. The one you will come across most
often in Zen Cart is a file with the name .htaccess as it is used to specify instructions to an Apache web server.
Note that this file does not have a file extension.

Some FTP programs and control panel software do not display files with names prefixed by a period. Check the
documentation pertaining to your FTP program and control panel for instructions on how to turn on the display of
such files. Examples on doing so for a cPanel control panel and the FileZilla program can be found in the section “A
word on hidden files”.

Working with text editors
Since you will be editing files on your local computer, you should look to use a proper programming editor for such
tasks instead of using something like a word processor (e.g. Microsoft Word).

A proper programming editor provides syntax coloring and other features which helps to save time and avoid mistakes
when changing code or saving files. Refer to the section “Text editors” for more information if you have not installed
a programming text editor on your local computer yet.

There is one very important point to note when saving files in your text editor. If you had chosen UTF-8 for the
Database Character Set / Collation field in the Database Setup screen, then you need to make sure you save any
language-related text files in UTF8-without-BOM encoding. If you are not sure how to do this, refer to your particular
text editor’s support resources for help.

While Adobe Dreamweaver is a powerful WYSIWYG editor, you should exercise caution if
you plan on using it as highlighted at http://tutorials.zen-cart.com/index.php?article=288.
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Characters with special meanings in HTML and PHP
For readers who are unfamiliar with HTML or PHP, there are several characters you need to pay attention to while
editing some of the files mentioned in the rest of this chapter.

Handling special characters in HTML code

For HTML code, some characters need to be escaped with HTML character entities to prevent browsers from failing
to display the affected web pages properly.

As an example, take a look at the snippet of HTML code that appears in [zc-home]/includes/languages/en-
glish/html_includes/define_contact_us.php. The code prints the header of the Contact Us page as Contact
Us Sample Text ….

<p><strong>Contact Us Sample Text ...</strong></p>

To change the text to Contact John & Jerry, the code would look like the following snippet instead. Notice that the
HTML character entity (&amp;) character is used to replace the ampersand sign (&) instead.

<p><strong>Contact John &amp; Jerry</strong></p>

A collection of commonly used HTML character entities is shown in the following table. For a detailed list of HTML
character entities, refer to http://www.w3schools.com/tags/ref_entities.asp.

Table 20.1: Commonly used HTML character entities

Character HTML Character Entities

< &lt;

> &gt;

& &amp;

" &quot;

Handling special characters in PHP code

For PHP code, text with a single quote (') or double quotes (") that appear between other quotes may need to be
escaped with a preceding backslash (\) character. The rules governing the use of these special characters can be quite
complex so interested readers are advised to turn to http://www.php.net/types.string for more information.

To simplify our discussion, we shall only look at how to escape single and double quotes (either ' or ") that appear
between single quotes (') because this is the most common scenario you will encounter when editing PHP files in
Zen Cart.

As an example, take a look at the snippet of PHP code that appears in [zc-home]/includes/languages/en-
glish/contact_us.php. The code prints the title of the Contact Us page as Contact Us.

define('HEADING_TITLE', 'Contact Us');

To change the title to Shop’s Contact, the code would look like the following snippet instead. Notice that a backslash
(\) character precedes the single quote which will be displayed to your customers.
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define('HEADING_TITLE', 'Shop\'s Contact');

To change the title to "Contact Us", the code would look like the following snippet instead. Notice that the double
quotes are replaced with the HTML character entity (&quot;) instead of a backslash character (\).

define('HEADING_TITLE', '&quot;Contact Us&quot;');

Terminating PHP files properly

PHP code in Zen Cart is enclosed by the use of the (<?php) and (?>) character sequences as shown in the following
example.

<?php

 // some PHP code here

?>

<p>This line contains HTML code.</p>

<?php // some PHP code here ?>

For .php files, the last line in the file is important as it can lead to problems with the rendering of your page if it
is wrongly specified.

The best thing to do is to omit the use of the terminating characters (?>) in the last line of a .php file. The Zen Cart
developers have intentionally taken this route. Hence, you will notice that many of Zen Cart’s files do not have the
terminating (?>) characters in the last line.

If you happen to come across a file that uses (?>) as the terminating characters, make sure there are no other characters,
including white space, that comes after those characters or you may encounter errors with messages like "Headers
already sent", etc.

Creating custom templates
In order to create a new template, you must create a directory under the [zc-home]/includes/templates directory.
The newly created directory should also contain a template_info.php file which would specify details about the
newly created template.

In order to help you understand the template creation process better, we shall go through the steps involved in creating
two templates in this section.

To create our first template:

1. Create a directory named "basic" under the [zc-home]/includes/templates directory.

2. Copy the [zc-home]/includes/templates/template_default/template_info.php file into [zc-
home]/includes/templates/basic.
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3. Edit and save the file template_info.php under the basic directory. You can use the following sample code
for testing purposes.

<?php
$template_name = 'Basic Template';
$template_version = 'Version 1.0';
$template_author = 'Store Owner - Claude Blanc';
$template_description = 'Custom template for comparison purposes.';
$template_screenshot = 'scr_template_default.jpg';
?>

To create our second template:

1. Copy and rename the [zc-home]/includes/templates/classic directory to [zc-home]/in-

cludes/templates/magic.

2. Edit and save the file template_info.php under the magic directory. You can use the following sample code
for testing purposes.

<?php
$template_name = 'Magic Template';
$template_version = 'Version 1.0';
$template_author = 'Store Owner - Claude Blanc';
$template_description = 'Custom template for testing purposes.';
$template_screenshot = 'scr_template_default.jpg';
?>

3. To allow you to visually differentiate between the default Classic template and your newly created Magic template
later, we shall modify the background color of your newly created template.

Edit the [zc-home]/includes/templates/magic/css/stylesheet.css file and change the alphanumeric
characters in the BODY section to six zeros which represents the color black.

BODY {
  background-color: #e5edf5;

BODY {
  background-color: #000000;
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If you have followed the preceding instructions to create the two templates, then the directory structure in your [zc-
home]/includes/templates directory should look like the following screen shot.

Here are some things to take note about the two templates we have just created.

▪ The directory names do not have to be named according to the template name. For example, you can give the Magic
template another name (e.g. "Happy Theme") but leave the directory name as magic in our previous example.

▪ The minimum requirement for a new template is to create a new directory with a template_info.php file under
the [zc-home]/includes/templates/ directory. This is what we have done with our Basic template.

▪ The contents of the template_info.php file always follows the same standard format: template name, author,
version, description and screen shot.

▪ The "$template_screenshot" field in the template_info.php file should preferably point to a screen shot of how
your Store Front looks when your newly created template is active. The screen shot image can be named anything
and should preferably be placed in the images sub-directory of your override directory’s (e.g. [zc-home]/in-
cludes/templates/magic/images/magic_screenshot.jpg).

For the two example templates we created, since we have not finished creating our new look-and-feel for the Store
Front, we leave the templates pointing to the default screen shot image.

▪ The fastest way to modify a template you want to change is to copy a file from the original template and then edit
the changes in the newly created template. We shall talk more about this process when we discuss the topic of
overrides later.

Switching templates
After you have created your new templates, you need to activate it in the Admin Console in order for it to take effect
in your Store Front.

To switch to your desired template:

1. Click on Tools > Template Selection to access the Template Selection screen.
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The "Basic Template" and "Magic Template" options are only shown in the side-panel if you have created them
by following the instructions in the previous section.

2. If you want your custom template to be applied for all languages used in your store.

a. Click the row with Template Language set as Default (All).

b. Click on edit to access the template details page.

c. Choose your desired template from the Template Name drop-down list box.

d. Click on update to save your changes.

3. If you want your custom template to be used only for a particular language in your store.

a. Click on the new language button.

b. Choose your desired template from the Template Name drop-down list box and associate it with your desired
language by choosing from the Language Name drop-down list box.

c. Click insert to save your changes.

If you visit your Store Front after switching to a new template, you will notice that all the side-boxes are missing. To
resolve this problem, follow these steps:

1. Click on Tools > Layout Boxes Controller to access the Column Boxes screen.

2. Click the reset button to quickly turn on the set of side-boxes that are displayed by default.
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To turn on or off the relevant side-boxes to suit your preferences, refer to the section “Side-boxes” for details.

If you have followed along with our examples and created the Basic and Magic templates, you will find that the look
of your Store Front will look different when switching between the two custom templates as shown in the following
screen shots. Notice that the Magic template has a black background and is contained within a fixed width as compared
to the Basic template.

The rest of this chapter assumes that you are using the name magic for your override directory
and that you have activated the "Magic Template". For the sake of convenience, we shall also
refer to the "Magic Template" simply as the Magic template in this book.

The Template Override System
To work effectively with templates in Zen Cart, you will need to be familiar with the Template Override System. It is
a very powerful and flexible system which serves the following purposes:

▪ Use templates to control the look and functionality of your store.
▪ Ease maintenance and upgrading efforts by not touching user-defined template files.

The Template Override System consists of three parts:

▪ Database settings.
▪ Automatically included files.
▪ The Override System.

The "database settings" feature uses the Admin Console to configure various settings in your store’s database that will
affect the appearance of your Store Front. For example, which side-boxes should appear for a given template can be
configured via the Column Boxes screen which we covered in the section “Side-boxes”.

The "automatically included files" feature allows custom files that are placed in specific directories and that follow
pre-defined naming conventions to be automatically picked up and included in Zen Cart’s processing logic when
rendering a page. We shall take a look at how this is possible when discussing CSS and Javascript customizations later
in this chapter. Other more advanced uses of this feature will not be discussed in this book because they apply more
to programmers looking to extend Zen Cart’s capabilities.

The "Override System" feature makes Zen Cart load your custom files instead of the default ones that it normally loads
when rendering a page. It is the primary method used by store owners to customize the look-and-feel of their stores
and hence the focus of our attention in this chapter.
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How the Override System works
To understand how the Override System works, we need to differentiate core files from template-specific files in Zen
Cart’s directory structure. Core files provide the the core functionality that makes Zen Cart work and are essential
to the normal operation of your store. Template-specific files, on the other hand, are non-essential to your store’s
operation and only take effect when a template is active.

A standard Zen Cart installation will contain a set of core files together with a Classic template. The Classic template
is associated with all classic directories that exist under the following directories. All other files not residing within
a classic directory are core files.

▪ [zc-home]/includes/templates

▪ [zc-home]/includes/languages

▪ [zc-home]/includes/modules

With the preceding concepts in mind, let us refer to the following files to see how the Override System works. Note
that both the header.php files in the following directories render the text displayed in your Store Front’s Header
Main Bar area. However, which file is chosen is dependent on how the Override System works.

▪ [zc-home]/includes/languages/english/header.php

▪ [zc-home]/includes/languages/english/classic/header.php

The pertinent differences between the contents of the two header.php files appear in the line containing the text
HEADER_SALES_TEXT as seen in the following code snippets.

For [zc-home]/includes/languages/english/header.php:

define('HEADER_SALES_TEXT', 'TagLine Here');

For [zc-home]/includes/languages/english/classic/header.php:

define('HEADER_SALES_TEXT', '<h1>Sales Message Goes Here</h1>');

When the Classic template is active, Zen Cart will load the contents of [zc-home]/includes/languages/en-
glish/classic/header.php file. When we switch to the Magic or Basic template we created earlier in this chapter,
Zen Cart will load the contents of the [zc-home]/includes/languages/english/header.php file. You can
verify this for yourself by looking at the header text that is displayed in your Store Front when you switch between
the Classic template and the other two custom templates you created.

What you have just witnessed is the effects of the Override System in action. In essence, how the Override System
works is it will always look to load a template-specific file over a core file if the currently active template contains a
template-specific file that has the same name as the core file. This process is known as overriding. The core file acts
as a fallback to ensure that Zen Cart will still continue to function properly when an overriding file is not present.

As you can see, the Override System greatly reduces the time that store owners need to customize the appearance of
their stores because only a handful of core files need to be overridden to achieve a custom look. Another benefit is
the preservation of your changes in your custom templates if any of the core files happen to be overwritten during
a Zen Cart upgrade.

Besides the core files, you should also not make any direct changes to any of the Classic template files. This is be-
cause the core files and Classic template files are under the purview of Zen Cart’s developers. Their contents may
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be overwritten when you upgrade Zen Cart to a newer version and hence any changes you make in those files will
be overwritten as well.

Hence, you should always create your own custom templates and override the relevant core files or Classic template
files in order to avoid having your changes accidentally wiped out during a Zen Cart upgrade.

In the event that you really need to make alterations to the code in a core file that cannot be overridden, make sure
you keep a copy of the modified core file somewhere safe. When you upgrade your Zen Cart to a newer version, you
can then merge the changes you made in the backed up copy of your modified core file with the code contained in
the latest core file.

Currently, the Override System only works for files that affect your Store Front appearance and
not that of your Admin Console.

Identifying directories that support overrides

There are three main directories located under the [zc-home] directory that will help you decide what you need to
override.

▪ includes/templates - To change the colors, fonts and images used on your site. For example, the color of
your side-boxes or the buttons that appear in your Store Front.

▪ includes/languages - To change the text that is displayed in your web pages. For example, the title of your
side-boxes or the contents of your define pages.

▪ includes/modules - To change the logic or display structure of certain display elements. For example, you
can override the files under the [zc-home]/includes/modules/sideboxes directory and change their code
to influence the contents that are displayed in your side-boxes.

All files in the preceding directories and their sub-directories can be overridden except for those files residing under
the following directories:

▪ [zc-home]/includes/modules/order_total

▪ [zc-home]/includes/modules/pages

▪ [zc-home]/includes/modules/payment

▪ [zc-home]/includes/modules/shipping

▪ [zc-home]/includes/modules/debug_blocks

To help you better visualize the different directories that contain files that can be overridden, refer to the following
screen shot.
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Figure 20.1: Directories that support overrides

Note that the classic directories appearing under the [zc-home]/includes directory in the preceding screen shot
also acts as an indicator that files in a directory above it or on the same level as it can be overridden. The next section
shall clarify the rules governing how the relevant files are to be overridden.

Creating your own overrides
Before you begin overriding a file, make sure you have already created a custom template under the [zc-home]/
includes/templates directory.

After you have determined that a file you want to modify can be overridden, use the following rules as a guide to
create your own custom override file:

▪ Your override directory name must be the same as your template directory name. For example, if your custom
template directory is named magic then the names of your override directories should all be magic as well.

▪ If the file you want to override is found somewhere under the [zc-home]/includes/templates directory. Your
override directory should be at the same-level as the file you want to override as shown in the following example.

Default path:

[zc-home]/includes/templates/template_default/sideboxes/tpl_languages.php

Override path:

[zc-home]/includes/templates/[custom-template]/sideboxes/tpl_languages.php

▪ If the file you want to override is found somewhere under the [zc-home]/includes/languages or [zc-home]/
includes/modules directories. Your override directory should be one-level below the file you want to override
as shown in the following example.
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Default path:

[zc-home]/includes/languages/english/header.php

Override path:

[zc-home]/includes/languages/english/[custom-template]/header.php

▪ Any content modifications you intend to make should only be applied to the file you copied over to your override
directory and not the original file. Many newcomers tend to make the mistake of unintentionally making changes
to the original file so it is good that you pay a bit more attention to this point.

▪ To see the effects of your overrides, go to your Admin Console and make sure that the currently active template for
your store has the same template directory name as that of your overrides directory.

Making changes to a template
Now that you understand how to create a new template and how the Override System works, we can safely begin
our customizations.

We shall assume that you have already switched over to your newly created template and not the Classic template
when you are working on your customizations.

Anytime you are unhappy with your new modifications or feel you have overridden something wrongly, switch back
to the Classic template to see if the changes you made in your custom template could be the problem.

Text customization

One of the most commonly asked questions on Zen Cart’s forums is how to change short phrases that appear in the
Store Front. For example, the text "Sales Message Goes Here" or a title appearing in one of the side-boxes. These short
phrases are usually specified in Zen Cart with the use of PHP define statements as shown in the following code. The
word appearing in all capital letters is known as a PHP constant.

define('HEADER_SALES_TEXT', '<h1>Sales Message Goes Here</h1>');

Another type of text content that store owners are likely to change usually consists of paragraphs of text or entire
pages of text. This type of text content can either be created using a Define Page or an EZ-Page. A Define Page can
be overridden but not an EZ-Page. This is because the former’s text content is contained within the files in the [zc-
home]/includes/languages/english/html_includes directory whereas the latter’s text content is stored in
the database.

For now, take a look at following sample content of a Define Page to get an idea of how it is different from the text
appearing in the previous PHP define statements.

<p><strong>Conditions of Use Sample Text?...</strong></p>
<p>
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 This section of text is from the Define Pages Editor located under Tools in the
 Admin.
</p>
<p>To remove this section of the text, delete it from the Define Pages Editor.</p>

Because the act of changing text is such a regular activity and one of the first things that store owners do when
customizing the look of their stores, we shall go through the entire process so that common mistakes can be avoided.

To locate a file containing text you want to change:

1. Click on Tools > Developers Tool Kit to access the Developers Tool Kit screen.

2. Concentrate on the first part of the screen with the heading Look-up CONSTANT or Language File defines.
Note that a CONSTANT refers to a PHP constant which we have mentioned earlier.

3. Enter the word(s) you would like to change in the Key or Name field. For example, enter Sales Message.

4. Choose an option from the Language File Look-ups drop-down list box according to which part of the file sys-
tem you want to look for the language file. For example, choose All Language Files for English-Cat-
alog/Admin.

Do not choose None because the search will then be conducted against the database only and not the language files.
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5. Click the Search button and you should see your search results displayed on the top of the screen. The following
screen shot shows the result of a successful search. It indicates the location of the file and also the matching line
within that file that corresponds to your search criteria.

If you cannot find what you are looking for via the Look-up CONSTANT or Language File
defines search option, switch to the Look-up in all files one instead. You may also want to
choose All Files Look-ups = All Files-Catalog Admin and File type = .php only to
maximize your search scope.

This search option will likely return more results because the search is performed against a more
extensive list of files. However, some of the results may be redundant as they relate to PHP
classes and functions which are useful only to programmers but not to store owners looking to
change text content only.

Before customizing a file containing text, make sure you read through the section “Characters with special meanings
in HTML and PHP” and the section “Working with text editors”. This is because many people do not know that failure
to properly escape special characters or saving a file wrongly can give rise to unexpected errors in Zen Cart.

To customize the file containing your text, override it by performing the following steps:

1. Copy the file you want to change (e.g. header.php) from its original directory (e.g. /english/classic) into
your currently active override directory (e.g. /english/magic).

2. Make your changes to the file in your override directory (e.g. /english/magic/header.php).

3. Refresh your web browser to verify your changes.

Image customization
We have discussed different aspects of working with images in previous chapters when we talked about multiple
images for a product, category images, product images, etc. In this section, we shall extend our understanding of how
Zen Cart template images are handled. Do consult the section “Images” for product and category image settings that
can be manipulated via the Admin Console.
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The image directories that are conventionally used by your templates can be found in the template_default direc-
tory as shown in the following screen shot.

As you have learned earlier, your override directory will only need to change some files instead of the full set of files
in the template_default directory. Therefore we shall use the template_default directory structure to explain
the purpose of the template-specific directories.

[zc-home]/includes/templates/template_default/buttons/english
This is the default directory holding the image buttons for stores that are using the English language. If your store
is using another language and is not using CSS buttons for display, you should see a language-specific directory
under the [zc-home]/includes/templates/template_default/buttons directory instead.

[zc-home]/includes/templates/template_default/images
This is the directory containing all template-specific images. This would include your store logo and any other
images you would usually refer to in your template-specific CSS stylesheet.

[zc-home]/includes/templates/template_default/images/icons
This is the directory containing template-specific icons like credit card icons, shopping cart icons, etc.

Helpful articles on preparing your images for use in your store can be found at http://
tutorials.zen-cart.com/index.php?article=224 and http://tutorials.zen-cart.com/index.php?arti-
cle=30.

CSS customization
The use of CSS stylesheets is the main approach to altering your store’s appearance if the settings in the Admin Console
are not able to do so. It is usually the place where store owners spend the most time trying to achieve a specific look
for their stores.

By default, Zen Cart’s comes with three stylesheets in the Classic template directory (i.e. [zc-home]/in-
cludes/templates/classic/css) as follows:

▪ stylesheet.css - Controls the overall look of the store (e.g. page margin, font size, colors, background images,
etc)

▪ stylesheet_css_buttons.css - Used to render buttons using CSS instead of images.

▪ print_stylesheet.css - Used to render a page when a user chooses to print a page from within a web browser.

When you choose to replace the GIF image buttons in your Store Front with CSS buttons,
you will need to have the CSS styles for the buttons present in a stylesheet. By default,
stylesheet_css_buttons.css is that stylesheet.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>

http://tutorials.zen-cart.com/index.php?article=224
http://tutorials.zen-cart.com/index.php?article=224
http://tutorials.zen-cart.com/index.php?article=30
http://tutorials.zen-cart.com/index.php?article=30


Chapter 20. Working with Store Front templates 297

To toggle between the display of CSS button or GIF image buttons, click on Configuration >
Layout Settings to access the Layout Settings screen and then edit the CSS Buttons field.

If your store is currently using the Classic template and if you were to view the HTML source code of any
page in your web browser, you will see the following code appearing between the <head> tags. Notice that the
print_stylesheet.css is specified with an attribute of media="print" unlike the other stylesheets.

<link rel="stylesheet" type="text/css" href="includes/templates/classic/css/
stylesheet.css" />
<link rel="stylesheet" type="text/css" href="includes/templates/classic/css/
stylesheet_css_buttons.css" />
<link rel="stylesheet" type="text/css" media="print" href="includes/templates/
classic/css/print_stylesheet.css" />

Besides the standard stylesheet files that come with the default Classic template directory, you can also add your own
custom stylesheets between the <head> tags of a Store Front page without altering any template code.

To do that, you need to make sure all your custom stylesheets are contained within the [zc-home]/includes/tem-
plates/[your-template]/css directory and adhere to the following naming conventions.

▪ For stylesheets that should be loaded in all pages, the file name syntax is as follows:

▸ Use style[xxxxxx].css for generic stylesheets; where [xxxxxx] represents the unique name you have given
the file.

This is why the stylesheet.css and stylesheet_css_buttons.css files of the Classic template are always
included in every Store Front page.

▸ Use print[xxxxxx].css for print-specific stylesheets; where [xxxxxx] represents the unique name you have
given the file.

This is why the print_stylesheet.css of the Classic template is always included in every Store Front page.
Note that print-specific stylesheets will also have the media="print" attribute when rendered in HTML as
mentioned earlier.

▪ For stylesheets that should be loaded only on a specific page, the file name syntax is as follows:

▸ Use [page-name].css for a stylesheet that should only be loaded when the user is on a page with its URL
corresponding to a specific page name. Here [page-name] represents the unique name you have given the file.

For example, contact_us.css will only be loaded if the customer is on the Contact Us page.

▸ Use index_home.css for a stylesheet that should only be loaded if you are on the home page of your Store Front.

▸ Use c_[category-path].css for a stylesheet that should only be loaded when the user is on a page with its
URL corresponding to a specific category path. Here [category-path] represents the collection of category
IDs which lead to the category page display.

For example,c_3_12.css will only be loaded if the customer is on a page displaying products or categories
belonging to a category with a category ID of 12 and that in turn belongs to a parent category with a category
ID of 3.

▸ Use c_[category-path]_children.css for a stylesheet that should only be loaded when the user is on a
page with its URL corresponding to a specific category path or has a parent category with the specific category
path. Here [category-path] represents the collection of category IDs which lead to the category page display
or a sub-category of the page display.
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For example, c_3_12_children.css will be loaded if the customer is on a page displaying products or sub-
categories belonging to a category with a category ID of 12 and that in turn belongs to a parent category with
a category ID of 3.

▸ Use m_[manufacturer-id].css for a stylesheet that should only be loaded when the user is on a page with
its URL corresponding to a specific manufacturer ID. Here [manufacturer-id] represents the ID assigned to
a manufacturer when it is created in the Admin Console.

For example, m_20.css will only be loaded if the customer is on a page displaying a list of products belonging
to a manufacturer with the manufacturer ID of 20.

▸ Use p_[product-id].css for a stylesheet that should only be loaded when the user is on a page with its URL
corresponding to a specific product ID. Here [product-id] represents the ID assigned to a product when it is
created in the Admin Console.

For example, p_23.css will only be loaded if the customer is on a Product Info page with a product ID corre-
sponding to 23.

Because multiple stylesheets with the same CSS rules can cause conflicts in certain situations, it is important that you
understand the sequence in which the stylesheets are loaded so that you can enforce your CSS rules better.

The sequence in which CSS stylesheets are loaded by Zen Cart is as follows:

1. Load style[xxxxxx].css. Applies to all pages in a store.

2. Load [page-name].css or index_home.css.

3. Load c_[category-path].css.

4. Load m_[manufacturer-id].css.

5. Load p_[product-id].css.

6. Load c_[category-path]_children.css.

7. Load print[xxxxxx].css. Applies to all pages in a store.

Besides having stylesheets load based on whether you want them to appear in a specific page or across all pages in your
Store Front, you can also have them load only when a particular language is active. To simplify our explanations and
minimize confusion, we will not be discussing language-specific stylesheets in this book. Readers who are interested
in the topic can refer to [zc-home]/includes/templates/template_default/css/CSS_read_me.txt.

Due to the lack of space in this book, we are not able to go through the code contained within each stylesheet to learn
how you can change the look of your store. Instead, you can consult the following pages on Zen Cart’s wiki to get a
feel of what the code in the stylesheet.css is doing.

▪ http://www.zen-cart.com/wiki/index.php/Customisation_-_Templates_-_Stylesheets_-_Annotated

▪ http://www.zen-cart.com/wiki/index.php/Customisation_-_Templates_-_Stylesheets_-_Annotated_P2

In addition, you can make your desired changes in the relevant stylesheets by doing a search in the "Templates,
Stylesheets, Page Layout" forum or looking up the "Template Customization/ Building Overrides" section of the Tu-
torial/FAQs at Zen Cart’s site. For example, you can change the width of your Store Front page by following the
instructions at http://tutorials.zen-cart.com/index.php?article=46.
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For more information on how Zen Cart works with CSS stylesheets, refer to http://www.zen-cart.com/wiki/index.php/
Customisation_-_Templates_-_Stylesheets.

Javascript customization
If you plan on using Javascript for your store, you will be glad to know Zen Cart comes packaged with the very popular
and powerful Javascript library, jQuery (http://jquery.com). Furthermore, whether you choose to use jQuery or not,
including your Javascript code for use in Zen Cart is also very easy.

Zen Cart allows you to load your custom Javascript code either between the <head> tags or directly into the onload
attribute of the <body onload=""> opening tag of an HTML page in your Store Front. All these can be accomplished
without having to make modifications to any PHP template file.

For Javascript code that is embedded between the <head> tags of an HTML page, they can appear either as a link to
an external file containing the raw Javascript code or have all the raw Javascript code appear directly in the HTML
source code. For example, if you were to view the HTML source code of the "Product Info" page in your web browser,
you will see the following code appearing between the <head> tags. Notice that a Javascript file is linked via the first
<script> tag and raw Javascript code is displayed in the second <script> tag.

<script type="text/javascript" src="includes/modules/pages/product_info/
jscript_textarea_counter.js"></script>

<script language="javascript" type="text/javascript"><!--
function popupWindow(url) {
  window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,
 menubar=no,scrollbars=no,resizable=yes,copyhistory=no,width=100,height=100,
 screenX=150,screenY=150,top=150,left=150')
}
function popupWindowPrice(url) {
  window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,
 menubar=no,scrollbars=yes,resizable=yes,copyhistory=no,width=600,height=400,
 screenX=150,screenY=150,top=150,left=150')
}
//--></script>

For Javascript code that is to be embedded directly into the onload attribute of the <body onload=""> opening tag
of an HTML page, only raw Javascript code will appear directly in the HTML source code. For example, if you were
to view the HTML source code of the "Contact Us" page in your web browser, you will see the following Javascript
code appearing within the opening <body onload=""> tag.

<body id="contactusBody" onload=" if (document.contact_us){ if
 (document.contact_us.contactname) {document.contact_us.contactname.focus()} };">

In order for your Javascript code to be embedded automatically by Zen Cart, the first thing you need to do is to make
sure the file containing your Javascript code is named according to the following conventions:

▪ For a file that is to be linked between the <head> tags of an HTML page, the file name syntax is
jscript_xxxxxx.js where xxxxxx represents the unique name you have given the file.

Note that the file can only contain pure Javascript code and no PHP code. The <script> and </script> tags
should not appear in the file as well.

▪ For a file that should have all its raw Javascript code appear between the <head> tags of an HTML page, the file
name syntax is jscript_yyyyyy.php where yyyyyy represents the unique name you have given the file.
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Note that the file may contain both PHP and Javascript code. The <script> and </script> tags must also enclose
the Javascript code in the file.

▪ For a file that should have all its raw Javascript code embedded directly into the onload attribute of the <body
onload=""> opening tag of an HTML page, the file name syntax is on_load_zzzzzz.js where zzzzzz repre-
sents the unique name you have given the file.

Note that the file can only contain pure Javascript code and no PHP code. The <script> and </script> tags
should not appear in the file as well.

After naming the file containing your Javascript according to the preceding conventions, you will need to place the
files into the following directories according to the Store Front pages you want the Javascript to appear.

▪ For your custom Javascript to be embedded within the <head> tags of the HTML source code within all pages
in your Store Front, place the Javascript file in your [zc-home]/includes/template/[yr-template]/tem-
plate/jscript directory.

▪ For your custom Javascript to be embedded within the <head> tags of the HTML source code within a specific page
in your Store Front, place the Javascript file in your [zc-home]/includes/modules/[page-name] directory.

▪ For your custom Javascript to be embedded within the <body onload=""> opening tag of the HTML source code
within all pages in your Store Front, place the Javascript file in your [zc-home]/includes/template/[yr-
template]/template/jscript/on_load directory.

▪ For your custom Javascript to be embedded within the <body onload=""> opening tag of the HTML source
code within a specific page in your Store Front, place the Javascript file in your [zc-home]/includes/mod-
ules/[page-name] directory.

After you are done naming your Javascript files and putting them into their respective directories, Zen Cart will au-
tomatically load and embed the necessary Javascript files according to the following sequence each time a page is
rendered in your Store Front.

Note that [yr-template] refers to your custom template name and [page-name] refers to the specific page where
the Javascript code should be embedded.

1. Load all jscript_xxxxxx.js files inside the [zc-home]/includes/template/[yr-tem-

plate]/jscript directory alphabetically.

2. Load all jscript_xxxxxx.js files inside the [zc-home]/includes/modules/[page-name] directory al-
phabetically.

3. Load all jscript_yyyyyy.php files inside the [zc-home]/includes/template/[yr-tem-

plate]/jscript directory alphabetically.

4. Load all jscript_yyyyyy.php files inside the [zc-home]/includes/modules/[page-name] directory al-
phabetically.

5. Load all on_load_zzzzzz.js files inside the [zc-home]/includes/modules/[page-name] directory al-
phabetically.

6. Load all on_load_zzzzzz.js files inside the [zc-home]/includes/template/[yr-tem-

plate]/jscript/on_load directory alphabetically.

Because the sequence in which Javascript functions (and hence Javascript files) load may affect how your custom
code functions. You should rename the affected Javascript files in alphabetical order if you need to further control
the Javascript loading sequence of each file.
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For more information on Zen Cart’s Javascript loading functionality, refer to http://www.zen-
cart.com/wiki/index.php/Customisation_-_Templates_-_Javascript.

Supporting multiple languages
Although Zen Cart is written in English, it has the capability to support additional languages. This is accomplished
through the help of language packs which can be downloaded from Zen Cart’s site.

If you do not find the language you require, you can even create your own language pack. However, this is not an easy
task because you would need to be familiar with all the words that need to be translated. To learn how you can create
your own language pack, you can refer to Zen Cart’s site for instructions.

The handful of language packs currently available vary in terms of their coverage for different areas of your store.
Some language packs cover both the Store Front and Admin Console whereas other language packs may only cover the
Store Front or Admin Console. As these language packs are developed by volunteers and not Zen Cart’s developers,
the quality of each translation will vary. If you spot any mistakes, just let the maintainers (i.e. volunteers) of those
language packs know.

Your operating system needs to have the necessary fonts installed in order for your web browser
to display the "foreign" text properly.

Understanding ISO language codes and language en-
codings
Before you begin adding a language pack, you need to know about language codes and language encodings. These
two topics allow you to configure Zen Cart to support additional languages and also for your web browser to display
other languages properly.

A language code is a 2-letter ISO 639-1 code or 3-letter ISO 639-2 code used to represent a language name. Zen Cart
only supports the 2-letter ISO 639-1 at the time of writing of this book. For example, "ja" is used to represent Japanese
and "en" is used to represent English. You can access a list of language codes at http://www.loc.gov/standards/iso639-2/
php/code_list.php.

A language encoding is a binary representation of a language’s character set. A character set is a grouping of several
characters that represent a language. For example, you can think of the English alphabet as a character set consisting
of 52 upper and lower-case letters. A language encoding allows a computer program to translate a set of bytes into the
correct character. However, to display the character properly on a system, the appropriate fonts must also be installed.

Web browser language preferences
Most modern graphical web browsers have the ability to let users configure the languages used to display web pages.
It is important to know where this setting is if you intend to test a new language that you have added to Zen Cart.

We shall use the free and open source Mozilla Firefox web browser in our examples to show you how to go about
configuring your browser languages. There are two ways to specify language preferences in Firefox and we shall
highlight both ways.
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▪ Static language preferences: This configuration lists the languages that are supported by a web browser. The list
of supported languages can automatically be detected by programs like PHP, Java, CGI etc. Zen Cart is written in
PHP so it uses this setting to determine a customer’s default language preferences.

▪ Dynamic language preferences: This configuration allows a user to change the web browser language currently
being used to render a web page. If you see gibberish being displayed in your web browser when viewing web pages
authored in foreign languages, you should experiment with this configuration.

Static language preferences

This configuration provides programs running on web servers with a way of automatically detecting what languages
are supported by a user’s web browser.

To edit the language preferences of your web browser:

1. Start up Mozilla Firefox if you have it installed on your system.

2. Click on Tools > Options to bring up a dialog box and navigate to the specified area as shown in the following
screen shot.

3. Click on Choose and you will be able to add any language preferences in the ensuing dialog box.

Note: The "us" behind the language "en-us" is referred to as a language variant. It is used to represent differences
in how a language is used in different locations. For example, "color" in the United States is spelled as "colour"
in the United Kingdom.

4. To add a language that your browser supports, choose one from the drop-down list box, then click Add.
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5. To specify your default language, make sure it is the top-most entry in the Languages in order of preference
list box.

6. Click on OK to confirm your changes.

Dynamic language preferences

This configuration changes the language encoding of a web page currently being displayed in your web browser.
Unlike the configuration mentioned in the previous section, this setting changes how your web browser interprets a
web page already sent by a web server. It does not send this setting to the web server.

To change the current language used by your web browser to render a web page:

1. Start up Mozilla Firefox if you have it installed on your system.

2. On the main menu bar, click on View > Character Encoding > Auto-Detect to display a list of languages.

3. Choose and click a language you wish to use to render a page you are currently viewing.

You can now view any web page dynamically with your desired language encoding instead of the static default lan-
guage which might be read by web applications and rendered to you.

Adding a language pack
A language pack is a collection of files that contain translations of different fields in Zen Cart in a specific language
(French, Spanish, etc). The language pack can either be for the Store Front only, Admin Console only, or for both
interfaces.

Before you begin adding a language pack:

1. Click on Configuration > My Store and edit the Language Selector field to specify how your browser will
switch to another language.
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▪ Default: Indicates that a visitor will see a site rendered according to the language you set for your store. For
testing purposes, you might like to set this as the option first.

▪ Browser: Indicates that your store will automatically switch to a language based on the language preferences in
a visitor’s browser. Refer to the section “Static language preferences” for an example showing how supported
languages are configured in a web browser.

2. Click on Configuration > Maximum Values and edit the Maximum Display of Language Flags in Language
Side Box field. As the name implies, this field specifies the number of languages (represented by flags) to display
in your Languages side-box in your Store Front.

We shall use the example of a Simplified Chinese Language Pack for Zen Cart as an example of how to add a language
pack to Zen Cart. You can then modify the steps to install your own language pack.

Download and install a new language pack

Before you begin adding your language pack, make sure you back up your [zc-home] directory. Refer to the sec-
tion “File system back up” for details on how to back up this directory properly.

To begin installing a language pack:

1. Obtain a language pack:

a. Go to Zen Cart’s home page and click the Plugins hyperlink on the top menu.

b. Click on the Language Packs hyperlink to see a list of language packs available for Zen Cart.

c. Check the version of Zen Cart that is supported for the desired language pack.

d. Download the required language pack to your machine. For our example, this file is named zen-cart-vChi-
nese-simplified-utf8.zip.

2. Expand your language pack into a separate directory and you should see the directory structure of a decompressed
Chinese language pack as shown in the following screen shot.

Note that the Chinese language pack we are using in this book does not contain any documentation. Other language
packs may have additional documentation containing installation and usage instructions.

3. Copy the relevant files and directories under the uncompressed language pack directory into the corresponding
directories under your [zc-home] directory.

4. Log in to your Admin Console.

5. Click on Localization > Languages bring up the Languages screen.
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6. Click on new language to provide details of your new language pack to Zen Cart. The following screen shot
shows the details we will specify for our example Chinese language pack.

7. Enter a name for your language pack in the Name field. E.g. Simplified Chinese.

8. Enter the two-letter ISO 639-1 code which represents the language in the Code field. Although Simplified Chinese
is used in both Mainland China and Singapore, it is customary to use China as the country code to represent
Simplified Chinese. Therefore, enter the country code for China as cn.

9. The default icon.gif in the Image field is an image that is provided by your language pack. Most likely, it is
the flag of a specific country synonymous with that language; e.g. the flag of China to represent the Simplified
Chinese language.

10. Enter the directory which holds all your language-specific files in the Directory field. You should be able to
derive this value via the following directory path of your language pack - [language-pack-directory]/in-
cludes/languages/[directory-path]. If you refer to the figure in Step 2, you will understand how we
obtained the value of schinese for our language pack.

11. Optionally, check the Set as Default check box if you intend to make this the default language that your store
uses. For testing purposes, do not check this field for now.

12. Optionally, if you would like to associate a specific template when this language is use in your Store Front.

a. Click on Tools > Template Selection to bring up the Template Selection screen.

b. Click on new language to specify what template should be used for your new language.

c. Specify the necessary details and click insert. The following screen shot shows an example of the Chinese
language pack being associated with the Magic Template.
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Note: While testing, it is best to leave the template set to the default Classic Template. This helps to confirm
your language pack is installed properly first before you do additional tweaking to your language settings.

After you have added a language pack, you can go to your individual products and categories
to add descriptions and names in the newly added language.

Associate currency in new language pack with a currency in the Currencies
screen

Depending on your language pack, you may need to add the currency code associated with your language pack to
Zen Cart after your language pack is installed. If you do not perform this step, your order totals may not add up when
switching your store over to the newly installed language.

Since we are using the Chinese language pack for our example, we will need to add a new currency (Chinese Yuan)
to your store as it is not in the list of currencies that comes with a default installation of Zen Cart.

To add the new currency associated with the new language pack:

1. Open up the [zc-home]/includes/languages/[your-language].php file and check the field containing
the words "LANGUAGE_CURRENCY". For the Chinese language pack, you should see something as follows.

define('LANGUAGE_CURRENCY', 'CNY');

2. Log in to your Admin Console.

3. Click on Localization > Currencies to access the Currencies screen.

4. Click on new currency and concentrate on the side-panel.

5. Use the currency code you saw in Step 1 and enter into the Code field for the currency. For example, enter CNY
for the Code field if you are using the Chinese language pack.

6. For the rest of the fields, enter the values according to those shown on the following screen shot if you are using
the Chinese language pack. If you have a problem entering the Chinese character for the Symbol Right field,
enter &#20803; instead.
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7. Click on insert to save your changes.

Test the new language pack integration

Before you begin testing, we shall assume you have set the Language Selector field to Default under Configuration
> My Store. The test shall be performed for both the Store Front and the Admin Console separately.

To test whether your language pack is working for your Store Front:

1. Start your web browser and proceed to your Store Front.

2. From the Languages side-box, click on the relevant flag representing the language you want to view the store in.

3. You screen should be refreshed and displayed in the chosen language. Adjust your browser language setting
dynamically if you see gibberish. Refer to the section “Dynamic language preferences” for details if you have
forgotten how to set your browser’s language dynamically.

A Store Front displayed in Chinese and using Chinese Yuan as its currency is shown in the following example
screen shot.
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Make sure you test out all the necessary screens by entering an order in your system to check whether all the function-
ality and calculations are correct! The following screen shot of a shopping cart with order calculations displayed is
to help remind you to perform these checks.

To test whether your language pack is working for your Admin Console (Note: Works only if your language pack
has support for Admin Console):

1. Start your web browser and log in to your Admin Console.

2. You should be able to switch your language according to the drop-down list box located underneath the Zen Cart
logo as shown in the following screen shot.

3. Choose your desired language from the drop-down list box and your entire Admin Console will now be rendered in
your selected language. The following example screen shot shows the home page of the Admin Console rendered
in Simplified Chinese.
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With our example of adding a Chinese language pack as a reference, you should now be able to easily add your own
language pack. Different language packs require different settings and may require you to perform certain manual
steps. Therefore, always read the instructions, if any, that come with each language pack before you begin installing it.

If you face problems working with a language pack, try looking up the solution on the language
pack’s support thread on the Zen Cart forums before approaching the author of the language
pack for help.

Provide translations for different parts of your store
After you are sure your new language pack is installed properly, you can begin updating all your product and category
details in the new language. Also do not forget to update all your define pages like Shipping and Returns Policy page,
Privacy Notice pages, etc.

Summary
In this chapter, you have learned how to make use of the Override System to modify your files to simplify any Zen
Cart upgrades you need to perform in future. This should be the approach you use whenever you need to make changes
to your store. You have also seen how language packs and changes in CSS files can drastically change the look-and-
feel of your store.

Although it is fun and exciting to change things around, always note down your changes in case you make a mistake
in your configuration and need to roll back your store’s look-and-feel to a previous state.
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Part V

Managing your store

This section discusses the activities you need to carry out once your store goes ‘live’ and starts accepting customer
purchases. You will learn to manage customers, configure stock settings and process orders. Different marketing
techniques are also presented to help you attract customers, boost sales and maintain rapport. Finally, you will learn
to deal with system administration duties to make sure your store runs smoothly.

This section covers the following topics:

▪ Chapter 21, “Managing customers”

▪ Chapter 22, “Managing orders”

▪ Chapter 23, “Managing stock”

▪ Chapter 24, “Marketing”

▪ Chapter 25, “System administration”

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



311

Chapter 21:

Managing customers

Introduction
Zen Cart provides a simple customer management interface for you to keep track of customer orders and to email
them if necessary. You also have the ability to specify a custom authorization status for customers, restricting their
purchasing actions in your store.

In this chapter, we shall:

▪ Manage common customer details.

▪ Manage individual customer details.

▪ Understand the impact of deleting customers.

▪ View the total number of customers in your store.

Common customer settings
Common customer settings affect all customers. It is closely related to the Create Account, Edit Account, Add Address
Book and Edit Address Book pages in your Store Front where customers can manage their account information. You
may want to refer to the screen shots in the section “The Store Front” to refresh your memory on how those pages
look before proceeding further.

To edit settings common to all customers:

1. Click on Configuration > Customer Details to access the common Customer Details screen.

2. To enable or disable the display of certain fields in the Create Account, Edit Account, Add Address Book and
Edit Address Book pages in your Store Front, edit the following fields accordingly:
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▪ Email Salutation

▪ Date of Birth

▪ Company

▪ Address Line 2

▪ State

▪ Create Account Default Country ID

▪ Fax Number

▪ Show Newsletter Checkbox

▪ Customer Default Email Preference

3. The State - Always display as pulldown? field alters how the State/Province field in the Log In screen of your
Store Front works. When set to true, a drop-down list box will be displayed for the State/Province field instead
of an input box. The entries in the drop-down list box are populated based on the currently selected entry in the
corresponding Country field of the Log In screen.

The entries in the State/Province field are actually taken from the settings you have configured via Locations/Tax-
es > Zones in the Admin Console. Various possible appearances of the State/Province field in the Store Front can
be seen in the following screen shots.

4. If you do not want customers to see a product notification prompt after the checkout process as shown in the
following screen shot, disable the Customer Product Notification Status field.

5. The Customer Shop Status - View Shop and Prices and Customer Approval Status - Authorization Pending
fields are related to the shopping functions of your store. Refer to the section “Working with store and catalog
restrictions” for details.

6. Do not edit the Customer Authorization: filename unless you are absolutely sure you know what you are doing!
This field specifies the name of the PHP file in Zen Cart that controls how customer authorization works.

7. Other fields related to how you want your store to be displayed, depending on the approval status of your customers
are as follows:
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▪ Customer Authorization: Hide Header

▪ Customer Authorization: Hide Column Left

▪ Customer Authorization: Hide Column Right

▪ Customer Authorization: Hide Footer

▪ Customer Authorization: Hide Prices

8. The Customers Referral Status field is related to how you want to use Discount Coupons to set up a referral
system in Zen Cart. Refer to the section “Implementing a customer referral scheme via discount coupons” for
details on implementing a customer referral scheme.

Do not set the State field which you encountered in the Customer Details screen to false unless
you understand the impact it has on tax calculations. Refer to the section “Impact of customer
zone information” for details on this issue.

To control the length of a customer field or to make a field optional:

1. Click on Configuration > Minimum Values to access the Minimum Values screen.

2. Only the following fields affect a customer’s profile in your Store Front. You can edit each field individually to
specify a minimum length for it. Note that the Nick Name field is only applicable if you have phpBB (http://
www.phpbb.com) installed. As this field relates to another piece of software, we shall not discuss it in this book.
▪ First Name

▪ Last Name

▪ Date of Birth

▪ E-Mail Address

▪ Street Address

▪ Company

▪ Post Code

▪ City

▪ State

▪ Telephone Number

▪ Password

3. Only the following fields can be made optional instead of compulsory. To do so, set the relevant field to 0 or
blank and settle on the one that works. Remember that the optional field will also need to be set to true in the
Customer Details screen.
▪ Date of Birth

▪ Company
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▪ Post Code
▪ Telephone Number

To control the maximum number of address book entries your customers are entitled to:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Address Book Entries field.

Individual customer settings

The Customers screen
The selection of individual customers and their respective configuration and functions are accomplished through the
Customers screen by clicking on Customers > Customers.

To change the number of customers appearing in the Customers screen, click on Configuration
> Maximum Values and edit the Maximum Display of Customers on Customers Page field.

Editing a customer’s details
To edit individual customer details:

1. Select a customer from the Customers screen and concentrate on the side-panel.

2. Click on edit to access the customer’s details screen.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 21. Managing customers 315

Most fields contain information captured when the customer signed up for an account with your store so we shall
not discuss them further. You will probably not need to make any changes to these fields because customers can
change their personal information anytime by logging into their own accounts.

3. The Customer Authorization Status allows you to control how the shopping function in your store should appear
to a particular customer. Refer to the section “Working with store and catalog restrictions” for various options on
how your store’s shopping function can be configured.

4. The Discount Pricing Group field allows you to assign a discount group to a customer. This field was discussed
in the section “Customer group discounts”.

5. The Customer Referral 1st Discount Coupon field will be discussed later when we talk about it in the sec-
tion “Implementing a customer referral scheme via discount coupons”.

Sending emails to selected customers

To send emails to selected customers:

1. Select a customer from the Customers screen and concentrate on the side-panel.

2. Click on email to access the screen for you to start composing your email message.
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The Rich Text Message text area allows you to send HTML-formatted email messages to your customers. It will
only appear if you set Enable HTML Emails to true when you click on Configuration > E-Mail Options.
Furthermore, if you have installed a rich-text editor, you can use the rich-text editor by selecting it from the Text
Editor drop-down list box as shown in the preceding screen shot.

3. Choose the email recipients from the drop-down list box in the Customer field. There is a wide choice of customers
you can choose from, namely:
▪ All customers.
▪ All newsletters subscribers.
▪ Customers who have been dormant for more than 3 months and are also newsletter subscribers.
▪ Active customers in the past 3 months who are also newsletter subscribers.
▪ Active customers in the past 3 months regardless of whether they are newsletter subscribers.
▪ Any individual customer, regardless of subscription status.

4. The From field for sending out emails is automatically populated.

To change to another email address to automatically appear next time, click on Configuration > E-Mail Options
to access the E-Mail Options screen and change the value of the Email Address (sent FROM) field. However,
this is not recommended because it affects all emails sent from your store.

5. Enter the subject line for your email message in the Subject field.

6. Enter your message in the Rich Text Message field for customers who prefer to receive HTML formatted emails.

7. Enter your message in the Text-Only Message field for customers who prefer to receive their emails in plain text.

8. Click on preview to proceed to the next screen to preview your email message.

9. Click on send mail to begin sending your email.

10. A success message will appear at the top of the screen if the email was sent successfully.

Viewing a customer’s order history
This function is available only to customers who have purchased products from your store.
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To manage individual customer orders:

1. Select a customer from the Customers screen and concentrate on the side-panel.

2. Click on order to access the Orders screen showing a list of orders previously made by the selected customer.

3. We will discuss the individual functions available in the Orders screen in the following chapter.

Deleting customers
To delete a customer, go to the Customers screen and click the delete button in the side-panel next to the selected
customer. Before you do that, take note of the following point.

Deleted customers will still have their orders preserved in Zen Cart. This is to comply with most
regulations which require that records of order transactions be kept to prevent accounting fraud.

Therefore, instead of deleting customers, you might want to set the Customers Authorization Status of the customer
to one of the pending statuses instead.

Determining how many customers you have
To view the total number of customers you have, click on Admin Home on the navigation menu and look at the
Customers field under the Statistics table.
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Sometimes, the figure reflected in the Customers field may not be what you want because you have disabled several
accounts by setting their authorization status to either the Pending Approval or Banned statuses. In that case, you
should subtract the number of non-approved customers from the above statistic to get a true view of the number of
customers you have.

To check the number of non-approved customers you have:

1. Click on Customers > Customers to access the Customers screen.

2. Click on the Asc or Desc hyperlink under the Authorized column to sort customers via their approval status. Note
that non-approved customers are represented by a red button icon in the Authorized column.

3. Count the number of non-approved customers based on the number of red button icons in the Authorized column.

Summary
In this chapter, you have learned how to manage both common and individual customer settings in Zen Cart. Main-
ly, you were shown how to manage customer details, send email to customers and also how to view an individual
customer’s order history.
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Chapter 22:

Managing orders

Introduction
Once a customer purchases products from your store, orders are generated and saved into Zen Cart’s database. Based
on these orders, statistics can be generated which allow you to gain an insight into how your store sales are faring.
With each order, you will also be able to generate the corresponding invoices and packing slips which will be attached
to your product shipment for delivery to customers.

In this chapter, we shall:

▪ Go through order statistics.
▪ Understand the different order statuses.
▪ Examine the different order processing stages.
▪ Learn how to reset order IDs.

Viewing order statistics
Zen Cart provides an easy way for you to view the following statistics for your orders:

▪ Total number of orders for each order status.
▪ Quick view of new orders received.

To access your order statistics:

1. Click on the Admin Home hyperlink near the top of your Admin Console.

2. Statistics relating to your customer orders are found in the New orders and Orders tables.

Working with order statuses
Each stage of the order fulfillment process can be reflected using an order status. Customers who log in to their accounts
can then track their orders themselves without having to call you. The following screen shot shows the different order
statuses appearing in different pages of a customer’s account.
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To change the number of orders displayed in the My Order History page of the customer’s
account, click on Configuration > Maximum Values and edit the Customer Order History
List Per Page field.

A customer can click on the "view" button to access the Order Information page as shown in the following screen
shot. Whenever you update the status of an order or add customer-visible comments to an order, the comments will
also appear on this page.

Another use for order statuses is to control whether digital downloads purchased from your store are entitled to imme-
diate or delayed downloads. Refer to the section “Selling downloadable products” if you have forgotten how down-
loads are configured.
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Typical usage of order statuses

By default, there are four order statuses available in your store. Let us use the following table as an illustration of their
typical usage based on the order management workflow common to most online businesses.

Table 22.1: Meaning of different order statuses

Status Meaning

Pending The default status defined in Zen Cart to assign to an order after a customer completes the
checkout process. Note: You can re-assign the default status to another order status.

Processing You acknowledge the receipt of an order and inform customers that you are currently look-
ing into their orders and taking the necessary steps to prepare the products before delivering
the items to them.

This usually denotes that payment has been received and is therefore the status typically
used for payment modules which process credit card payments in real-time.

Delivered Indicates that products which customers have ordered have been shipped. This step usually
signals that the order fulfillment process has been completed.

Update Usually used only for exceptional cases in the order fulfilment process. For example, cus-
tomers receive their products but complain that the products are faulty. You can then set the
order status to "Update" for you to conduct further investigation into the matter before de-
ciding whether to grant a full or partial refund to the customer.

Another special case is the resetting of download properties for downloadable products in
a customer’s order as mentioned in the section “Step 4 of 5: Specify when downloads are
made available”.

There is no "hard-wiring" of order statuses to meanings and so you are always free to alter their meanings to suit your
business needs.

For example, if your online store sells rental space for a block of flats; since you have nothing to deliver, the "Shipped"
status becomes meaningless. Instead, you can think of the "Shipped" status as a "Rented" status or even customize
it to fit your own needs.

Customizing order statuses

As mentioned earlier, your business needs might require that you have additional order statuses to cater for your order
fulfillment work flow. For example, if your store offers refunds for faulty products shipped to customers, you can
choose to create an additional "Pending Goods Return" status to indicate you are waiting for your customer to return
the faulty products before refunding them the amount for the purchase.

To customize the order statuses available in your store

1. Click on Localization > Order Status to access the Orders Status screen.
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Pay attention to the order status which appears in bold and is marked as the default order status on the screen. If
your payment modules have their Set Order Status field set to default, then your customer’s order status will
be set to the corresponding default order status in this screen upon a successful checkout.

2. To change the name of an order status or to edit its other fields, choose the order status and then click on edit.

3. To create an additional order status, click on insert.

4. To remove an existing order status, click on delete. Before doing so, make sure you have considered the following
warning.

Avoid deleting the default order statuses that come with Zen Cart as they are used in several
parts of your store. For example, when configuring whether customers are entitled to immediate
or delayed product downloads.

Instead, you should only delete an order status if you have created it yourself and no longer need
to use it. However, there is a catch you need to be aware of - if you delete an order status that
is linked to any existing orders, then those affected orders will not display their order statuses
correctly!

Processing orders
Now let us turn our attention to how you actually manage the orders from within your Admin Console. Before you
do that, you might want to turn to the section “The Store Front” to get an idea of how customers in your store interact
with an order after they have made their purchases.

Overview of the main screens
There are two main screens that you will use to manage your orders. As such, we will take a closer look at them in
order for you to make sense of them and to work more efficiently with them.

The Orders screen

Most functions pertaining to order management in Zen Cart first go through the Orders screen. There are several ways
in which you can access the Orders screen. The two most common ways are as follows:

▪ To access the Orders screen for all customers, click on Customers > Orders.

▪ To access the Orders screen for individual customers, click on Customers > Customers and then click on orders.
The Orders screen accessed via this method will contain an extra reset button. By clicking on that button, your
screen will refresh to show an Orders screen for all customers.
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The following sample screen shot shows an Orders screen for all customers.

To change the number of orders that appear in each Orders screen, click on Configuration >
Maximum Values to access the Maximum Values screen and edit the Maximum Display of
Orders on Orders Page field.

Here are some points to note about the Orders screen:

▪ The first column is the Order ID and it is the unique number used to identify your order. You can do a search for a
particular order in the Order ID field near the top-right corner of the screen.

▪ If the shipping and billing addresses differ for an order, a little "red" icon will appear to the left of the order ID.
This is a good indicator for store owners to scrutinize the order more carefully since fraud is common when large
amounts of money are paid using one billing address but are to be delivered to a different location.

That said, there can be genuine cases for different billing and shipping addresses. For example, if a customer were
to buy a product from your store as a gift to a friend.

Note that for orders that contain only downloadable products, the little "red" icon will always appear because these
orders contain only billing addresses and no shipping addresses as the Shipping Information page is skipped during
checkout.

▪ Next to every customer’s name in the Customers column is a little "note" icon. When you click on this icon, it will
immediately bring you to the Customers screen where a short preview of the relevant customer is displayed in the
side-panel as seen in the following screen shot.

▪ A "yellow" icon is shown under the Customer Comments column only if an order contains comments entered by
a customer during checkout.

▪ The side-panel contains a brief summary of an order’s details and buttons acting as shortcuts to actions you can
perform via the order’s details screen as well.

Make a mental note of the Orders screen as we shall be referring to it throughout this chapter.

The Order Details screen

As its name implies, the Order Details screen provides all the details of a customer’s order. It is accessible when you
click the edit button in the respective side-panel of an order in the Orders screen.
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The details in the Order Details screen may vary depending on the type of items in the order (e.g downloable products),
modules you are using (e.g. PayPal), or other add-ons you have downloaded and installed. If your order includes
tax calculations, the prices displayed may be different from what you expect. Refer to the section “Display of tax
information” for more information on how taxes are displayed.

To get an idea of how an Order Details screen may look like, refer to the following screen shot where a customer has
paid via the Cash-On-Delivery payment module for a set of downloadable files and a laptop.

Many of the fields in the Order Details screen are self-explanatory so we shall only highlight the less common ones,
namely:

▪ The Invoice Number corresponds to the Order ID of the order. It is just another name to refer to the order in this
screen.

▪ The IP address field shows two different IP addresses. The one on the left gives the IP address of the computer the
customer used to log in to your store and the other one is the IP address used to complete the purchase. The two IP
addresses can differ for a number of reasons. Common situations usually involve the use of third-party gateways
(e.g. PayPal) which have their own IP addresses different from those that customers use to log in with.
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▪ The table containing a row of status buttons is only visible if the customer has purchased any downloadable products.

Make a mental note of the Order Details screen as well because we shall be referring to it throughout this chapter.

Updating order information
Each time you perform a task in your order fulfillment process, you can update the status of an order. Order statuses
which have been updated will be reflected when customers log in to their accounts to view their order history. Fur-
thermore, you also have the option of sending an email to customers upon updating their order statuses.

To update an order’s information:

1. Go to the Order Details screen of the order you are interested in.

2. Concentrate on the following part of the screen.

3. Add any remarks you have regarding the updated order status in the Comments field.

4. Optionally, choose a new order status from the Status drop-down list box.

5. If you have entered some comments in the Comments field, you can control how the comments will be displayed
as follows:

▪ Select the Email radio button but do not check the Append Comments checkbox if you do not want to include
your comments in the order update email sent to a customer but want the comments to be displayed in the
customer’s Order Information page in the Store Front.

▪ Select the Email radio button and check the Append Comments checkbox if you want to include your com-
ments in the order update email sent to a customer and also want the comments to be displayed in the customer’s
Order Information page in the Store Front.

▪ Select the No Email radio button if you do not want an order update email to be sent to the customer but want
the comments to be displayed in the customer’s Order Information page in the Store Front.

▪ Select the Hide radio button if you do not want an order update email to be sent to the customer and for the
comments not to be displayed in the customer’s Order Information page in the Store Front.

6. Click on update to confirm the change in order information. If you have not changed the order status nor added
any comments before pressing the update button, then no changes will apply to the order.

Each time you update your order, a log of the order is captured and displayed in the following part of the Order Details
screen. The meanings of the icons are as follows:

▪ "tick" icon: an email was sent to the customer regarding the order. There is no indication whether the email
includes any comments by the store owner.

▪ "locked" icon: no email was sent to the customer. Comments are visible only to the store owner but not the
customer (i.e. private comments).

▪ "unlocked" icon: no email was sent to the customer. Comments are visible to both the store owner and customer.
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To verify the visibility of the comments in a customer’s Order Information page, refer to the following screen shot
which is correlated to the preceding screen shot.

If you want to receive copies of the order confirmation emails sent to customers, click on Configuration > E-Mail
Options to access the E-Mail Options screen and enter the relevant email addresses into the Send Copy of Admin
Orders Status Emails To field. A sample plain-text email sent to a customer is shown in the following screen shot.

Resetting download limits
When dealing with orders containing downloadable products, you can reset the download limits available to a customer
at the click of a button without the need to add any comments or click the update button. This is also the only way to
control the accessibility of individual downloadable files in an order containing several downloadable files.

To enable or disable a customer’s access to a downloadable file:

1. Go to the Order Details screen of the order you are interested in.

2. Look for the button under the Status column of the table containing the downloadable files the customer pur-
chased. Consult the "LEGEND" area to understand the colors of the different download status buttons.
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3. To toggle the status of a downloadable file between "Expired" and "Available", click on the corresponding button
next to the respective file name.

Generating invoices and packing slips

Whenever you ship physical products to a customer, you will likely need both an invoice and a packing slip to ac-
company the shipment. You will be glad to know that both of these documents can be easily generated at the click
of a button.

To generate an invoice or packing slip from an order:

1. Go to the Order Details screen of the order you are interested in.

2. To generate an invoice, click the invoice button. A new window appears showing the invoice generated by Zen
Cart.

Examine the information contained in the invoice carefully. If your invoice includes tax information, the prices
displayed may be different. Refer to the section “Display of tax information” for more information on how taxes
are displayed.

3. To generate a packing slip, click the packing slip button. A new window appears showing the packing slip gen-
erated by Zen Cart.
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Examine the information contained in the packing slip carefully. Unlike an invoice, no payment information is
displayed in the document.

To change how comments will be displayed in the generated invoice or packing slip:

1. Click on Configuration > Shipping/Packaging to access the Shipping/Packaging screen.

2. Edit the Display Order Comments on Admin Invoice field to change how comments should be displayed in
an invoice.

3. Edit the Display Order Comments on Admin Packing Slip field to change how comments should be displayed
in a packing slip.

The image displayed in both the invoice and packing slip is the same one appearing in the top-left corner of your
Admin Console. You can change the image as follows:
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1. Examine or edit the following settings in the [zc-home]/[admin]/includes/languages/english.php
file. No overrides are available for this file because it is in the [zc-home]/[admin]/includes and not the
[zc-home]/includes directory. Therefore, you will need to keep a back up of it if you make any changes here.

define('HEADER_LOGO_WIDTH', '200px');
define('HEADER_LOGO_HEIGHT', '70px');
define('HEADER_LOGO_IMAGE', 'logo.gif');

2. Upload and replace the file [zc-home]/[admin]/images/logo.gif if your custom image has the same name
and dimension as that specified in the previous step.

3. If you have uploaded an image with a different name or dimension, adjust the settings in Step 1 accordingly.

To change the store information displayed on the top-left corner of the invoice, click on Configuration > My Store
to access the My Store screen and edit the Store Address and Phone field.

Deleting an order
To delete an order, go to the Orders screen and click the delete button in the side-panel next to the selected order.
Before you do that, take note of the following point.

Check with your local authorities on their view with regards to gaps in order IDs due to the
deletion of orders. There may be specific regulations you need to follow in order not to break
any laws.

Therefore, instead of deleting orders, you might want to create custom order statuses to represent the orders you want
to delete. For example, creating and assigning an order status of "Testing" for your test orders. Just remember not to
set that order status (e.g. Testing) to be the default one!

Resetting order IDs
If you have been testing your store setup, you will have undoubtedly created several test orders. Before your Zen
Cart store goes 'live' and starts accepting real customer orders, you might want to reset the order ID. For example, if
your test orders end at the order ID of "123". You might want to reset the order ID to "1000" instead. This helps you
differentiate your test orders from your real orders.

To reset your order IDs:

1. Click on Tools > Store Manager to access the Store Manager screen.

2. Concentrate on the portion of the screen as shown in the following screen shot.

3. Enter the order ID that you want Zen Cart to assign to the next order in the New Order ID field.

4. Click the reset button to use the new order ID on the next customer order.
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Summary
In this chapter, you have gone through the different order-related statistics which can help you assess how well your
business is doing. You have also learned about the characteristics of different order statuses and how to define your
own custom order statuses. Different stages in the order processing workflow were also covered. Finally, you saw how
you can reset your order IDs before accepting real-world orders.
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Chapter 23:

Managing stock

Introduction
The proper management of stock levels plays an important part in any business. Zen Cart currently provides a basic
stock management system for you to view different stock-related information and to help you meet customer demand
for your products.

In this chapter, we shall:

▪ View stock information.
▪ Configure stock settings.
▪ Specify low stock email notification.

Checking stock information
Stock information allows you to quickly see which products need replenishment or which products have yet to reach
your store for sale.

Current stock levels
To check current stock levels:

1. Click on Reports > Products Low Stock to access the Product Stock Report screen.

Notice that products with the lowest stock levels are listed first.

2. The figures displayed under the Quantity column are taken from the Products Quantity fields of the correspond-
ing products in their respective Product Details screens. Products that have their Products Status field marked as
Out of Stock in their respective Product Details screens will still be displayed in this screen.

To control the number of products that are displayed in each page of the Product Stock Report screen, click on Con-
figuration > Maximum Values and edit the Maximum Display of Products on Reports field.

Future stock expected
Another report of interest to you when assessing your stock level is the products that you have ordered but have yet to
arrive in your store. Currently, this report only displays the names of the products and not the quantity.
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To check the products that have yet to arrive:

1. Click on Catalog > Products Expected to access the Products Expected screen.

2. The dates displayed under the Date Expected column are taken from the Date Available fields of the correspond-
ing products in their respective Product Details screens.

3. To view or change the product’s details, including its availability date and quantity, click on edit to access the
product’s Product Details screens.

Configuring stock settings
Besides generating reports on stock-related information, Zen Cart allows you to configure how your stock levels are
controlled and how you want your stock-related information to be displayed to customers.

To configure your stock settings:

1. Click on Configuration > Stock to access the Stock screen.

2. The following fields on the Stock screen relate more to the display of the customer’s shopping cart contents in
the Store Front than to stock-related information. For details on these fields, refer to the section “The Shopping
Cart page”.
▪ Show Shopping Cart - Delete Checkboxes or Delete Button

▪ Show Shopping Cart - Update Cart Button Location

▪ Show New Products on empty Shopping Cart Page

▪ Show Featured Products on empty Shopping Cart Page

▪ Show Special Products on empty Shopping Cart Page

▪ Show Upcoming Products on empty Shopping Cart Page

3. The Show Notice of Combining Shopping Cart on Login field was discussed in detail in the section “Persisting
shopping cart items between visits”.

4. For a discussion of the rest of the fields that relate to your store’s stock settings, refer to the following table.
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Table 23.1: Meaning of selected Stock fields

Field Comments

Check stock level Indicates whether a warning message will be displayed when the number of items for a par-
ticular product added to a shopping cart exceeds the actual quantity of the product. Consider
the case when you set this field to true.

If you have specified that the quantity of a product is "1" and a customer adds "3" items of
the same product to the shopping cart, an error message will be displayed indicating there is
insufficient stock for the customer to purchase.

Subtract Stock Indicates whether to automatically decrease the stock level by an amount equivalent to that
which the customer purchased. Consider the case when you set this field to true.

If you have specified that the quantity of a product is "10" and a customer adds "4" items of
the same product to the shopping cart. The quantity of the product in your store will auto-
matically be set to "6" after the customer completes the checkout process.

Allow Checkout Indicates whether to prompt a customer to change the number of items in the shopping cart
if the number of items exceed the product quantity.

If you set this value to true, you run the risk of over-selling and if your suppliers cannot
meet your sudden demand, your reputation with customers will suffer. Therefore, the rec-
ommended value is false.

Mark product out of
stock

Sets the display characters that should be displayed to indicate that a product is out of stock.
An example screen shot of the default value "***" appearing in a shopping cart is shown be-
low.

Stock re-order level Specifies the level of stock that you want to use as an indicator for you to begin ordering
more supplies.

This field will come in handy if you intend to receive email alerts for products that are out
of stock.

Products status in
Catalog when out of
stock should be set
to

If you have set the Subtract Stock field to true; when the stock level reaches zero or a
negative number, the Products Status field of the product in the Product Details screen will
be updated according to the setting in this field.

If this field is set to 0, the Products Status field in the product’s Product Details screen will
be set to Out of Stock and the product will not be displayed in the Store Front. If this
field is set to 1, the Products Status field will be set to In Stock instead.

Show Sold Out Im-
age in place of Add
to Cart

If this value is set to 1, an image with the words "Sold Out" will be displayed on the Prod-
uct Info page in the Store Front instead of the usual "Add This To My Cart" button and the
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Field Comments

check box to specify the number of items to order. Similarly, a "Sold Out" image will ap-
pear in a search listing or product listing of the product.

Product Quantity
Decimals

Allows you to sell products that do not come in whole units. For example, if you sell fabric
by the yard, customers can enter 1.25 yards when adding the product to the cart.

Remember to adjust the product’s quantity-related fields in the Product Details screen if
you intend to support fractional quantity values in your store.

Receiving low stock email notifications
Zen Cart has the ability to send email alerts to you when the stock reaches the re-order level you specified in the
preceding Stock screen.

Note that an email alert will not be sent if you manually alter the product quantity to reach a level below the re-order
level. Only re-order levels that have been reached via the system subtracting the product’s quantity by an equivalent
number of purchased items will trigger the email alert.

To receive emails for stocks that have reached the re-order level:

1. Click on Configuration > E-Mail Options to access your E-Mail Options screen.

2. Edit the following fields accordingly:
▪ Send Low Stock Emails
▪ Send Low Stock Emails to

Summary
In this chapter, you have learned to view stock-related information and how to configure your desired stock settings.
You have also seen how you can configure email alerts for products that have reached a predetermined low stock level,
thus eliminating the need for you to constantly log in to your store to check your stock levels.
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Chapter 24:

Marketing

Introduction
Besides having great products and services, one of the keys to profitability is how you market your online store and
products. The marketing aims you can achieve with the techniques presented in this chapter are as follows:

▪ Direct customers to visit your store.

▪ Build long-term relationships with your customers in order to increase the likelihood of repeat sales.

▪ Promote other products which customers may not be looking to buy when they visit your store.

In this chapter, to help you achieve the above marketing aims, we shall:

▪ View statistics which will help you in your marketing decisions.

▪ Go through the following marketing techniques:

▸ Discount coupons

▸ Gift certificates

▸ Newsletters

▸ Product reviews

▸ Banners

▸ Search Engine Optimization (SEO)

▸ Other product promotion features

Note that you can also use the sales techniques presented in the section “Giving discounts” to achieve some of the
marketing aims.

Be warned that this chapter is very long. So if you are short of time, you should just read the section “Gathering useful
statistics”, and then jump to a specific marketing technique you are interested in implementing.

Gathering useful statistics
Before deciding on a marketing technique to use, you should gather some statistics to understand current customer
spending and viewing behavior in your store. You can then measure the effectiveness of each marketing technique
by comparing the before-and-after results of these statistics. These statistics can also be used to target high-value
customers because repeat business from these customers will have a higher impact on your profits.

Products viewed and products purchased

Statistics generated from products viewed and products purchased from your store allow you to tailor your marketing
campaign in a product-centric manner. For example, if you realize a product is commonly viewed but not usually
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purchased by customers, you can create and send a newsletter to your customers telling them the benefits of the product
thus creating the impetus for them to buy.

To view statistics for products viewed, click on Reports > Products Viewed to access the Best Viewed Products
screen.

To view statistics for products purchased, click on Reports > Products Purchased to access the Best Products Pur-
chased screen.

You may want to reset the statistics for the preceding screens if you wish to begin a new marketing campaign. In this
way, the effectiveness of your marketing campaign can be more easily determined as you do not have to take into
account any old values when viewing the statistics.

To reset the statistics for the preceding screens:

1. Click on Tools > Store Manager and concentrate on the following portion of the screen.

2. To reset the statistics for the Best Viewed Products screen, click on the reset button next to the Reset ALL
Products Viewed field.

3. To reset the statistics for the Best Products Purchased screen, click on the reset button next to the Reset ALL
Products Ordered field

To control the number of products that are displayed in each page of the Best Viewed Products
screen and Best Products Purchased screen, click on Configuration > Maximum Values and
edit the Maximum Display of Products on Reports field.

Total order values per customer
Statistics generated from the relationship between customers and their total order values allow you to tailor your
marketing campaign in a customer-centric manner. For example, you can use this information to identify high-value
customers and use Discount Coupons or Gift Certificates to reward them and breed long-term customer loyalty.

To view statistics relating customers to total order values, click on Reports > Customers Orders-Total to access the
Best Customer Orders-Total screen.
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The statistics presented in the Best Customer Orders-Total screen are not very accurate as it includes all orders a
customer has purchased; including duplicate orders and refunded orders.

Recall that store owners have the flexibility to assign non-standard order statuses (e.g. "Withheld") to their orders to
suit their business processes. Hence, there is no definite way for Zen Cart to know exactly which orders have been
refunded or are duplicate transactions based on their order statuses alone.

Discount coupons
Discount coupons are used by customers to purchase products at a discounted value. The discounted value can either
be a percentage off a product’s price or an absolute dollar amount. Discount coupons can also be applied to customer
orders to give free shipping if a minimum order value is reached.

They have proven to be very popular with customers and can be used as a low-cost way of introducing your product
to the marketplace. For example, you can give out discount coupons to loyal customers to try your new products at
a discounted rate. Over time, your products will gain the recognition of customers as they keep coming back to buy
more products from you.

As discount coupons may eat into your profits, you should exercise discretion when using them. Zen Cart can help
you in this aspect by restricting the use of discount coupons to certain categories of products only.

How discount coupons work
An outline of how discount coupons work is as follows:

1. Discount coupons are created by store owners and sent to customers either during account creation or selectively
via email from the Admin Console. Alternatively, discount coupon codes can be advertised in newspapers and
magazines or disseminated through salespersons if you want to implement a customer referral scheme.

2. Store owners can choose to restrict the usage of discount coupons to certain categories and products. Coupon
usage can also be restricted based on the billing addresses of customers.

3. Customers can make use of their discount coupons when they are prompted to enter a discount coupon code on
the Payment Information screen during the checkout process.

Configuring the Discount Coupon module
Before you can start using Discount Coupons in your store, you need to enable and configure the Discount Coupon
order total module as follows:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Discount Coupon module. Install it if required.
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3. Enter a suitable value for the Sort Order field. Refer to the section “The Order Total Modules screen” if you
have forgotten the purpose of this field.

4. Specify true for the Include Shipping field if you want shipping charges to be covered by a discount coupon.

5. Specify true for the Include Tax field if you want taxes to be covered by a discount coupon.

6. The Re-calculate Tax field must be set to none if you have set Include Tax as true or you will receive an error
message later. none is also the most commonly used setting. If you choose Standard or Credit Note, you will
need to play around with different test orders to see whether they suit your needs.

7. If you have chosen Credit Note for the Re-calculate Tax field, you should choose a suitable option from the
Tax Class drop-down list box.

8. Click update to finish configuration of your Discount Coupon order total module.

You should play around with the Sort Order field for all the order total modules if you encounter erroneous or
illogical calculations. If that does not help, your last resort is to refer to the PHP code contained in the [zc-home]/
includes/modules/order_total/ot_coupon.php file.

After a Discount Coupon module is enabled, a Discount Coupons hyperlink will appear in the Information side-box.
Upon clicking this hyperlink, visitors can type in a discount code to view the details associated with that particular
discount code. The following screen shots illustrate the process.
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Creating discount coupons

To create a discount coupon:

1. Click on Gift Certificates/Coupons > Coupon Admin to access the Discount Coupons screen.

2. Click on insert to access the Discount Coupon Details screen.
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3. All fields on the screen have corresponding explanations next to them so you should not have any problems
entering the correct values. However, before entering the relevant details into the screen, take note of the following
points:

▪ Coupon Amount and Free Shipping are mutually exclusive! You should only specify one or the other; but not
both at the same time. The system will not show any errors but you will have problems later when customers
start using their coupons. Also make sure the Free Shipping module is enabled if you enable the Free Shipping
check-box.

▪ It is a good idea to leave the Coupon Code field empty to allow Zen Cart to generate a unique code for you.
This is because humans tend to specify coupon numbers in sequence and clever customers might just make use
of this loophole to use the coupon codes of other customers!

▪ What you specify for the Uses per Coupon field will depend on how you structure your coupon marketing
campaign. The following two scenarios should help you decide what value to enter for the field:

If you advertise a 10% discount coupon in the newspapers for a laptop your store sells, you are limited to a
single discount coupon code for that advertisement. Thus, you would have to leave the Uses per Coupon field
blank because you want as many people as possible to use the same discount code to purchase the laptop from
your store.

If you send unique discount coupons to customers on their birthdays, then you might want to restrict them to
use the coupon for one time purchases only. In this case, you should specify 1 for the Uses per Coupon field.

▪ The Uses per Customer field allows you to limit the use of a discount coupon on a per-customer basis.

There might be some confusion with the Uses per Coupon field if you happen to specify both at the same time.

For example, if you had specified Uses per Coupon to be 50 and Uses per Customer to be 1, then how many
times can each customer use a particular coupon? The answer is each customer can use a particular coupon only
once. However, if the same coupon is given to another 60 customers, then only the next 49 customers can use
the same coupon code and each of those 49 customers can only use the coupon once as well.

▪ You are strongly advised to set the Start Date and End Date fields to limit the validity period for your discount
vouchers. There are two benefits to this approach:
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▸ Customers will tend to make their purchase decisions faster with a looming expiry deadline for their discount
coupons.

▸ It limits the possibilities of customers turning up with old discount coupons with rates you offered long ago,
which are no longer profitable for you to continue offering now.

▪ If you want to restrict coupon usage to a particular zone, select your desired zone from the Coupon Zone
Restriction drop-down list box. Note that if you had checked the Free Shipping checkbox, the zone restriction
will apply to a customer’s shipping address, otherwise it will apply to a customer’s billing address.

4. After entering all the relevant coupon details, click preview to proceed to the next screen to have a look at your
changes.

5. Once you are satisfied with your changes, click confirm to create the coupon.

To change the number of discount coupons appearing in the Discount Coupons screen, click on
Configuration > GV Coupons and edit the Maximum Discount Coupons Per Page field.

Restricting coupon usage by category or product
It is a good idea to restrict the use of your coupons to certain categories of products in your store. This allows you to
better control the cost of running your discount coupon campaign as you can work out which products you can afford
to offer at discount, and with what percentage or value, without eating into your profits significantly.

To limit the use of discount coupons to certain categories or products:

1. Select the discount coupon to which you want to apply a restriction from the Discount Coupons screen.

2. Click on restrictions to bring up a screen for you to restrict the use of the discount coupon to certain categories
and products.

3. To restrict your coupon usage to specific categories, choose from the relevant drop-down list boxes under the
Category Restrictions heading. After making your choice, click Add to confirm the restriction. Repeat this step
for all other categories you wish to restrict.

4. To restrict your coupon usage to specific products, choose from the relevant drop-down list boxes under the
Product Restrictions heading. Choose the different products you want to allow or deny and click Add. Repeat
this step for all other products you wish to restrict.

5. After you are satisfied with your choice, click back to return to the Discount Coupons screen.
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The use of your discount coupon should now be limited only to the specific categories and/or products you have
allowed or denied. If you face problems configuring your product restrictions, try setting Deny on the Top category
before setting Allow on individual products.

Delivering discount coupons to customers electronically
There are two ways by which discount coupons can be sent to customers electronically:

▪ Selectively email discount coupons to customers manually via the Admin Console.
▪ Send discount coupons automatically to customers upon account creation.

Manually email discount coupons to customers

To receive copies of discount coupon emails sent manually via the Admin Console, click on Configuration > E-Mail
Options and enable the following fields:

▪ Send Copy of Admin Discount Coupon Mail Emails To - Status
▪ Send Copy of Customer Admin Discount Coupon Mail Emails To

To send discount coupons to customers directly via the Admin Console:

1. Click on Gift Certificates/Coupons > Coupon Admin to access the Discount Coupons screen.

2. If you have installed a rich-text editor and want to use it to help you compose HTML email messages in a Rich-
Text Message text area you may see in the next screen, choose it from the Text Editor drop-down list box.

3. Select the discount coupon you want to mail to your customers and click email on the side-panel to bring up the
email details page.

You will see two text areas for you to enter your email message if you have enabled Enable HTML Emails in
Configuration > E-Mail Options.

4. Enter the relevant details and click send mail to bring up another screen for you to preview your email message.

5. Click on send mail in that screen to send your discount coupons to the relevant parties.

A sample discount coupon plain-text email sent to a customer via the Admin Console is shown in the following screen
shot.
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Automatically send a discount coupon on account creation

To receive copies of discount coupon emails sent automatically to customers on account creation, click on Configu-
ration > E-Mail Options and enable the following fields:

▪ Send Copy of Create Account Emails To - Status
▪ Send Copy of Create Account Emails To

To enable selected discount coupons to be sent on account creation:

1. Click on Configuration > GV Coupons to access the GV Coupons screen.

2. Click on New Signup Discount Coupon ID# and concentrate on the side-panel.

3. Choose a discount coupon you have previously created from the drop-down list box and click update. The selected
discount coupon will be sent to the next customer who signs up for an account with your store.

4. If you want to change the generated discount coupon code length, edit the Length of the redeem code field.
For example, if you specify this length to be 10, then the redeem code generated by Zen Cart may look like
9e47daba3b.

If you had previously specified your own value instead of leaving the code generation to Zen Cart for the Coupon
Code field when creating the discount coupon, then this field will have no effect. Furthermore, note that a change
to this field will also affect the length of the redeem codes for gift certificates!

5. If you want to change the order status for an order total balance of zero after applying your discount coupon, you
can edit the Default Order Status For Zero Balance Orders field.
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A sample discount coupon plain-text email received by a customer on account sign-up is shown in the following screen
shot. Note that the screen shot only shows the portion where the discount coupon details are highlighted and not the
entire email.

Implementing a customer referral scheme via discount
coupons
A Customer Referral scheme allows you to expand your customer base and assess how effective your marketing
campaign is by tracking how effective your different channels of marketing (salespersons, advertisements, etc) are
performing.

For example, if you have a team of salespersons, you can give each of them a unique discount code. Your salespersons
will give out their individual discount codes to each new customer they find for your business. When these new
customers sign up for an account with your store, they will use the unique discount code of the salesperson who
introduced them to your business. In this way, you can track the performance of each salesperson by looking at the
number of new customers who sign up with your store using the unique discount code of a salesperson.

How customer referrals work

The term referral code appears constantly when discussing referrals. It is actually a discount coupon code which has
been "tagged" to specific customers to identify how they arrived at your store. It can only be used once per customer
and is used to find out how customers come to know about your site.

For example, when a customer signs up with your store using a discount code they acquired from a magazine, radio
or TV advertisement. That discount code is then known as a referral code because that customer was "referred" to
your store by that magazine advertisement.
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Here is how referrals works in Zen Cart:

1. Discount coupons are created.

2. Discount coupons are then disseminated through different channels accordingly; salespersons, advertisements,
parties, etc.

3. Customers learn of your online store through one of your referrers (salespersons, advertisements, etc).

4. Customers sign up with your store using the discount code you handed out in Step 2. Optionally, customers can
enter the discount code handed out in Step 2 when they check out their purchases.

5. Zen Cart associates each discount code with the referrer and calls it a referral code.

6. Store owner views a report of how the different referrers and referral schemes have performed.

Track customer referrals

There are two methods to track customers who were referred to your site:

▪ When customers sign up for a new account, they can enter the referral discount coupon code on the sign-up form
of the Log In screen.

In this case, Zen Cart is able to determine the referrer immediately after the account creation process completes
successfully.

▪ When customers enter their referral discount coupons in the Payment Information screen during checkout.

In this case, Zen Cart stores the first discount coupon code used by the customer during checkout in order to identify
the referral source.

To configure which method you would like to use to track customer referrals:

1. Click on Configuration > Customer Details to access the Customer Details screen.

2. Click on Customer’s Referral Status field and concentrate on the side-panel.
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▪ Choose 0 if you do not want to use the Customer Referral feature.

▪ Choose 1 if you want to track customers by noting the first time a discount coupon is redeemed by them.

▪ Choose 2 if you want to track customers by asking them how they were referred to your store from the sign-up
portion of the Log In screen or when customers edit the referral source in their My Account area if the referral
source has not already been set.

3. Click on update to effect your changes.

Once a referral code has been attached to a customer, only the store owner can change the referral code. To see where
the referral code for a customer is stored:

1. Click on Customers > Customers to access the Customers screen.

2. Select your desired customer and click the edit button on the side-panel.

3. The referral code for a customer is shown in the Customer Referral 1st Discount Coupon field as shown in
the following screen shot.

View report on customer referrals

To view the performance of your referrers and referral schemes:

1. Click on Reports > Customers Referral to access the Customers Referral Report screen.

2. Choose a referral coupon code from the drop-down list box at the top of the screen.

3. Specify which period of the report you would like to view by entering the appropriate dates into the Start Date
and End Date fields.
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4. Click display and a list of orders using the particular referral coupon you specified in Step 2 will be displayed
as shown in the following sample screen shot.

Viewing discount coupon usage statistics

To view the usage statistics for individual discount coupons:

1. Click on Gift Certificates/Coupons > Coupon Admin to access the Discount Coupons screen.

2. Select a discount coupon and click Report to bring up the Discount Coupons Report screen.

To change the number of entries appearing in the Discount Coupons Report screen, click on
Configuration > GV Coupons and edit the Maximum Discount Coupon Report Results Per
Page field.

Gift certificates
Gift certificates are commonly used as a marketing tool for businesses as they offer the following advantages:

▪ Convenient for people who do not know what gifts to buy.

▪ Provide immediate cash to the business without having to supply a product or service until a later date. Thus,
they behave similarly to an interest-free loan.

▪ Inexpensive way to widen your customer base.

There are some important concepts to take note of before you start offering gift certificates in your store:

▪ Unlike discount coupons for which you can specify an expiration date, gift certificates represent real money and
do not expire.

▪ Gift certificates can be purchased by customers like ordinary products, sent by store owners to customers or
transferred between customers.
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▪ Discounts cannot be applied to gift certificates.

▪ A unique code is associated with each gift certificate.

▪ Gift certificate values are transferable. For example, if a customer has a $100 gift certificate, he is able to transfer
$20 to his relative and his account will be left with $80.

▪ They cannot be restricted to different categories like discount coupons.

The terms Gift Certificate and Gift Voucher are used interchangeably in Zen Cart.

How gift certificates work

An outline of how gift certificates work is as follows:

1. Gift certificates are created as products and sold; or they are created by the store owner and sent to customers
either during account creation or selectively via email from the Admin Console.

2. Customers who purchase gift certificates will have the amount credited into their gift certificate accounts in your
store. Customers who receive their gift certificates via email will have to redeem them at your store using the gift
certificate code in their emails. After a gift certificate is redeemed, the gift certificate amount will be credited into
the gift certificate account of the redeemer.

3. To prevent cases of fraud, the store owner can configure whether gift certificates need to be approved before they
can be used in your store.

4. The value contained in gift certificates can then be used when purchasing products from your store. The customer
will be prompted to enter a gift certificate code on the Payment Information screen during the checkout process.

To give you a more complete picture of the workings of gift certificates, we shall cover the following areas in greater
detail.

▪ How customers receive their gift certificates.

▪ How gift certificates are displayed on customer account screens.

▪ How gift certificates are used for purchase and transfer.

How customers receive their gift certificates

There are actually several ways by which customers can receive their gift certificates.

▪ Customers can buy them from your store if you have created your gift certificates as products.

▪ Store owners can create gift certificates and send them to selected customers manually via email. Alternatively,
gift certificates can be automatically sent via email on account creation.

▪ Customers can also receive their gift certificates from other customers. If the receiving parties are not currently
customers of your store, they will be prompted to sign up for an account before their gift certificate values can
be redeemed.

Gift certificates which are not bought as products from your store will have to be redeemed. Details required to redeem
a gift certificate are contained in emails sent to customers. A sample gift certificate email sent to a customer by a store
owner is shown in the following screen shot.
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Redemption of gift certificate values

There are two ways customers can go about redeeming the values in their gift certificates as shown in the gift certificate
emails sent to them:

▪ By clicking on the hyperlink which contains a gift certificate code in the gift certificate email sent to them, the
customer will be redirected to your online store. After logging in or creating a new account if the customer does
not have an account yet, the gift certificate value will automatically be redeemed. A success message indicating the
value of the gift certificate redeemed will be shown to the customer as seen in the following sample screen shot.

▪ By entering the gift certificate code contained in the gift certificate email in the Redemption Code field of the
Payment Information screen during the checkout process.

A success message indicating the value of the gift certificate redeemed will be shown to the customer only when
proceeding to the next screen. A sample success message when a $50.00 gift certificate is redeemed is shown in
the following screen shot.

The gift certificate account balance

Customers can check their gift certificate balance when they log in to view their account details. A gift certificate
balance displayed in a customer’s account is shown in the following sample screen shot.
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Alternatively, if a customer is logged in, the gift certificate balance will be displayed in the Shopping Cart side-box
as shown in the following screen shot.

How gift certificates can be used

Customers can choose to use their gift certificates for the following purposes:

▪ Purchase of products in your store using the balance in their gift certificate account.

▪ Transfer the value (either wholly or partially) to someone else.

To purchase products using the balance in their gift certificate accounts:

▪ At the Payment Information screen during the checkout process, customers can make full or partial use of the money
currently in their gift certificate accounts for their purchase by entering a suitable value in the Apply Amount field.

Alternatively, if customers want to redeem and use the value in a gift certificate at the same time, they can enter
the redeem code into the Redemption Code field instead.

To transfer the values within their gift certificate account balances:
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▪ Customers can click on the Send a gift certificate hyperlink in their Account Information screen and the following
screen will appear.

After they are done filling in the details in the screen, they can click send to transfer a portion of their gift certificate
account balance as a gift certificate to another person.

When customers transfer the gift certificate amounts in their accounts to other customers, you can also be notified
via email. To set up this email notification, go to Configuration > E-Mail Options and set the following fields
accordingly.

▪ Send Copy of Customer GV Send Emails To - Status

▪ Send Copy of Customer GV Send Emails To

Configuring the Gift Certificates module

Before you can start using gift certificates in your store, you need to enable and configure the Gift Certificates order
total module as follows:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Gift Certificates module. Install it if required.
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3. Enter a suitable value for the Sort Order field. Refer to the section “The Order Total Modules screen” if you
have forgotten the purpose of this field.

4. The Queue Purchases field is only relevant for gift certificates that are purchased as products from your store.
This field has no effect for gift certificates that are emailed to customers.

Choose false for the Queue Purchases field if you want the amount in a gift certificate to be credited automat-
ically into a customer’s gift certificate account after purchase. If Queue Purchases is set to true, you will have
to manually credit the amount to the customer’s gift certificate account.

Recommended value is true if you want to avoid the possibility of fraud. For example, consider the case where
you set this value to false and customers pay for a gift certificate via credit card. If the gift certificate amount is
immediately credited into their accounts, they can use it to purchase goods or services from your store immediately.
After they know your goods are being shipped to them, they then cancel their credit card payment.

However, you might choose to set this value to false if it becomes impractical for you to manually approve gift
certificates because too many people are buying them. In that case, make sure you use a payment method that
would reduce the possibility of fraud (i.e. PayPal).

5. Specify true for the Include Shipping field if you want shipping charges to be covered by a gift certificate.

6. Specify true for the Include Tax field if you want taxes to be covered by a gift certificate.

7. The Re-calculate Tax field must be set to none if you have set Include Tax as true or you will receive an error
message later. none is also the most commonly used setting. If you choose Standard or Credit Note, you will
need to play around with different test orders to see whether they suit your needs.

8. If you have chosen Credit Note for the Re-calculate Tax field, you should choose a suitable option from the
Tax Class drop-down list box.

9. The Credit Including Tax field is only relevant for gift certificates which you have created as taxable products.
For example, suppose you have created a gift certificate as a product for sale and applied a tax rate of 10% to it.
If the gift voucher is priced at $10.00, the customer will be charged $11.00 on checkout due to product tax.

Now how much should go into the customers gift certificate account balance? If this option is set to true, then
customers will receive $11.00 in their gift certificate account balance. If this option is set to false, then customers
will get $10.00 in their gift certificate account balance instead.
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10. Choose an order status to associate to an order from the Set Order Status field if a gift certificate covers the
full amount of an order.

11. Click update to finish configuration of your Gift Certificates order total module.

You should play around with the Sort Order field for all the order total modules if you encounter erroneous or
illogical calculations. If that does not help, your last resort is to refer to the PHP code contained in the [zc-home]/
includes/modules/order_total/ot_gv.php file.

If a Gift Certificate module is enabled, a Gift Certificate FAQ hyperlink will appear in the Information side-box. Upon
clicking this hyperlink, a customer can redeem a gift certificate or find out more about the use of gift certificates by
clicking the relevant hyperlinks under the "Gift Certificate FAQ" text. The entire process is illustrated in the following
screen shots.

Selling gift certificates as products

Unlike discount coupons, you can sell gift certificates as products. Since gift certificates are commonly displayed with
their values, you may want to consider creating the relevant gift certificate images before you start creating your gift
certificate product.

If you have installed the sample data during Zen Cart installation, you can refer to the [zc-home]/im-
ages/gift_certificates directory to take a look at some of the sample Gift Certificate images available.

To create gift certificates as products in your store:

1. Navigate to the Categories/Products screen and create a product belonging to the "Product-General" type under
your desired category.

2. In the Product Details screen of the product, pay extra attention to the fields shown in the following table while
creating your product.

Field Value Explanation

Product is Virtual Yes, Skip Ship-

ping Address

Since this is an electronic Gift Certificate, no delivery of the Gift
Certificate is required.

Always Free Ship-
ping

Yes, Always

Free

Since a cash amount equivalent to the value of the Gift Certificate
is stored in the customer’s account, there is nothing to physically
ship to a customer.
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Field Value Explanation

Products Model GIFT-XXX This field must begin with the characters "GIFT" and the char-
acters must be in upper-case. Consider marking this field as
"GIFT-10" or "GIFT-100" to differentiate between gift certifi-
cates of different monetary values. Do not mis-configure this
step!

Products Shipping
Weight

0 Since an electronic Gift Certificate has no weight.

3. Use your discretion to specify the values for the other fields on the screen.

4. Click on save to create the gift certificate as a product.

Approving gift certificates

Note that a gift certificate purchased as a product by a customer may not have its value credited into a customer’s
account immediately. An optional approval process may need to be performed by the store owner before the gift
certificate value is released into the customer’s gift certificate account balance as a precaution against possible fraud.
This additional approval process does not apply to gift certificates that are sent via email from Zen Cart to customers
or between customers themselves.

To ensure that gift certificates are approved by the store owner before their values are released into customer accounts:

1. Click on Modules > Order Total to access the Order Total Modules screen.

2. Edit the Gift Certificates module.

3. Make sure that the Queue Purchases field is set to true.

To approve a gift certificate:

1. Look for the GIFT Queue button that appears at the top of your Admin Console as shown in the following screen
shot.

2. Alternatively, click on Customers > Orders to access the Orders screen and then run through each individual
order to see which are the orders that have a GIFT Queue button displayed in their side-panels as shown in the
following sample screen shot.
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3. Either way, by clicking on a GIFT Queue button, you will reach the Gift Certificate Release Queue screen.
Another way to reach the Gift Certificate Release Queue screen is to simply click Gift Certificates/Coupons >
Gift Certificates Queue.

This screen contains a list of gift certificates that are waiting for approval before their amounts are credited into
the relevant customer’s gift certificate account.

4. Choose the gift certificate you wish to approve and click on Release GIFT to bring up a side-panel prompting
you to confirm your decision.

5. Click on Confirm to release the value of the gift certificate to a customer’s gift certificate account balance.

Once money is credited into a customer’s gift certificate account, a store owner will not be able
to reverse the action. This is to prevent unscrupulous store owners from "stealing" money from
their own customers.

Delivering gift certificates to customers

There are two ways which gift certificates can be sent to customers electronically:

▪ Selectively email gift certificates to customers manually via the Admin Console.

▪ Send gift certificates automatically to customers upon account creation.
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Manually email gift certificates to customers

To receive copies of gift certificate emails manually sent to customers from the Admin Console, click on Configura-
tion > E-Mail Options and edit the following fields accordingly:

▪ Send Copy of Admin GV Mail Emails To - Status

▪ Send Copy of Customer Admin GV Mail Emails To

To send gift certificates to customers manually via the Admin Console:

1. Click on Gift Certificates/Coupons > Mail Gift Certificate to access the Send Gift Certificate To Customers
screen.

You should be able to see two text areas for you to enter your email message if you have enabled Enable HTML
Emails under Configuration > E-Mail Options.

2. If you have installed a rich-text editor and want to use it to help you compose HTML email messages in the Rich-
Text Message text area, choose it from the Text Editor drop-down list box.

3. Specify the recipient(s) of the gift certificate by choosing from the Customer drop-down list box or entering an
email into the Email To field.

4. The From field is automatically populated with the value from the Email Address (sent FROM) field of the
E-Mail Options screen.

5. Enter some text for the Subject field which will appear in customer emails.

6. Specify the value of the gift certificate you wish to send to customers by entering a number into the Amount field.
Do not specify the currency symbol as Zen Cart automatically appends the symbol of the default currency to this
amount when sending out the email.

7. Enter any other text that you might want to send to your customers in the Rich Text Message and Text-Only
Message fields. These fields correspond to emails that are formatted in HTML and plain-text respectively.

8. Click on send mail to bring up another screen to preview the email message and message recipients.
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9. Click on send mail in that screen to send the gift certificate.

A sample plain-text gift certificate email sent to a customer from the Admin Console is shown in the following screen
shot.

Automatically send a gift certificate on account creation

To receive copies of gift certificate emails sent automatically to customers on account creation, click on Configuration
> E-Mail Options and enable the following fields:

▪ Send Copy of Create Account Emails To - Status
▪ Send Copy of Create Account Emails To

To enable Gift Certificates to be automatically created and sent on account creation:

1. Click on Configuration > GV Coupons to access the GV Coupons screen.

2. Click on New Signup Gift Voucher Amount and concentrate on the side-panel.

3. Enter the gift certificate amount into the text box and click update.

4. If you want to change the gift certificate code length, edit the Length of the redeem code field. For example, if
you specify this length to be 10, then the redeem code generated by Zen Cart for the gift certificate may look like
9e47daba3b. (Warning: This field also affects the length of a redeem code for discount coupons!)
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5. If you want to change the order status for an order total balance of zero after applying your gift certificate, you
can edit the Default Order Status For Zero Balance Orders field.

A sample plain-text gift certificate email received by a customer on account sign up is shown in the following screen
shot. Note that only the gift certificate portion of the email is displayed.

Track gift certificates sent

To track all the gift certificates you have sent to customers or those that customers send between themselves, click
on Gift Certificates/Coupons > Gift Certificates sent sent to access the Gift Vouchers Sent screen as shown in the
following sample screen shot.

Newsletters
Newsletters allow customers to stay informed of the latest happenings in your store. They are delivered via email and
provide an excellent means of building relationships with your customers.

Zen Cart provides two types of newsletters:

▪ General newsletters - for promotional purposes and general store news.
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▪ Product newsletters - these are divided into product-specific and all-products newsletters.

How newsletters work

An outline of how newsletters work is as follows:

1. Customers opt in to receive a particular newsletter. There are several ways this can be done.

▪ During account creation, customers can opt in to receive General newsletters.

▪ After account creation, customers can log in to their accounts to opt in to receive General newsletters or Product
newsletters.

▪ When customers are viewing a product’s details, they can opt in to receive a Product-specific newsletter by
clicking in the Notifications side-box.

2. Store owners compose and send the relevant newsletters to interested customers.

3. Customers can choose to unsubscribe from any newsletter at any time. Again, there are several ways to do this.

▪ By clicking on the Newsletter Unsubscribe hyperlink in the Information side-box. This will allow customers to
unsubscribe from the General newsletter. Customers will be prompted to log in if they have not done so.

▪ Customers can log in to their accounts and unsubscribe from the General or Product newsletters.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 24. Marketing 360

Only HTML-formatted newsletters will contain newsletter unsubscribe hyperlinks. Plain-text
newsletters do not contain any unsubscribe hyperlinks.

Enabling newsletter sign-up on account creation
This feature applies only to General newsletters where users can be informed of the latest promotion or news from
your store.

To allow customers to opt in to receive newsletters during account creation:

1. Click on Configuration > Customer Details to access the Customer Details screen.

2. Make sure the Show Newsletter Checkbox field is enabled.

Your customers should now see the newsletter subscription option when they sign up for an account with your
store as shown in the following screen shot.

Creating newsletters
We shall now look at the process of creating the relevant General and Product email newsletters for your customers.

To create and send newsletters to your customers:

1. Click on Tools > Newsletter and Product Notifications Manager to access the Newsletter and Product Notifi-
cations Manager screen.
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2. To create a new newsletter, click on new newsletter to proceed to the Newsletter and Product Notifications
Manager Details screen.

3. If you have installed a rich-text editor and want to use it to help you compose HTML email messages in the Rich-
Text Content text area, choose it from the Text Editor drop-down list box.

4. In the Module field, choose newsletter if you wish to create a General newsletter and
product_notification if you wish to create a Product newsletter.

5. Enter a name for your newsletter in the Subject field. This name will also be displayed in the subject line of
emails that customers receive.

6. Recall that users have the option of choosing whether they want to receive their emails in HTML or plain text
when they sign up for a newsletter. Therefore, enter your newsletter details into both the Rich-Text Content and
Plain-Text Content areas to cater for both sets of users.

7. Enter all relevant details and click save to effect your changes. Your newly created newsletter will be displayed
in the Newsletter and Product Notifications Manager screen.

8. To send your newly created newsletter, click on your desired newsletter in the Newsletter and Product Notifica-
tions Manager screen.

9. Click on send to begin sending your newsletter. What screen you see next will depend on what you entered for
your Module field in Step 3.

▪ If you specified newsletter, you will be prompted to select your newsletter recipients.
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Choose your desired newsletter subscribers from the drop-down list box and then click on select. You will be
shown a preview of your message and the number of recipients for the newsletter. Click on send mail in that
screen to send your newsletter.

▪ If you specified product_notification, you should see the following screen.

If your newsletter is general enough to encompass all products, click Global. If your newsletter is meant for
users who have signed up for specific products only, you need to choose the relevant products from the Products
list and move them to the Selected Products list by clicking on >>>.

Once you have completed your selections, click on Submit. You should see a screen saying how many sub-
scribers will receive the Product newsletter. Click on send in that screen to send your newsletter.

10. You can check whether your newsletter is sent by looking for a green tick icon under the Sent column of the
Newsletter and Product Notifications Manager screen.

Viewing the number of newsletter subscribers you have
To view the number of newsletter subscribers you have, click on the Admin Home hyperlink near the top of the Admin
Console. Look at the Newsletter subscribers field under the Statistics table as shown in the following screen shot.

Product reviews
Product reviews increase the likelihood that customers will return to your site, either to write a review of the items
they bought or to see what other customers think of a product they want to buy. You also stand to benefit because
you can learn from customer preferences, thus adjusting your product offerings and directing your marketing efforts
more effectively.

Although product reviews are useful, they can be susceptible to abuse. For example, an unscrupulous competitor could
sign up for an account with your store and write bad reviews about your products or store. To overcome this problem,
Zen Cart allows you the option of moderating all reviews before they are posted on your site for everyone to see.
Furthermore, customers have to sign up for an account first before they are allowed to write any reviews. There is no
option to allow anonymous users to write reviews.
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How product reviews work
An outline of how product reviews work is as follows:

1. Customers select a product and proceed to the Product Info page as shown in the following screen shot. If there
are currently no reviews written for the product, customers will see a "write a review" button. Otherwise, they will
see a "read the reviews" button with the total number of reviews written for that product displayed underneath
the "read the reviews" button.

2. Customers click on "write a review" to proceed to a page where a review of the product can be written as shown
in the following screen shot. Zen Cart will prompt customers to log in if they have not done so.

Customers can also reach this screen by first clicking the "read the reviews" button and then clicking the "write
a review" button in the ensuing screen.

3. Customers choose a rating for the product by clicking on any of the radio buttons with stars displayed next to them.

4. Reviews are entered into the text area on the screen. The minimum number of characters that customers should
type before Zen Cart allows a product review to be submitted is configured via the Product Review Text field
under Configuration > Minimum Values.

5. After the product review is completed, customers click on submit to send their reviews for the store owner to
moderate and approve. Note: Moderation is optional.

6. Once reviews are approved, they will appear in the Reviews side-box randomly.
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7. To see a list of all product reviews in your store, customers can click on the the product image or the "Reviews
[more]" hyperlink at the top of the side-box. A list of sample reviews is shown in the following screen shot.

Enabling product reviews
Product reviews are limited to selected product types only; they cannot be enabled on a per-product basis currently.
Before users can write product reviews, you need to enable it first.

To allow users to write reviews:

1. Click on Catalog > Product Types to access a list of product types in your store.

2. Choose a product type you want users to be able to write reviews on and then click on edit layout.

3. Make sure the Show Product Reviews Button field is enabled.

4. Optionally, you can decide whether to display the number of reviews for a particular product (which appears
underneath the "write a review" button) by editing the Show Product Reviews Count field.

Moderating product reviews
It is a good idea to moderate reviews to check that the comments are genuine and legal. For example, you do not
want comments that praise your products but criticize that of other companies because you could end up with a legal
case on your hands.
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Product reviews submitted by customers may be subjected to moderation by store owners. A store owner is then able
to edit the contents of a product review before approving it for display to all visitors.

Enable moderation for products reviews

To enable a product review to be moderated:

1. Click on Configuration > Product Info to access the Product Info screen.

2. Make sure the Product Reviews Require Approval field is enabled.

Receive emails for products pending reviews

If you would like to receive email alerts informing you of product reviews ready for moderation, click on Configura-
tion > E-Mail Options and configure the following fields accordingly.

▪ Send Notice of Pending Reviews Emails To - Status

▪ Send Notice of Pending Reviews Emails To

This is a good idea if you want to save yourself the effort of constantly logging into your Admin Console to check
for product reviews to moderate and approve.

Moderate a product review

To moderate a review:

1. Click on Catalog > Reviews to access the Reviews screen as shown in the following screen shot. Alternatively,
you can reach the same screen by clicking on the Admin Home hyperlink near the top of the Admin Console,
and then clicking on Reviews Pending Approval in the Statistics table.

2. If you wish to view and edit the contents of a product review written by a customer, click on edit to bring up the
product review details page as shown in the following screen shot.
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a. Make any changes and preview your changes in another screen by clicking preview.

b. Click on update in the new screen once you are satisfied with your changes. You should be redirected back
to the Reviews screen after the update completes.

3. To approve a product review, simply click the respective red button under the Status column to change its color
to green.

Viewing product review statistics

To view statistics for product reviews in your store, click on Admin Home on the navigation menu to reach your Admin
Console’s home page. Look at the following fields under the Statistics table as shown in the following screen shot.

▪ Reviews

▪ Reviews Pending Approval

Banners
You may be familiar with how banners are used on websites for placing advertisements. These advertisements can
either be used for generating revenue and/or as part of a link exchange program for cross-promoting your site with
other sites. For example, if you sell cars, you can exchange banners with a magazine that covers the car industry. In
this way, both sites stand to gain exposure to their products without using any money for advertising.
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Banners in Zen Cart are much more flexible and can be used for other purposes as well. For example, you can create
eye-catching image banners that link to products and categories in your store that are currently on sale. You can then
look at the banner statistics to determine how effective your in-store promotions are.

How banners work
An outline of how banners work is as follows:

1. Store owners create different banners and position them at specific locations in their Store Fronts.

2. Site visitors click on any of the banners.

3. Zen Cart then re-directs visitors either to external sites or internal store pages depending on the URL associated
with each individual banner.

4. Store owners can check the banner statistics generated by Zen Cart to determine the effectiveness of their banner
marketing campaign or to determine popularity of a specific page in their store.

Banner display concepts
Before we begin, take a look at the following screen shot to see the different locations where your banners can be
located in your Store Front.

Figure 24.1: Locations of different banners in the Store Front

To facilitate the display of different banners in a selected location, each banner you create in Zen Cart will be assigned
to a banner group. These banner groups are then assigned to the different banner locations in your Store Front.
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The Banner Box All side-box is the only location which will display multiple banners simultaneously. Only one banner
group can be assigned to this location. On the other hand, multiple banner groups can be assigned to each of the other
locations. For each of these other locations, the banners in each group are then rotated randomly one at a time.

There are two types of banners that you can create in Zen Cart - Normal banners and HTML Text banners. Normal
banners use images found in the folders of your store’s server for display. HTML Text banners are more flexible and
allow you to use other forms of multimedia (e.g. Adobe Flash or Java Applet) as banners. They also allow you to link
directly to images hosted on our sites.

Regardless of which type of banner you create, you should make sure that the size of the banner will fit properly into
its intended location in your Store Front. For example, banners which are to be placed inside side-boxes should not
be too wide.

For both types of banners, Zen Cart automatically records the number of times each banner is displayed regardless
of its location in your store. Additionally, for Normal banners, Zen Cart automatically records the number of clicks
each banner receives as well.

The statistics collected are displayed in the Display/Views column of the Banner Manager screen so you can get a quick
idea of how your banners are performing. Note that the terms "Impressions" and "Views" are also used interchangeably
with "Display" when referring to banners in Zen Cart.

Creating a banner

To create a banner:

1. Click on Tools > Banner Manager to access the Banner Manager screen.

Make sure you do not overlook the statistics shown under the Displays/Clicks column. These statistics allow you
to measure the effectiveness of a banner advertisement by showing you how many clicks were recorded for the
number of times a banner is displayed.

2. To add a new banner, click new banner to bring up the Banner Manager Details screen. To save space, only the
top half-of the screen is shown.
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Read the instructions displayed prominently below the buttons (shown in the following screen shot) to understand
some of the rules governing the use of different fields in this screen.

3. Set the Banner Status field as Active if you want your banner to be displayed. Disregard this field if you have
configured values for Scheduled At and Expires On as the banner status will be managed automatically by Zen
Cart once those fields are set.

4. Set the Banner New Window field to Yes if you want a new window to appear when a customer clicks on the
banner. The new window will display the site that is associated with this banner.

Do note that pop-up blockers on your customers' computers can prevent the new window from appearing if this
field is set to Yes.
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5. Set the Banner on SSL field to Yes if you want your banner to be displayed correctly if your store’s URL switches
from "http" to "https".

If this field is set to No, then on SSL pages, your banner will not appear. You may want to do this if your banner
references graphics or content external to your site that will likely throw up security alerts on SSL pages.

6. Enter a name for your banner in the Banner Title field.

7. For the Banner Group field, either choose an existing banner group from the drop-down list box or enter a new
banner group name in the text box to create a new banner group.

8. The next part is a bit tricky because you need to specify whether you want a Normal or HTML Text banner.

▪ To configure a Normal banner:

a. In the Banner URL field, enter the web address with which to redirect users when they click on the banner.

▸ For a web address that references an external site, prefix the value with either a "http" or "https". An
example value is http://www.yahoo.com.

▸ For a web address that references an in-store page, enter the part of your
store’s URL which begins with "index.php". An example value is index.php?

main_page=product_info&cPath=1_9&products_id=1.

b. For the Image and Image Target (Save To) fields, refer to the "Image Notes" section at the bottom of the
screen in order to correctly specify your banner image.

▪ To configure an HTML Text banner:

▸ Enter the appropriate HTML code into the HTML Text field. For example, you can enter <a
href="http://www.yahoo.com">Yahoo Site</a> into this field to show a hyperlink which will redi-
rect users to Yahoo’s site if they click on it. Note that if you are using other multimedia files (e.g. Flash, Java
Applets), you will need to find out the correct HTML code to use before entering it into this field.

9. If the banner group (i.e. the value for Banner Group) which this banner is created in will be displayed in the
Banner Box All side-box, then you may want to enter a value into the Sort Order - banner_box_all field to
ensure the banners are visually stacked against each other according to your preference.

10. Leave the Schedule At field blank if you want the banner to be displayed immediately. Alternatively, if you want
the banner to be displayed starting from a certain date, choose the desired date from the calendar that is displayed
when clicking on the dark button next to the field.

11. Leave the Expires On field blank if you want the banner to be displayed for an indefinite period of time. Alter-
natively, if you want to automatically disable the display of the banner, you can choose either one of the following
actions:

▪ To disable the banner display on a particular date, choose the desired date from the calendar that is displayed
when clicking on the dark button next to the field.

▪ To disable the banner display based on the number of times that the banner has been displayed, enter a value
in the text box next to the words "impressions/views".

12. Click on insert to create your banner. You will be redirected to the Banner Manager screen once the banner is
created.

13. At the Banner Manager screen, make sure the Status button of the banner you just created is green or your banner
will not be displayed in the Store Front either immediately or when the scheduled date for banner activation arrives.
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Positioning a banner

You can refer to Figure 24.1: “Locations of different banners in the Store Front” to visualize
exactly where you want to position the banners in your Store Front.

Before we begin, turn on the relevant banner side-box(es) that you want to use:

1. Click on Tools > Layout Boxes Controller to access the Column Boxes screen.

2. Enable the respective side-box(es) accordingly:
▪ sideboxes/banner_box.php
▪ sideboxes/banner_box2.php
▪ sideboxes/banner_box_all.php

To specify where your banners should be positioned:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. If you want your banners to be randomly displayed one at a time, select any of the following fields. For each field,
you can enter one or more banner groups as its value.
▪ Banner Display Groups - Header Position 1
▪ Banner Display Groups - Header Position 2
▪ Banner Display Groups - Header Position 3
▪ Banner Display Groups - Footer Position 1
▪ Banner Display Groups - Footer Position 2
▪ Banner Display Groups - Footer Position 3
▪ Banner Display Groups - Content Box banner_box
▪ Banner Display Groups - Content Box banner_box2

3. If you want your banners to be statically displayed together all at once instead of being rotated randomly, select
the following field. Note that this field accepts only one banner group as its value.

▪ Banner Display Group - Content Box banner_box_all

4. For each field you selected, enter your desired banner group name(s) and click the update button to save your
changes.

Search Engine Optimization (SEO)
One of the most important things to do after getting your site online is to get it listed on search engines. By doing so,
you are able to drive a greater amount of traffic to your site and subsequently increase your sales.

To get listed on a search engine you will need to submit the URL of your site and some personal details to the relevant
search engine. Submission rules vary among different search engines so you will need to do some research. Since the
rules on site submission to different search engines are updated constantly, we shall not show the steps here as they
are likely to become obsolete soon after this book is published.

Once your application is approved, the search engine will send a little program called a "web-bot" , "robot" or "spider"
to crawl and index your site pages. The robot then sends back the relevant data it has obtained from your site to the
search engine and the algorithms in each search engine will decide how your site ranks when someone performs a
search in that particular search engine.
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Because robots are computer programs, they cannot "see" the pages like human beings. Instead, they can only see
the source code that is used to render your web page in web browsers. To help these robots understand your site and
content better, Zen Cart provides several features to aid in their indexing work.

We shall use the term Search Engine Optimization (SEO) to describe the features offered by Zen Cart in helping robots
index your site more efficiently. Most people use the term to describe the methods used to make a site appear on top
of page rankings when users perform a search in a search engine. Getting on top of page rankings is a big deal for
many online businesses because it increases the exposure of a business to customers and hence drives greater traffic
to the site compared to sites that do not rank as high.

The SEO methods described in this book are legal and widely-accepted by search engines as long as you do not abuse
them. Other SEO methods might be targeted more for specific search engines. Regardless of which SEO method you
use, do check that the method has not been outlawed by a search engine before using it. Search engines tend to change
their rules periodically to prevent anyone from using a specific method to get listed on top of page rankings.

Watch out for Search Engine Optimization (SEO) companies that claim they can help you
achieve top rankings in search results. Most of these companies employ means that can get you
banned from ever appearing in search engines again!

Canonical URLs
Websites that contain duplicate or very similar content that can be accessed via different URLs may see the quality
of their search engine rankings for the affected content drop. This is because search engines need to determine which
URL best represents the duplicate content and at the same time avoid diluting the strength of the content’s ranking
across different URls.

To alleviate the preceding problem with duplicate content, the major search engines like Google, Yahoo, and Microsoft
have teamed up to support the use of canonical URLs. This allows a site owner to indicate the preferred version of a
URL to use when a search engine encounters different URLs that produces duplicate content on a site.

Because the contents of Zen Cart are generated dynamically, different Zen Cart URLs can point to the same or very
similar content in your store. This is not a problem for search engines because Zen Cart is smart enough to automatically
generate the relevant canonical URLs for the affected content.

Let us take a look at the following two examples to see how canonical URLs are generated in Zen Cart. This allows
you to understand how your store’s URL may appear in search engine results and allows you to check that canonical
URLs are working correctly in your store.

For the first example, we shall assume that your store contains a product with product ID "8" and that is linked to
multiple categories (i.e. "22", "30", and "45"). When you access the product’s Product Info page in your Store Front
with the following URLs, you will notice that the content displayed is identical.

▪ http://www.example.com.com/store/index.php?

main_page=product_info&cPath=22&products_id=8

▪ http://www.example.com.com/store/index.php?

main_page=product_info&cPath=30&products_id=8

▪ http://www.example.com.com/store/index.php?

main_page=product_info&cPath=45&products_id=8

Regardless of which URL you use to access the Product Info page, you will notice that a canonical URL similiar to
the following one has been generated by Zen Cart when you use your web browser to view the HTML source code of
the page. Notice that the category ID is left out of the generated canonical URL. This ensures that search engines will
not have a problem locating the product even if you were to remove it from one of the linked categories.
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<link rel="canonical" href="http://www.example.com.com/store/index.php?
main_page=product_info&amp;products_id=8" />

For the second example, we shall make use of the New Products listing page to illustrate how canonical URLs work
for pages that can display very similar content.

Let us first assume that you can access the New Products listing page in your store via the following URL.

http://www.example.com.com/store/index.php?main_page=products_new

By tweaking the options in the "Sort by" drop-down list box and the paging hyperlinks as shown in the following
screen shot, you will be able to change the order in which the relevant products are displayed.

Each time you change the display options on the New Products listing page, you will notice that the URL for the
page changing to include extra parameters which reflect your selections. Some examples of the changed URLs are
as follows:

▪ http://www.example.com.com/store/index.php?

main_page=products_new&disp_order=4&page=1

▪ http://www.example.com.com/store/index.php?

main_page=products_new&disp_order=6&page=2

▪ http://www.example.com.com/store/index.php?

main_page=products_new&disp_order=1&page=3

Again, if you use your web browser to view the HTML source code of the New Product listing page each time you
change the page’s display options, you will notice that a canonical URL similiar to the following one has been auto-
matically generated by Zen Cart. Notice that the extra URL parameters are not present in the canonical URL. This
ensures that search engines will know which URL to use as the definitive version and not dilute the strength of the
page’s content when it sees varying parameters in the page’s URL.

<link rel="canonical" href="http://www.example.com.com/store/index.php?
main_page=products_new" />

As you have seen in the preceding examples, Zen Cart is smart enough to generate the relevant canonical URLs
throughout various parts of your store. There is thus no need for store owners to do any manual configuration unless they
have very specific requirements as to how canonical URLs should be generated for their stores or wish to troubleshoot
why canonical URLs are not being generated properly. For those rare occassions, store owners can refer to the code
in the [zc-home]/includes/init_includes/init_canonical.php file.

Web spiders

robots.txt

A robots.txt file, if present, exists in the root of your site’s domain (usually the document root of a web server)
to help web spiders indexing your site to ignore certain content which are not important to your site’s search engine
rankings.
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As a robots.txt file is publicly accessible and viewable via http://www.example.com.com/robots.txt, it
should not contain any references to private directories or files you do not want the public to know about. This is
because not all web spiders respect or interpret the instructions in a robots.txt file fully and malicious hackers are
also known to scan the contents of the file to determine whether there are any directories or files which might be of
interest to them.

If you had followed the instructions in the section “Helping search engines index your site correctly” after installing
your Zen Cart store, then you will already have a robots.txt file in your remote server’s document root directory.

In addition, if you had used Zen Cart’s robots_example.txt file as a template when creating your own robots.txt
file instead of creating one from scratch, then the contents of your robots.txt file should include the following code.
The code tells all web spiders to ignore the /cgi-bin directory which is commonly found on Linux-based web hosts.

User-agent: *
Disallow: /cgi-bin/

Nowadays, some search engines provide users the ability to search for images directly (e.g. Google Images or Yahoo!
Image Search). To discourage web spiders from indexing the images and pop-up images in your store, you can also
follow the contents in the robots_example.txt file and add the following code to your robots.txt file:

Disallow: /images
Disallow: /index.php?main_page=popup_image*

As mentioned earlier, search engines may interpret the instructions in a robots.txt file differently. Therefore,
you should consult each search engine’s documentatation separately to determine whether you need to tweak your
robots.txt file to suit their requirements. For example, to remove an image from Google Images, refer to http://
www.google.com/support/webmasters/bin/answer.py?hl=en&answer=35308.

For more information on the workings of the robots.txt file and how to properly edit its contents, refer to http://
www.robotstxt.org/.

Robots and security

Session IDs are unique sequences of characters generated by web applications to keep track of users actions. Session
IDs generated by Zen Cart when a user visits your Store Front are preceded by a "zenid" character . An example of a
session ID appearing in a store’s URL is shown in the following example:

http://www.example.com/store/index.php?
main_page=index&zenid=af40be3714c3b6e70c83e958c1f6e1f6

Session IDs appearing in search engine results can lead to some strange problems with your store. When multiple users
click on the search engine result hyperlink with your session ID embedded in the URL, they could potentially see each
others' carts and account details giving rise to security and privacy issues.

Besides the online risks of exposing your session IDs, you should also avoid exposing your store session IDs when
displaying your store’s URL in magazines, email signatures or other advertising material.

To turn off session ID indexing by robots:

1. Click on Configuration > Sessions to access the Sessions screen.

2. Make sure the Prevent Spider Sessions field is set to True.

Advanced users who have defined their own custom web pages might want to consider look-
ing at the file [zc-home]/includes/languages/english/meta_tags.php. You can add
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the names of specific pages to exclude from robot indexing in a line that contains the words
"ROBOTS_PAGES_TO_SKIP".

Site map

When users click on the Site Map hyperlink in the Information side-box in your Store Front, they will be redirected to
a page that shows the different products available in your store and how your store is organized. All this information
is automatically generated by Zen Cart, and is clearly useful to visitors who might otherwise get lost in your store
if you have a lot of content.

Besides being useful to humans, the site map is also beneficial for robots. This is because all the relevant pages in
your store are conveniently located in a single place which eases the robot’s task of crawling and indexing your site.
Furthermore, robots are also able to derive useful relationships between the different products in your store as the
structure of your site makes it easier to understand for them.

As a site map is automatically enabled and generated by Zen Cart, the only concern you may have with the site map
is the privacy issues it can raise when robots start crawling your site. To address this concern, you should make sure
that Zen Cart does not generate My Account hyperlinks in the site map so that robots do not have a chance of crawling
them. This is because My Account pages contain sensitive information that should only belong to individual customers
and not be indexed as part of your site’s content.

To turn off the display of My Account links in a generated Site Map:

1. Click on Configuration > Layout Settings to access the Layout Settings screen.

2. Click on the Site Map - include My Account Links? field and concentrate on the side-panel.
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3. Make sure the field is set to No before you click update to effect your changes.

To customize the look of your site map:

1. Click on Configuration > Define Page Status to access the Define Page Status screen.

2. Click on the Define Site Map Status field and concentrate on the right-panel.

3. Select your desired setting and click update to effect your changes.

To change the wordings of the template text in your site map, use the Template Override System to override the [zc-
home]/includes/languages/english/html_includes/define_site_map.php file.

Meta tags
Meta tags are special HTML tags that communicate information to web browsers and robots. They are not meant for
human viewing and you can only see them when you view the HTML source code of a web page from within your
web browser.

If you are using Mozilla Firefox, you can right-click on a web page and then click View Page Source on the pop-up
menu to see the HTML source code associated with that page. Similarly, if you are using Internet Explorer, you can
right-click on a web page and click View Source on the pop-up menu.

Any tag that contains the word "meta" is a meta tag; e.g. <meta name="keywords">.

There are several different types of meta tags but we will look at two of the most general ones here. The first type
of meta tags is meant for web browsers. The following example meta tag tells your web browser what format and
language the web page is encoded in so that your web browser knows how to display it properly.

<meta http-equiv="Content Type" content="text/html; charset=iso_8859_1" />
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The other type of meta tags is meant for robots as they provide details of the contents in your store and help the robots
index your store pages according to your input. These are the meta tags that we will concentrate on and talk about
for the rest of this chapter. The following example meta tag may be read by robots to understand the contents of your
store better.

<meta name="keywords" content="fruits, grocery, apples, oranges, grapes">

Note that nowadays, the influence of meta tags on search engine results has been drastically reduced as other parameters
are used by search engines to index and rank websites. Therefore, do not spend too much time fine-tuning your meta
tag descriptions.

Information you define for meta tags can be divided into the following categories:

▪ General information.

▪ Category and Product information

Although we shall be talking about the configuration of meta tags later, you will notice that the
web browser title bar is also used by Zen Cart to provide information about your site. This is
because robots can also make use of this information for indexing.

General and page-specific information

If you wish to have general information about your store or page-specific information appear in meta tags generated
by Zen Cart, you will need to edit the [zc-home]/includes/languages/english/meta_tags.php file. Some
of the contents of the file are shown in the following code. Note that we have removed some of the comments for
easier reading and to save space in this book.

// page title
define('TITLE', 'Zen Cart!');

// Site Tagline
define('SITE_TAGLINE', 'The Art of E-commerce');

// Custom Keywords
define('CUSTOM_KEYWORDS', 'ecommerce, open source, shop, online shopping');

// Home Page Only:
define('HOME_PAGE_META_DESCRIPTION', '');
define('HOME_PAGE_META_KEYWORDS', '');
define('HOME_PAGE_TITLE', ''); // usually best left blank

// EZ-Pages
define('META_TAG_DESCRIPTION_EZPAGE_#','');
define('META_TAG_KEYWORDS_EZPAGE_#','');
define('META_TAG_TITLE_EZPAGE_#', '');

// Per-Page
define('META_TAG_DESCRIPTION_page_name','');
define('META_TAG_KEYWORDS_page_name','');
define('META_TAG_TITLE_page_name', '');

// Review Page can have a lead in:
define('META_TAGS_REVIEW', 'Reviews: ');

// separators for meta tag definitions
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// Define Primary Section Output
define('PRIMARY_SECTION', ' : ');

// Define Secondary Section Output
define('SECONDARY_SECTION', ' - ');

// Define Tertiary Section Output
define('TERTIARY_SECTION', ', ');

The information contained in this file will be included in other meta tags in some other pages that appear in your store.
Remember to use the Template Override System if you want to make changes to the file.

Category and product information

To add category and product information to your meta tags, you will need to configure each individual category and
product separately.

To create meta tags for a category:

1. Click on Catalog > Categories/Products to access your Categories/Products screen.

2. Navigate to your desired category and click on the "biohazard" button; i.e. the button with four quadrants.

3. Enter the name of the web page for the Title field. This name will be shown on the web browser title bar when a
customer goes to the category page by clicking on the category hyperlink in the Categories side-box.

4. Enter the keywords you want to associate with the category in the Keywords field. For example, if you specify
test, experiment for this field, your meta tag will show up as <meta name="keywords" content="test, ex-
periment">.

5. Enter the description you want to associate with the category in the Description field. For example, if you specify
testing purpose for this field, your meta tag will show up as <meta name="description" content="testing pur-
pose">.

6. Click save to save your changes into the database.

To specify meta tags for a product:
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1. Click on Catalog > Categories/Products to access your Categories/Products screen.

2. Navigate to your desired product and click on the "biohazard" button; i.e. the button with four quadrants.

3. Click the relevant radio buttons under the Mark What the Product’s Meta Tag Title Should Include table
heading to specify which piece of product information should appear in the title bar of a customer’s web browser
when the customer reaches the Product Info page in your Store Front.

To change the default values for the radio buttons, click on Catalog > Product Types to access the Product Types
screen. Select a product type and click edit layout and then customize the following fields accordingly.
▪ Show Metatags Title Default - Product Title
▪ Show Metatags Title Default - Product Name
▪ Show Metatags Title Default - Product Model
▪ Show Metatags Title Default - Product Price
▪ Show Metatags Title Default - Product Tagline

4. Enter the name of the web page for the Meta Tag Title field. Depending on the settings of the radio buttons, this
name might be shown on the web browser title bar together with other product information when a customer goes
to the Product Info page in your Store Front. Note that other general keywords might also appear in the meta tag.
Refer to the section “General and page-specific information” for more information.

5. Enter the keywords you want to associate with the product in the Meta Tag Keywords field. For example, if you
specify test, experiment for this field, your meta tag will show up as <meta name="keywords" content="test,
experiment">. Again other general keywords might also appear in the meta tag.

6. Enter the description you want to associate with the product in the Meta Tag Description field. For example,
if you specify testing purpose for this field, your meta tag will show up as <meta name="description"
content="testing purpose">.

7. Click preview to proceed to the next screen which summarizes your product meta tag configuration.

8. Click update in that screen to confirm your changes.

Customizing meta-tag appearances

To further configure meta tag appearances in the Product Info page of your Store Front:
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1. Click on Configuration > Product Info to access the Product Info screen.

2. Edit the following fields accordingly:

▪ Meta Tags - Include Product Model in Title

▪ Meta Tags - Include Product Price in Title

▪ Meta Tags Generated Description Maximum Length

Other product promotion features
We shall now talk about some marketing features that are seldom noticed or used by store owners. Two of these
features (Also Purchased Products and Best Sellers) are automatically enabled in Zen Cart while the third (Featured
Products) needs to be configured.

Also Purchased Products
The Also Purchased Products feature is automatically available in Zen Cart. This feature is similar to a familiar mar-
keting technique called "Cross-Selling" which aims to sell other related products to a customer when the customer
is viewing a particular product. An example would be recommending nails when a customer is looking at a hammer
in your store.

The Also Purchased Products feature works like this: When a visitor views a product in the Product Info page, Zen
Cart will analyze whether the currently viewed product has ever been ordered together with other products by other
customers. If the analysis is positive, those other products that were purchased by other customers will appear in the
Customers who bought this product also purchased center-box at the bottom of the Product Info page. The following
screen shot gives you an idea of how things look.
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Note that the recommended products appear randomly in the center-box. There is no way to specify which specific
products should be recommended based on the currently displayed product.

To change the appearance of the Customers who bought this product also purchased center-box:

1. Click on Configuration > Product Info to access the Product Info screen.

2. Edit the Also Purchased Products Columns per Row field accordingly.

To specify how many eligible recommended products should be available before the center-box is shown:

1. Click on Configuration > Minimum Values to access the Minimum Values screen.

2. Edit the Also Purchased Products field accordingly. Hint: If you do not want the center-box to ever appear,
specify a very high value for this field.

To limit the maximum number of eligible products displayed in the center-box:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the Also Purchased Products field accordingly.

Best Sellers

The Best Sellers feature displays a list of products that have chalked up the most sales in your store. It takes advantage
of the curiosity factor in humans whereby everyone is interested to find out what and why others are buying. This is
especially so if customers are looking for products that are "safe-bets" as gifts for loved ones.

For more information on the configuration of the Bestsellers side-box, refer to the section “Best Sellers”.

Featured Products

Featured Products allow you to showcase certain products distinctively across several areas of your store as shown
in the following screen shots.
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There are many reasons why stores might want to put products in a designated "feature" area. For example, if a store
has the rights to sell a very limited edition of a branded game console, the store could market the console as a featured
product to build up interest and bring in pre-orders before the actual launch of the product.

Take note of the following differences between Specials (refer to the section “Product specials” for more information)
and Featured Products:

▪ Specials always include a discount whereas Featured Products have the option of not having a discount.

▪ Specials can also be positioned as Featured Products too.

To create a featured product:

1. Click on Catalog > Featured Products to access the Featured Products screen.
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2. Click on new product to access the Featured Product Details screen.

3. Choose a product from the Product field.

4. Optionally, choose a future date for the Available Date field by clicking on the dark button next to the field to
pop up a calendar, if you want the product to be placed on Featured on the future date. Leave the field blank if
you want the product to be placed on Featured immediately.

5. Optionally, choose a future date for the Expiry Date field by clicking on the dark button next to the field to pop
up a calendar, if you want the product to be removed from the Featured Product areas on that date. Leave the field
blank if you want the product to be placed on Featured forever.

6. Click insert to create the Featured Product.

To view statistics for Featured Products in your store, click on the Admin Home hyperlink near the top of your Admin
Console. Look at the following fields under the Statistics table.

▪ Featured Products Expired

▪ Featured Products Active

New Products

For some stores, constantly refreshing the list of products for sale can increase the number of repeat and new customers
to their sites. For example, if your store sells handphone covers, you will attract more customers if your customers
anticipate that you will replenish your stock with the latest designs to match the latest handphone models.

The list of display elements that relate to new products in your store can be seen in the following screen shot.
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To control the time period when a product is added to your catalog and hence defined as a new product:

1. Click on Configuration > Maximum Values to access the Maximum Values screen.

2. Edit the New Product Listing - Limited to field accordingly.

Summary
As you have seen, Zen Cart provides a wide variety of techniques to help you achieve your marketing aims. Experiment
with those marketing features that interest you and assess their effectiveness by examining the relevant statistics. With
imagination and hard work, you should be able to tune your marketing strategies to generate profits for your business.
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Chapter 25:

System administration

Introduction
Proper system administration ensures that your online store stays secure and performs reasonably when users visit
your store. System administration may not be directly related to your business processes but it can affect the smooth
operation of your online store.

In this chapter, we shall:

▪ Examine general system administration tasks.

▪ Learn to properly back up files and database.

▪ Consider important security settings.

▪ Look at factors that contribute to site performance bottlenecks.

▪ Look at how you would upgrade your Zen Cart to a newer version.

▪ Get an idea of how third-party add-ons are installed.

General tasks
We shall now discuss some of the general system maintenance tasks that you may need to perform from time to time.

Checking server time

If your site is hosted on a remote server, it is important to know whether there is any difference between the server time
and your local time. For example, if you live in Singapore (i.e. GMT +0800 hrs) and your remote server is located in
London (United Kingdom) (i.e. GMT +0000 hrs) then there is a time difference of 8 hours between the two locations
assuming no daylight saving time is taken into consideration.

As all your orders and log files are recorded in server time, knowing this time difference allows you to better understand
when payments are received and also when orders are issued. You can then translate from server time to the local
times of your customers when answering customer queries regarding their orders or shipping dates.

To get a quick glance of your server’s date and time, look at the top of your navigation menu in your Admin Console
as shown in the following screen shot.
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To be more specific, the preceding server date and time actually reflects that of the web server in which Zen Cart is
running on. It is usually good enough because most shared hosting packages place their web and database servers in
the same machine and hence both of them usually share the same server time. However, with some hosting packages,
the database server and the web server may be located in different physical computers or have their times configured
differently. This can present a problem when you are trying to make sense of customer order queries or troubleshoot
your Zen Cart installation.

To more accurately determine both your remote web and database servers' time:

1. Click on Tools > Server/Version Info to access the Server Information screen. A portion of that screen is shown
in the following screen shot.

2. The server time for both your web server and database server is found in the following two fields. If you notice
a significant difference between the two fields, you should immediately alert your web hosting provider and find
out the reason.
▪ Server Date

▪ Database Date

Website maintenance
There will be times when you need to close your online store for a short period of time. You could use this time to do
a stock take, do a Zen Cart version upgrade or simply to back up all your data. You can inform customers about an
impending service disruption by placing your site in maintenance mode.

When your store is placed in maintenance mode, customers can still reach your website. However, they will see a
message indicating that your store is undergoing maintenance and will not be able to perform any transactions. What
a customer may see for a store placed under maintenance mode is shown in the following screen shot.

Although a website can be placed in maintenance mode immediately, most websites will inform customers a few days
or weeks ahead before doing so. This leaves a better impression on users because they will not begin to suspect that
you had to place your site under maintenance to handle an emergency (e.g. hackers).
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When configuring settings for website maintenance, always specify the time values in server time instead of your local
computer time. Furthermore, try to set the time in GMT or another timezone format to cater to international users.

Before learning how to place your store in maintenance mode, you should know where to look for the current IP address
which you are using to access your Zen Cart store. This is because you can configure your store to be accessible only
to you based on your IP address while other users on your site are taken to a "Down for Maintenance" page instead.
This feature allows you to check your normal store functions before you decide to take your store out of maintenance
mode and allow access to real-world customers.

To determine the IP address (e.g. 127.0.0.1) you are currently using to access your store:

▪ If you are in your Store Front, look at the footer of your Zen Cart store.

▪ If you are in your Admin Console, look at the top of your navigation menu.

To place your store in maintenance mode:

1. Click on Configuration > Website Maintenance to access the Website Maintenance screen.

2. To put your store in maintenance mode immediately, set the Down for Maintenance: ON/OFF field to true.

3. If your store is already in maintenance mode; i.e. Down for Maintenance: ON/OFF is set to true.

a. Set the Display when web master has enabled maintenance field to true if you want to inform users when
your site was placed under maintenance.

b. Set the Display website maintenance period field to true if you want to display the value specified for
the Website maintenance period field. Preferably, leave this option as false because you do not want to
pressurize yourself and disappoint your customers if you cannot complete your maintenance on time.

c. Enter a value for the Website maintenance period field to inform visitors how long you expect the site to
be down for maintenance.

d. Set the Down For Maintenance (exclude this IP-Address) field with a list of IP addresses (separated by a
comma) that will still be able to access all the normal Store Front functions like buying products and checking
out.
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e. To specify how your store should look when visitors reach your site while it is under maintenance, modify
the following fields accordingly:

▪ Down for Maintenance: Hide Header

▪ Down for Maintenance: Hide Column Left

▪ Down for Maintenance: Hide Column Right

▪ Down for Maintenance: Hide Footer

▪ Down for Maintenance: Hide Prices

4. If your store is not in maintenance mode; i.e. Down for Maintenance: ON/OFF is set to false.

a. Set the NOTICE PUBLIC Before going Down for Maintenance: ON/OFF field to true if you want the
value in the Date and hours for notice before maintenance field to be displayed in your Store Front. Note
that if the Down for Maintenance: ON/OFF field has been set to true, the NOTICE PUBLIC Before going
Down for Maintenance: ON/OFF field will be ignored and no maintenance notification will be displayed.

b. Enter the desired time for the beginning of your website maintenance in the Date and hours for notice
before maintenance field. Your store will not be placed in maintenance mode automatically when this date
is reached.

5. Leave the Down for Maintenance: filename field alone. This field specifies which program file in Zen Cart
should handle the programming logic behind the website maintenance module.

To enable EZ-Pages to be viewed by store owners accessing the store from IP addresses specified in the Down For
Maintenance (exclude this IP-Address) field of the Website Maintenance screen:

1. Click on Configuration > EZ-Pages Settings to access the EZ-Pages Settings screen.

2. Set your desired field to a value of 2.

▪ EZ-Pages Display Status - HeaderBar

▪ EZ-Pages Display Status - FooterBar

▪ EZ-Pages Display Status - Sidebox

Viewing who’s online information

Both site visitors and administrators are able to view information regarding other visitors who are currently accessing
an online store. However, a customer’s view and an administrator’s view of information pertaining to other visitors
is different.

The customer’s view

The Who’s Online side-box allows your customers to see the total numbers of users currently browsing your online
store. No detail on individual customers are provided.

This feature is not very useful unless you have a community-driven site where users can reach out to each other
in real-time and communicate. To disable this side-box, click on Tools > Layout Boxes Controller and edit the
sideboxes/whos_online.php field under Box File Name accordingly.
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The administrator’s view

Store owners can see more information related to customers or search engine robots visiting their stores. They can
use the information to ascertain which pages are the most popular, where most of the customers come from, etc. The
information can also be used for system maintenance purposes. For example, you can check that there are currently
no visitors in your store before bringing it down for maintenance.

To see information regarding who is currently accessing your store:

1. Click on Tools > Who's Online to access the Who's Online screen. A list of users currently using your system or
a list of search engine robots currently indexing your site will be displayed.

2. You can choose to either refresh the screen information manually or automatically.

▪ To refresh the screen manually, click OFF in the Updating Manually field and then click on the REFRESH
LIST hyperlink when you wish to refresh the screen.

▪ To let the screen automatically refresh by itself, click on your desired refresh rate in the Updating Manually
field.

3. Click on your desired value in the Exclude Spiders field to control whether you want search engine robots crawl-
ing your store to be displayed.

4. Click on your desired value in the Exclude Admin IP Addresses field to control whether you want customers
accessing your store from the same IP address as the currently logged-in admin user to be displayed.

Note that the list of admin IP addresses that are affected include those in the Down For Maintenance (exclude
this IP-Address) field of the Website Maintenance screen which is accessible via Configuration > Website
Maintenance.

You can learn a lot of interesting stuff about your site visitors using this screen, so make sure you read through the
legend and other statistics in smaller print.

Backing up your store’s data
Back up your data routinely. This point cannot be overstated enough because your business depends on it. Imagine if
your database gets corrupted for some reason, how are you going to deliver your goods to customers who have already
paid up? Your reputation is at stake and you may even end up in court to face legal proceedings.
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Even if your web host offers automatic backups on your behalf, you are still encouraged to make your own backups.
You never know whether your web host will go bust one day or whether they have under-delivered on their guarantee.

There are essentially two things you need to back up.

▪ File system.

▪ Database.

Before performing your backup, make sure that there are no users online and your site has been placed under main-
tenance mode.

Besides the back up techniques presented in this section, you may also want to refer to the sec-
tion “Backups and restores” in order to familiarize yourself with some of the back up function-
alities that may be offered by your web host.

File system back up
There are essentially two approaches to backing up the directories and files related to your Zen Cart store — a minimum
back up or a full back up.

If you prefer to do a minimum back up, you just need to back up the following files because the rest of the files that
make up your Zen Cart store can be re-downloaded via Zen Cart’s site.

▪ Any core Zen Cart files you have changed.

▪ Both the configure.php files.

▪ Your template-specific directories and files.

▪ Images for your store catalog and also any files you have made available for customer downloads.

▪ Any files uploaded by customers as part of their purchases.

▪ Any third-party modules you have installed.

If you are paranoid, you can perform a full back up by copying all files from the [zc-home] directory of your remote
web host to your local computer. Personally, I use this approach as it is faster and less error-prone because there is no
need to spend time sifting through the specific directories and files that need to be backed up.

When performing your back up, use your web host’s control panel to compress all the files you want to back up before
downloading the files onto your local machine. This saves bandwidth, speeds up your download, and your downloaded
files are less susceptible to corruption.

Database back up
This is the most important backup because most of your system settings and all your customer, payment and order
data, etc, are stored here. If anything goes wrong or you feel that your database is corrupted, you can always recover
your database via a database backup file.

Besides the database backup functionality offered by your web host’s control panel, you can also use phpMyAdmin
to back up your database if it is available via your web host’s control panel.

phpMyAdmin gives you finer control over how you want your database to be backed up and is usually the preferred
approach. However, if your database is too large, you may encounter time out issues with phpMyAdmin. Under such
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circumstances, you may have no choice but to revert to the database functionality offered by your web host’s control
panel or have your web host perform the back up for you.

To back up your database using phpMyAdmin:

1. Access the phpMyAdmin web interface via your web host’s control panel.

2. Select the database which you used to set up Zen Cart during your installation on the left-panel.

3. You should see all the tables in your store’s database listed on the right-panel of your screen.

4. Click on the Export tab near the top of the screen to go to the next screen where you can configure the relevant
settingsto export data from your database.
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5. Under the Export section, click the Select All hyperlink to select all the tables in your store for export. Make
sure the radio button is set to SQL.

6. Under the Options section, use the settings shown in the preceding screen shot. Only check the Add DROP
TABLE option if you want to be able to use the backed up data to overwrite an existing database!

7. Check the Save as file check-box and use the settings shown in the following screen shot as a guide. You can
choose the zipped option for the Compression field to save space and bandwidth.

8. Click Go to begin the backup process on your remote server.

9. After the backup process completes, download the backup file to your local machine when prompted by your
web browser.

To recover your database using the backup file you downloaded previously:

1. Access the phpMyAdmin web interface via your web host’s control panel.

2. Select the database which you want to use to recover your backed up data from the drop-down list box on the left-
panel. Double-check the selected database because all existing data will be overwritten if you had checked the
ADD DROP TABLE option when you created your back up file earlier.

3. Click on the Import button on the top row of tabs and a screen will appear with details on how you can import
data into your database.
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4. Click on the Browse button to choose the backup file you want to use to restore your database.

5. Click on the Go button next to the character set of the file drop-down list box to begin your database recovery
process. If errors occur during the recovery process, unzip the backup file on your local computer and then repeat
the previous step using the unzipped file.

6. A success message will be shown if your database recovery process completes without problems.

After your database is recovered successfully, you should log in to your Admin Console and Store Front and run some
test transactions to verify that everything is recovered properly.

If you experience problems during the export or import of your database data while using ph-
pMyAdmin, try experimenting with the different options in the phpMyAdmin screens. If that
still does not help, approach your web host and see what recommendations they may have.

Addressing security concerns
Security is a big and intimidating topic in all IT-related systems and a whole book will be required to write about all
aspects of this topic. Therefore, to reduce the scope of security coverage, we will only be touching on issues specific
to your Zen Cart website in this book.

Before we begin, if you have a local copy of Zen Cart’s files, you can open up [zc-home]/docs/
important_site_security_recommendations.html in your web browser to run through a list of things you
can do to make your site more secure.

Managing access to the Admin Console
The Admin Console is a very powerful interface which has the ability to alter many sensitive and critical functions of
your store. Therefore, Zen Cart has incorporated a set of security features to protect against unauthorized access to the
Admin Console as well as limit the Admin Console functions available to different admin users.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 25. System administration 394

Zen Cart controls access to different Admin Console functions by using the concept of admin profiles. Each admin
profile is given a name and mapped to a set of admin pages. New admin pages can be added by third-party add-ons
using a page registration mechanism. Every admin user is in turn assigned a specific admin profile. In this way, access
to different admin pages can easily be demarcated based on the roles that different admin users perform.

Besides controlling access to different Admin Console functions, all activities performed by logged in users are auto-
matically recorded by Zen Cart in the database. Detailed reports of all admin user activities can then be generated for
viewing on an ad-hoc basis or archived for future reference as per PCI DSS requirements.

Enforcing a strong password policy

Attacks on web sites commonly target the login pages because it allows hackers to gain wide access to a web application
and wreak the most damage. One of the most common reasons why hackers have been so successful in carrying out
their exploits is due to the poor use of passwords such as using passwords which are too short or that can be easily
guessed.

To overcome the potential problems with password use, Zen Cart has followed the PCI DSS standards and implemented
a robust password policy for the Admin Console. This policy requires admin users to use strong passwords, change
their passwords every 90 days, and not re-use the last four passwords, etc;

For store owners who do not need to be PCI DSS-compliant nor want to deal with the hassle of having to adhere
fully to the password policy, they can go to Configuration > My Store and change the value of the PA-DSS Strong
Password Rules Enforced field accordingly.

Working with admin profiles

When a Zen Cart store is first installed, the first admin user that is created is commonly known as the Superuser
because it is assigned the default Superuser profile. The Superuser profile has full and irrevocable access rights to all
the functions that can be performed in the Admin Console. The Superuser profile cannot be deleted as well. Hence, a
new admin profile must be created in order to restrict access to only a selected number of admin pages.

To add a new admin profile:

1. Click on Admin Access Management > Admin Profiles to access the User Profiles screen.

2. Click on add profile and you should see something similar to the following screen shot.
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3. Take some time to scan through the preceding screen shot. Notice that the checkbox entries represent different
admin pages and are nicely segregated according to the menu headers in the admin menu bar.

Furthermore, many of the admin pages can be directly accesed by clicking their corresponding menu entries in
the admin menu bar except for the following admin pages. As the names of the pages may not be immediately
clear to store owners, the following list gives a quick indication of their individual purposes in order to help you
make a decision on their accessibility later.

▪ "Catalog :: Product" - a Product Detail page.

▪ "Catalog :: Products to Categories" - a page where products can be linked to multiple categories.

▪ "Customers :: Invoice" - an Invoice page generated from an order.

▪ "Customers :: Packing Slip" - a Packing Slip page generated from an order.

▪ "Gift Certificates/Coupon :: Coupon Restrictions" - a page where restrictions on coupon usage can be limited
to different categories and products.

▪ "Product Types" - each page under this heading is accessible by clicking the relevant links after going to Catalog
> Product Types

4. Type the name of the admin profile you wish to create into the empty field above the save button.

5. Check all relevant checkboxes representing admin pages that need to be accessible to the new admin profile. To
check all checkboxes in a group simultaneously, click on the relevant check All button.

6. Click on save to create the new admin profile. You will be redirected back to the User Profiles screen as shown
in the following screen shot.
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Renaming a non-Superuser admin profile or adjusting its access rights to admin pages is straight-
forward. However, deleting the non-Superuser admin profile is only possible when no admin
users are currently assigned to it.

Refer to the following screen shot of a sample User Profiles screen to see what we mean. Notice
that the Web Designer admin profile cannot be deleted because it is currently assigned to a user.

Working with admin users

Besides the default admin user that was created during Zen Cart installation, you can create other admin users to help
with the running of your online store.

To add an admin user:

1. Click on Admin Access Management > Admin Users to access the Admin Users screen.

2. Click on add user and you should see something similar to the following screen shot.

3. Enter a username in the empty field under the Name column. The username is case-sensitive and will be required
when logging into the Admin Console.

In addition, the username can accommodate more than a single word. Hence, both "Jean" and "Jean Simmons"
are valid usernames. You may want to choose the longer version as it removes any ambiguity when interpreting
the admin activity logs.

4. Enter the admin user’s email address in the empty field under the Email column.
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5. Choose an admin profile that is to be assigned to the admin user from the drop-down list box under the Profile
column.

6. Type in the login password that the admin user should use in both the empty fields under the Password and
Confirm Password columns. Note that admin user passwords in Zen Cart are case-sensitive and must exceed 7
characters in length.

7. Click on save to add the admin user. You will be re-directed back to the Admin Users screen. Simultaneously,
an email will be sent to the email addressed specified in the Email Address (Displayed to Contact you) field
of the E-Mail Options screen.

The process of deleting an admin user, editing an admin user’s details, or resetting an admin user’s password is straight-
forward as all these functions are performed via the Admin Users screen. However, there are some finer points you
need to take note of when performing any of the aforementioned functions.

When deleting an admin user, take note of the following points.

▪ Admin users cannot delete themselves.

▪ Emails will be sent to the email address specified in the Email Address (Displayed to Contact you) field of the
E-Mail Options screen after an admin user is deleted.

When editing an admin user’s details, take note of the following points.

▪ Admin users cannot change their own admin profiles. This prevents admin users from assigning themselves to
an admin profile with greater page access rights.

▪ Emails will only be sent if an admin user’s email, name or profile details has been changed.

▪ Emails will be sent to both the email address configured in the Email Address (Displayed to Contact you) field
of the E-Mail Options screen and the affected admin user’s email as well. If the email address of the admin user
was changed, then the notification email will be sent to the admin user’s old email address.

When resetting an admin user’s password, take note of the following points.

▪ Due to PA-DSS requirements, the new password must meet the following list of requirements.
▸ it must contain both letters and numbers.

▸ it must be at least seven characters long.

▸ it must not be the same as the last four passwords used.

▸ it will automatically expire every 90 days.

▪ No emails will be sent when an admin user’s password is changed.
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Adding new admin pages

If a third party add-on is installed and adds new admin pages to your Admin Console, then those admin pages can also
be subjected to admin profile access controls via the User Profiles screen.

To add a new admin page that will show up in the User Profiles screen, you would need to click on Admin Access
Management > Admin Page Registration to access the Admin Page Registration screen.

We will not be going through how to add an admin page using the Admin Page Registration screen as the exact values
to be used on this screen will depend on the instructions provided by the specific add-on you are installing. We only
highlight this capability of Zen Cart’s in case store owners come across unfamiliar screen names in the User Profiles
screen.

Working with admin activity logs

In addition to controlling access to the Admin Console, Zen Cart keeps track of all actions admin users perform by
logging those actions in the database. Log files of these activities can then be generated and archived for use by store
owners or security consultants to look out for malicious activities or to trace a sequence of activities.

To generate an admin activity log:

1. Click on Admin Access Management > Admin Activity Logs to access the Admin Activity Log Manager screen.
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2. Choose the severity level of logged messages you want to view from the Which log data do you want to see
drop-down list box.

3. To generate the log in HTML format that is directly viewable within your web browser window.

a. Choose Export as HTML (ideal for on-screen viewing) from the Export File Format drop-
down list box.
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b. Click on the go button and your web browser window will display a report similar to the following screen shot.

4. To generate the log in CSV format so that you can use a separate software program (e.g. Microsoft Excel or
OpenOffice Calc) to view and sort the entries for better data analysis later.

a. Choose Export to CSV (ideal for importing to spreadsheets) from the Export File Format
drop-down list box.

b. Type a name for the file you want to generate into the Export Filename field or use the default one provided.
Avoid the use of empty spaces for your file name due to how empty spaces are interpreted by different
operating systems.

c. You can choose to download the log file directly to your local computer or saving it on your remote server
by checking the Save to file on server checkbox accordingly.

d. Click on go to generate the report.

▪ If you had unchecked the Save to file on server checkbox, then your web browser will prompt you to
download the admin activity log file to your local computer.

▪ If you had checked the the Save to file on server checkbox, then a copy of the log file will be saved
to the [zc-home]/[admin]/backups folder of your Zen Cart installation on the server as seen in the
Destination directory path appearing in italics.

You can change the Destination path by editing the following line in your {DIR_ZC)/[admin]/in-
cludes/configure.php file.

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

You may not fully understand the contents of the admin activity log because it contains some data that would only
make sense to programmers or security consultants. However, it is still good that you refer to the following table to
get an idea of what the different headings appearing in the admin activity log file mean. If you suspect some malicious
activity has happened, you can then turn over the file to a security consultant for a full review.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>



Chapter 25. System administration 401

Table 25.1: Meaning of different fields in the admin activity log

Column Meaning

timestamp The time an admin action occurred.

admin_user The admin id of the admin user performing the action.

ip_address The IP address that an admin user uses to access the Admin Console to perform
an action.

page_accessed The name of the PHP file that was accessed by the admin user when performing
the action.

parameters Contains information that was submitted to an admin page via a HTTP GET op-
eration. In other words, it is information that was submitted together with the
URL when an admin user accesses an admin page. This field will make more
sense to programmers and security consultants.

flagged A value of "1" indicates that a possibly malicious activity has been detected
while a value of "0" indicates otherwise.

attention If the flagged column has a value of "1", then this column will show the possi-
ble cause that triggered the warning. For example, a XSS (i.e. Cross-site script-
ing) attack on your Admin Console will trigger an alert in this field.

post_data Contains information that was submitted to an admin page via a HTTP POST
operation. In other words, it is usually data that an admin user enters into a form
and submits through an admin page. This field will make more sense to pro-
grammers and security consultants.

As the admin activity log records all admin user activities in your Admin Console, its size will increase very quickly
and possibly impact the performance of your store. Therefore, Zen Cart will issue periodic alerts that appear at the top
of your Admin Console to remind you to purge the admin activity log.

To purge the admin activity log:

1. Either click on the reset button as shown in the preceding screen shot or click on Admin Access Management
> Admin Activity Logs to access the Admin Activity Log Manager screen.

2. Concentrate on the Purge Log History section of the screen and pay attention to the words that are highlighted
in red.
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3. If you are sure that you are ready to purge the admin activity log, click the reset button and you will be redirected
to the following screen.

4. Click the reset button to purge the admin activity log. You will be redirected back to the Admin Activity Log
Manager screen. The message under the Purge Log History section of the screen will now appear as follows.

File permissions

Misconfigured file permissions allow hackers to easily gain unauthorized access to your system. Therefore, you should
pay careful attention to the permissions you set for certain Zen Cart directories when your site is hosted on a remote
server.

Before we continue, make sure you refer to the section “Changing file and directory permissions” in order to have a
basic grasp of some file permission concepts which is important to our discussion in this book. Note that the permissions
mentioned here may not work for you as it is targeted at the majority of web hosts. You should consult your web
host in order to determine the best permissions to set for their servers without compromising your site security and
functionality.

Furthermore, because most web hosts use Linux-based servers, we shall use Linux-style permissions to explain how
file permissions should be set for certain directories and files in your Zen Cart directories. If your site is hosted on a
Windows or Mac OS platform, check with your site administrator as to how you can achieve the same effect as the
permission levels discussed here.

When you first uploaded your Zen Cart directories and files to your server, directories are usually set to chmod 755
and files are set to chmod 644. These permissions are usually secure enough and will only need to be adjusted when
you need to perform certain tasks depending on how your web host is set up.

Recall during Zen Cart installation that the following directories (either chmod 755 or chmod 777) and files (either
chmod 644 or chmod 777) had to be set to writeable.
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▪ /include/configure.php

▪ /[admin]/include/configure.php

▪ /cache

▪ /images (and all its sub-directories)
▪ /includes/languages/english/html_includes

▪ /logs

▪ /media

▪ /pub

▪ /[admin]/backups

▪ /[admin]/images/graphs

After installation is complete, the two configure.php files should be set to read only (i.e. chmod 444 in most cases
or chmod 400 on some web hosts) for added security.

For the aforementioned directories, they only need to stay writeable when you want to perform tasks like uploading
an image or editing a Define Page directly within the Admin Console. For some web hosts, the default chmod 755
is secure and good enough and you do not need to do anything more.

However, some web hosts require that you set the affected directories or files to chmod 777 in order to make them
writeable. If your web host requires that you do so, then you may want to set the permissions back to something
more restrictive after performing your task. This is recommended only if it will not compromise your normal store
operations or your site security.

Do not forget to check the permissions of the files and directories that you have created through
the Template Override System or third-party modules you have installed.

Secure Sockets Layer (SSL)
Secure Sockets Layer (SSL) ensures that the traffic between users, browsers and your server is secure and not open
to sniffing by hackers. When an active SSL connection is achieved between a web browser and a website, the URL
for the website will transition from http to https.

SSL capability is achieved by installing a digital certificate on your web server. The digital certificate contains infor-
mation identifying a site and proves that your site is who it claims it is. The installation of an SSL certificate is usually
done by your web host if you are on a shared hosting account.
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Although many web hosts provide you with a shared certificate for free, it is recommended that you fork out some
money and get yourself a dedicated (also called private) certificate since you will be running an e-commerce store
with Zen Cart.

A dedicated certificate ensures that the certificate is uniquely identified with your domain and is tied to a single IP
address. Visitors to your site are can switch between http://www.example.com to https://www.example.com
transparently. Users are also assured that your site is legitimate if they choose to inspect the details shown in the digital
certificate sent from your server to their web browsers.

With shared certificates, the certificate is tied to the IP address of your web host instead of your site. Transitioning
from http://www.example.com to https://www.example.com usually results in a pop-up dialog box in the web
browsers of your site visitors warning them to beware of the site they are dealing with because the certificate can only
verify your web host is who it claims to be but is not able to do so for your site. The outcome looks unprofessional and
users might decide to leave when they encounter the pop-up warning; thus abandoning their carts altogether. Hence,
we will not discuss how to configure SSL support for your store using a shared certificate in this book.

Although you can configure SSL for your entire site, this is not advisable. SSL requires intensive computing resources
because of the encryption and decryption processes and thus slows down your site tremendously.

Instead, SSL is usually configured only for certain areas of your site where information confidentiality is of utmost
importance. Some areas on your site which will benefit from the use of SSL are:

▪ Customer login and sign-up pages.
▪ Customer checkout pages.
▪ Admin login screen.
▪ Admin catalog modification screens.

Verifying SSL support for your site

Before you can configure SSL support for your store, you need to purchase a dedicated SSL certificate and have your
host install the SSL certificate onto your server for you.

After your web host has installed the SSL certificate on your site, you can verify the presence of the SSL certificate
and its details by typing something like https://www.example.com or https://example.com into your web
browser. The www is required only if you have stipulated that www be included in your SSL certificate when you
purchased the certificate.

When you access any SSL-enabled pages on your site, your web browser will give you some visual feedback such
as a security-related icon (e.g. a "lock" or "tick" icon) appearing at the bottom of your browser window or in your
browser’s address bar. Furthermore, most browsers allow you to click on the icon to view an SSL certificate’s details.

Check with your web host if you are unable to verify that SSL is working on your site or the SSL certificate’s details
are incorrect.

Configuring SSL support for your store

After your SSL certificate is installed on your server, there are essentially two files in Zen Cart you need to edit in
order for Zen Cart to make use of SSL support:

▪ [zc-home]/includes/configure.php

▸ Changes to this file affects SSL access to your Store Front. Zen Cart will automatically redirect customers to
a secure checkout process via SSL. Customers will also be automatically redirected to a SSL page during sign
up or log in.

▪ [zc-home]/[admin]/includes/configure.php
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▸ Changes to this file affects SSL access to your Admin Console. Zen Cart will automatically redirect the store
owner to an SSL page when a login to the Admin Console is performed.

To set up Zen Cart to automatically switch to SSL during a customer login or account checkout, edit the contents of
the [zc-home]/includes/configure.php file according to how your SSL certificate is tied to your domain and
where your Zen Cart directory is found.

Example 25.1: SSL certificate identified with domain "www.example.com" and Zen Cart directory is
found under "/store".

  define('HTTP_SERVER', 'http://www.example.com');
  define('HTTPS_SERVER', 'https://www.example.com');

  define('ENABLE_SSL', 'true');

  define('DIR_WS_CATALOG', '/store/');
  define('DIR_WS_HTTPS_CATALOG', '/store/');

Example 25.2: SSL certificate identified with domain "example.com" and Zen Cart directory is under
root directory "/".

  define('HTTP_SERVER', 'http://example.com');
  define('HTTPS_SERVER', 'https://example.com');

  define('ENABLE_SSL', 'true');

  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

To set up Zen Cart to automatically switch to SSL for an administrator during log in and catalog manipulation, edit
the contents of the [zc-home]/[admin]/includes/configure.php file according to how your SSL certificate
is tied to your domain and where your Zen Cart directory is located.

If you only want Admin Console logins to be on SSL but not for catalog manipulation, set ENABLE_SSL_CATALOG
to false in the following examples.

Example 25.3: SSL certificate identified with domain "www.example.com", Zen Cart directory found
under "/store".

  define('HTTP_SERVER', 'http://www.example.com');
  define('HTTPS_SERVER', 'https://www.example.com');
  define('HTTP_CATALOG_SERVER', 'http://www.example.com');
  define('HTTPS_CATALOG_SERVER', 'https://www.example.com');

  define('ENABLE_SSL_CATALOG', 'true');
  define('ENABLE_SSL_ADMIN', 'true');

  define('DIR_WS_CATALOG', '/store/');
  define('DIR_WS_HTTPS_CATALOG', '/store/');
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Example 25.4: SSL certificate identified with domain "example.com", Zen Cart directory found under "/".

  define('HTTP_SERVER', 'http://example.com');
  define('HTTPS_SERVER', 'https://example.com');
  define('HTTP_CATALOG_SERVER', 'http://example.com');
  define('HTTPS_CATALOG_SERVER', 'https://example.com');

  define('ENABLE_SSL_CATALOG', 'true');
  define('ENABLE_SSL_ADMIN', 'true');

  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

Perform the following checks to verify that SSL has been configured properly for your store.

1. To check that admin login will automatically switch to SSL:

▪ Enter your Admin Console URL into your web browser’s URL location (e.g. http://www.example.com/
store/myadmin). You should be automatically redirected to a SSL-secured URL preceded by "https" (e.g.
https://www.example.com/store/myadmin/login.php).

2. To check that customer login or sign-up will automatically switch to SSL:

▪ Go to your Store Front and click on the Login hyperlink. You will automatically be redirected to a secure page
to enter your login credentials. After you have logged in, you will be redirected back to a non-secure page.

3. To check that customer checkout will automatically switch to SSL:

▪ Go to your Store Front and purchase a test product. Once you initiate a checkout, you will automatically be
redirected to a SSL page to complete the transaction.

If you are unable to get SSL support to work with your Zen Cart store using the method highlighted in this book, check
with your web host to see if their server configuration requires that you take some other steps as well. If you want
to have a shared SSL certificate working with your store for personal reasons, refer to http://tutorials.zen-cart.com/
index.php?article=14 for instructions.

Sessions
Sessions are your server’s way of keeping track of who you are and some of the activities you have performed on a site
(e.g. added items to a shopping cart). There are a number of ways your server can do this, most notably using cookies.

Because web applications typically identify individual users to their site via the use of sessions, you should guard
against malicious users from launching session-based attacks on your online store.

Zen Cart allows you to configure how sessions are set up on your store. The default settings are sufficient in most
cases, so unless you are a developer, you are unlikely to change any settings here. Nevertheless, it is always good to
know there is such a feature in case you need to use it.

General session settings

Click on Configuration > Sessions to access the Sessions screen.
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The Session Directory field is obsolete and you can safely ignore it. It was used in earlier versions of Zen Cart to store
sessions via files on your server but the option to do so is no longer available since Zen Cart version 1.5.0.

For all other fields in the Sessions screen, the default values should work well for most servers. Do not make any
changes here unless you are absolutely sure you know their consequences. Most of these settings will only make sense
to advanced users with web programming knowledge, so do not worry too much if you are unsure of their meanings
or purposes.

Admin session settings

There are two settings that control how long a logged in admin user is allowed to remain inactive before Zen Cart
automatically logs the person out of the Admin Console. However, you should only change them if you are sure your
store does not need to adhere to PCI DSS standards.

To change the duration of inactivity for an admin user in the Admin Console, click on Configuration > My Store and
concentrate on the PA-DSS Admin Session Timeout Enforced and Admin Session Time Out in Seconds fields.

If the PA-DSS Admin Session Timeout Enforced field is set to On, then the value of the Admin Session Time Out
in Seconds field will be ignored and the duration of inactivity for an admin user will always be 900 seconds (i.e. 15
minutes).

If the PA-DSS Admin Session Timeout Enforced field is set to Non-Compliant, then the duration of inactivity for
an admin user will depend on the value found in the Admin Session Time Out in Seconds field.

Viewing customer’s session history

Zen Cart provides a convenient view of your customer’s session history in a Counter History table. This table can be
accessed by clicking on Admin Home in the navigation menu of your Admin Console.
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The information displayed in the table shows you the statistics for each day - the unique number of session hits to
your site and the total session hits to your site. In layman terms, this means how many unique visitors came to your
site, and the total number of pages viewed by all visitors. For example, if a customer visits your store once that day
and moves around 5 pages before leaving, you will see a statistic of "1 - 5". If another customer came that day and
viewed 10 pages, you will see a statistic of "2-15".

Server log files
If your online store is hosted on a remote server, your web hosting provider will likely have log files configured to
record information about your online store. These server log files are an important source for troubleshooting your
application or identifying hacking attempts.

Although these files can be a bit unwieldy to read and understand for non-technical people, you should still find out
from your web host where they are located and then download them periodically. If you encounter any problems with
your online store (fraud, hacking attempts, etc), you can then turn over these log files to experts for analysis.

The main server log files you may have access to are as follows:

▪ Apache web server log files.

▪ MySQL database log files.

Improving site performance
Performance issues are usually the most frustrating to resolve because complaints are usually based on perceived
experiences. For example, a customer can call you to say your online store is behaving slowly today compared to
yesterday. But your question will be how slow is the site? This is because you know that there will be times when the
server will be slightly slower if there are too many users accessing it at the same time.

We will restrict our performance discussions strictly to what you can achieve with Zen Cart instead of topics like
hardware upgrades, network selection, etc. This helps sharpen our focus and allows you to concentrate only on tasks
that are directly within your control.

Gathering performance statistics
Always be objective and gather useful statistics for your server before deciding whether to look into how to improve
your server performance. Indeed, such statistics will also be the reference point by which you can use to conclude
whether your performance tuning has yielded any measurable results.
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Page parse time

For each page that is dynamically generated, Zen Cart is able to log the amount of time required to process that page.
The page parse time can either be displayed in real-time in your Store Front or be recorded in a separate log file on
your server which can be downloaded for off-line analysis.

To analyze your page processing performance:

1. Click on Configuration > Logging to access your Logging screen.

2. Make sure the Log Database Queries field is set to false unless you are a programmer interested in how Zen
Cart works. Otherwise, a large number of log files with names starting with query_selects will be created in
your [zc-home]/cache directory.

3. If you want to have a separate log file generated for off-line analysis, edit the following fields accordingly.

a. Set the Log Page Parse Time field to true to enable logging to a server file.

b. Specify the name of a file in the Log Destination field to store the page parse time data. Ensure that the
directory holding the page parse time log file restricts viewing by normal website visitors and is writeable.

A simple approach is to give the log file a unique name and place it under the [zc-home]/cache directory.
For example, you might specify something like /home/johndoe/public_html/store/cache depending
on where your Zen Cart installation is located.

c. If you want to change the display format of the entries in the log file, you can enter the appropriate value in the
Log Date Format field. For a list of date display formats, refer to http://php.net/manual/en/function.date.php.

The following screen shot of a sample off-line file that is generated by Zen Cart should give you an idea of how
the contents of a log file might look like.

4. If you also want to have real-time logging statistics displayed in the Store Front, set the Display The Page Parse
Time to true. An example of how the page parse time will be displayed at the bottom of your Store Front is
shown in the following screen shot.

If you have enabled real-time logging statistics in your Store Front’s footer, you will notice three different values
displayed. Query Time refers to the time used in interacting with the database. An unusually long time could mean
that your store’s database is very likely the bottleneck choking your store’s performance. Parse Time refers to the time
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used to render a web page. It is usually handled by the web server and PHP. Check with your host if you encounter
an unusually long time for this field.

Remember to turn off page parsing after you feel you have have gathered enough data to help you troubleshoot your
performance problem. If page parsing is left enabled, it can also be a performance drain on your server since it requires
more processing for each page to load.

User load

User load refers to the number of page hits to your online store. This is usually the number of page views by your site
visitors but it can also include indexing activities by a search engine robot. For the purpose of our discussion, we shall
not discuss search engine indexing activities as they do not play a big part in the statistics related to user load.

Recall that we came across the Counter History table when we spoke about customer session history in the sec-
tion “Viewing customer’s session history”. You can use the statistic in that table to quickly identify the user load
on your site for a particular day. If a sudden spike in user load is detected, you should not be surprised if your site
behaves slower than normal.

Another use for the Counter History table is in determining the average number of visitors to your site over a period
of time by performing a manual calculation. With this information, you can then decide what a reasonable response
time for your website performance is. Thus, if your customer complains that a page is taking too long to load, you can
refer to your desired response time and provide an appropriate reply.

To identify the user load on your site over a period of time, you should refer to the Hit Counter statistic found under
the Statistics table in your Admin Home page.

To reset the value in the Hit Counter field, click on Tools > Store Manager and edit the Update Hit Counter field
before clicking reset. Note that the Hit Counter Started field in the Statistics table will not be updated to the latest date.

Checking server uptime
Server uptime shows how long your server has been running since the last system restart. If a system is restarted, your
Zen Cart customers may perceive a disruption in their shopping experience.

Before we continue, note that some web hosts might not allow the server uptime information to be made available
via the Zen Cart Admin Console. In that case, you may want to check with your web host to find out their reasons
for doing so.

To enable Zen Cart to check how long your server has been running.

1. Click on Configuration > My Store to access the My Store screen.

2. Make sure the Server Uptime field is enabled.

To check how long your server has been up and running:

1. Click on Tools > Server/Version Info to access the Server Information screen.
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2. The uptime is found in the Server Up Time field.

Check with your web host if you find that your server has been constantly restarted (i.e. uptime is always a few days).
This might explain why your site is performing slowly because they might just be performing upgrades to the server
while your store is still running.

Enabling GZip compression
GZip compression enables a faster display of web page contents in a web browser. If GZip compression is enabled,
the server first compresses the contents of a web page before delivering it to a customer’s web page. When the page
reaches the customer’s end, the web browser will automatically uncompress and display the contents to the customer.

If GZip compression has been enabled, you will notice that your browser window goes blank for a while before the
actual page you requested is displayed.

Note that some web hosting providers turn on PHP Output Buffering and GZip compression by default. In such cases,
you should not turn on GZip compression in Zen Cart as you will be recompressing already-compressed content, thus
slowing things down rather than gaining speed.

You can ask your web hosting provider whether GZip compression is on by default in their PHP configuration; or
you can click on Tools > Server/Version Info and check the value for the output_buffering field. If GZip compres-
sion is on, the value of the output_buffering field will show as either On or 1. Alternatively, you can go to http://
www.whatsmyip.org/http_compression/ to check whether your web server has enabled GZip.

To turn on GZip compression in Zen Cart:

1. Click on Configuration > GZip Compression to access the GZip Compression screen.

2. Set the Enable GZip Compression field to 1.

Although this feature can minimize your CPU and bandwidth loads tremendously, some older browsers do not support
it. Use your own discretion to decide whether you want to enable this feature.

Optimizing image sizes
Image size is usually the main culprit why web pages load slowly and it is also the main consumer of bandwidth
on your site. Therefore, you should always optimize your images by reducing their file sizes if you find your site is
loading slowly.

As a general guideline, you can reduce the size of your product images to 30 kilobytes each. Icon images are usually
small enough in size so you can ignore them when optimizing your images. For other images, you will need to decide
for yourself as you need to balance the need for visual clarity and appeal against speed.
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For store owners, the file size limit for images they upload is indicated by the upload_max_filesize field under Tools
> Server/Version Info. If an image exceeding this limit is uploaded, the file will not be uploaded and no warning
messages will be displayed.

Reducing database reads

One of the most common and effective ways to improve your site performance is to reduce the number of database
read operations. One of the biggest culprits of excessive database reads is the category count that you see next to your
catalog entries in your Categories side-box.

To remove the category count from your catalog:

1. Click on Configuration > My Store to access the My Store screen.

2. Set the Show Category Counts field to false.

As most side-boxes and product listings may also involve a lot of database reads, try to turn them off if they are not
essential to your customers' purchasing decisions.

Optimizing your store’s database

Another technique to improve database performance is to delete unwanted records that have been deleted by the Zen
Cart program but are still present in the database. This action should be performed periodically and preferably at a
time when your store does not have many customers as it will impact the database performance during that time.

To optimize your database:

1. Click on Tools > Store Manager to access your Store Manager screen.

2. Go to the bottom of the screen and you will see a section similar to the following screen shot.

3. Click on confirm to begin optimizing your database.

4. After the cleanup is completed, a message indicating how many database tables were affected will be displayed.

Tuning SQL cache methods

Recall when you ran the Zen Cart web installer during installation that one of the options you had to specify was the
SQL cache method you wish to employ in the Database Setup screen as shown in the following screen shot.
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If you click on the more info hyperlink, you will see an explanation of how the field works as shown in the following
screen shot.

We will not talk further on the SQL cache option as it is already explained in the preceding screen shot. Instead, take
note that you can change your SQL cache method and SQL cache directory (if you had chosen to cache your SQL
queries via the file-based approach) in both your configure.php files as shown in the following sample code.

  // The next 2 "defines" are for SQL cache support.
  // For SQL_CACHE_METHOD, you can select from:  none, database, or file
  // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory
 where your apache
  // or webserver user has write privileges (chmod 666 or 777). We recommend using
 the "cache" folder inside the Zen Cart folder
  // ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash
  define('SQL_CACHE_METHOD', 'file');
  define('DIR_FS_SQL_CACHE', '/home/johndoe/public_html/store/cache');

Upgrading your Zen Cart installation
From time to time, you will have to perform upgrades to your Zen Cart installation. This could be because you want
to utilize features in a more recent version or you need to upgrade to higher versions to fix some security loopholes.

Checking your Zen Cart version
To check for available updates to your Zen Cart store, click on Configuration > My Store and enable the Show if
version update available field. To check whether you are running the latest version of Zen Cart, click on the Check
for Updates button at the top-right corner of your Admin Console as shown in the following screen shot.

If your Admin Console is still not able to check whether your Zen Cart version is up-to-date, then open up the [zc-
home]/[admin]/includes/local/skip-version-check.ini file and make sure the following line is set to on.

version_check=on
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Obtaining the latest upgrade instructions
Whenever a new version of Zen Cart is available, an announcement will be posted in Zen Cart’s forum. Details on
how to perform an upgrade are also posted there. As upgrade instructions may vary from version to version, we shall
not cover them here.

One important point to note when performing upgrades is to avoid using any automated scripts or wizards provided
by your web host to perform an upgrade as they usually result in problems or incomplete upgrades which can be
especially time consuming and difficult to track down and solve. Instead, seek to always perform manual upgrades
to avoid or minimize such problems.

Zen Cart does not automatically upgrade your store from one version to the next. If you find
that this is happening, check with your web host and tell them to disable this functionality for
your site.

This is because automatic updates can overwrite any files that you have customized and thus
cause errors in the normal operation of your store.

Installing third-party add-ons
Pieces of software code that do not belong to a default Zen Cart installation but are written in such a way as to integrate
into a Zen Cart store are known as add-ons because they add to the functionality or look of a store. Various terms such
as contributions (contribs in short), modules (mods in short), and plug-ins are also loosely used to refer to these add-
ons so do not be confused if you encounter such terms being used in the Zen Cart forums.

Your first stop when looking for add-ons that will meet your business needs should always be Zen Cart’s site because
the add-ons there are free and most widely used by store owners. Other sites that offer Zen Cart add-ons may require
you to make a purchase or answer your support questions regarding their add-ons only on their site.

To browse or search for add-ons on Zen Cart’s site, click on the "Plugins" hyperlink on the site and you should see
a page similar to the following screen shot.

To minimize the risk of an add-on adversely affecting the functionality or look of your store, use the following points
as a checklist when deciding on and working with an add-on you are interested in.
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1. Find out what others have to say about the add-on. For example, are there any conflicts with other add-ons, will
the add-on require specific server configurations to work, is the add-on reliable and secure.

2. Look for a dedicated support thread in the Zen Cart forums for the add-on. Alternatively, find out if the add-on
author provides an alternative support channel (e.g. paid email support).

If a dedicated support thread exists, subscribe to the thread and keep yourself abreast of any changes (e.g. security
releases or bug fixes) with the add-on. This is because, unlike Zen Cart itself, new releases of add-ons do not
automatically trigger notification messages in your Admin Console.

3. After you have decided on which add-on to use, download the add-on and and see if the add-on comes with any
documentation (e.g. README.txt or README.html) which will tell you how to install or work with the add-on.
Important information relating to the add-on can often be found in such documentation so do not skip it.

4. Before installing an add-on, back up your site’s database and files.

5. When installing your add-on, watch out for the following scenarios if it applies to you.

▪ If you are required to make database changes to your store by running some SQL scripts, do not use phpMyAd-
min to do so unless explicitly told to do so by an add-on author or as indicated in an add-on’s installation
instructions.

Instead, click on Tools > Install SQL Patches to access the SQL Query Executor screen and run your SQL
script from there so that the SQL code can be applied correctly even if the table names in your database contain
prefixes (e.g. zen_orders instead of orders).

▪ If a core file needs to be changed, make sure you make a note of it or you may accidentally overwrite the
changed file and break your store’s functionality when you upgrade your Zen Cart store in future.

6. If you find problems or want to offer suggestions for improvements after installing and testing out an add-on,
you should first visit the add-on’s support thread in the Zen Cart forums before turning to the author’s published
support channel. This gives the add-on’s author a chance to understand the circumstances surrounding an issue
before rectify any problems or improving the add-on further.

Summary
After completing this chapter, you should be able to identify areas that makes your online store perform better and
more securely. You have also seen how to perform proper backups of your important data and guidelines for upgrading
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your Zen Cart installation. Although the techniques here are not directly related to your business objectives, do not
ignore them as they play an important part in the smooth operation of your online store.
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Part VI
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Appendix A:

Utility software

Introduction
Besides the standard web browser (Internet Explorer, Mozilla Firefox, etc), email clients (Microsoft Outlook, Mozilla
Thunderbird, etc) and file compression tools (WinZip, WinRAR, etc), you will need additional utility software to
customize Zen Cart properly.

Because similar programs are easily available for the Linux, Mac and Windows platforms, we will only highlight
those available for the Windows platform. You can find more of such programs by running a search at http://
www.download.com.

Each software category will highlight the desirable features that should exist in a utility program before recommending
a free-ware version and a share-ware version that supports those features. Which program you decide to use will depend
purely on your personal preference.

Text editors
To customize any Zen Cart installation properly, you will need to edit some of text files (i.e. HTML, CSS or PHP).
Do not use word processors (e.g. Microsoft Word) to edit the text files as they will add invisible characters to those
files. These invisible characters can cause problems either for Zen Cart or for web browsers.

Before you settle on a text editor, make sure it has the following features:

▪ Supports syntax highlighting for HTML, CSS, Javascript and PHP. This helps you to code and debug faster by
visually separating the different elements of the file. For example, such a text editor might highlight PHP code in
blue and HTML code in red.

▪ Automatic error highlighting for HTML, CSS, Javascript and PHP. This helps you catch errors in your programs
while you are writing your code before these errors are detected when you run your program in Zen Cart. For
example, if you fail to specify a closing tag for your HTML code, the editor may use a red underline to highlight
the offending HTML tag.

Notepad++
Web Address: http://notepad-plus-plus.org/.

This is a simple and free program which is easy to use for readers who need basic source code editing capabilities in
a text editor. It is not related to Microsoft Notepad.

EditPlus
Web Address: http://www.editplus.com.
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This is a very powerful program that even boasts a built-in web browser. You can download it for a free trial of 30
days before deciding whether to buy it.

FTP software
To transfer files between a remote server and your local computer, you will need to use an FTP client software.a

Although the standard FTP command line commands are available for both the Windows and Unix/Linux platforms,
it is advisable to look for one that has an intuitive Graphical User Interface (GUI).

Before settling on an FTP client program, make sure it has the following features:

▪ Ability to transfer many files reliably. Some FTP clients are known to corrupt files if too many files are transferred
at one go to the server. Do some research on your choice of FTP program to avoid this problem.

▪ Automatically switch between text and binary modes when transferring multiple files. This helps avoid the corrup-
tion of files as the FTP protocol requires binary files (images, compressed archives, etc) to be transferred in binary
mode and text-based files (HTML, CSS, PHP, etc) to be transferred in text mode.

Avoid using a program that does not do FTP as its core functionality. For example, Adobe
Dreamweaver has a built-in FTP function but it may not handle file permissions properly on
your server.

FileZilla
Web Address: http://filezilla.sourceforge.net.

This is one of the most popular free FTP clients in use today. Besides Microsoft Windows, it can also run on Linux
and Mac OS X. Be sure to download only the FileZilla FTP client and not the FTP server.

WS_FTP Professional
Web Address: http://www.ipswitch.com.

This program has a long history and is very popular. It has a wide user base and the program is very stable. You can
download it for a free trial of 30 days before deciding whether to buy it. An online tutorial on how to use the program
is available at http://www.ipswitch.com/support/ws_ftp/tutorials/tours/index.asp.

File comparison software
File comparison software allows you to compare differences between two or more files visually. It is an indispensable
tool when upgrading Zen Cart as it is used to determine which files have changed between different versions and
therefore need to be updated. It is also used commonly in program debugging to understand changes between different
versions of a software.
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WinMerge
Web Address: http://winmerge.sourceforge.net/

This free program has the ability to compare more than two files at once. File differences are highlighted using different
colors. It also has the ability to compare separate directory hierarchies using simple drag-and-drop.

Beyond Compare
Web Address: http://www.scootersoftware.com/

This program has the ability to compare directories in addition to comparing files. It supports many other advanced
features so you will need to spend more time learning how to use it. You can download it for a free trial of 30 days
before deciding whether to buy it.
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Appendix B:

Choosing a web host

Introduction
Once you are familiar with running Zen Cart on your local computer, you can begin to set up your store on the web.

To get your store to run on the Internet, you will need to perform the following steps:

▪ Choose a domain name.

▪ Register the domain name.

▪ Choose a web hosting provider.

▪ Install Zen Cart on the remote server.

The first thing you need to need to do is to come up with a domain name for your website (e.g. wildsales.com). This
domain name will be used by users to access your online store. Because domain names are unique across the Internet,
you will need to register it to prevent other people from using the same domain name.

The second thing you need to do is to find a web hosting provider that will provide you the infrastructure (hardware,
network, etc) and software (Apache, PHP, etc) necessary for you to run a Zen Cart store online. Your hosting provider
will also let you know what the IP address (e.g. 191.0.34.43) of the machine hosting your website is.

Finally, you will need to make the association between your domain name and IP address known to one or more DNS
servers across the Internet.

The above steps are just a logical view of how things are done. For practical purposes, you will usually just choose a
domain name and sign up for a hosting plan with a web hosting provider. The web hosting provider will then perform
all the necessary steps to get your site hosted on the Internet.

Choosing a domain name
Your first task before setting up shop on the Internet is to choose a domain name for your online store. For example,
if you choose "www.pets-r-us.com" as the URL for your store, the domain name will be "pets-r-us.com".

To find out whether your desired domain is available, you can perform a search at http://
www.godaddy.com.

When choosing a domain name, look out for the following criteria:

▪ For stores engaged in commercial activities, try to choose a domain name which ends with ".com" or ".biz". Other
top-level domains (TLDs) such as ".net", ".org", ".info", etc are also available.
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▪ Avoid domain names which end with a country code. For example, ".com.sg", ".biz.my", etc, unless your business
activities are limited to a specific locale (e.g. pizza delivery business). The purpose of using the Internet to conduct
business is to gain maximum exposure for your business and to serve a large pool of customers regardless of ge-
ography.

▪ Choose a domain name that is short and easy to remember. Most people have problems remembering long names,
let alone typing them out error-free.

▪ Avoid the use of numbers in your domain name to minimize problems with users typing the URL incorrectly.
For example, if you tell customers your web address is "www.numberonecakes.com". They may accidentally type
"www.number1cakes.com" into their web browser instead.

▪ Use words with their proper English spelling when coming up with your domain name to minimize human errors
when typing your URL into a web browser. For example, using "kar-tiuns.com" instead of "cartunes.com".

Registering a domain name
After you have found an available domain name, you should have it registered to prevent other people from laying
claim to it. There are two ways you can go about doing this:

▪ Register your domain name yourself.

▪ Register your domain name through a web hosting provider when you sign up for a hosting plan with them.

Usually, a small fee will need to be paid to secure your rights to a domain name for a period of time (e.g. one year).
Thereafter, it will need to be renewed annually. Therefore, practice due diligence to check that your domain name
never expires by paying your fees on time. You do not want to lose all the hard work you have done in building up a
brand name for your online store only to lose it to someone else just because your domain name needs to be changed!

If you choose to register a domain name yourself, you can go to http://www.godaddy.com to do so. There are many
other companies who can do the same job, so you might want to try running a search in your favorite domain name
search engine.

Most web hosting providers can also provide domain name registration on your behalf. However, you need to be
careful when dealing with them. Some unscrupulous web hosting providers will register your domain name under
their company name instead of your name. If you decide to migrate your online store to another web hosting provider
later, they will demand a huge fee from you if you want to use back the same domain name they registered on your
behalf. Therefore, it is best to sign up with reputable and well-established web hosting providers and not those which
simply offer the cheapest prices.

Choosing a web hosting provider
A web hosting provider provides the infrastructure that determines whether your online business runs smoothly and
reliably. An online store that is constantly inaccessible or performs sluggishly will hurt your image and your sales.
Therefore, do as much research as possible when deciding on a suitable web hosting provider.

Some things you will need to look out for when evaluating a web hosting provider are summarized in the following
table.
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Table B.1: Criteria for evaluating web hosting providers

Criteria Explanation

Operating system and
software

Try to pick a host that offers a Unix/Linux-based web hosting plan. This is because Apache
has a long history of working with Unix/Linux rather than Windows-based operating sys-
tems and is consequently more stable on Unix/Linux.

Also make sure that the web hosting provider supports PHP and MySQL versions that are
compatible with Zen Cart.

Email Because you are running an online store, you need to make sure that your web hosting
provider allows you to set up email accounts with them. These email accounts must be for
both inbound and outbound usage.

Price Price should never be the deciding factor when choosing a web hosting provider. The mar-
ket is very competitive for web hosting and most hosting plans vary by a few dollars. Ulti-
mately, what matters more to an online store is speed and reliability.

Technical support Provides different means (e.g. by phone, by email or online only) to reach the web hosting
provider when you face problems with your account or setup. Most web hosting providers
will advertise how good their support is. Do not take their word for it. Try to find out
more information about their claims from online forums or people you know to determine
whether they are really performing up to task and the level of support they actually provide.

A poor supporting staff or system can cripple your online business for long periods if they
cannot quickly and reliably solve your problems.

Uptime Refers to the time that your site will remain accessible. No web hosting provider can guar-
antee your site will be up 100% of the time but most will likely quote a figure of 99.5% or
more.

Bandwidth Refers to the amount of data (in bytes) that is transferred from your site to visitors. If your
store sells digital goods for download, you will need to sign up for a plan which permits a
higher bandwidth.

Some web hosting providers state that they offer unlimited bandwidth, remember to read the
fine print. Ultimately, web hosting providers need to pay for bandwidth and they will not al-
low you to constantly exceed that bandwidth at their expense.

Disk space Refers to the amount of storage space allocated to your site. Make sure there is enough
space to include an entire Zen Cart installation including any images or files you are likely
to upload.

Again, be wary of sites that offer unlimited disk space for the same reason as they offer un-
limited bandwidth.

Web-based control
panel

This feature gives you the convenience and power of managing certain aspects of your web
account from the comfort of your desk without having to go through technical support every
time. You will be able to view server logs, create user accounts, create email and FTP ac-
counts, etc. Common control panels you might encounter include CPanel, Plesk and Ensim.
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Criteria Explanation

SSL installation No proper online store is complete without an SSL certificate to encrypt sensitive parts of
the store’s website. Make sure your host has the ability to provide a SSL certificate to meet
your business requirements.

To make your store appear more professional and legitimate to your users, pay for a dedi-
cated SSL certificate instead of using a shared SSL certificate. Also make sure that the SSL
certificate you purchase offers at least 128-bit of encryption.

A recommended solution - Zen Cart certified
hosting providers
If you have trouble deciding on a suitable web hosting provider for your online store, there is good news. Just click
the hosting hyperlink at the top of Zen Cart’s website to see a list of Zen Cart certified web hosting providers.

These web hosting providers have met the rigorous requirements of the Zen Cart team for hosting Zen Cart sites so
you can be sure about their work quality. They are very experienced and knowledgeable in the workings of Zen Cart
and will thus be able to provide good technical support if you encounter problems with your store configuration. They
even offer free installation of Zen Cart on your site.

It is highly recommended that you sign up with one of them if you are just starting a new Zen Cart store or dissatisfied
with your current web host. The latest list of Zen Cart certified web hosting providers can be found at http://www.zen-
cart.com/partners/certified_hosts. Go through their plans and send them an email if you have any questions regarding
their hosting packages.
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Appendix C:

Working with your remote computer

Host control panels
After you have registered a domain and signed up for a hosting package, your web host will assign you an account
with which you can work with your remote computer.

For most shared hosting accounts, the bulk of your interactions (file manipulation, database management, etc) with
your remote server will be through the use of a control panel provided by your web host.

There are many different control panel software (e.g. Plesk, HSphere) available but the most popular one among web
hosts is cPanel (http://www.cpanel.net). Hence, we shall use cPanel for our discussions in this book.

If you are using a different control panel software or a different version of cPanel, do not worry. The cPanel function-
alities highlighted in this book are very basic and can usually be found in other control panel software. All you need
to do is to adapt the instructions to suit your particular control panel software or version of cPanel.

Gathering important server information
After logging into your hosting control panel and orientating yourself on the available functionalities, you should start
gathering some important pieces of information about your remote server. These pieces of information will come in
handy for someone helping you troubleshoot a problem related to your Zen Cart store.

Installed server software

The pieces of server software information you need to collect are as follows:

▪ host operating system (e.g. Windows or Linux)

▪ web server information (e.g. Apache or IIS)

▪ PHP version

▪ MySQL version

Do note that you may need to check this information from time to time because web hosts may upgrade their server
software versions without informing their customers. Such silent upgrades can sometimes lead to problems working
with your online store.

Depending on your web host, the information you need may be readily available via your control panel software
as shown in the following screen shot of a cPanel side-box. Contact your web host if the information is not readily
available via your control panel software.
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Identifying the server’s document root
The document root (sometimes also known as the web root) refers to the directory on your remote server where
your site’s contents will be accessible by a public user’s web browser unless some extra security measures have been
implemented by your web host to prevent access to those files. We will use [doc-root] to represent the document
root in this book.

For instance, if you place a test.php file in your document root, then a user will be able to access that file from a web
browser by visiting http://www.example.com/test.php. If you place the same test.php file in a lab which
is a subdirectory of the document root, then a user will be able to access that file at http://www.example.com/
lab/test.php.

Depending on your web host, your [doc-root] could be named htdocs, public_html, wwwroot, or www. Consult
your web host if you are not sure which folder to use. Assuming johndoe is your user account name, some examples
of document root directories are as shown in the following list to help you identify the document root directory on
your server.

For Linux-based servers:

▪ /home/johndoe/public_html

▪ /var/www/johndoe/httpdocs

For Windows-based servers:

▪ C:\Inetpub\wwwroot

▪ D:\home\johndoe\htdocs

Do not confuse the document root directory with the home directory on your remote computer.
The home directory (e.g. /home/johndoe) is where all files related to your hosting account
are stored and which also happens to include the document root directory (e.g. /home/john-
doe/public_html) as well.

Managing files and directories
To manage files and directories on your remote server, you can choose to use either a local FTP client software (e.g.
FileZilla) or a file management application in your web host’s control panel software.

For cPanel, the file management application is known as File Manager and it is accessible by clicking the corresponding
icon in the "Files" section of a cPanel account.
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A word on hidden files

On Linux operating systems, a file with a preceding dot (e.g. .htaccess) is known as a hidden file. Hidden files may
not appear when you attempt to browse all the files in a given directory. This can cause much frustration when you
attempt to edit a file but cannot find it.

To ensure that hidden files are displayed in cPanel’s File Manager application, make sure you check the Show Hidden
Files checkbox after clicking the File Manager icon in the "Files" section.

FTP clients will usually display all hidden files by default. However, some web hosts may have mis-configured their
FTP servers thus resulting in the non-display of hidden files. For FileZilla, you can fix this problem by clicking on the
menu option Server > Force showing hidden files as shown in the following screen shot.

Transferring files between local and remote computers

The transfer of files between your local computer and your remote server can be achieved via a client FTP program
or your web host’s file management application. We shall look at some of the issues you may encounter when using
each of these options.

Via a client FTP program

Almost all GUI-based client FTP programs provide a very user-friendly drag-and-drop interface for you to transfer
files between your local computer and a remote server.
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To minimize chances of file corruption, all FTP transfers take place using one of two modes: ASCII vs binary. Text
files (.php, .css, .html, etc.) are usually transferred via ASCII mode while non-text files (e.g. compressed archives
or image files) should be transferred via binary mode. Most good FTP clients (e.g. FileZilla) provide an auto mode
that automatically switches between ASCII or binary mode depending on the file type. You should use the auto mode
if it is available for your FTP client. For FileZilla, this option is available via Transfer > Transfer type.

Via cPanel’s File Manager application

To transfer files via cPanel’s File Manager application, click either the Download or Upload icons as shown in the
following screen shot.

If you click on the Upload icon, you will be re-directed to a page which will allow you to transfer files to your server.
Note that the issue of transfer modes when using an FTP client does not apply when using File Manager.
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Compared to a client FTP program, file transfers via File Manager is not encouraged as a limited number of files can
be transferred at one go and each transfer also takes a longer time which can lead to time-out issues for large files.

Performing common file manipulation operations

Common file and directory manipulation operations like copy, rename, delete, and move can also be achieved using
your FTP client or your web host’s file management application.

Via a client FTP program

For a client FTP program like FileZilla, file manipulation operations can be accomplished via the use of a context
menu which will appear when you right-click on a file or directory.

Via cPanel’s File Manager application

For cPanel’s File Manager application, file manipulation operations can be performed either by clicking the relevant
icons on the top menu or the use of a context menu when clicking on a file or directory.
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Avoid editing files directly via File Manager as the files could become corrupted due to file
encoding issues. Instead, you should download your desired files and edit them on your local
computer before uploading those files back to your remote server.

Changing file and directory permissions

Most computer systems impose permissions on file and directories to protect files and directories from unauthorized
reading and writing. No one wants a situation where other users on a server could access and manipulate the files
of another user’s home directory. This is especially important in shared hosting environments where many users can
access and manipulate files on the same computer.

We shall cover some of the more common approaches here which relates to a shared web hosting environment and
highlight some of the problems you might face using these approaches.

There are many ways in which file permissions are defined, configured and set. If the informa-
tion in this book is insufficient for you to properly set the file permissions on your server, refer
to http://tutorials.zen-cart.com/index.php?article=9 for more information.

A word on Linux file permissions

When working with Zen Cart and many other web-based applications, you will often encounter instructions to make
a file read only or writeable and to ensure a directory is writeable. If these permissions are not set properly, you will
often encounter problems like not being able to edit a file or upload an image to a specific directory from within your
Zen Cart Admin Console.

File permissions on Linux-based systems are commonly expressed using a series of digits (e.g. 755) or a series of letters
(e.g. drwxr-xr-x). The former representation is more commonly used when changing file permission as it is shorter
and less likely to be mis-read. The latter representation is less ambiguous and more easily understood at a glance.
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In this book, we shall use the digit representation to specify the particular permission you should apply to a file or
directory. Each time we do that, we will also prefix the digits with the word chmod so that you do not confuse the
digits with something else other than file permissions. The word chmod stands for "change mode". It is a command
used commonly on Linux operating systems for changing file and directory permissions.

Depending on how your web host has configured PHP to work with your web server, the actual values to use for your
file and directory permissions to make then read only and writeable may vary as shown in the following two examples.
Always check with your web host if you are unsure how permissions should be set on their servers.

Example C.1: PHP configured to run under Fast-CGI and with phpsuexec installed

Directory (writeable) = chmod 755

File (writeable) = chmod 644

File (read only) = chmod 444 or chmod 400

Example C.2: PHP configured to run as an Apache module and Apache server runs as user "nobody"

Directory (writeable) = chmod 777

File (writeable)= chmod 777

File (read only) = chmod 444 or chmod 400

We have only scratched the surface of Linux file permissions in this book, if you are interested in knowing more about
the subject of Linux file permissions, refer to http://catcode.com/teachmod/.

Default permissions for files and directories that are uploaded to a server are usually chmod
644 and chmod 755 respectively. Files that are required to be read only are usually set to
chmod 444.

chmod 777 is the most relaxed permission and makes your remote server vulnerable to mali-
cious hackers. This is the reason why some web hosts disallow this permission to be set.

If you have relaxed the permission of a file or directory to chmod 777, make sure you set the
permission back to its required or default setting after you are done performing your desired
operation on the file or directory.

Via a client FTP program

Some FTP clients (e.g. FileZilla) allow you to directly alter file and directory permissions from within the software.
The following screen shot shows how FileZilla is able to do this.
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Although changing permissions via an FTP client is convenient, you should take note that this approach may not be
reliable. This is because permission changes may not have actually taken effect on the files and directories on your
server although you may have changed the permissions successfully in the FTP client.

Via cPanel’s File Manager application

For shared hosting accounts, your web host will usually allow you to change file permissions via an application in their
control panel software. For example, the following screen shot shows how you can use the File Manager application
in cPanel to change a file’s permission.

This approach of changing file permissions is the most reliable and is thus the recommended approach.

Via a PHP program

If you are unable to change to your desired file permission using the the previous two approaches, you can try changing
file permissions using PHP code. This approach is not recommended and should only be used if you are sure that the
permission you want to set is safe for your web host’s hosting environment. A real-life example where this approach
was employed can be found at http://www.zen-cart.com/forum/showthread.php?t=122852.
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Managing databases
Most hosting control panels offer an assortment of options to help users manage their databases. For example, the
following screen shot shows a "Databases" section in a cPanel account that offers some of these options.

Using some of the cPanel options shown in the preceding screen shot as examples, you shall see how you can go about
performing some database management tasks that are common to most Zen Cart site owners.

Setting up a new database

Setting up a new database generally involves the following steps:

1. Create a database.

2. Create a database user who will access the database.

3. Assign appropriate database usage permissions to the new database user.

Technically, the "Database Wizard", "phpMyAdmin", and "MySQL Databases" options can all perform the preceding
steps. In actual practice, due to security limitations and in order to ensure user convenience, the "Database Wizard"
option is usually used for this purpose and thus the one we shall make use of for illustration purposes.

Before you begin, find a piece of paper to write down the the database user, database password, and database name
of your newly created database.

To set up a new database using the "Database Wizard" option, follow these steps:

1. Click on the "Database Wizard" icon in the "Databases" section of your cPanel account and you should be direct-
ed to the "Create A Database" page. For most hosting accounts, your database name and database user will be
preceded by your account name.

For example, in the following screen shot, notice that the account name is johndoe_ and it is what precedes
whatever value you enter for your database name and database username later.

2. Enter the name (e.g. zencart) of your database in the input box and click the Next Step button and you should
be redirected to the "Create Database Users" page.
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3. Fill in the username and password of the new database user who will have access to the database you created in the
preceding step. Click the Create User button and you should be redirected to the "Add User to Database" page.

4. Click the All Privileges checkbox to allow the database user to have permissions to perform all tasks on the target
database. Click on the Next Step button and you should be redirected to the task completed page.

Modifying or deleting an existing database

To delete or modify (e.g. re-assign database user permission, reset a database user password) an existing database, the
"MySQL Databases" option is usually used. You can also set up a new database this way but it is more cumbersome
and is less preferable compared to the use of the "Database Wizard" option.

We shall not go into detail on how you can perform these tasks as your web host will likely provide the instructions
already. Instead, we shall provide a screen shot of a sample "MySQL Databases" page to give you an idea what are
some of the available functionalities when using this option.
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Manipulating database data

To manipulate the actual data (e.g. customer records) contained within a database, the "phpMyAdmin" option is usually
the only option available to you.

phpMyAdmin is a very popular open source web-based MySQL database management software. For more informa-
tion on phpMyAdmin and its uses, consult its official site at http://www.phpmyadmin.net. Do take note that not all
functionalities in your hosting control panel’s version of phpMyAdmin software is enabled due to security reasons.

The main method by which data in a database is manipulated is through the use of SQL (Structured Query Language)
commands. SQL is a computer language that is used to display and manipulate database information. You do not need
to understand or write SQL commands to work with your Zen Cart database. However, there may be occasions where
you will need to issue SQL commands so we will show you how you can access this functionality in phpMyAdmin.

To issue SQL commands in phpMyAdmin, follow these steps:

1. Click on the "phpMyAdmin" icon in the "Databases" section of your cPanel account and you should be directed
to the main phpMyAdmin screen. Note that the left panel of the page is where a list of your available databases
is displayed.

This PDF has been licensed for use to:

Book available for purchase from http://www.cucumbermedia.com

Alan Deverell <aland@casa.co.nz>

http://www.phpmyadmin.net


Appendix C. Working with your remote computer 436

2. Click on a database on the left panel that contains data you wish to manipulate and you should see a screen which
contains the existing tables in that particular database.

3. Click on the SQL tab to access the area in phpMyAdmin that you will use to issue your SQL commands.

4. Enter your SQL commands into the main text area.

5. Click Go to execute your SQL command.
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Backups and restores
Backups and restores are critical but often overlooked tasks of most store owners. Most web hosts offer some sort of
basic backup and restore options and you should find out what capabilities these options offer before you pursue a
backup and restore strategy that will meet your needs.

To give you an idea of what capabilities some of the backup and restore options offer, look at the following screen
shots which shows the "Backup" and "Backup Wizard" screens respectively. These screens are accessed by clicking
on their respective icons in the "Files" section in a cPanel account.
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Appendix D:

Zen Cart file structure

Zen Cart’s directory structure
The directory structures in a freshly downloaded Zen Cart installation will vary from that of a "live" Zen Cart store
serving real-world customers due mainly to security reasons. Take a look at the following screen shot to see the differ-
ences between the two directory structures. Note that we have used [zc-home] to represent the directory containing
all your Zen Cart files and [admin] to refer to your renamed admin directory. [doc-root] is also assumed to be
the document root of the web server.

Figure D.1: Directory structure differences between downloaded Zen Cart package and ‘live’ store

We shall not go through the purpose of each and every file and directory in a Zen Cart installation. Instead, refer to the
following table for an overview of the top-most directories residing directly underneath the main Zen Cart installation.
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Table D.1: Purpose of different Zen Cart directories

Directory Comments

[admin] Contains the main programming logic for the Admin Console part of the Zen
Cart system.

/cache May contain SQL cache files depending on a store owner’s configuration set-
tings.

/logs Contains error and debug log files generated by Zen Cart.

/docs Contains documentation related to Zen Cart.

/download Contains customer downloadable files.

/editors Contains files that allow a store owner to use a rich-text editor (e.g. CKEditor or
TinyMCE) when working in the Admin Console.

/email Contains email template files.

/extras Contains files used for troubleshooting purposes.

/images Contains catalog images of products, categories, manufacturers, attributes, ban-
ners, etc.

/includes Contains the main programming logic for the Store Front and other parts of the
Zen Cart system.

/media Contains media files that are offered by products which belong to the Prod-
uct-Music product type.

/pub Used for file download purposes when the download-by-redirect option is cho-
sen.

/zc_install Contains Zen Cart installation files.

The main configuration files

The configure.php files
Zen Cart makes use of the information contained with a configure.php to accomplish the following tasks.

▪ Define the URLs to use for your site.
▪ Toggle the use of SSL for your site.
▪ Specify the relative and absolute paths to important directories.
▪ Place your database connection settings.
▪ Control how database SQL caching should be done.
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The location of the two configure.php files can be seen in the screen shot in the earlier section. The sections of code
found in each configure.php file is well commented within the file itself. As such, you are unlikely to encounter
any problems (when attempting to edit them.

For your reference, we shall provide the following sample configure.php files. Both files strive to mimic that of a
"live" store and has been slightly re-formatted for better readability. The settings in the sample files assume that your
Store Front is accessible via http://www.example.com/store while your SSL-enabled Admin Console is accessible via
https://www.example.com/store/myadmin. They further assume that your online store resides on a Linux web host with
your document root as /home/johndoe/public_html and you have chosen to use the Latin-1 encoding instead of
UTF-8 encoding when you installed Zen Cart.

If your settings differ from that shown in the examples, make the necessary adjustments in both configure.php files
and consult the Zen Cart Tutorials and FAQs section if you face any problems.

The contents of the [zc-home]/includes/configure.php file is as follows:

<?php

// Define the webserver and path parameters
// HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
// HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com

  define('HTTP_SERVER', 'http://www.example.com');
  define('HTTPS_SERVER', 'https://www.example.com');

// Use secure webserver for checkout procedure?

  define('ENABLE_SSL', 'true');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make
 changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html
 or httpdocs folder)

  define('DIR_WS_CATALOG', '/store/');
  define('DIR_WS_HTTPS_CATALOG', '/store/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
  define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

  define('DIR_WS_PHPBB', '/');

// * DIR_FS_* = Filesystem directories (local/physical)
//the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/
accountname/public_html/store/

  define('DIR_FS_CATALOG', '/home/johndoe/public_html/store/');

//the following path is a COMPLETE path to the /logs/ folder
//eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash

  define('DIR_FS_LOGS', '/home/johndoe/public_html/store/logs');
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  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
  define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
  define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');

// define our database connection

  define('DB_TYPE', 'mysql');
  define('DB_PREFIX', '');
  define('DB_CHARSET', 'latin1');
  define('DB_SERVER', 'localhost');
  define('DB_SERVER_USERNAME', 'johndoe_janedow');
  define('DB_SERVER_PASSWORD', 'secretpasswd');
  define('DB_DATABASE', 'johndoe_zencart');

// The next 2 "defines" are for SQL cache support.
// For SQL_CACHE_METHOD, you can select from:  none, database, or file
// If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory
 where your apache
// or webserver user has write privileges (chmod 666 or 777). We recommend using
 the "cache" folder inside the Zen Cart folder
// ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash

  define('SQL_CACHE_METHOD', 'database');
  define('DIR_FS_SQL_CACHE', '/home/johndoe/public_html/store/cache');

Although they have the same names, the contents of the configure.php file for the Admin Console differs from
that of the Store Front.

The contents of the [zc-home]/[admin]/includes/configure.php file is as follows:

<?php

// Define the webserver and path parameters
// Main webserver: eg, http://localhost - should not be empty for productive
 servers
// HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
// HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com
// HTTP_CATALOG_SERVER is your Main webserver: eg, http://www.yourdomain.com
// HTTPS_CATALOG_SERVER is your Secure webserver: eg, https://www.yourdomain.com
/*
 * URLs for your site will be built via:
 *     HTTP_SERVER plus DIR_WS_ADMIN or
 *     HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or
 *     HTTP_SERVER plus DIR_WS_CATALOG or
 *     HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG
 * ...depending on your system configuration settings
 */

/**
 * WE RECOMMEND THAT YOU USE SSL PROTECTION FOR YOUR ENTIRE ADMIN:
 * To do that, make sure you use a "https:" URL for BOTH the HTTP_SERVER and
 HTTPS_SERVER entries:
 */

  define('HTTP_SERVER', 'http://www.example.com');
  define('HTTPS_SERVER', 'https://www.example.com');
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  define('HTTP_CATALOG_SERVER', 'http://www.example.com');
  define('HTTPS_CATALOG_SERVER', 'https://www.example.com');

// secure webserver for admin?  Valid choices are 'true' or 'false' (including
 quotes).
  define('ENABLE_SSL_ADMIN', 'true');

// secure webserver for storefront?  Valid choices are 'true' or 'false' (including
 quotes).
  define('ENABLE_SSL_CATALOG', 'true');

  define('DIR_WS_ADMIN', preg_replace('#^' . str_replace('-',
 '\-', zen_parse_url(HTTP_SERVER, '/path')) . '#', '',
 dirname($_SERVER['SCRIPT_NAME'])) . '/');
  define('DIR_WS_CATALOG', '/store/');
  define('DIR_WS_HTTPS_ADMIN', preg_replace('#^' . str_replace('-',
 '\-', zen_parse_url(HTTPS_SERVER, '/path')) . '#', '',
 dirname($_SERVER['SCRIPT_NAME'])) . '/');
  define('DIR_WS_HTTPS_CATALOG', '/store/');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make
 changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html
 or httpdocs folder)

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG .
 'images/');
  define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG .
 'includes/templates/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG .
 'includes/languages/');

// * DIR_FS_* = Filesystem directories (local/physical)

  define('DIR_FS_ADMIN', preg_replace('#.includes$#', '',
 realpath(dirname(__FILE__) . '/../') . '/'));

//the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/
accountname/public_html/store/

  define('DIR_FS_CATALOG', '/home/johndoe/public_html/store/');

//the following path is a COMPLETE path to the /logs/ folder
//eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash

  define('DIR_FS_LOGS', '/home/johndoe/public_html/store/logs');

  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
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  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

// define our database connection

  define('DB_TYPE', 'mysql');
  define('DB_PREFIX', '');
  define('DB_CHARSET', 'latin1');
  define('DB_SERVER', 'localhost');
  define('DB_SERVER_USERNAME', 'johndoe_janedow');
  define('DB_SERVER_PASSWORD', 'secretpasswd');
  define('DB_DATABASE', 'johndoe_zencart');

// The next 2 "defines" are for SQL cache support.
// For SQL_CACHE_METHOD, you can select from:  none, database, or file
// If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory
 where your apache
// or webserver user has write privileges (chmod 666 or 777). We recommend using
 the "cache" folder inside the Zen Cart folder
// ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash

  define('SQL_CACHE_METHOD', 'database');
  define('DIR_FS_SQL_CACHE', '/home/johndoe/public_html/store/cache');

The .htaccess files

.htaccess files are found in several directories within a default Zen Cart installation as shown in the preceding screen
shot. They are commonly used in shared-hosting environments to allow hosting account owners to modify some of
the server’s configurations thus allowing these hosting account owners greater control over their individual sites.
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They are only applicable to Apache web servers and may even cause problems if found on other web servers (e.g.
Microsoft IIS). If you suspect that they are causing problems to your non-Apache web server, temporarily rename all
the .htaccess files in your Zen Cart installation to .htaccess_OFF to see if that would solve your problems. For
readers who are using non-Apache web servers, consult the relevant web server documentation or your web host to
see how you can implement similar security measures to that of Zen Cart’s .htaccess files.

The instructions in a .htaccess file applies to the current directory the file resides in as well as all child directories
underneath it. This is the default behavior unless the server administrator has changed it. Your server administrator
also has the ability to change what instructions in your .htaccess files are allowed. Therefore, you should approach
your web hosting company if you have problems getting your .htaccess file to work with your Apache web server.

While there are many uses for .htaccess files, Zen Cart provides them mainly for security and anti-phishing reasons.
For some situations (e.g. file downloads), instructions in .htaccess files can also provide a smoother user experience.

.htaccess files are named with a period in front of them. This makes them hidden files on
Linux servers. Therefore, make sure you turn on the display of hidden files in your FTP client
software or server control panel software when accessing your server’s file system in order to
see them.

Common Zen Cart usage

The most common configuration instruction contained within Zen Cart’s .htaccess files is to limit the files that can
be directly accessible by users (e.g. via a web browser) of your site to those belonging to certain file types only.

This can be seen from the following lines of code which has been distilled from some of the .htaccess files in
your Zen Cart folders. Note that the permitted file types have already accounts for file extensions specified in either
lower-case, upper-case, or a mixture of both.

# deny *everything*
<FilesMatch ".*">
  Order Allow,Deny
  Deny from all
</FilesMatch>

# but now allow just *certain* necessary files:
<FilesMatch "(?i).*\.(jpe?g|gif|webp|png|swf)$" >
  Order Allow,Deny
  Allow from all
</FilesMatch>

IndexIgnore */*

Depending on the location of your .htaccess file, the list of allowed file types may vary. You may want to check
the following list of directories to manually edit the .htaccess file in order to add a custom file type which you
will be offering.

▪ [zc-home]/images

▪ [zc-home]/media

▪ [zc-home]/pub

▪ [zc-home]/download

File download operations

To provide added functionality and security with regards to file downloads, Zen Cart adds a bit more instructions in
the relevant .htaccess files on top of the common file type limiting functionality you saw earlier.
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If you had specified that downloads are to be performed by redirection on a Unix or Linux server, then the added
information in the [zc-home]/pub/.htaccess file ensures that redirection works.

## the following line is needed to allow Download-By-Redirect to work

Options +FollowSymLinks

On the other hand, the [zc-home]/download/.htaccess file provides an extra layer of security by specifying the
following section of code.

AuthType Basic
AuthName "No access"
AuthUserFile .htnopasswd
AuthGroupFile /dev/null
#Require valid-user

There is a common section of code which is very helpful and enabled by default in both the [zc-home]/
download/.htaccess and [zc-home]/pub/.htaccess files. This section of code (which we have reformatted
for readability) forces a customer’s web browser to pop-up a "Save As" file dialog box when attempting to download
a file instead of directly opening the file in the web browser (e.g. Adobe PDF files).

# ALERT: ForceType requires Apache2 or later. If using older version of Apache,
# it will need mod_mime installed. Or just comment out the ForceType line below
# (to disable, just comment the next 2 lines by adding a '#' at the beginning of
 each):

ForceType application/octet-stream
Header set Content-Disposition attachment

Block all direct access

For three directories that contain particularly sensitive information, Zen Cart uses the .htaccess files to deny all
direct access to the contents of the directories even if the file names are known. These three directories are as follows:

▪ [zc-home]/images/uploads

▪ [zc-home]/cache

▪ [zc-home]/logs

Store owners who need to access the files contained in the aforementioned directories will need to either FTP into the
server or use the server’s control panel software to download the relevant files.

The contents of the [zc-home]/images/uploads/.htaccess file is as follows:

<Files *>
  Order Deny,Allow
  Deny from all
</Files>

The contents of the [zc-home]/cache/.htaccess file is as follows:

<Limit GET POST PUT>
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  Order Allow,Deny
  Deny from All
</Limit>

#NOBODY SHOULD BE SNOOPING HERE

# deny *everything*
<FilesMatch ".*">
  Order Allow,Deny
  Deny from all
</FilesMatch>

IndexIgnore */*

While we have discussed the general uses for the .htaccess files in this book, we have not gone into detail on their
actual configurations as there is no need to do that for a standard Zen Cart installation. Furthermore, .htaccess con-
figuration is also a very technical topic which can lead to serious consequences if done wrongly. For more information
regarding .htaccess files and their uses, refer to http://httpd.apache.org/docs/2.2/howto/htaccess.html.
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