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Executive summa ry 
Keeping PCs in a  business up to da te with the la test softwa re a nd ha rdwa re upda tes presents a  
number of problems, including time, ba ndwidth, a nd logistica l issues. HP offers two tools, HP SoftPa q 
Downloa d Ma na ger (SDM) a nd HP System Softwa re Ma na ger (SSM) tha t ca n be used in conjunction 
to help strea mline the upda te process, reducing IT costs a nd improving the TCO  for your HP PCs.  
 
By using these tools, compa nies will be a ble to keep a ll of their HP PCs up to da te with the la test 
SoftPa qs (softwa re pa cka ges for upda tes to drivers/ BIO Ses a nd certa in softwa re for HP computers) 
a utoma tica lly, instea d of ha ving to run ea ch SoftPa q individua lly on ea ch ma chine, not knowing if the 
SoftPa q a ctua lly needs to be insta lled or not. 
 
The following topics in this document a re covered: 

• O verview of HP SDM a nd HP SSM 
• Setting up a nd using HP SDM a nd SSM 
• Customizing usa ge of HP SDM a nd SSM 

 

O verview of HP SDM a nd HP SSM 
HP SoftPa q Downloa d Ma na ger (SDM) is a  softwa re tool designed to strea mline the downloa d a nd 
extra ction process of SoftPaqs. Instea d of ma nua lly sea rching for a nd downloa ding ea ch SoftPa q, IT 
personnel ca n find a nd grab a ll the a ppropria te SoftPa qs for ea ch of their ma chines a ll in one sitting. 
 
HP System Softwa re Ma na ger (SSM) is a  free softwa re tool designed to simplify deployment of 
SoftPa qs to HP PCs. The SSM tool detects which upda tes a pply to the system from the a va ila ble 
SoftPa qs a nd insta lls them onto the system, so you do not ha ve to worry a bout a ccidenta lly insta lling 
a n older version. SSM a ccesses the SoftPa qs from the loca l network or loca l folder instea d of 
downloa ding them from the internet, cutting down on upda te time a nd sa ving network ba ndwidth. 
 
For more deta ils on either of these tools visit the following webpa ges: 
 
SDM: http:/ / www.hp.com/ go/ SDM 
SSM: http:/ / www.hp.com/ go/ SSM  
 

Use Ca se for SDM/ SSM 
Using HP SDM a nd SSM to ma na ge softwa re upda tes is idea l for: 

• Sma ll to medium business sizes (1 -1 00) 
• Upda ting a  group of PCs outside norma l IT ma intena nce 
• Recommended for Enterprise Customers for fa ster downloa d of SoftPa qs 
• Using HP Business Notebooks Common Products Ca ta log 

 
Note tha t SSM will only upda te PCs with SoftPa qs tha t a re ma rked a s SSM complia nt. 
 
 

http://www.hp.com/go/SDM
http://www.hp.com/go/SSM
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How SDM a nd SSM work together 
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Setup a nd Usa ge Process O verview   
1 . Downloa d a nd insta ll HP SDM. 
2 . Setup SDM configura tion for the models of ma chines you wa nt to upda te. 
3 . Downloa d desired SoftPa qs. 
4 . Run SSM in a dmin mode to prepa re the downloa d directory for SSM usa ge.  
5 . Repea t 2  a nd 3  for a ny a dditiona l file sha res tha t you ma y wa nt to crea te a nd use. 
6 . Ma nua lly sha re the file sha re, if necessa ry. 
7 . Setup SSM on the client ma chines to run a t predetermined times or run SSM ma nua lly. 

 

Genera l Requirements a nd Setup 
HP Sof tPaq  Dow nload  M anager  
.Net Framework 3.5 or later 
Broadband Internet Connection (Authenticated proxies supported: Basic, Digest, KLM and Kerberos)  
512MB RAM minimum, 1GB recommended 
W indows XP, Vista or W indows 7 
 
HP Sy stem  Sof tw are M anager  
Computer to host a W indows-compatible file share 
Supported HP /  HP Compaq computers attached to a network, running W indows XP, Vista or 
W indows 7 
 

Supported Client PCs and SoftPaqs 
 
HP SDM and SSM are only supported for certain HP business products (desktops, notebooks, tablets, 
workstations, and blades). Servers and consumer-level products are not supported with SDM and 
SSM. SDM will also indicate whether a SoftPaq is SSM compliant or not. If the SoftPaq is not marked 
as SSM compliant, SSM cannot be used to deploy that SoftPaq. 
 
In addition, certain platforms and operating systems may not be supported under SDM and/ or SSM. 
Consult the documentation that comes with SDM and SSM for details. 
 
 

Downloading and Installing HP SDM and SSM 
The latest versions of HP SoftPaq Download Manager and System Software Manager are available 
from HP at http:/ / www.hp.com/ go/ sdm and http:/ / www.hp.com/ go/ ssm respectively. 
 
HP SDM will appear in the Start Menu, under All Programs -> HP -> HP SoftPaq Download Manager.  
 
W hen you install SSM, no icon will be placed in the Start Menu for SSM; however, the program will 
be available in Hewlett-Packard\ SSM under the Program Files directory for 32-bit W indows systems 
and Program Files (x86) directory for 64-bit W indows systems. 
 
 

http://www.hp.com/go/ssm
http://www.hp.com/go/sdm
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Setting up a nd using HP SoftPa q Downloa d Ma na ger 

Option 1:  Using HP SoftPaq Download Manager to find updates for 
current model 
 

1. Launch SoftPaq Download Manager 
2. W hen prompted, select Show software for this model only.  (NOTE: If wanting to automatically 

install the updates on the current system, you can use the Check software updates for this model 
option.  If the goal is to download SoftPaqs to install on similar systems as the current platform 
than use the Show software for this model only option.) 

 

 
 

3. The current platform will automatically be displayed and selected in the Product Catalog window. 
 

 
 

4. Select the desired SoftPaqs from the Available SoftPaqs window. 
a. NOTE: Only SoftPaqs which are marked as SSM-compliant will be added to the SSM 

database. To help with the selection process you can have SDM select all SSM-
compliant SoftPaqs by clicking on Select SoftPaqs -> Auto-Installable (SSM-
Compliant). 
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5. After selecting the desired SoftPaqs, the following options are available in the Downloaded 
SoftPaqs window: Download Only, Download and Unpack or Download and Install. 
 

 
 

a. Download Only – This option will download all selected SoftPaqs to the Download 
Folder (SSM Filestore) location found on the “ Dow nload ”  tab under Configuration 
Options. 

b. Download and Unpack – This option will download all selected SoftPaqs to the 
Download Folder (SSM Filestore) location found on the “ Dow nload ”  tab under 
Configuration Options and will unpack each individual SoftPaq to the Unpack 
Directory location found on the “ Unpack ”  tab under Configuration Options.   

c. Download and Install – This option will download all selected SoftPaqs to the 
Download Folder (SSM Filestore) location found on the “ Dow nload ”  tab under 
Configuration Options and then install each individual SoftPaq on the current system 
via SSM.   

 

Option 2:  Using HP SoftPaq Download Manager to download SoftPaqs 
for multiple platforms. 

 
1. Launch HP SoftPack Download Manager 
2. W hen prompted, select Show software for all supported models.  If already in SDM, select “Show 

All Products” . 
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3 . Prior to downloa ding a ny SoftPa qs, set your preferences in the Configuration Options window 
accessed from the Tools menu (Tools -> Configuration Options). 

 

Tip: 
Once all of the selections have been made, you can save the configuration 
file for future usage and backup purposes. This will preserve the download 
directory, download structure, OS and language settings, and the products 
you selected. To save it, go to File -> Save Product Configuration.   

For each respective tab, select from the following options: 
 

• Downloa d 
o Dow nload  Directory  – Set it to a folder that you can share. This can be either a 

local folder or a mapped network drive/ folder. This will be the location of your SSM 
File Store. 

o Dow nload  Folder  Op tions – Select either Single Folder to put all SoftPaqs in a 
single location or Separate Folders by SoftPaq Names to separate them according to 
name. 
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• Unpa ck  

o Unpack Directory – this field allows the user to change the location of where they 
want the SoftPaqs unpacked to once they are downloaded. 

o Unpack Folder Options 

 Legacy Behavior – This option will unpa ck a ll selected SoftPa qs in the 
Downloa d Directory esta blished on the Dow nload  tab (above).  Unpack 
directory field will be locked.   

 Separate by SoftPaq IDs – This option will unpack all selected SoftPaqs in the 
folder designated in the Unpack Directory.  Individual SoftPaqs will be 
unpacked in a unique folder based on SP#: (i.e. \ SPxxxxx) according to 
SoftPaq category (Driver – Video, Driver – Audio, etc.).  

 Separate by SoftPaq Names – This option will unpack all selected SoftPaqs in 
the folder designated in the Unpack Directory.  Individual SoftPaqs will be 
unpacked in a unique folder based on SP Name: (i.e. HP Universal Camera 
Driver) according to SoftPaq category (Driver – Video, Driver – Audio, etc.).  
                    



9 
 

  
 
 

Exa mple of Sepa ra te by SoftPa q IDs option:    

 

Exa mple of Sepa ra te by SoftPa q Na mes option:    
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• O S Filter 

o Select from the list the opera ting systems tha t a re running on the network. Note tha t 
not a ll O Ses listed a re supported by SSM. The list of O Ses supported by SSM is 
included in the SSM User’s Guide, which is included in the SSM SoftPa q.   
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• La ngua ge Filter 

o Select the desired la ngua ges of the opera ting systems on your network.  
 

 
 
 

• Columns 
o Controls which fields a re displa yed in the “Ava ila ble SoftPa qs” window. 
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4 . O nce a ll of the Configura tion O ptions ha ve been set, select the respective pla tforms in the Product 
Ca ta log window a nd click “Find Ava ila ble SoftPa qs” to displa y a  list of a va ila ble SoftPa qs for 
your selected systems. 
 

 
 

a . NO TE: For common driver support a cross multiple notebook pla tforms, select the HP 
Business N otebook s Com m on Prod ucts catalog. 

 
 

5. Select the desired SoftPaqs from the Available SoftPaqs window. 
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6 . After selecting the desired SoftPa qs, the following options a re a va ila ble in the Downloa ded 
SoftPa qs window: Download Only or Download and Unpack. 
 
 

 
 

a. Download Only – This option will download all selected SoftPaqs according to the 
settings established in the Download tab in the Configuration Options dialog.  
Default is Single Folder set to “C:\ SoftPaqDownloadDirectory” . 

b. Download and Unpack – This option will download all selected SoftPaqs according 
to the settings established in the Unpack tab in the Configuration Options dialog.  
Default is Legacy Behavior (unpack in Download directory) 
“C:\ SoftPaqDownloadDirectory” .   

7. After download is complete, the SoftPaqs can either be installed directly / via SSM or imported 
into your respective management solution. 

a. NOTE: To quickly view the contents of either the Download or the Unpack folders, 
use the Explore drop down in the Downloaded Softpaqs window. 

 
 
 
8. Once the SoftPaqs have been downloaded/ unpacked/ installed, they will be displayed in the 

Downloaded SoftPaqs window.  Right-clicking on any SoftPaq in this window will present the user 
with the following options: 

a. View  Sof tPaq  Release N otes:  Provides detailed information about the SoftPaq 
contents – title, version, description, OS support, hardware support, fixes, etc.  

b. View  Sof tPaq  CVA:  Provides detailed installation instructions (including silent 
install instructions) as well as any dependencies.  
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c. Insta ll Sof tPaq :  Provides capability to install (silently) the SoftPaq directly from 
within SDM.  

d. Cop y  Sof tPaq  to Directory :  Provides capability to copy the SoftPaq (EXE), CVA 
and HTML files to a designated folder other than Download folder.  

 

 
 
 
 
 

Setting up HP SSM (Admin) 
SSM admin mode setup is run in order to accept the license agreement, configure user options and to 
build a database (called Update Information Database or UID) of SoftPaq information from the CVAs.  
This information is used by clients when SSM is run in client mode. 

Note: 
The SSM Admin setup process should be run after the SoftPaqs have been 
downloaded.   

 
To run and setup SSM in admin mode, perform the following: 

1. Navigate to Hewlett-Packard\ SSM in the Program Files directory (or Program Files (x86) if 
you’re running 64-bit W indows ) to run SSM.exe 

2. W hen prompted for the location of the file store, navigate to the SDM download directory. 
Type in the name you wish to use for the file store. Click next. 

3. If you are presented with a message about SSM.CAB being missing, double click on the 
specified text to copy the file to the file store, then click next until you reach client options. 

4. Check the box “Reboot client upon completion of upgrades” . Click next. 
5. Click next until you reach the Build Database window. 
6. Check the “Check ftp.hp.com for CVA file updates”  box first. This will cause SSM to update 

the specification file for each SoftPaq, which may include bug fixes and expanded coverage.  
7. Click on Build Database. W ait for the build process to finish.  
8. Click Finish to complete the process. 
9. Copy SSM.EXE to the root of the SDM download directory. This will allow easier execution of 

SSM from the network. 
 
The client PCs will need access to the file store containing the SoftPaqs in order for SSM to run 
properly on those machines. SSM will try to create the share automatically; however, this may not 
work in certain cases (domain settings, share is located on another computer, etc.), so you may need 
to share and/ or change the settings of the target folder manually. 
 

ftp://ftp.hp.com/
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Setting up HP SSM (Clients) 
In client mode, SSM uses the informa tion in the UID da ta ba se to query for a pplica ble SoftPa qs.  If no 
da ta ba se is present, SSM will dyna mica lly crea te a  tempora ry da ta ba se on the client by rea ding 
ea ch CVA in the file store over the network. Hence, for optima l performa nce ma ke sure the SSM 
da ta ba se is present in the file store a nd is up-to-da te. 
 
To run SSM in client mode, you only need to specify the loca tion of the file store a nd a ny other 
desired comma nd line switches a s pa ra meters. SSM.exe should be run from the root of the file store. 
The recommended comma nd used to run SSM is: 
 
<f ile store pa th>\ SSM .EXE . / IN STALL  
 
To prevent network authentication issues it is recommended to map the network share to a drive letter, 
and then use that mapped network drive as the file store path. 
 
There are multiple options in getting SSM to run: 

• Ma nua l Execution 
• Scheduled Ta sks 
• 3 rd pa rty ma na gement tool 

 
You ca n use the Scheduled Ta sks fea ture in W indows to ha ve SSM run a utoma tica lly on a  regula r 
ba sis. Depending on which O S the computers ha ve the setup, the process will va ry. 
 
If you use the Schedule Ta sks fea ture, HP recommends the following options be set when setting up 
the ta sk: 

• In Vista  a nd W indows 7 , SSM needs to be run with the highest privileges, so the “Run with 
highest privileges” option needs to be checked. No UAC prompt will a ppea r when this 
option is set. 

• To ensure upda tes a re a pplied, a llow SSM to run even when the user is logged off, a nd a dd 
the reboot comma nd line option a s a  pa ra meter. 

 

Ma intena nce Process 

Adding a nd Removing SoftPa qs 
The SDM ca ta log is upda ted on a  weekly ba sis on Monda y nights (US CST), so you ca n check ba ck 
then if you’re looking for the la test upda tes for your ma chines. 
 
As SoftPa qs a re a dded, you ma y wa nt to remove older or unneeded upda tes from the sha re to reduce 
size. This ca n be done ma nua lly by clicking on the Explore button in SDM. Be sure to remove the .exe 
a nd the corresponding .cva  when removing a  delivera ble. After a dding a nd removing SoftPa qs, 
reloa d the configura tion file in SDM to get a n upda ted list of downloa ded SoftPa qs. Note tha t deleted 
SPs from the Downloa d Directory will show up a ga in in the “Ava ila ble SPs” list.  
 
The SSM da ta ba se will a lso need to be rebuilt to reflect the upda ted SSM file sha re. Either run 
through the SSM setup process a ga in or use the comma nd line option. For deta ils, look in the 
Adva nced usa ge of HP SDM a nd SSM section. 
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Adva nced usa ge of HP SSM 

Running SSM from Remova ble Media  
SSM ca n be run directly from remova ble media , such a s a  USB memory stick or porta ble ha rd drive. 
The setup process is simila r to setting up SSM for use a cross the network, except tha t the SSM file 
store is copied to a  USB drive instea d of being sha red a cross the network. SSM is then run directly 
from the USB drive. This ca n be useful for upda ting ma chines not a tta ched to a  network or for 
ma chines with specia l considera tions. 
 
It is recommended to crea te a  .ba t loca ted in the root of the SSM folder with a  comma nd tha t would 
execute SSM with the desired pa ra meters. This would a llow for ea sy double-click execution when 
moving from machine to machine.  
 

Note: 
Certain SoftPaqs that deal with USB devices (such as Bluetooth drivers) may 
interfere with the operation of the update process in SSM if run from a 
removable drive. To work around this, copy the SSM directory to the local 
hard drive and run SSM from there. 

 

Updating the SSM DB and CVAs via command line 
Instead of running through the SSM wizard to rebuild and update the DB, you can perform the 
process via a command line. The command is: 
 
SSM  / AM _BLD_DB 
 
SSM.exe must be run and located in the root of the file store for this command to work. 
 
This command will also update the CVA files by downloading updated ones from HP’s server. Each 
SoftPaq comes with a CVA file that determines which SoftPaq applies to what machines. Sometimes 
these CVA files are updated to add supported machines/ OSes or to fix errors. If you do not wish to 
update the CVAs use the / N OCVAUPDATE switch. 
 

Other SSM Configuration Options 
SSM has a number of command-line switches and options that can be used during the setup and 
execution process. For more details on the options, please refer to the SSM  User ’ s Guid e included 
with SSM. 
 
 

Multiple File Stores 
You can share copies of the SSM file share on more than one computer or use multiple SDM 
configurations and download directories to create different SSM file shares. By spreading the load 
you may be able to alleviate network performance issues you may run into and help simplify the 
update process when trying to update a large number of PCs via SSM.  
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O ther HP Solutions 
For needs tha t outgrow SDM a nd SSM, HP offers a  va riety of solutions. Visit 
http:/ / www.hp.com/ go/ clientma na gement for more deta ils. 
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For more informa tion  
To lea rn more a bout HP business notebooks a nd desktops, conta ct your loca l HP sa les representa tive 
or visit www.hp.com/ go/ notebooks a nd www.hp.com/ go/ businesspc.  
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